Jump to content
Proud Mary

Problem installing Dutch language pack

Recommended Posts

I've recently installed the Duch language pack using filezilla.

I tried to follow the instructions of the readme file but they were not very helpful since they did not specify which file(s)/folder(s) where to upload.

 

So, I finally uploaded the "dutch" and the "php" folder seperately into my "www.proudmary.me/winkel/catalog/includes/languages" folder. (see attchment)

I went to "localization", "languages" in the dashboard and ticked the box for "default" after Dutch.

When I go to "tools","define language" I can choose Dutch (all the V's are green)

But when I visit my shop the language is still English.

 

I guess I need to store something more from the 'dutch language pack ' , that instructs the shop to really go for Dutch.

But I'm not sure what, and then where to file it.

 

Help is greatly appreciated!

 

Marieke

post-321414-0-68284800-1368604221_thumb.png

Share this post


Link to post
Share on other sites

@@Proud Mary

 

Marieke

 

The language displayed depends on the browser default language.

 

You also need to put dutch.php in ...../winkel/catalog/includes/languages.

 

The language code is set to ne shouldn't it be nl to be iso compliant?

 

HTH

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

I already added the dutch.php to the folder.

Changed the code to nl, but that doesn't seem to make a difference.

My shop is still in English.

 

Maybe I need to do something with the admin folder of the langueage pack.

Anyone any bright ideas?

Share this post


Link to post
Share on other sites

What is the default languguage of your pc?

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Hi,

 

Did You upload the Language Pack from the file oscommerce-233-full-dutch-language-pack-ver-2.zip which I contributed to the addons area the 5th of may? If not try that language pack. In the README.pdf file I clearly state that the directory structure contained in the catalog directory is to be copied to the webshop, and then all directories and files in the admin and include directories are copied to their rigt places. I looked at your webshop and see that you are missing a lot of text definitions. That indicates a lot of files are missing in the folder /catalog/include/languages/dutch/ . You can fix it by copying via Filezilla the catalog/includes/languages/dutch/ and catalog/includes/languages/dutch.php to the webshops folder catalog/includes/languages . And for the Administrator part copy catalog/admin/includes/languages/dutch/ and catalog/admin/includes/languages/dutch.php to the webshops folder catalog/admin/includes/languages/ .

 

Then You have to edit the product descriptions for the new dutch language as administrator in Catalog -> Categories/Products , and klick on each product and klick edit. There you have a description text field for each language. If you only would have the dutch language, you can delete the english language in Localization -> Languages.

 

/Bertil

Share this post


Link to post
Share on other sites

Hi Marieke,

 

I see that your webshop is installed not in the root of your website but in a subdirectory called winkel. You probably copied the catalog folder from the language pack to the root of your website, thats why nothing worked. If so, you can delete this catalog folder. In the right pane of Filezilla you have to first klick into the catalog winkel, and thereafter do the copy of the "catalog" folder from the language pack according to instructions in the README file.

 

If you have any additional questions on howto get your webshop up and running, please e-mail me at info@shopwebshop.eu

 

 

/Bertil

Share this post


Link to post
Share on other sites

Dunno.

 

As a last resort, have two shops

 

www.proudmary.me/winkel

www.proudmary.me/shop

 

They can address the same database. The google-searcher has chosen a phrase from a particular language. Having implicitly specified a language, he is happy to get through to a page that offers that language and no other. I am sceptical of the multi-language thing.

 

A fresh install is likely to be easier than copying the winkel directory. And then re-naming the copy. And then fiddling about with the configure files. It has to be an 'upload install', so far as I can see. Fantastico would insist on making a new database.

 

How much of the duplicated admin can be deleted, I do not know. Try it and see. A directory can be 'half-deleted', by vandalising its name. The code, that is looking for it, cannot then find it.

 

Then it's a case of getting into

 

includes/languages/english.php

 

to change 'welcome guest' to 'welkom gast'. Leaving the filename unchanged of course.

 

Like Bertil, I don't see that you need a 'catalog' directory. Directories like 'images' and 'includes' can be directly under 'winkel'.

Share this post


Link to post
Share on other sites

Chris H,

 

I've tried a multilingual web shop with 24 different languages ​​and 12 different currencies, shopwebshop.eu ,it works great.

The integrated control of the language from the browser language setting does not work though, but it can be fixed by having a front page that sets the correct language from the browser language setting. like this for switching between english and swedish language depending on browser language setting:

---

<script type="text/javascript">

<!--

function start() {

document.write ("Your browser languagecode is = ");

document.write (languageinfo.substr(0,2));

setTimeout( "end();", 500);

}

 

var langcodes=new Array(

"en",

"sv",

"default")

var langredirects=new Array(

"/osc_shop/catalog/index.php?language=en",

"/osc_shop/catalog/index.php?language=sv",

"/osc_shop/catalog/index.php?language=en")

var languageinfo=navigator.language? navigator.language : navigator.userLanguage

var gotodefault=1

function redirectpage(dest){

if (window.location.replace)

window.location.replace(dest)

else

window.location=dest

}

function end() {

for (i=0;i<langcodes.length-1;i++){

if (languageinfo.substr(0,2)==langcodes){

redirectpage(langredirects)

gotodefault=0

break

}

}

if (gotodefault)

redirectpage(langredirects[langcodes.length-1])

}

//-->

</script>

----

 

To test the different languages ​​you can click on the flags in the right column, or better yet surf to the page with the Opera browser in which you can set the language without having to restart the browser.

 

I think that the best is to start with the original osCommerce 2.3.3 installation without any changes, because if you change a lot You are on your own, and can't get any help.

So the original installation root directory is "catalog". My suggestion is don't change that.

 

/Bertil

Edited by burt
removed a bunch of external links pointing to provider of commercial services

Share this post


Link to post
Share on other sites

Hi Bertil (and others),

 

I've been trying stuff all afternoon and I finally got it!!! (w00t)

The instructions and the pack function as they should.

I don't understand why it took me this long. (The fact that there are 2 directories called "catalog" and some wild ideas of my own did not help in this matter :blush: )

 

Anyway, thanks for all the help :thumbsup:

Marieke

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×