Jump to content

Recommended Posts

Hi Jack

 

second question:

 

In admin view_counter/Monitor, youh "getting started" drop Down says:

 

Configuration Settings:
ON/OFF - This turns View Counter on or off. With it set to off, it will not function at all.
Active Time - This is used to determine what constitutes a live session
 
I  cannot find ON/OFF??
 
After installing and clicking around on my "localhost" shop there is no logging of my activities, does logging only take place on a shop in the air?
 
sorry for the previous post but unfortunately it was posted, I do not know why!!
 
I am looking forward to your answers.
 
Kind regards
 
Kurt K

Share this post


Link to post
Share on other sites

@@kurtk The left column change only applies to shops that have the old style of left_column.php (before 2.3.3, I think).

 

The on/off is a setting in configuration->View Counter.

Share this post


Link to post
Share on other sites

dear Jack

 

you are right, I was not looking in "configuration" folder, but there it is.

 

I am still running on a localhost until I get it all working, but unfortunately I cannot see any activities displayed in the "view counter/monitor" section.

 

does the "view counter" only Work on a live shop??

 

is it nessesary to get an API KEY to get it to Work properly?

 

kind regards

 

Kurt K

 

 

 

Share this post


Link to post
Share on other sites

It will work in a local setup. You don't need a key but you do need the database file.

Share this post


Link to post
Share on other sites

Hi Jack

 

thanks for all your efforts in this topic.

 

after installing the app. live fortunately it Works!!

 

but the admin response time is increased up to 5 to 10 times!

when switching the "view counter " OFF" in the "configuration pane". The response time is back to normal.

 

is that like it is??

 

kind regards

 

kurt K

Share this post


Link to post
Share on other sites

@@kurtk No, you shouldn't see such a slowdown.  You can try reducing the rows per page setting, turning of the flags, block countries and show account details settings to see if it changes things.

Share this post


Link to post
Share on other sites

I don't know if those are the same but I have to think they are since that site references the one in the install file in the archive, and vice versa. The link on the main site says free databases but the ones on the main site are free too so I don't know why both exists, other than for more exposure. But it is just a matter of downloading, renaming and uploading the file to see if it works. No harm will be done other than it may not work.

Share this post


Link to post
Share on other sites

Hmm, on the main page is said, that one have to pay for the databases? Can you confirm, that the databases are for free right now?

Edited by stefan21

Share this post


Link to post
Share on other sites

The link in the install file to the databases says free open source and is the one I, and probably everyone else, always use so unless they just recently started charging for them, they are free.

Share this post


Link to post
Share on other sites

Free Databases seem to work. As far as I can see. Running OsCommerce 2.3.4, PHP 5.3.29, MySQL 5.5.44-log. Not able to block countries. If I choose i.e. China from the list on the left side, it will not appear on the right side. Any idea what could be wrong?

 

Thank you for your reply,

stefan

Share this post


Link to post
Share on other sites

The list on the right side is only populated as IP's from the blocked country are used. So if you never have a visitor from China, there will never be an entry for China in that list.

Share this post


Link to post
Share on other sites

The countries are written in the database, and I can confirm, that visitors from blocked countries are listed at the right side. Thank you for clarification.

 

the install instructions say,

 

"13) If your shop doesn't have the GeoIP.dat and geoip.inc files in admin/includes/,
upload the ones in the Extra directory."

 

I didn'd have the two files in admin/includes yet. So, why not uploading the files in admin/includes instead of admin/ext (or do you mean catalog/ext?

 

Thank you for your reply,

stefan

Share this post


Link to post
Share on other sites

The install instructions say:

 

"6) In admin/includes/column_left.php, look for require(DIR_WS_BOXES...  
   or include(DIR_WS_BOXES..., and add this line before it:
 
  require(DIR_WS_BOXES . 'view_counter.php');"

 

Can't find this in OsC 2.3.4?

 

<?php
/*
  $Id$

  osCommerce, Open Source E-Commerce Solutions
  http://www.oscommerce.com

  Copyright © 2014 osCommerce

  Released under the GNU General Public License
*/

  if (tep_session_is_registered('admin')) {
    $cl_box_groups = array();

    if ($dir = @@dir(DIR_FS_ADMIN . 'includes/boxes')) {
      $files = array();

      while ($file = $dir->read()) {
        if (!is_dir($dir->path . '/' . $file)) {
          if (substr($file, strrpos($file, '.')) == '.php') {
            $files[] = $file;
          }
        }
      }

      $dir->close();

      natcasesort($files);

      foreach ( $files as $file ) {
        if ( file_exists(DIR_FS_ADMIN . 'includes/languages/' . $language . '/modules/boxes/' . $file) ) {
          include(DIR_FS_ADMIN . 'includes/languages/' . $language . '/modules/boxes/' . $file);
        }

        include($dir->path . '/' . $file);
      }
    }

    function tep_sort_admin_boxes($a, $b) {
      return strcasecmp($a['heading'], $b['heading']);
    }

    usort($cl_box_groups, 'tep_sort_admin_boxes');

    function tep_sort_admin_boxes_links($a, $b) {
      return strcasecmp($a['title'], $b['title']);
    }

    foreach ( $cl_box_groups as &$group ) {
      usort($group['apps'], 'tep_sort_admin_boxes_links');
    }
?>

<div id="adminAppMenu">

<?php
    foreach ($cl_box_groups as $groups) {
      echo '<h3><a href="#">' . $groups['heading'] . '</a></h3>' .
           '<div><ul>';

      foreach ($groups['apps'] as $app) {
        echo '<li><a href="' . $app['link'] . '">' . $app['title'] . '</a></li>';
      }

      echo '</ul></div>';
    }
?>

</div>

<script type="text/javascript">
$('#adminAppMenu').accordion({
  heightStyle: 'content',
  collapsible: true,

<?php
    $counter = 0;
    foreach ($cl_box_groups as $groups) {
      foreach ($groups['apps'] as $app) {
        if ($app['code'] == $PHP_SELF) {
          break 2;
        }
      }

      $counter++;
    }

    echo 'active: ' . (isset($app) && ($app['code'] == $PHP_SELF) ? $counter : 'false');
?>

});
</script>

<?php
  }
?>
 

What's wrong?

stefan

Share this post


Link to post
Share on other sites

the install instructions say,

 

"13) If your shop doesn't have the GeoIP.dat and geoip.inc files in admin/includes/,

upload the ones in the Extra directory."

 

I didn'd have the two files in admin/includes yet. So, why not uploading the files in admin/includes instead of admin/ext (or do you mean catalog/ext?

The instructions tell you where to upload it.

 

The IP locator at ipinfodb no longer works.

 

Shops after 2.3.3.3, or thereabout, don't require changes to the column_left file.

Share this post


Link to post
Share on other sites

Hi

has the http://api.hostip.info/site gone down

 

or

 has something changed?

 

my site times out, so I've made the following change

// switch the following two line of code when the external site is down
 //if (strpos($_SERVER['PHP_SELF'], DIR_WS_ADMIN) === FALSE) {
     if (false) {
     include(DIR_WS_MODULES . 'view_counter_country_block.php');

 

any advise please

 

regards

Mike


osC CE live - developing osC Phoenix adding modules with no core changes(awesome and easy!)

Share this post


Link to post
Share on other sites

Yes, it appears to be down again. You can turn off the country blocking option in the settings to get around this since it is the only part that uses that site, assuming you are using the latest version.

Share this post


Link to post
Share on other sites

@@Jack_mcs

Thanks, I've upgraded to V1.5.

 

As http://api.hostip.info/ is still down, will the admin monitor not response? My server will not even time out.

 

thanks for the upgrade.  country checking is now off until the site comes back up again..

Regards

Mike


osC CE live - developing osC Phoenix adding modules with no core changes(awesome and easy!)

Share this post


Link to post
Share on other sites

You may need to turn off the display flag option for View Counter in admin not to be slow.

Share this post


Link to post
Share on other sites

@@Jack_mcs

I've switched the display flag option off, and the monitor doesnt response or time out.

 

My test environment operates differently, it times out and will give a display of the active users.

 

The production shop is on linux, the test shop is on PC using a local network (but connected to the internet via a router)

 

I may copy over the updated files again, but everything else is working OK

 

do you have any more ideas?

 

Mike


osC CE live - developing osC Phoenix adding modules with no core changes(awesome and easy!)

Share this post


Link to post
Share on other sites

If it works on one and not the other there must be some difference in the setup, though I don't know what that might be.

Share this post


Link to post
Share on other sites

@@Jack_mcs

fixed........., the permissions on a .htaccess file wasnt readable from the http server.

 

the monitor now times out, and eventually the log of users are shown.

 

do you know what the safest permission for a .htaccess file is?

 

Regards

Mike


osC CE live - developing osC Phoenix adding modules with no core changes(awesome and easy!)

Share this post


Link to post
Share on other sites

Like with most files, the correct permissions are 644. That can vary with the server setup, though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×