Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Archived

This topic is now archived and is closed to further replies.

MWebb

SPPC help

Recommended Posts

I am trying to install the separate price per customer contribution and I keep getting some problems. I know there are a few posts on this but none of these seem to help me.

 

When I first installed it I got this message when visiting the site 1054 - Unknown column 'customers_group_id' in 'where clause'

 

select specials_new_products_price from specials where products_id = '22' and status and customers_group_id = '0'

 

[TEP STOP]

 

and also this message when going to the admin page 1146 - Table 'oscommerce_8.TABLE_ACTION_RECORDER' doesn't exist

 

select id from TABLE_ACTION_RECORDER where module = 'ar_admin_login' and (user_name = 'Admin' or identifier = '77.76.64.210') and date_added >= date_sub(now(), interval 5 minute) and success = 0 order by date_added desc limit 3

 

[TEP STOP]

 

I then got direct in http://forums.oscommerce.com/topic/392689-membership-options/ this post to try an earlier package which I did but then I got this message 1054 - Unknown column 's.customers_group_id' in 'where clause'

 

select p.products_id, pd.products_name, p.products_price, p.products_tax_class_id, p.products_image, s.specials_new_products_price from products p, products_description pd, specials s where p.products_status = '1' and p.products_id = s.products_id and pd.products_id = s.products_id and pd.language_id = '1' and s.status = '1' and s.customers_group_id = '0' order by s.specials_date_added desc limit 10

 

[TEP STOP]

 

I'm not sure what I've done wrong, I think in the install instructions there's a line that says

Run the spcc_v421_install.sql database installation file on your MySQL database. But I don't know how to run this file as I can't find any instructions for it.

Share this post


Link to post
Share on other sites

I'm not sure what I've done wrong, I think in the install instructions there's a line that says

Run the spcc_v421_install.sql database installation file on your MySQL database. But I don't know how to run this file as I can't find any instructions for it.

 

You've answered your own question. You need to run the sql file upon your database.

Do you have access to your servers control panel? such as phpadmin or webmin ?

If not you will need to ask your host for control panel access or ask them to run the sql file for you.

BACKUP the database first!

 

If you need more direction, google : install.sql file on your MySQL database : or something like that. its very easy actually.


-Dave

Share this post


Link to post
Share on other sites

I use phpadmin but I don't know how to run the sql file. Also I've just tried the autoinstaller pack in the contribution and when I changed all of the permissions it's left the the shop page as blank and the only thing left is the header.

Share this post


Link to post
Share on other sites

Ok I found the sql file and have installed it (i think) through the phpadmin and installed all the other files but now I'm getting this message

 

1054 - Unknown column 's.customers_group_id' in 'where clause'

 

select p.products_id, pd.products_name, p.products_price, p.products_tax_class_id, p.products_image, s.specials_new_products_price from products p, products_description pd, specials s where p.products_status = '1' and p.products_id = s.products_id and pd.products_id = s.products_id and pd.language_id = '1' and s.status = '1' and s.customers_group_id = '0' order by s.specials_date_added desc limit 10

 

[TEP STOP]

 

I then installed the bug fixes and I got this message 1054 - Unknown column 'customers_group_id' in 'where clause'

 

select specials_new_products_price from specials where products_id = '17' and status and customers_group_id = '0'

 

[TEP STOP]

Share this post


Link to post
Share on other sites

i have looked all through the SPPC thread and can not get any help, maybe someone can help here. I have the SPPC addon in my easy populate file and it is not showing the SPPC pricing change when signed under the appropriate customer group does anyone no what may be causing this?

Share this post


Link to post
Share on other sites

×