Jump to content

Archived

This topic is now archived and is closed to further replies.

benny2012

broken borders in fancier-invoice-packingslip

Recommended Posts

hi

 

ok so im using the fancier-invoice-packingslip Module

 

firstly im posting here as support for that module withered away some time ago from reading the support topic

yes i read all 70 pages.

 

anyhow i know a lot of folk use it so thought this a better route for help and advise.

 

I have the contribution fully working however,

 

The borders are all broken upon printing or print preview,

 

I Have set my browser to print Colours and Backgrounds, as per instructions, however it still breaks the borders up.

 

anyone any ideas on how to fix this ??

 

many thanks in advance

Share this post


Link to post
Share on other sites

I Have the same problem on my 2.2 Rc2a sites - I think it may be something in the css maybe a missing repeat ?

 

Many Thanks


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

I had a similar problem and copied the page part of the code from the admin invoice and packing slip as this seemed to work correctly. I didnt compare the code to see what the differences were.


REMEMBER BACKUP, BACKUP AND BACKUP

Share this post


Link to post
Share on other sites

@@14steve14 Hi Steve, Exactly what did you copy to where ?

 

Thanks


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

My admin invoice page worked correctly, but the store side invoice didnt.

 

I copied everything from the admin invoice page from after the closing </head> tag to the store side invoice file.

 

For me that worked.


REMEMBER BACKUP, BACKUP AND BACKUP

Share this post


Link to post
Share on other sites

@@14steve14 mine is the other way round - the store side "Print my invoice" works fine, as does the admin side invoice when you view it from the admin screen, the problem occurs when you try to print the invoice - this is when the breaks occur as you can see below:

 

1) Extract from Admin page invoice

 

 

 

 

2) Print priview of same invoice:


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

I am in the process of amending the files to use css for the borders, but it is something that will be done eventually, and is causing a few problems at the moment as I dont think I know enough to do it as it should be done.


REMEMBER BACKUP, BACKUP AND BACKUP

Share this post


Link to post
Share on other sites

my error is same as Mort , in print preview and print the error occurs. (browser settings set to images/borders =yes, tried on firefox, IE and chrome)

 

many thanks Steve for attempting to fix the files, id not mind but to customer it looks like seller has dodgy printer lol

 

anyways hope you have success, any type of work around would be good. many thanks

Share this post


Link to post
Share on other sites

I'm looking for a fix here too. Used to work fine fpor years, but no longer. Invoices and Packing Slips look like s--t, very poor prresentation.

Share this post


Link to post
Share on other sites

Sorry, Chrome is also missing this feature. See:

 

http://productforums.google.com/forum/#!topic/chrome/rywToswM-EY

 

Looks like, if you want background images with and you've lost it with the newest FF upgrade, you'll have to use IE 9! Did MS use its influence to be the only browser now which can print background images,. since FF got rid of it!! This blows. So, IE 9, or an earlier version of FF. Aurora, too won't do it either!!!

Share this post


Link to post
Share on other sites

×