Jump to content
Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

alexpacteau

SSL Messed Up Site

Recommended Posts

If/when you need help with SSL click the "SSL Implementation Help" link in my signature. Read the first post very thoroughly.


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

I have managed to get access to the Admin side of my store now but am getting notice once clicking onto the administration tab stating that the .htaccess/htpassword_oscommerce is not secure.

 

Additional Protection With htaccess/htpasswd

This osCommerce Online Merchant Administration Tool installation is not additionally secured through htaccess/htpasswd means.

The following files need to be writable by the web server to enable the htaccess/htpasswd security layer:

  • /home5/fantata1/public_html/store/admin/.htaccess
  • /home5/fantata1/public_html/store/admin/.htpasswd_oscommerce

Reload this page to confirm if the correct file permissions have been set.

I tried to post an image but couldn't work out how to so this is what was stated in the Administration section of the Admin Side of the Store.

 

Hope someone can help with this soon, I did manage to work out how to fix it once but have forgotten how I did it when setting the site up initially.

Share this post


Link to post
Share on other sites

Set chmod on both those files to 0777 and then reload the page. And then follow the instructions.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

I set the .htaccess to 0777 but .htpassword_oscommerce isn't there to change. At this stage changed the permissions back to 0644 on .htaccess.

 

Thanks for the help @@burt but couldn't change the .htpassword_oscommerce to 0777 as it doesn't exist in that folder or any that I could find.

 

Hope you can suggest something else to try. Please leave comments and will try them once I wake in the morning. Hopefully I will be able to fix this tomorrow.

 

Thanks for trying.

 

Just noticed that there wasn't any 0 in front of the numbers when changing the permissions, not sure if that is anything wrong or not or whether I am changing the permissions using the correct manner.

Share this post


Link to post
Share on other sites

Sometimes you require a 0 and sometimes not.

 

If there is no file called .htpasswd_oscommerce then you can make a new blank file and name it .htpasswd_oscommerce

then set 777 on it.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

Tried to do what you suggested but keeps on going back to the same way after following the information on the screen. Just goes back to the same line as I posted earlier. Unsure whether I am doing something wrong or not but just following instructions on the page. For some reason it isn't working properly. As it is 11.25 PM here I am heading to bed and will endeavour to try and work this out more in the morning.

 

If you can further assist me in this I will be very appreciable. Thanks for your assistance so far and hope this can be worked out simply so I can go back to accessing my Admin Side of things securely.

Share this post


Link to post
Share on other sites

×