Jump to content

Recommended Posts

I am new to using OsCommerce and have had it running on our Online Store with no issues until this morning when we get an error HTTP/1.1 404 Not Found

 

The error was referring to OzPost module that you get 60 days free then have to pay a subscription to use it. Last night I had 33 days left of the free part so I was shocked to see the error this morning when I woke and checked the site. I contacted my IP and they re-installed a backup from the 9th Nov and that seemed to work until I edited the module again to try and allow international buyers to select shipping through it. Then we got the same error again, called IP again and was on the phone with them for over an hour. Sent in a ticket to see if they could sort it out and got this response:

 

 

The error attached seems to indicate an issue with getting the URL:

/postage.php?flags=get_latest_client_version_oc

 

The reason this is failing is because the postage.php file is not able to be found on the server. It's returning a 404 page to the program. ie:

curl -IL fantasy-art-trading.com/postage.php?flags=get_latest_client_version_oc

HTTP/1.1 404 Not Found

Date: Mon, 12 Nov 2012 07:31:54 GMT

Server: Apache

Vary: Accept-Encoding

Content-Type: text/html

 

(I wasn't able to find any postage.php file anywhere on your account)

I recommend either editing the /home5/fantata1/public_html/store/includes/modules/shipping/ozpost.php file to not check the postage.php file, or contacting the plugin developers to find exactly what is happening with that.

If you'd like us to look into anything else for you, please don't hesitate to ask.

 

If someone could help me with this I would be grateful as I have had to resort to using a Flat Rate Postage Fee until this is fixed.

 

Comes up with Unable to connect to Ozpost server

 

Hopefully this is an easy fix and can be sorted very quickly.

Edited by FantasyArt

Share this post


Link to post
Share on other sites

There are major problems with the primary ozpost server at the moment.

 

Both backup servers are fully functional.

 

Most of the ozpost client modules will detect the svr1 problem and use srv2.ozpost.net instead (and if that fails they should use svr0.ozpost.net).

 

If you are experiencing an issue as a result of this current outage, you have three options.

 

1) update to the latest ozpost code.

 

2) Load the code /includes/modules/shipping/ozpost.php into a text editor.

Locate the line of code that reads:

curl_setopt($ch, CURLOPT_URL,"svr1.".$server.$request);

(it'll be somewhere around line #1477)

 

Change 'svr1' to 'svr2'.

 

Resave the file.

 

This'll force the module to use the secondary server 1st :)

 

or

 

3) Be patient. svr1 will be back online ASAP.

 

Cheers

Rod

Share this post


Link to post
Share on other sites

Thanks for your help Rod,

Seems that the problem has been solved and all is working again properly.

 

Thanks Craig.

Share this post


Link to post
Share on other sites

Would anyone know how to add all the International Countries back into the database as I originally deleted them one by one as we were intending to only sell within Australia. Since then we have had some interest in selling Internationally and would like to make it possible for International customers to create an account within our OsCommerce Store so that they would be able to purchase like everyone from Australia is able to do.

 

I also need to know whether I would also have to add all the Zones as well seeing as their would be States/provinces for the International Residents to fill in. At this stage we have the Australian Zones setup as all the States within Australia. Is there a way that we can remove all the Zones so that everyone would have to TYPE in their State/Province manually, then select their Country from the pulldown menu.

 

If anyone can help me with this or send me in the right direction to find the right module or the ability to add the Countries back and make the Zones section into a TEXT field I would be very grateful.

Share this post


Link to post
Share on other sites

obtain a copy of the file /catalog/install/oscommerce.sql

 

Copy the lines starting with

INSERT INTO zones .....

 

Paste them into your database using your favourite SQL editor (probably phpmyadmin)

 

Alternatively, save the line out to a new file, the 'import' the file.

 

Cheers

Rod

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×