Jump to content
vjwebb

Problem with USPS parcel post delivery confirmation

Recommended Posts

In April of 2011, I upgraded to USPS methods 5.2.1. This new version had a check box to add 19 cents to First Class and Parcel Post shipping costs (to handle the delivery confirmation charge that PayPal forces).

 

I just realized yesterday that the 19 cents is not being added. I am almost positive that I tested the feature when I did the upgrade. I had made a change on the older version that I was running that handled adding the 19 cents after the response from the post office.

 

Can someone tell me why this has stopped working. I don't see the 19 cents coded anywhere so I am asuming that it supposed to be part of the response from the post office.

 

Any help will be greatly appreciated.

 

V J


-- A ship in a harbor is safe, but that is not a ships ultimate purpose.

Share this post


Link to post
Share on other sites

I turned on the email diagnostic and found the problem.

 

The usps.php file had the following code:

 

if ((MODULE_SHIPPING_USPS_DMST_DEL_CONF == 'True') && (preg_match('/<\/ServiceName><Available>true<\/Available><AvailableOnline>true<\/AvailableOnline><Price>0.80<\/Price><PriceOnline>/', $response[$i])))

{ $del_conf = ereg('</ServiceName><Available>true</Available><AvailableOnline>true</AvailableOnline><Price>0.80</Price><PriceOnline>(.*)</PriceOnline>', $response[$i], $regs);

 

The post office apparently raised the not-online price from 0.80 to 0.85. I changed it from 0.80 to 0.85 and it is

again working perfectly.

 

Sorry for the trouble but maybe it will help someone else.

V J

 

 

 

 

In April of 2011, I upgraded to USPS methods 5.2.1. This new version had a check box to add 19 cents to First Class and Parcel Post shipping costs (to handle the delivery confirmation charge that PayPal forces).

 

I just realized yesterday that the 19 cents is not being added. I am almost positive that I tested the feature when I did the upgrade. I had made a change on the older version that I was running that handled adding the 19 cents after the response from the post office.

 

Can someone tell me why this has stopped working. I don't see the 19 cents coded anywhere so I am asuming that it supposed to be part of the response from the post office.

 

Any help will be greatly appreciated.

 

V J


-- A ship in a harbor is safe, but that is not a ships ultimate purpose.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×