Jump to content
Sign in to follow this  
broadstreetbully

Must Agree To Conditions Addon Issue-Help Needed

Recommended Posts

I'm trying to install the MATC addon but the conde in account_checkout does not match...

the addon is here >-->http://addons.oscommerce.com/info/8205

 

the instructions say this:

post-242891-0-60911600-1347491533_thumb.png

 

but my account_checkout.php looks like this:

post-242891-0-13424400-1347491605_thumb.png

 

the code circled is the part I'm suppossed to edit but if you looks at the instructions you'll see it is different...

 

has anyone else had an issue installing this addon?

I saw in other threads that people were having trouble installing the addon but none of their issues were similar to mine...........

 

all help is appreciated.

Share this post


Link to post
Share on other sites

The instructions you are following look different to the ones i used for my install. Looking at the contribution, use the middle of the three versions. It was uploaded by chrish123 on the 28th october 2011.

 

I installed this version and it works as it should. The code from the instructions is below.

 

VI. STEP
in /checkout_payment.php
Find :
  <h2><?php echo TABLE_HEADING_BILLING_ADDRESS; ?></h2>

Add before :
<?php //-----   BEGINNING OF ADDITION: MATC   -----//
if($HTTP_GET_VARS['matcerror'] == 'true'){
?>
  <tr>
    <td><?php
$matc_error_box_contents = array();
$matc_error_box_contents[] = array('text' => MATC_ERROR);
new errorBox($matc_error_box_contents);
?></td>
  </tr>
<?php } //-----   END OF ADDITION: MATC   -----// ?>

Find :
		    <?php echo tep_draw_textarea_field('comments', 'soft', '60', '5', $comments); ?>
Add after :
<!-- BEGINNING OF ADDITION: MATC -->
<?php
if(MATC_AT_CHECKOUT != 'false'){
require(DIR_WS_MODULES . 'matc.php');
}
?>
<!--   END OF ADDITION: MATC   -->


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Hi, I am running 2.3.3 and downloaded the middle version from Oct 28th, 2011. After following the instructions step by step, I don't get any error messages, but I don't get any MATC boxes to tick or buttons to click either. Simply nothing has changed.

Any ideas what went wrong?

Thank you

Share this post


Link to post
Share on other sites

In your admin area in the configuration section have you turned it on, on the pages that you want it to show on.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×