Jump to content

Archived

This topic is now archived and is closed to further replies.

dallasbird

Entry Processes/CPU hits 100% all the time

Recommended Posts

Hello,

I have been reading every forum post I can on this topic and I still cannot fix. My site (this is an adult site - couplescorner.biz) is reaching 100% cpu usage all the time. I am now using cloudflare, thumbnail generator, making notes in robots.txt to stop bot from overcrawling site. I really do not know where to look to correct this problem. I get most of my information/education from these forum pages and I think I am out of my league here. If anyone could help or direct me, I would be most grateful.

Thanks

 

Jen

Share this post


Link to post
Share on other sites

Try installing the KISS Error Handler and see if the queries on your site are slow.

 

Deinstall the thumbnailer and see if that is causing it.

 

Deinstall cloudflare for 24 hrs and see if that improves things.

 

HTH

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Ok I will try the kiss error handler. This has been happening before the thumbnailer and cloudflare - I did those things to try to fix. I do not know how to check for bottlenecks - will the kiss error handler help?

Thanks for your response and help.

Jenny

Share this post


Link to post
Share on other sites

First I would try removing the code for live help or install it correctly.

 

HTH

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Geoffry,

I just renamed live help so that it wouldn't show up - it was working fine - i just changed the name back. I installed kiss error and it is showing up at the bottom of my page, I wasn't sure where to put the address to have it show on another screen. I am kind of overwhelmed. Do I just follow the reccomendations. It seems like the html_output.php file has a lot of errros, what is exactly 'depreciated'

I really appreciate your help. I have been struggling on this for months and I would love to get this resolved. - my store is suffering.

Jenny

Share this post


Link to post
Share on other sites

I always read deprecated to mean this command need to be updated to run with the latest version of php.

 

There are several threads that point to an add-on that lists these updates.

 

This is not the real problem.

 

your site is taking nearly 10 seconds to load.

 

Have you looked at the queries being run?

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Total query time about 0.5 sec so not that.

 

Have a look at the processes being run on your db using phpmyadmin.

 

Is there a locked process?

 

Is this a shared server?

 

What load is on it if no one is on your site?

 

GTG

 

Cheers

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

This should help get rid of the deprecated error messages if they are for deprecated ereg and eregi commands.

 

Cheers

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

G,

I am on a shared server

 

this is the message I get on my cpanel in resource usage :

'CPU resources were limited for your site

You have reached entry processes (number of simultaneously running php and cgi scripts, as well as cron jobs and shell sessions) limit 10 times'

 

I didn't see any locked processes on the database and I optimized them while there.

 

cloudflare stats for yesterday were 462 reg. traffic/221 unique - 951 crawlers & bots/31 unique and I have it set to high security so the 67 unique threats didn't get through. This seems really high for bots and crawlers - I tried slowing down google and others in robots.txt - but am told googe ignores, they will not let me change crawl rate either.

 

My disc space usage is 1553.08/3000

 

what did you mean 'This should help get rid of the deprecated error messages if they are for deprecated ereg and eregi commands.' - what will help ?

Thanks again.

Share this post


Link to post
Share on other sites

Many people think of Bots and Crawlers as good things, like google. But there are thousands of search engines that do nothing for your site but eat up your accounts resources. My guess is that that is what's happening in your case. You need to review your servers raw access log, available in CPanel, to find any offending visitors and block them.

Share this post


Link to post
Share on other sites

Jack,

Thanks for your input, I've used a lot of contributions you've worked on and I have a good deal of respect for you. I thought that cloudflare was blocking bad bots, but if I still have 31 different bot/crawlers a day that does seem like a lot.

If I were to block all bots/crawlers for 3 weeks a month or all together, would I still come up on the search engines. Google has crawled tens of thousand of pages - they don't need more information. What do you think I should do?

Share this post


Link to post
Share on other sites

×