Jump to content
thejudge99

CONTRIBUTION Social Login with Facebook / Google 2.3.1/2

Recommended Posts

Hello,

 

I installed your contribution in osCommerce 2.3.3 and found followwing issues:

 

1) I get this message when accessing to my store:

 

Warning: session_save_path() has been disabled for security reasons in /home/anclasol/public_html/prog/osc/web233/catalog/includes/functions/sessions.php on line 169

 

2) I cannot access to my admin area where shows followin messages:

 

Warning: session_save_path() has been disabled for security reasons in /home/anclasol/public_html/prog/osc/web233/catalog/PanelControl/includes/functions/sessions.php on line 165

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/anclasol/public_html/prog/osc/web233/catalog/PanelControl/includes/functions/sessions.php:165) in /home/anclasol/public_html/prog/osc/web233/catalog/PanelControl/includes/functions/sessions.php on line 102

 

Warning: Cannot modify header information - headers already sent by (output started at /home/anclasol/public_html/prog/osc/web233/catalog/PanelControl/includes/functions/sessions.php:165) in /home/anclasol/public_html/prog/osc/web233/catalog/PanelControl/includes/functions/general.php on line 38

 

3)After log in with Google I get following message:

 

There was an error with your Social Login attempt !

 

4) After log in with Facebook I get following messages:

 

Warning: session_save_path() has been disabled for security reasons in /home/anclasol/public_html/prog/osc/web233/catalog/includes/functions/sessions.php on line 169

 

Fatal error: Call to a member function restore_wishlist() on a non-object in /home/anclasol/public_html/prog/osc/web233/catalog/includes/login-facebook.php on line 78

 

I have installed Security Pro 2.0 r11 and made two exclusions: googleloader.php and login.php

I have also installed SiteMonitor but I don't think this means any problem as this program only send reports but don't take any action.

 

Is this contribution compatible with osCommerce 2.3.3 and if so, please, can you help me with this issues?

 

Thank you.

 

Hi Can i know what did u change in your hosting server?

Share this post


Link to post
Share on other sites

I can display. I am only using FACEBOOK LOGIN. The thing is that it cant connect to the fb. MY site pops out in the new window when i click login in with FB.

 

Any ideas?

Share this post


Link to post
Share on other sites

Hi i am able to connect with facebook and the app recognises the connection but then a developer error displays in the pop up(image1).After clicking OK the window displays "Access denied for user ''@'10.0.230.14' (using password: NO)" When interogatting with Firebug there is an error (image2). Any suggestions. I am only using the Facebook login not Google.http://silvereclipse.co.uk/login.php

 

post-301275-0-35014000-1383394290_thumb.pngpost-301275-0-02248900-1383394292_thumb.png

Edited by WeeCB

Share this post


Link to post
Share on other sites

Hi i am able to connect with facebook and the app recognises the connection but then a developer error displays in the pop up(image1).After clicking OK the window displays "Access denied for user ''@'10.0.230.14' (using password: NO)" When interogatting with Firebug there is an error (image2). Any suggestions. I am only using the Facebook login not Google.http://silvereclipse.co.uk/login.php

 

post-301275-0-35014000-1383394290_thumb.pngpost-301275-0-02248900-1383394292_thumb.png

Just set up the Google API with exactly the same result. This looks like a database access error but I cannot find any reference to the i.p anywhere in the addon files. The 10.0.230.14 ip address is not even close to the ip used by my server.

Share this post


Link to post
Share on other sites

Rectified the first issue by removing the height and width element from the jquery

<script type="text/javascript">
jQuery(document).ready(function($) {  
 jQuery('a.slogin').live('click', function(){
	 newwindow=window.open($(this).attr('href'),'','height=,width='); 
  if (window.focus) {newwindow.focus()}	  
   return false;   
   });
   });
</script>

But I still cannot find any way to to deal with the Access Denied Message.

Anyone have any suggestions?

Share this post


Link to post
Share on other sites

Julian, great contribution, thanks! :)

Can you please make this great contribution work on osC 2.2 RC2a or let me know what I should revise during installation to make the latest contribution version work?

Share this post


Link to post
Share on other sites

Hi Guys,

 

When I installed this plugin last year it was working fine but it was having redirect loop problem on FB same with Google but I was able to fix the Google problem, I am not sure if its bec. I have installed ssl recently.

 

Here is the url: http://yazbeck.com/shop/login.php

 

Pol

Edited by polphoenix

Share this post


Link to post
Share on other sites

Hi, I have installed this mod. It works fine for google. But when I logged in it is not redirected to original page. I only get logged in in pop window where I entered google credentials. And for facebook it shows Error code: ERR_TOO_MANY_REDIRECTS. Need help.Thanks.

Share this post


Link to post
Share on other sites

@@thejudge99 Seems like the entire module has stopped working.  Also your demo site http://ocraw.conzept.de/login.php  is returning many 'deprecated' errors.

 

As mentioned by previous commentors on this thread @@AllThingsTrendy @@vinitthakre @@polphoenix etc.

 

And I have to report the module has stopped working on my site as well.  

 

Facebook returns a "Website Redirect Loop". @@thejudge99 If you happen to still be around and can give some tips that would be great.

 

@@vourlismenos I noticed on your site http://www.walkincloset.gr/index.php your facebook login works, how did you fix it?

Edited by jimmylaz

Share this post


Link to post
Share on other sites

Hello everyone! thanks thejudge99 for your effort. I will try to install this application right now, then I will tell you about the results!  :thumbsup:

Share this post


Link to post
Share on other sites

Nope! dont work! I will tell you if I can make it working.

Big shame out of an entire community of programmers none of us can seem to get this module working.  At least my login via Twitter code still works.  I also hired programmers to fix this contribution and no luck.  They got back to me after days of analysis and said it was impossible.  UGH!

Share this post


Link to post
Share on other sites
On 10/2/2014 at 3:21 PM, jimmylaz said:

@@thejudge99 Seems like the entire module has stopped working.  Also your demo site http://ocraw.conzept.de/login.php  is returning many 'deprecated' errors.

 

As mentioned by previous commentors on this thread @@AllThingsTrendy @@vinitthakre @@polphoenix etc.

 

And I have to report the module has stopped working on my site as well.  

 

Facebook returns a "Website Redirect Loop". @@thejudge99 If you happen to still be around and can give some tips that would be great.

 

@@vourlismenos I noticed on your site http://www.walkincloset.gr/index.php your facebook login works, how did you fix it?

please share the steps to install the social login in google or facebook

Share this post


Link to post
Share on other sites

Hi,

 

Have installed this addon in oscommerce 2.3.3.4. Google login working fine, but the facebook login not working it's showing error as "You are not logged in: You are not logged in. Please log in and try again."

Anyone can please help to fix this issue ?

Thank you

Screenshot_1.png

Share this post


Link to post
Share on other sites

@kumarpragmatic

You would better invest your time in upgrading to the Community Edition of osCommerce and then installing the EZSocial addon

osCommerce responsive is the best version of osCommerce.

Download it here: https://github.com/gburton/Responsive-osCommerce

EZSocial: https://apps.oscommerce.com/vVTNW&amp;ezsocial-for-osc2-3-4bs-v1-0a

EZSocial thread:

 


Let's make things easier for new osCommerce users http://forums.oscommerce.com/topic/402638-discussion-about-hard-coded-database-tables/?p=1718900  Getting there with osCommerce 2.4! :thumbsup:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×