Jump to content

Archived

This topic is now archived and is closed to further replies.

tgely

v2.3.2 upgrade experience from v2.3.1

Recommended Posts

I am having a problem updating I went through everything and now i am testing. When you send for a new password email arrives with this link http://www.phantomcustomwheels.com/password_reset.php?account=phantomwheels%40gmail.com&key=5SIFNICQyCsK3rCfhegxTkG5ZbE7YAiklMxVQQp2 but the link shows nothing but a white screen any ideas whats goin on?

Share this post


Link to post
Share on other sites

@@Procella

 

Your database are not utf8 collation. Would be better to use utf8 everywhere.


:blink:
osCommerce based shop owner with minimal design and focused on background works. When the less is more.
Email managment with tracking pixel, package managment for shipping, stock management, warehouse managment with bar code reader, parcel shops management on 3000 pickup points without local store.

Share this post


Link to post
Share on other sites

@@Phantomwheels

 

Probably & in the URL link is false. After the correct core update you should have URL links without html ampersands.


:blink:
osCommerce based shop owner with minimal design and focused on background works. When the less is more.
Email managment with tracking pixel, package managment for shipping, stock management, warehouse managment with bar code reader, parcel shops management on 3000 pickup points without local store.

Share this post


Link to post
Share on other sites

@@Phantomwheels

 

http://yourdomain.com/password_reset.php?account=somebody%40freemail.hu&key=7EvmvBOWEG2ite0a8BqTkOzPMGd62L1A2w2S4kkj

 

http://forums.oscommerce.com/tracker/issue-314-malformed-url-issue/


:blink:
osCommerce based shop owner with minimal design and focused on background works. When the less is more.
Email managment with tracking pixel, package managment for shipping, stock management, warehouse managment with bar code reader, parcel shops management on 3000 pickup points without local store.

Share this post


Link to post
Share on other sites

@@Procella

 

Your database are not utf8 collation. Would be better to use utf8 everywhere.

 

PHPMyAdmin:

General Setting:

Server Connection Collation: UTF8_general_ci

 

Database Server:

  • Server: Localhost via UNIX socket
  • Software: MySQL
  • Software version: 5.1.66-cll - MySQL Community Server (GPL)
  • Protocol version: 10
  • User: ********@@localhost
  • Server charset: UTF-8 Unicode (utf8)

So, i guess the database is using utf8.


Timo Jensen

Share this post


Link to post
Share on other sites

@@Procella

 

DATABASE INSTALLATION

- focus on charsets (multibytes)

 

 

 

A FIRST INSTALLATION

when creates new database the SQL default install code for some reason is no influence.

 

**************************************************

* CREATE DATABASE `oscommerce_example_database`; *

**************************************************

 

* if hosting not set utf8 to default charset need to use

 

*****************************************************************************

* CREATE DATABASE `oscommerce_example_database` DEFAULT CHARACTER SET utf8; *

*****************************************************************************

 

SQL command.

 

Need inform before!

 

For informing yourself about charsets use SQL engine checking tools. osCommerce package

has a simple tool for checking.

 

Path: extras/create_database_tool.php

Note: need edit mysql_connect parameters before run this php script

The script give all create database alternative commands before installation.

(The default asked charset is "utf8" but allowed to change

$default_charset = 'utf8'; )

 

THE CHARSET PARAMETER NEED IN OSCOMMERCE SETUP PROCEDURE LATER!!!

 

Useage:

1. Copy create_database_tool.php to webserver

2. Edit create_database_tool.php file with a txt editor and give user password, database name

and host server name for sql commands. The dafault parameters good for local testing only.

 

$db_server = 'localhost';

$db_server_username = 'root';

$db_server_password = '';

 

3. Save file after changes and run

4. Green SQL commands are recommended

5. Select one best choice to Create oscommerce database

6. Change `oscommerce_example_database` name in SQL script you want

7. Run the new SQL created sript in SQL engine

8. Delete create_database_tool.php from webserver because this is a security risk!!!

 

 

 

B UPDATES

* if you already have non utf8 COLLATED EMPTY DATABASE

use alter database like this:

 

****************************************************************************************************

* ALTER DATABASE `oscommerce_example_database` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci; *

****************************************************************************************************

 

* if already use non utf8 COLLATED DATABASE

Need alter the all table with SQL commands for each table which are exist!

 

* After core updates need to edit configure.php-s

add new line in

catalog/admin/includes/configure.php

 

define('DB_DATABASE_CHARSET', '');

 

and

catalog/includes/configure.php

 

define('DB_DATABASE_CHARSET', '');

 

Don't forget to set the charset value in changes!!

 

C INSTALLING OSCOMMERCE INTO COMMON USED DATABASE

oscommerce v2 is not use table prefixes, not recommended

 

 

 

D CHARSET PACKAGE SOLVE OTHER PROBLEMS

 

1. Default database charset of the core

 

2. Multibyte string problem in wordwrap

 

3. Search issues

 

4. Email issues

 

 

You can see more info in my github cointaner.


:blink:
osCommerce based shop owner with minimal design and focused on background works. When the less is more.
Email managment with tracking pixel, package managment for shipping, stock management, warehouse managment with bar code reader, parcel shops management on 3000 pickup points without local store.

Share this post


Link to post
Share on other sites

@@Gergely

 

C INSTALLING OSCOMMERCE INTO COMMON USED DATABASE

oscommerce v2 is not use table prefixes, not recommended

 

 

 

D CHARSET PACKAGE SOLVE OTHER PROBLEMS

 

1. Default database charset of the core

 

2. Multibyte string problem in wordwrap

 

3. Search issues

 

4. Email issues

 

 

You can see more info in my github cointaner.

 

What i did was actually upgradign V2 to v233, Then took a backup. Deletede the OsCommerce, installed 233 from scratch, setup the language files, and then restored DB. Via PHPMyAdmin i checked the DB is UTF8 (it is). Also the server is UTF8. So i think im good.


Timo Jensen

Share this post


Link to post
Share on other sites

@@Procella

 

the previous (saved) table was on utf8? Maybe the migrated table source is bad. Typical problem when used latin1 tables with non-latin1 characters and saved data into tables with wrong codings. I think you have utf8 tables now but some reason the characters looks like wrong encoded.

 

v2.3 and above the html pages use utf8 codepage, but v2.2 used latin encodes. When you saved non-latin characters into latin1 collated tables the characters missed because the colation was on utf8. In phpMyadmin and utf8 coded user interface (new oscommerce page) you can see good characters in your browsers because your browser transform multibytes characters to utf8 as html page coded. But you have wrong characters in data tables.

 

For this reason I used a lot of php scripts to encode my wrong coded latin2 characters from latin1 table on oscommerce.sql files. After the encoding I inserted into the new utf8 website data table.

 

I see that you can use phpAdmin. Could you list here one record example from products_description table with critical characters?


:blink:
osCommerce based shop owner with minimal design and focused on background works. When the less is more.
Email managment with tracking pixel, package managment for shipping, stock management, warehouse managment with bar code reader, parcel shops management on 3000 pickup points without local store.

Share this post


Link to post
Share on other sites

@@Gergely

 

Ok, i think i havent expressed what the problem is.

 

1. When i save the files with the built in tool, the files that are saved, becomes empty.

a. Solution: Edit locally, upload with FTP (apparently).

 

2. Text from my languagefiles (includes/language/dansk.php), does not show danish letters. http://drikkegel.dk/?page_id=26&slug=index.php&language=da


Timo Jensen

Share this post


Link to post
Share on other sites

The language files are not encoded using utf-8, you have to convert them to UTF-8 and check all files in your language to clean out non UTF-8 characters.

Share this post


Link to post
Share on other sites

In phpmyadmin i inserted the letters æøå in a few records. A dump look like this. On http://drikkegel.dk/?page_id=26 i cant see the letters in products, but in the text like the "greeting guest" theres an error. Guest in danish is gæst. not "g�st".

 

 

-- Data dump for tabellen `products_description`

--

 

INSERT INTO `products_description` (`products_id`, `language_id`, `products_name`, `products_description`, `products_url`, `products_viewed`, `products_head_title_tag`, `products_head_desc_tag`, `products_head_keywords_tag`) VALUES

(1, 1, 'ÆØÅ Matrox G1æ200 MMS', 'ÆØÅ æøåReinforcing its position as a multi-monitor trailblazer, Matrox Graphics Inc. has once again developed the most flexible and highly advanced solution in the industry. Introducing the new Matrox G200 Multi-Monitor Series; the first graphics card ever to support up to four DVI digital flat panel displays on a single 8" PCI board.<br /><br />With continuing demand for digital flat panels in the financial workplace, the Matrox G200 MMS is the ultimate in flexible solutions. The Matrox G200 MMS also supports the new digital video interface (DVI) created by the Digital Display Working Group (DDWG) designed to ease the adoption of digital flat panels. Other configurations include composite video capture ability and onboard TV tuner, making the Matrox G200 MMS the complete solution for business needs.<br /><br />Based on the award-winning MGA-G200 graphics chip, the Matrox G200 Multi-Monitor Series provides superior 2D/3D graphics acceleration to meet the demanding needs of business applications such as real-time stock quotes (Versus), live video feeds (Reuters & Bloombergs), multiple windows applications, word processing, spreadsheets and CAD.', 'www.matrox.com/mga/products/g200_mms/home.cfm', 0, NULL, NULL, NULL),

(2, 1, 'ÆØÅ Matrox G400 32MB', '<strong>Dramatically Different High Performance Graphics</strong><br /><br />Introducing the Millennium G400 Series - a dramatically different, high performance graphics experience. Armed with the industry''s fastest graphics chip, the Millennium G400 Series takes explosive acceleration two steps further by adding unprecedented image quality, along with the most versatile display options for all your 3D, 2D and DVD applications. As the most powerful and innovative tools in your PC''s arsenal, the Millennium G400 Series will not only change the way you see graphics, but will revolutionize the way you use your computer.<br /><br /><strong>Key features:</strong><ul><li>New Matrox G400 256-bit DualBus graphics chip</li><li>Explosive 3D, 2D and DVD performance</li><li>DualHead Display</li><li>Superior DVD and TV output</li><li>3D Environment-Mapped Bump Mapping</li><li>Vibrant Color Quality rendering </li><li>UltraSharp DAC of up to 360 MHz</li><li>3D Rendering Array Processor</li><li>Support for 16 or 32 MB of memory</li></ul>', 'www.matrox.com/mga/products/mill_g400/home.htm', 0, NULL, NULL, NULL),


Timo Jensen

Share this post


Link to post
Share on other sites

The language files are not encoded using utf-8, you have to convert them to UTF-8 and check all files in your language to clean out non UTF-8 characters.

@@www.in.no

Isnt æøå/ÆØÅ UTF8 characters?

Is there a difference to using UTF8, da_DK.utf8 or en_US.UTF8 etc...


Timo Jensen

Share this post


Link to post
Share on other sites

Those characters can be represented in many encodings, but the code used may be different for different encodings. You must match the encoding used to that specified by osCommerce.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I am trying to find the best way to load the Dashboard/jQuery only when it's needed, so I would like to have your opinion on this little tweak in admin template_top:

 

<?php
if ($current_page == FILENAME_DEFAULT) {
?>
<!--Introduce Administration Tool Dashboard and Add jQuery-->
<!--[if IE]><script language="javascript" type="text/javascript" src="<?php echo tep_catalog_href_link('ext/flot/excanvas.min.js'); ?>"></script><![endif]-->
<script language="javascript" type="text/javascript" src="<?php echo tep_catalog_href_link('ext/jquery/jquery-1.4.2.min.js'); ?>"></script>
<script language="javascript" type="text/javascript" src="<?php echo tep_catalog_href_link('ext/flot/jquery.flot.js'); ?>"></script>
<?php
}
?>

 

The reason is that it would give better performance. For example the login page do not need the Dashboard.

 

So, what's your thoughts of the above?

 

Sara

Share this post


Link to post
Share on other sites

All pages use jQuery to load the buttons. Since the jQuery files are cached locally when the first page is loaded, you wouldn't notice any difference anyway.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@@kymation

Hi Jim. Yes, you are right. Apart from the buttons it's used for the datepicker and in the dashboard...

Since jQuery do have bugs, I wonder which version of it is the "best" to use?

I am thinking of take the last version that can be used for legacy browsers like IE, and then debug it.

Thanks for your answer.

 

Sara

Share this post


Link to post
Share on other sites

:blink:
osCommerce based shop owner with minimal design and focused on background works. When the less is more.
Email managment with tracking pixel, package managment for shipping, stock management, warehouse managment with bar code reader, parcel shops management on 3000 pickup points without local store.

Share this post


Link to post
Share on other sites

@@Juto I would use the latest version if you want to replace or update the theme, then patch any errors that affect your store. In the current version that's the base bug.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Sorry for being a pain... but I still don't get it!

 

I get .." The password reset link was not found in our records, please try again by generating a new link. " when trying to reset the password.

 

The thing is I can't see Security Pro anywhere in my "includes/application_top.php". In orther words I do not even know if I have Security Pro FWR (My site was put together for me about a year ago)

 

Please help! I just want to be able to reset password.

 

BTW Many thanks for the instructions ...this is my first time ever doing an upgrade & it seems it went well from 1 to 2 to 3

Share this post


Link to post
Share on other sites

Harald resolved my problem. For anyone having the same issue...

 

Go to "password_forgotten.php" search that page for $reset_key_url and change the following part:

 

if ( strpos($reset_key_url, '&') !== false ) {

$reset_key_url = str_replace('&', '&', $reset_key_url);

}

 

To:

 

if ( strpos($reset_key_url, '&') !== false ) {

$reset_key_url = str_replace('&', '&', $reset_key_url);

}

 

 

..The fix is shown at link below

https://github.com/haraldpdl/website_library/commit/a78adcae8faf73e89cb52feacf3ff7bc2e27136e

Share this post


Link to post
Share on other sites

Hi, Timo, open up your Danish languages files and just resave them in utf-8 encoding. I think they are ANSI encoded.

Sara

 

Finally figured it out.

Thank you so much for helping a novice in this aspect.

I installed notepad++ (dont know how i survuved this long without). You are right, it was ANSI, Now Ansi with UTF8, And it works.

I didnt figure out how to change the encoding, but i copied the content from the original, created a new UTF8 document and pasted to it, Saved it over the original file. Now on to the rest of the files.....


Timo Jensen

Share this post


Link to post
Share on other sites

Good morning. I downloaded V2.3.2 to my desktop expecting an *.exe file to be in the folder. There isn't one. How do I upgrade to 2.3.2. I'll need to upgrade to V3.2.3 after that as well since the tempalte I'm purchasing requires it. Any help qwould be most appreciated.

 

Paul

Share this post


Link to post
Share on other sites

×