Jump to content
FWR Media

KissIT Image Thumnailer

Recommended Posts

@@Rainer

 

The only problem I have now is, when I remove these 3 lines, then the themes is no more possible to change. I don't know why. I asked also in the support forum from the theme switcher, but no answer.

 

Wha can I do now?

Share this post


Link to post
Share on other sites

@@cramli,

 

Forum maintainers are not always online and may take some days to answer.

I downloaded the newest theme switcher version and compared the included template_top.php with yours.

It's not the same.

Download the newest theme switcher:

Go to:

http://addons.oscommerce.com/info/7663

Click on "History"

download: Theme Switcher 1.4.4

follow the instructions to update.

The main difference is that they do not delete these famous 3 lines in the ht_theme_switcher.php header tag, but they remove them in template_top.php

 

regards

Rainer

Share this post


Link to post
Share on other sites

@@Rainer

 

Done.

I made the changes so far but the pictures are still all the same size. Why or what I have to change again?

 

Any idea how to resize the addidional pictures?

Have a look here http://apromo.com.br/product_info.php/cPath/45/products_id/75/language/en

 

Thank you for helping

Edited by cramli

Share this post


Link to post
Share on other sites

@@Rainer

 

Could be the problem in my Stylesheet? 

 

Here a part of it:

 

.contentContainer {
  padding-bottom: 50px;
  padding: 35px;
}
 
.contentContainer h2 {
font-size: 16px;
font-weight: normal;
text-decoration: none;
margin-bottom: 0;
padding-bottom: 5px;
}
 
.contentText, .contentText table {
font-size: 12px;
line-height: 2.0;
 
}
 
.productListTable {
  padding: 5px;
  font-size: 11px;
  line-height: 1.5;
}
 
.productListTable tr.alt td {
  background-color: #ecf6fc;
}
 
.fieldKey {
  font-size: 11px;
  font-weight: bold;
  line-height: 1.5;
  width: 150px;
}
 
.fieldValue {
  font-size: 11px;
  line-height: 1.5;
}
 
// h1 {
  font-size: 20px;
  margin-bottom: 0;
  padding-bottom: 5px;
}
 
img {
  border: 0px;
}
 
table, p {
  font-size: 11px;
  line-height: 1.5;
}
 
#piGal {
  float: right;
  width: 250px;
}
 
#piGal img {
  max-width: 250px;
  height: auto;
}
#piGal ul.thumbs li img{height: 50px !important;}

Share this post


Link to post
Share on other sites

@@Rainer

 

Something strange, in the source code after removing in the template_top.php these lines are still coming back?? :(

Share this post


Link to post
Share on other sites

@@Rainer

 

I found the problem why in the source code it was twice. I had to remove <?php echo $oscTemplate->getBlocks('header_tags'); ?> in the template_top.php because I had it twice :(.

But now the problem is, how I can manage that the additional pictures are a little bigger?

 

Here the link : http://apromo.com.br/product_info.php/cPath/45/products_id/75/language/en

Thank you

Share this post


Link to post
Share on other sites

@@cramli,

 

I'm sorry, but I told you already that this is probably hardcoded in the colorbox script and I have no idea.

Please search for the correct forum for that problem and post it there.

Please consider that we are all doing this support for free and our time is limited.

If you are in hurry and can't find an answer you can always post in the commercial support forum.

 

Best regards

Rainer

Edited by raiwa

Share this post


Link to post
Share on other sites

@@Rainer

Sorry I forgot that I asked this once. Of corse I will try to fin the right forum.

 

Thank you again for helping and it was very helpfull from your side.
 

Best regards

Share this post


Link to post
Share on other sites

Been awhile since I install this one. Tried it on a fresh install of 2.3.4 didn't work out.  So I decided to try on a fresh install of 2.3.2 and got a surprise. txomega.net/whats up.png Add the http: if you would like to see it.

Edited by badbo

Share this post


Link to post
Share on other sites

Been awhile since I install this one. Tried it on a fresh install of 2.3.4 didn't work out.  So I decided to try on a fresh install of 2.3.2 and got a surprise. txomega.net/whats up.png Add the http: if you would like to see it.

@@badbo,

Which exact version did you download, please post the link to the add-on, and on which osc2.3.4 version did you try to install it, standard 2.3.4 or bootstrap?

Edited by raiwa

Share this post


Link to post
Share on other sites

@@badbo,

Which exact version did you download, please post the link to the add-on, and on which osc2.3.4 version did you try to install it, standard 2.3.4 or bootstrap?

KissIT_image_thumbnailer_r9 on 2.3.2 and 2.3.4 not BS That snapshot I posted only happened on one monitor on every page. I tried on another server and different monitor in same room all was normal. I still don't think things are working correctly. When I use gtmetrix to check. Have a very poor score for scaled images. Will put both sites up for you to see if and when you have time.

txomega.com and txomega.net both are running. I could not make the changes for product_info.php because those edits are not there to make. Thanks

Share this post


Link to post
Share on other sites

KissIT_image_thumbnailer_r9 on 2.3.2 and 2.3.4 not BS That snapshot I posted only happened on one monitor on every page. I tried on another server and different monitor in same room all was normal. I still don't think things are working correctly. When I use gtmetrix to check. Have a very poor score for scaled images. Will put both sites up for you to see if and when you have time.

txomega.com and txomega.net both are running. I could not make the changes for product_info.php because those edits are not there to make. Thanks

.com is 2.3.4 .net is 2.3.2

Share this post


Link to post
Share on other sites

.com is 2.3.4 .net is 2.3.2

@@badbo,

 

You have a totally confusing setup and you are giving totally confusing information:

1. You say you tried on fresh installs, but your store is modified with a template. Thats why your snapshot looks how it looks.

2. You say you didn't apply the changes to product_info and it's where the kissit modifications are applied. They are not applied on the product listings. There your images point to: images/small/........not to: includes/modules/kiss_image_thumbnailer/thumbs/........

3. "When I use gtmetrix to check. Have a very poor score for scaled images." What do you expect if your images are still scaled from 150x150 to 80x80 in the product listings.

4. In the 2.3.4 store txomega.com you point in the header to the bxgallery and fancybox scripts (included in older versions until 2.3.3.4);

<script type="text/javascript" src="ext/jquery/bxGallery/jquery.bxGallery.1.1.min.js"></script>
<link rel="stylesheet" type="text/css" href="ext/jquery/fancybox/jquery.fancybox-1.3.4.css" />
<script type="text/javascript" src="ext/jquery/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
But in product_info.php you are using the colorbox and photogrid script of 2.3.4:

<script type="text/javascript">
$(function() {
  $('#piGal').css({
    'visibility': 'hidden'
  });

  $('#piGal').photosetGrid({
    layout: '1',
    width: '250px',
    highresLinks: true,
    rel: 'pigallery',
    onComplete: function() {
      $('#piGal').css({ 'visibility': 'visible'});

      $('#piGal a').colorbox({
        maxHeight: '90%',
        maxWidth: '90%',
        rel: 'pigallery'
      });

      $('#piGal img').each(function() {
        var imgid = $(this).attr('id').substring(9);

        if ( $('#piGalDiv_' + imgid).length ) {
          $(this).parent().colorbox({ inline: true, href: "#piGalDiv_" + imgid });
        }
      });
    }
  });
});
</script>
Please if you claim that something doesn't work, try first on a unmodified store installation.

 

regards

Rainer

Edited by raiwa

Share this post


Link to post
Share on other sites

@@badbo,

 

You have a totally confusing setup and you are giving totally confusing information:

1. You say you tried on fresh installs, but your store is modified with a template. Thats why your snapshot looks how it looks.

2. You say you didn't apply the changes to product_info and it's where the kissit modifications are applied. They are not applied on the product listings. There your images point to: images/small/........not to: includes/modules/kiss_image_thumbnailer/thumbs/........

3. "When I use gtmetrix to check. Have a very poor score for scaled images." What do you expect if your images are still scaled from 150x150 to 80x80 in the product listings.

4. In the 2.3.4 store txomega.com you point in the header to the bxgallery and fancybox scripts (included in older versions until 2.3.3.4);

<script type="text/javascript" src="ext/jquery/bxGallery/jquery.bxGallery.1.1.min.js"></script>
<link rel="stylesheet" type="text/css" href="ext/jquery/fancybox/jquery.fancybox-1.3.4.css" />
<script type="text/javascript" src="ext/jquery/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
But in product_info.php you are using the colorbox and photogrid script of 2.3.4:

<script type="text/javascript">
$(function() {
  $('#piGal').css({
    'visibility': 'hidden'
  });

  $('#piGal').photosetGrid({
    layout: '1',
    width: '250px',
    highresLinks: true,
    rel: 'pigallery',
    onComplete: function() {
      $('#piGal').css({ 'visibility': 'visible'});

      $('#piGal a').colorbox({
        maxHeight: '90%',
        maxWidth: '90%',
        rel: 'pigallery'
      });

      $('#piGal img').each(function() {
        var imgid = $(this).attr('id').substring(9);

        if ( $('#piGalDiv_' + imgid).length ) {
          $(this).parent().colorbox({ inline: true, href: "#piGalDiv_" + imgid });
        }
      });
    }
  });
});
</script>
Please if you claim that something doesn't work, try first on a unmodified store installation.

 

regards

Rainer

 

Seems you missed the part where i said the image i posted just showed on one monitor and not the monitor next to it on a different machine. What I should have said is the edits for the product_info.php are not in 2.3.4 because bx gallery is not there and the edits won't work. I did not mean the mod does not work. I just wanted to know if there is a setting to get those images scaled on the index. Thanks

Edited by badbo

Share this post


Link to post
Share on other sites

@@badbo,
 

Seems you missed the part where i said the image i posted just showed on one monitor and not the monitor next to it on a different machine.

I didn't mention that because it's secondary. It may be related to browsers cache or missing javascript or whatever. First try to install KissIt add-on correct.

 

What I should have said is the edits for the product_info.php are not in 2.3.4 .....

 KissIt modifications are applied to your txomega.com 2.3.4 store product_info.php:

<a href="http://txomega.com/images/small/comp/DHSSDSC2BB480G401.jpg" target="_blank"><img width="300" height="200" src="includes/modules/kiss_image_thumbnailer/thumbs/300x200_DHSSDSC2BB480G401.jpg" title="" alt="" hspace="5" vspace="5" id="piGalImg_1" /></a>

I did not mean the mod does not work.

Tried it on a fresh install of 2.3.4 didn't work out.

?????????????????????????????????????
 
 

I just wanted to know if there is a setting to get those images scaled on the index.

There are 3 conditions to get KissIt  to work:
1. the catalog/includes/modules/kiss_image_thumbnailer/thumbs directory must be writeabel.
    This seems to be ok on your stores, it works on the product_info page and category images.
2. height and width for images must be set to a numeric value.
    This seems to be done in your product listing: <img src=........ width="80" height="80" />
3. The tep_image function must be used to call images. I can't check this in the html source code.This should be the reason why it doesn't work on your product listing.
     Please check this and post the code lines where the images are called in includes/modules/product_listing.php
 
KissIT works correct on your index for the category images:
http://txomega.com/includes/modules/kiss_image_thumbnailer/thumbs/100x57_DHMB994IPO3SB.jpg
 
It may also be possible that the problem is related to the modifications of your template. In that case you should ask your template providers for help.
 
regards
Rainer

Edited by raiwa

Share this post


Link to post
Share on other sites

I've read this topic three times and still can't figure this out. 

 

I've installed the r9 version on a 2.2 (but heavily modified) shop. It does work on the product images. However I have two boxes on my product page where the images are not being thumbnailed. 

 

This is the code for one: 

'text' => '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $some_products['products_id']) . '" title="' . $some_products['products_name'] . '">' . tep_image(DIR_WS_IMAGES . $some_products['products_image'], $some_products['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '<br />' . $some_products['products_name'] . '</a><br>' . '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $some_products['products_id']) . '">' . $currencies->display_price($some_products['products_price'], tep_get_tax_rate($some_products['products_id'])) . '</a>');

As you see the tep_image is there with the correct small_image_width etc. What is causing it to not work?

 

I have another box on the same page, it's not working either:

$info_box_text .= tep_image(DIR_WS_IMAGES . $products_data[$products_id]['image'], $products_data[$products_id]['name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="2" vspace="3"');

Can anyone help me?

 

Thank you in advance.

Share this post


Link to post
Share on other sites

Ok, I got the first box thumbnailed. I had to change the size in admin from 0 to 80. It worked. Now I can't get this code right to make it work. 

$info_box_text .= tep_image(DIR_WS_IMAGES . $products_data[$products_id]['image'], $products_data[$products_id]['name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="2" vspace="3"');

Share this post


Link to post
Share on other sites

@,

Just to be sure: small_image_width and height is defined with a numeric value in admin : configuration : images?
Can you please post your store URL. If you prefer not to publish it, you can send me a private message.

Share this post


Link to post
Share on other sites

 

Ok, I got the first box thumbnailed. I had to change the size in admin from 0 to 80. It worked. Now I can't get this code right to make it work. 

$info_box_text .= tep_image(DIR_WS_IMAGES . $products_data[$products_id]['image'], $products_data[$products_id]['name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="2" vspace="3"');

ok we published our posts at the same time, taht's it both must be numeric and >0

Share this post


Link to post
Share on other sites

I figured it out, edited the wrong file! Now that I have edited the CORRECT file it works perfectly! Thank you so much Rainer for your help and I apologize for my own stupidity. 

Share this post


Link to post
Share on other sites

I figured it out, edited the wrong file! Now that I have edited the CORRECT file it works perfectly! Thank you so much Rainer for your help and I apologize for my own stupidity. 

Don't worry we are all human :thumbsup:

Share this post


Link to post
Share on other sites

@@badbo,

 

I didn't mention that because it's secondary. It may be related to browsers cache or missing javascript or whatever. First try to install KissIt add-on correct.

 

 

 KissIt modifications are applied to your txomega.com 2.3.4 store product_info.php:

<a href="http://txomega.com/images/small/comp/DHSSDSC2BB480G401.jpg" target="_blank"><img width="300" height="200" src="includes/modules/kiss_image_thumbnailer/thumbs/300x200_DHSSDSC2BB480G401.jpg" title="" alt="" hspace="5" vspace="5" id="piGalImg_1" /></a>

?????????????????????????????????????

 

 

There are 3 conditions to get KissIt  to work:

1. the catalog/includes/modules/kiss_image_thumbnailer/thumbs directory must be writeabel.

    This seems to be ok on your stores, it works on the product_info page and category images.

2. height and width for images must be set to a numeric value.

    This seems to be done in your product listing: <img src=........ width="80" height="80" />

3. The tep_image function must be used to call images. I can't check this in the html source code.This should be the reason why it doesn't work on your product listing.

     Please check this and post the code lines where the images are called in includes/modules/product_listing.php

 

KissIT works correct on your index for the category images:

http://txomega.com/includes/modules/kiss_image_thumbnailer/thumbs/100x57_DHMB994IPO3SB.jpg

 

It may also be possible that the problem is related to the modifications of your template. In that case you should ask your template providers for help.

 

regards

Rainer

          $product[$row]['image_size'] = az_get_image_size(DIR_WS_ . $listing['products_image'], '80', '');
          $product[$row]['image']      = tep_image(DIR_WS_ . $listing['products_image'], $listing['products_name'], '80', '');
seems it is calling get_ image instead of tep_image

Share this post


Link to post
Share on other sites

@@badbo,

 

You have a totally confusing setup and you are giving totally confusing information:

1. You say you tried on fresh installs, but your store is modified with a template. Thats why your snapshot looks how it looks.

2. You say you didn't apply the changes to product_info and it's where the kissit modifications are applied. They are not applied on the product listings. There your images point to: images/small/........not to: includes/modules/kiss_image_thumbnailer/thumbs/........

3. "When I use gtmetrix to check. Have a very poor score for scaled images." What do you expect if your images are still scaled from 150x150 to 80x80 in the product listings.

4. In the 2.3.4 store txomega.com you point in the header to the bxgallery and fancybox scripts (included in older versions until 2.3.3.4);

<script type="text/javascript" src="ext/jquery/bxGallery/jquery.bxGallery.1.1.min.js"></script>
<link rel="stylesheet" type="text/css" href="ext/jquery/fancybox/jquery.fancybox-1.3.4.css" />
<script type="text/javascript" src="ext/jquery/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
But in product_info.php you are using the colorbox and photogrid script of 2.3.4:

<script type="text/javascript">
$(function() {
  $('#piGal').css({
    'visibility': 'hidden'
  });

  $('#piGal').photosetGrid({
    layout: '1',
    width: '250px',
    highresLinks: true,
    rel: 'pigallery',
    onComplete: function() {
      $('#piGal').css({ 'visibility': 'visible'});

      $('#piGal a').colorbox({
        maxHeight: '90%',
        maxWidth: '90%',
        rel: 'pigallery'
      });

      $('#piGal img').each(function() {
        var imgid = $(this).attr('id').substring(9);

        if ( $('#piGalDiv_' + imgid).length ) {
          $(this).parent().colorbox({ inline: true, href: "#piGalDiv_" + imgid });
        }
      });
    }
  });
});
</script>
Please if you claim that something doesn't work, try first on a unmodified store installation.

 

regards

Rainer

 

You said:

2. You say you didn't apply the changes to product_info and it's where the kissit modifications are applied. They are not applied on the product listings. There your images point to: images/small/........not to: includes/modules/kiss_image_thumbnailer/thumbs/........

 

Open catalog/product_info.php in your flat file editor

Find ( about line 88 ) ...

          $pi_entry .= '" target="_blank" rel="fancybox">' tep_image(DIR_WS_IMAGES $pi['image']) . '</a>';

Replace with ...

          $pi_entry .= '" target="_blank" rel="fancybox">' tep_imageDIR_WS_IMAGES $pi['image'], ''KISSIT_MAIN_PRODUCT_IMAGE_WIDTHKISSIT_MAIN_PRODUCT_IMAGE_HEIGHT ) . '</a>';

Find ( about lines 104 - 106 )

$('#piGal ul').bxGallery({

  maxwidth300,

  maxheight200,

Replace with ...

$('#piGal ul').bxGallery({

  maxwidth: <?php echo KISSIT_MAIN_PRODUCT_IMAGE_WIDTH?>,

  maxheight: <?php echo KISSIT_MAIN_PRODUCT_IMAGE_HEIGHT?>,

Find ( about line 118 )...

      <?php echo '<a href="' tep_href_link(DIR_WS_IMAGES $product_info['products_image']) . '" target="_blank" rel="fancybox">' tep_image(DIR_WS_IMAGES $product_info['products_image'], addslashes($product_info['products_name']), nullnull'hspace="5" vspace="5"') . '</a>'?>

Replace with ...

      <?php echo '<a href="' tep_href_link(DIR_WS_IMAGES $product_info['products_image']) . '" target="_blank" rel="fancybox">' tep_imageDIR_WS_IMAGES $product_info['products_image'], addslashes($product_info['products_name']), KISSIT_MAIN_PRODUCT_IMAGE_WIDTHKISSIT_MAIN_PRODUCT_IMAGE_HEIGHT'hspace="5" vspace="5"' ) . '</a>'?>

 

Those edits not available on a fresh download of 2.3.4

<?php

/*
  $Id$
 
  osCommerce, Open Source E-Commerce Solutions
 
  Copyright © 2014 osCommerce
 
  Released under the GNU General Public License
*/
 
  require('includes/application_top.php');
 
  if (!isset($HTTP_GET_VARS['products_id'])) {
    tep_redirect(tep_href_link(FILENAME_DEFAULT));
  }
 
  require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_PRODUCT_INFO);
 
  $product_check_query = tep_db_query("select count(*) as total from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'");
  $product_check = tep_db_fetch_array($product_check_query);
 
  require(DIR_WS_INCLUDES . 'template_top.php');
 
  if ($product_check['total'] < 1) {
?>
 
<div class="contentContainer">
  <div class="contentText">
    <?php echo TEXT_PRODUCT_NOT_FOUND; ?>
  </div>
 
  <div style="float: right;">
    <?php echo tep_draw_button(IMAGE_BUTTON_CONTINUE, 'triangle-1-e', tep_href_link(FILENAME_DEFAULT)); ?>
  </div>
</div>
 
<?php
  } else {
    $product_info_query = tep_db_query("select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'");
    $product_info = tep_db_fetch_array($product_info_query);
 
    tep_db_query("update " . TABLE_PRODUCTS_DESCRIPTION . " set products_viewed = products_viewed+1 where products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and language_id = '" . (int)$languages_id . "'");
 
    if ($new_price = tep_get_products_special_price($product_info['products_id'])) {
      $products_price = '<del>' . $currencies->display_price($product_info['products_price'], tep_get_tax_rate($product_info['products_tax_class_id'])) . '</del> <span class="productSpecialPrice">' . $currencies->display_price($new_price, tep_get_tax_rate($product_info['products_tax_class_id'])) . '</span>';
    } else {
      $products_price = $currencies->display_price($product_info['products_price'], tep_get_tax_rate($product_info['products_tax_class_id']));
    }
 
    if (tep_not_null($product_info['products_model'])) {
      $products_name = $product_info['products_name'] . '<br /><span class="smallText">[' . $product_info['products_model'] . ']</span>';
    } else {
      $products_name = $product_info['products_name'];
    }
?>
 
<?php echo tep_draw_form('cart_quantity', tep_href_link(FILENAME_PRODUCT_INFO, tep_get_all_get_params(array('action')) . 'action=add_product')); ?>
 
<div>
  <h1 style="float: right;"><?php echo $products_price; ?></h1>
  <h1><?php echo $products_name; ?></h1>
</div>
 
<div class="contentContainer">
  <div class="contentText">
 
<?php
    if (tep_not_null($product_info['products_image'])) {
      $photoset_layout = '1';
 
      $pi_query = tep_db_query("select image, htmlcontent from " . TABLE_PRODUCTS_IMAGES . " where products_id = '" . (int)$product_info['products_id'] . "' order by sort_order");
      $pi_total = tep_db_num_rows($pi_query);
 
      if ($pi_total > 0) {
        $pi_sub = $pi_total-1;
 
        while ($pi_sub > 5) {
          $photoset_layout .= 5;
          $pi_sub = $pi_sub-5;
        }
 
        if ($pi_sub > 0) {
          $photoset_layout .= ($pi_total > 5) ? 5 : $pi_sub;
        }
?>
 
    <div id="piGal">
 
<?php
        $pi_counter = 0;
        $pi_html = array();
 
        while ($pi = tep_db_fetch_array($pi_query)) {
          $pi_counter++;
 
          if (tep_not_null($pi['htmlcontent'])) {
            $pi_html[] = '<div id="piGalDiv_' . $pi_counter . '">' . $pi['htmlcontent'] . '</div>';
          }
 
          echo tep_image(DIR_WS_IMAGES . $pi['image'], '', '', '', 'id="piGalImg_' . $pi_counter . '"');
        }
?>
 
    </div>
 
<?php
        if ( !empty($pi_html) ) {
          echo '    <div style="display: none;">' . implode('', $pi_html) . '</div>';
        }
      } else {
?>
 
    <div id="piGal">
      <?php echo tep_image(DIR_WS_IMAGES . $product_info['products_image'], addslashes($product_info['products_name'])); ?>
    </div>
 
<?php
      }
    }
?>
 
<script type="text/javascript">
$(function() {
  $('#piGal').css({
    'visibility': 'hidden'
  });
 
  $('#piGal').photosetGrid({
    layout: '<?php echo $photoset_layout; ?>',
    width: '250px',
    highresLinks: true,
    rel: 'pigallery',
    onComplete: function() {
      $('#piGal').css({ 'visibility': 'visible'});
 
      $('#piGal a').colorbox({
        maxHeight: '90%',
        maxWidth: '90%',
        rel: 'pigallery'
      });
 
      $('#piGal img').each(function() {
        var imgid = $(this).attr('id').substring(9);
 
        if ( $('#piGalDiv_' + imgid).length ) {
          $(this).parent().colorbox({ inline: true, href: "#piGalDiv_" + imgid });
        }
      });
    }
  });
});
</script>
 
<?php echo stripslashes($product_info['products_description']); ?>
 
<?php
    $products_attributes_query = tep_db_query("select count(*) as total from " . TABLE_PRODUCTS_OPTIONS . " popt, " . TABLE_PRODUCTS_ATTRIBUTES . " patrib where patrib.products_id='" . (int)$HTTP_GET_VARS['products_id'] . "' and patrib.options_id = popt.products_options_id and popt.language_id = '" . (int)$languages_id . "'");
    $products_attributes = tep_db_fetch_array($products_attributes_query);
    if ($products_attributes['total'] > 0) {
?>
 
    <p><?php echo TEXT_PRODUCT_OPTIONS; ?></p>
 
    <p>
<?php
      $products_options_name_query = tep_db_query("select distinct popt.products_options_id, popt.products_options_name from " . TABLE_PRODUCTS_OPTIONS . " popt, " . TABLE_PRODUCTS_ATTRIBUTES . " patrib where patrib.products_id='" . (int)$HTTP_GET_VARS['products_id'] . "' and patrib.options_id = popt.products_options_id and popt.language_id = '" . (int)$languages_id . "' order by popt.products_options_name");
      while ($products_options_name = tep_db_fetch_array($products_options_name_query)) {
        $products_options_array = array();
        $products_options_query = tep_db_query("select pov.products_options_values_id, pov.products_options_values_name, pa.options_values_price, pa.price_prefix from " . TABLE_PRODUCTS_ATTRIBUTES . " pa, " . TABLE_PRODUCTS_OPTIONS_VALUES . " pov where pa.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pa.options_id = '" . (int)$products_options_name['products_options_id'] . "' and pa.options_values_id = pov.products_options_values_id and pov.language_id = '" . (int)$languages_id . "'");
        while ($products_options = tep_db_fetch_array($products_options_query)) {
          $products_options_array[] = array('id' => $products_options['products_options_values_id'], 'text' => $products_options['products_options_values_name']);
          if ($products_options['options_values_price'] != '0') {
            $products_options_array[sizeof($products_options_array)-1]['text'] .= ' (' . $products_options['price_prefix'] . $currencies->display_price($products_options['options_values_price'], tep_get_tax_rate($product_info['products_tax_class_id'])) .') ';
          }
        }
 
        if (is_string($HTTP_GET_VARS['products_id']) && isset($cart->contents[$HTTP_GET_VARS['products_id']]['attributes'][$products_options_name['products_options_id']])) {
          $selected_attribute = $cart->contents[$HTTP_GET_VARS['products_id']]['attributes'][$products_options_name['products_options_id']];
        } else {
          $selected_attribute = false;
        }
?>
      <strong><?php echo $products_options_name['products_options_name'] . ':'; ?></strong><br /><?php echo tep_draw_pull_down_menu('id[' . $products_options_name['products_options_id'] . ']', $products_options_array, $selected_attribute); ?><br />
<?php
      }
?>
    </p>
 
<?php
    }
?>
 
    <div style="clear: both;"></div>
 
<?php
    if ($product_info['products_date_available'] > date('Y-m-d H:i:s')) {
?>
 
    <p style="text-align: center;"><?php echo sprintf(TEXT_DATE_AVAILABLE, tep_date_long($product_info['products_date_available'])); ?></p>
 
<?php
    }
?>
 
  </div>
 
<?php
    $reviews_query = tep_db_query("select count(*) as count from " . TABLE_REVIEWS . " r, " . TABLE_REVIEWS_DESCRIPTION . " rd where r.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and r.reviews_id = rd.reviews_id and rd.languages_id = '" . (int)$languages_id . "' and reviews_status = 1");
    $reviews = tep_db_fetch_array($reviews_query);
?>
 
  <div class="buttonSet">
    <span class="buttonAction"><?php echo tep_draw_hidden_field('products_id', $product_info['products_id']) . tep_draw_button(IMAGE_BUTTON_IN_CART, 'cart', null, 'primary'); ?></span>
 
    <?php echo tep_draw_button(IMAGE_BUTTON_REVIEWS . (($reviews['count'] > 0) ? ' (' . $reviews['count'] . ')' : ''), 'comment', tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params())); ?>
  </div>
 
<?php
    if ((USE_CACHE == 'true') && empty($SID)) {
      echo tep_cache_also_purchased(3600);
    } else {
      include(DIR_WS_MODULES . FILENAME_ALSO_PURCHASED_PRODUCTS);
    }
?>
 
</div>
 
</form>
 
<?php
  }
 
  require(DIR_WS_INCLUDES . 'template_bottom.php');
  require(DIR_WS_INCLUDES . 'application_bottom.php');
?>

Share this post


Link to post
Share on other sites

 

 

@@badbo,

 

I know this:

Those edits not available on a fresh download of 2.3.4

 

And it's just what you tried on your txomega.com 2.3.4 store product_info.php:

<a href="http://txomega.com/images/small/comp/DHSSDSC2BB480G401.jpg" target="_blank"><img width="300" height="200" src="includes/modules/kiss_image_thumbnailer/thumbs/300x200_DHSSDSC2BB480G401.jpg" title="" alt="" hspace="5" vspace="5" id="piGalImg_1" /></a>

I only wanted to explain why the product images do not show on your txomega.com 2.3.4 store product_info.php.

It's all explained: your header is wrong, it's not 2.3.4, and your modifications are wrong. That's all.

If you download the newest version for 2.3.4BS, youll find instructions how to modify the 2.3.4 product_info.php.:

http://addons.oscommerce.com/info/9206

 

 

          $product[$row]['image_size'] = az_get_image_size(DIR_WS_ . $listing['products_image'], '80', '');
          $product[$row]['image']      = tep_image(DIR_WS_ . $listing['products_image'], $listing['products_name'], '80', '');
seems it is calling get_ image instead of tep_image

 

That's it.

You can try to tweak the az_get_image_size funktion to work with kissit or to add a numeric value for height.

Try this:

    $product[$row]['image_size'] = az_get_image_size(DIR_WS_ . $listing['products_image'], '80', '80');
          $product[$row]['image']      = tep_image(DIR_WS_ . $listing['products_image'], $listing['products_name'], '80', '80');
seems it is calling get_ image instead of tep_image

Or contact your template provider for help.

Finally you paid them for the template, I suppose, and they should give you support for it. :-

 

regards

Rainer

Edited by raiwa

Share this post


Link to post
Share on other sites

@@badbo,

 

I know this:

 

And it's just what you tried on your txomega.com 2.3.4 store product_info.php:

<a href="http://txomega.com/images/small/comp/DHSSDSC2BB480G401.jpg" target="_blank"><img width="300" height="200" src="includes/modules/kiss_image_thumbnailer/thumbs/300x200_DHSSDSC2BB480G401.jpg" title="" alt="" hspace="5" vspace="5" id="piGalImg_1" /></a>

I only wanted to explain why the product images do not show on your txomega.com 2.3.4 store product_info.php.

It's all explained: your header is wrong, it's not 2.3.4, and your modifications are wrong. That's all.

If you download the newest version for 2.3.4BS, youll find instructions how to modify the 2.3.4 product_info.php.:

http://addons.oscommerce.com/info/9206

 

That's it.

You can try to tweak the az_get_image_size funktion to work with kissit or to add a numeric value for height.

Try this:

    $product[$row]['image_size'] = az_get_image_size(DIR_WS_ . $listing['products_image'], '80', '80');
          $product[$row]['image']      = tep_image(DIR_WS_ . $listing['products_image'], $listing['products_name'], '80', '80');
seems it is calling get_ image instead of tep_image

Or contact your template provider for help.

Finally you paid them for the template, I suppose, and they should give you support for it. :-

 

regards

Rainer

Thanks Rainer i will give it a try

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×