Jump to content
Latest News: (loading..)
FWR Media

KissIT Image Thumnailer

Recommended Posts

Hi Robert,

 

I installed KissIT Image Thumbnailer and it works great, but i have one issue.

 

We also have MailBeez and after installing KissIT ,MailBeez stopped working ?

 

after hrs of bug-fixing Cord from MailBeez found out, that your tep_image() function is causing issues.

Our current guess is that by extending the ArrayObject:

 

Image_Helper extends ArrayObject {

}

 

the code interfers with the MailBeez system.

 

Do you know a way to solve this problem so that I can run both modules ?

Share this post


Link to post
Share on other sites

There is no reason for any conflict .. unless Mailbeez have been daft enough to use the class name of one of the SPL classes.

Share this post


Link to post
Share on other sites

This code is the reason why Mailbeez doesn't work.

$image = mh_image($img_folder . $products_array['products_image'], $products_array['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="10" vspace="0" align="left" border="0"');

 

I tryed to changed it to

$image = mh_image($img_folder . $products_array['products_image'], $products_array['products_name'], KISSIT_MAIN_PRODUCT_IMAGE_WIDTH, KISSIT_MAIN_PRODUCT_IMAGE_HEIGHT, 'hspace="10" vspace="0" align="left" border="0"');

 

But didn't work.

 

Any idea's ?

Edited by Ps4Life

Share this post


Link to post
Share on other sites

@@Ps4Life

 

That code uses a function called mh_image, KissIT uses tep_image.

 

Quite simply if tep_image is used and the relative image path exists and height and width are numeric then KissIT will generate an image.

 

You need to look at this mh_image code.

Edited by FWR Media

Share this post


Link to post
Share on other sites

great work as alway FWR!

 

 

.jpg works great.

.png dont work.

any fix for that? or is it just me? :)

 

another question.

is there any tip on how to hide the thumbnail folder? htaccess rewrite? or maby change it to catalog/thumbnail/

instead?

thought for secuirty reason? maby useless idont know. just got a feeling thats no reason showing of subfolders like that.

 

 

thanks again for a great addon!

if everyone would be like you.. what a wonderful world.

Share this post


Link to post
Share on other sites

@@snights

 

PNG works fine my end but i want to do some transparency testing .. could you send me a large image example that "doesn't work" please,

Share this post


Link to post
Share on other sites

@@FWR Media I've sent you a PM with image .png.

 

Another "error". saw that my pixel_trans.gif got a thumbnail now and its white not transparency.

Maybe same thing or maby its something wrong with the person behind screen. (me :) )

Share this post


Link to post
Share on other sites

@@snights

 

Well the image you sent worked at my end. I have however done some work on transparencies.

 

Send me your email and I'll send you a new kiss_image_thumbnailer/classes/image.php to try out.

Share this post


Link to post
Share on other sites

If anyone is struggling with transparencies could you please try the attached and post here your findings.

 

If you try this new file be sure to delete all current thumbs in the thumbs directory otherwise you will just see the old versions .. also hard refresh the browser as the old images may be cached.

 

The attached file replaces: -

 

catalog/includes/modules/kiss_image_thumbnailer/classes/Image.php

Image.php

Edited by FWR Media

Share this post


Link to post
Share on other sites

Nice contribution and working very good. The only question is, where can I change the background color.

 

Thank you

and best regards

 

Marc

Share this post


Link to post
Share on other sites

@@cramli

 

The code you put in the includes/functions/html_output.php tep_image() function.

 

Change the RGB colours.

Share this post


Link to post
Share on other sites

IYou mean this part of the code: // The HTML image wrapper function

function tep_image_legacy($src, $alt = '', $width = '', $height = '', $parameters = '') {

if ( (empty($src) || ($src == DIR_WS_IMAGES)) && (IMAGE_REQUIRED == 'false') ) {

return false;

 

Can you show me please a example how to write the backgroun color in this code?

 

Other question: For what is the style.css file in this add on and is is right to put it in: root/include?

Share this post


Link to post
Share on other sites

@@cramli

 

you are uploading the wrong files, the only files that should be uploaded are those in the "uploads" directory.

 

Re: background:

 

When you installed, when you ( hopefully ) followed the instructions you added some code to includes/html_output.php, some of which looked like the following: -

 

$image = new Image_Helper( array( 'src' => $src,

'attributes' => $attributes,

'parameters' => $parameters,

'default_missing_image' => DIR_WS_IMAGES . 'no_image_available_150_150.gif',

'isXhtml' => true,

'thumbs_dir_path' => DIR_WS_MODULES . 'kiss_image_thumbnailer/thumbs/',

'thumb_quality' => 75,

'thumb_background_rgb' => array( 'red' => 255,

'green' => 255,

'blue' => 255 ) ) );

 

You change the red/green/blue values.

 

After you have done so you need to delete all of the thumbs that have already been generated.

Share this post


Link to post
Share on other sites

Ok and where can I delete the generated Thumbs?

 

So that means the style.css file is not needet, right?

Share this post


Link to post
Share on other sites

Rob, I made a mistake and now it works like a charme. The only question is, for what is this style.css file?

Share this post


Link to post
Share on other sites

@@cramli

 

The instructions for the contribution are very clear, please follow them.

 

This thread is here to support the contribution, discuss/solve any problems etc.

 

Your posts are, generally, not related to the support of the contribution but related to the fact that you are new to osCommerce and don't understand the basics, which is of course fine .. but please ask these questions in the general forum and not in this support thread.

 

Why? because people look here to solve any issues they may have with KissIT and they won't be able to find help because it is full of unrelated questions.

Share this post


Link to post
Share on other sites

Rob, I made a mistake and now it works like a charme. The only question is, for what is this style.css file?

 

There IS no style.css file in the uploads directory as I've already explained.

Share this post


Link to post
Share on other sites

Ok, I will do so. Just one thing:

In the whole code file when I click on documentation and then are there the following files:

-installation.htm

-2_3_1_product_info.htm

-includes

 

When I click on includes there is this the style.css and fwrlogo.png files. For what there are?

Share this post


Link to post
Share on other sites

@@cramli

 

Style and images for the documentation you need to read in order to install it correctly.

Share this post


Link to post
Share on other sites

Why you can not answer to this?

 

In the general forum I could't find a answer. So please answer

 

Thank you and best regards

 

Marc

Share this post


Link to post
Share on other sites

Thanks for a great contribution! Very easy install/setup! I just have one question. The pics on the categories are re-sizing properly, but the pics on my pages are not. I did set the folders to 777 to make sure they could be written. I am running OSC 2.3.3 / PHP 5.3.14.

Thanks again,

Dave

Edited by videod

Share this post


Link to post
Share on other sites

Never mind.. I found the second part of the install (duh!). Anyway, do the Manufacturer Info box images pass through the wrapper?

 

Thanks again,

 

Dave

Edited by videod

Share this post


Link to post
Share on other sites

Hi Roberts!

 

Great work!

 

an attribute value must be a literal unless it contains only name characters

…="The Matrix" alt="The Matrix" hspace=&quot;5" vspace="5" /></a…

 

I was looking for many times, but this was very simple finaly.

 

when install for bcGallery

 

Find ( about line 118 )...

 

  <?php echo '<a href="' . tep_href_link(DIR_WS_IMAGES . $product_info['products_image']) . '" target="_blank" rel="fancybox">' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], addslashes($product_info['products_name']), null, null, 'hspace="5" vspace="5"') . '</a>'; ?>

 

would be more valid if change like this

 

to:

  <?php echo '<a href="' . tep_href_link(DIR_WS_IMAGES . $product_info['products_image'], '', 'NONSSL', false) . '" target="_blank" rel="fancybox">' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], addslashes($product_info['products_name']), KISSIT_MAIN_PRODUCT_IMAGE_WIDTH, KISSIT_MAIN_PRODUCT_IMAGE_HEIGHT, "hspace='5' vspace='5'") . '</a>'; ?>

 

Just the comas: "hspace='5' vspace='5'".

 

Regards,

Gergely


:blink:
osCommerce based shop owner with minimal design and focused on background works. When the less is more.
Email managment with tracking pixel, package managment for shipping, stock management, warehouse managment with bar code reader, parcel shops management on 3000 pickup points without local store.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×