Jump to content
Sign in to follow this  
nan

Is anybody using the Template System?

Recommended Posts

Does anyone else have a lof of broken page headers. on my privacy page it says Heading_TITLE. Still got nothign but good reviews from the lok of the site

Share this post


Link to post
Share on other sites

someone please answer that is all I have to do to get my site online. im waiting for you Peter :oops:

Share this post


Link to post
Share on other sites
Does anyone else have a lof of broken page headers. on my privacy page it says Heading_TITLE. Still got nothign but good reviews from the lok of the site

 

Please add in the URL so I can have a look....

 

But, the site text editor will allow you to add in any HEADING_TITLE defines to the system...

 

To do so, you will need to click on the site text editor

 

click on the page that the text is located on, click on new

 

the next page will allow you to add in the text, just follow the instructions provided with the editor tool.....

 

cheers and HTH


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

my shop is

 

http://www.tank27.com/shop/default.php

 

when you get there you will see that the mainpage.php will not show up and if you look in the privacy statement you ll see the broken text also when you order a product you will see that the checkout page (i think the third page) a lot of text is broken

Share this post


Link to post
Share on other sites
To do so, you will need to click on the site text editor

 

click on the page that the text is located on, click on new

 

the next page will allow you to add in the text, just follow the instructions provided with the editor tool.....

 

there is no new button on the text editor page

Share this post


Link to post
Share on other sites
there is no new button on the text editor page

 

try insert...sorry.....

 

I seen your problem, did you enter all of the fields info when you created the page??

 

I have made up dozens of pages and they all have the info set into the db...

 

 

BTW your site is starting to look pretty good...

 

 

cheers,


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

I know I love the temp I chose. Did you see the problem Im having with mainpage.php. no matter what I do I cant get it to show up on my default.php any idea why. BTW. Let me know and Ill hook you up whit some free stuff

Share this post


Link to post
Share on other sites
I know I love the temp I chose. Did you see the problem Im having with mainpage.php. no matter what I do I cant get it to show up on my default.php any idea why.

 

try this URL (I use index.php)

 

http://www.tank27.com/shop/index.php

 

but it is broken for some reason (did you play with it??)....I will be changing it somewhat, email me and I will send you an unbroken file.....

 

BTW. Let me know and Ill hook you up whit some free stuff

 

my favorite word too FREE :lol: :lol:

 

I am always looking for free stuff....

 

cheers and HTH


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

I see the index.php file and I got it to work. But my mainpage.php works in index.php and not default.php and my new products box works in default.php and not index. that is weird

Share this post


Link to post
Share on other sites

ok here is what is in the default.php page in includes/body

 

<?php

 if ($category_depth == 'nested') {

   $category_query = tep_db_query("select cd.categories_name, c.categories_image from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.categories_id = '" . $current_category_id . "' and cd.categories_id = '" . $current_category_id . "' and cd.language_id = '" . $languages_id . "'");

   $category = tep_db_fetch_array($category_query);

?>

   <td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="0">

     <tr>

       <td><table border="0" width="100%" cellspacing="0" cellpadding="0">

         <tr>

           <td class="pageHeading"><?php echo HEADER_TITLE; ?></td>

           <td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

         </tr>

       </table></td>

     </tr>

     <tr>

       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

     </tr>

     <tr>

       <td><table border="0" width="100%" cellspacing="0" cellpadding="2">

         <tr>

           <td><table border="0" width="100%" cellspacing="0" cellpadding="2">

             <tr>

<?php

 

I had made the modifications we talked about but still no luck

Share this post


Link to post
Share on other sites

Has no one got mainpage.php to work in the template from hosting-osc.com. i cant get this to work no matter how hard I try

Share this post


Link to post
Share on other sites

That is your index.php file not your default.php file. I want my mainpage to show up on my default page like the 2.1 of oscommerce

Share this post


Link to post
Share on other sites
That is your index.php file not your default.php file. I want my mainpage to show up on my default page like the 2.1 of oscommerce

 

Have you looked at the contribution instructions?

 

pretty much all you have to do is add in the code which calls the mainpage box....

 

this code is placed in the cat/includes/body/default.php file....

 

Sorry I have been a little swamped here lately....but the instructions with the contribution are very clear.....my system does not deviate from osc very much and all contributions which work with osc MS1 will work with my system....

 

cheers


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

ok. i did that but it does not format the box correctly. it puts it to the left of the new products box. and for some reason the box doesnt look right. look at me www.tank27.com/shop/index.php and see what you think?

Share this post


Link to post
Share on other sites

OK I have gone away from default.php and went to index.php. I think I might like this better actually after loking at some live shops.

 

check me out www.tank27.com

 

Peter who made this template because I want to know how to put a banner at the bottom. I went to vipixel but that site was not much help

Share this post


Link to post
Share on other sites

Hi

I am trying to add the above contribution to my store... but I am having a problem installing because there has been some changes made to the language files part of oscommerce... for e.g listed below are some of the install instructions for the Purchace without account V.0.59..

 

To Install:  

Copy the files as they occur in their appropriate directories, be sure to backup your originals first in case you don't like it, or more likely I missed something, better to be on the safe side.  

 

/catalog/login.php  

/catalog/Order_Info.php  

/catalog/Order_Info_Process.php  

/catalog/Order_Info_Check.php  

/catalog/includes/login_pwa.php  

/catalog/includes/login_acc.php  

/catalog/includes/modules/Order_Info_Process.php  

/catalog/includes/modules/Order_Info_Check.php  

/catalog/includes/modules/languages/english/login.php

/catalog/includes/modules/languages/english/images/buttons/button_create_account.gif  

 

Database changes new as of v0.57  

 

INSERT INTO configuration_group VALUES (40, 'Accounts', 'Configuration of Account settings', 40, 1);  

 

INSERT INTO configuration VALUES ('', 'Purchase Without Account', 'PWA_ON', 'true', 'Allow Customers to purchase without an account', 40, 1, '2003-04-08 13:07:44', '2003-04-08 12:10:51', NULL, 'tep_cfg_select_option(array('true', 'false'),');  

 

 

You need to open some files and add some lines also, follow the instructions below and you should be ready in no time.

 

 

The one in bold does not exist in your template contribution...

 

Can any one help with this one :lol:

 

Malc

Share this post


Link to post
Share on other sites

TANK27 wrote:

 

Peter who made this template because I want to know how to put a banner at the bottom. I went to vipixel but that site was not much help

 

I cannot tell a lie it was I

but it looked a little better when I did it :wink:

 

You can try inserting the code below just after the following:

 

."<img name="Footer_r3_c1" src="includes/classes/thema/V-BlueBaby/images/spacer.gif" width="1" height="1" border="0" alt="">n";

 

Insert this:

 

if ($banner = tep_banner_exists('dynamic', '468x50')) {

echo "<br>n"

    ."<table border="0" width="100%" cellspacing="0" cellpadding="0">n"

    ."<tr>n"

    ."<td align="center">" . tep_display_banner('static', $banner) . "</td>n"

    ."</tr>n"

    ."</table>n";

 }

 

You will need to add your banner in the admin area.

Share this post


Link to post
Share on other sites
I cannot tell a lie it was I  

but it looked a little better when I did it  

 

How do i take the extra spaces away in the banner area

 

www.tank27.com[/code]

Share this post


Link to post
Share on other sites

If you view your source code it shows the code below that's found in the footer:

 

    <div align="center">

     <img name="Footer_r3_c1" src="includes/template/V-BabyBlue/template_images/spacer.gif" width="1" height="1" border="0" alt>

     <br>

     <table border="0" width="100%" cellspacing="0" cellpadding="0">

       <tr>

         <td align="center">

         <a href="http://www.tank27.com/shop/redirect.php?action=banner&goto=8&osCsid=xxxxxxxxxxxxxxx" target="_blank">

         <img src="images/CABXP3EQ.gif" border="0" alt="WizardsAndWars" title=" WizardsAndWars " width="468" height="60"></a></td>

       </tr>

     </table>

     <br />

     <br />

     <span class="slogan">  </span> <br />

     </div>

 

Remove from your thema_footer.php file the <br /><br /> and the <br /> after your span class

Share this post


Link to post
Share on other sites

well I tried to put contribs into this template system and they are never formatted correctly

Share this post


Link to post
Share on other sites

Which contributions. So far I have integrated several with no problems. Maybe I can help.

 

Has anyone encountered a problem where the Latest News box has an orphan botton if the latest news mod is turned off?


"If you rundown your shadow, you will never catch it"

Bob Marley

Share this post


Link to post
Share on other sites
Which contributions.  So far I have integrated several with no problems. Maybe I can help.

 

Im trying to put the osc affiliates contrib and the forum contrib

Share this post


Link to post
Share on other sites

Hi there,

 

I seem to have intstalled this successfully along side my existing OSC but how do I go about using my existing database. I figured the easiest solution would be to restore my latest backup to the new system but when I do I loose most of my content on the new system. Most obvious is the columns dissapear.

 

Any suggestions?

 

Also, does this system come complete with the header tags controller? I could've sworn it did but for some reason it's not there...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×