Jump to content
Sign in to follow this  
nan

Is anybody using the Template System?

Recommended Posts

just dl'd it again and still getting the same error - in the browser code it looks like:

 

<!-- categories_eof //--><!-- whats_new //-->

<tr>

<td>

</td>

</tr>

<!-- whats_new_eof //-->

<!-- store //-->

<tr>

<td>

<table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td height="14" class="infoBoxHeading"><img src="includes/template/original_osc/blue/infobox/corner_right_left.gif" border="0" alt="" width="15" height="19"></td>

<td width="100%" height="14" class="infoBoxHeading">Site Information</td>

<td height="14" class="infoBoxHeading"><img src="images/pixel_trans.gif" border="0" alt="" width="11" height="14"></td>

</tr>

</table>

<font color="#000000"><b>1146 - Table 'themes.web_pages' doesn't exist<br><br>select distinct page_name from web_pages order by page_name<br><br><small><font color="#ff0000">[TEP STOP]</font></small><br><br></b></font>

 

 

Site Information1146 - Table 'themes.web_pages' doesn't exist

select distinct page_name from web_pages order by page_name

[TEP STOP]


Reading is beneficial - Searching is enlightening

find answers at wiki.oscommerce.com/top

Share this post


Link to post
Share on other sites

Hi Jeff,

 

I did the zip file up-date about the same time....so you might not have gotten the up-date....

 

if you have a problem, please let me know asap, I have this system up and running on about 6 sites or more and know it runs without problems.

 

As for themes, well I have made up one that follows the same as phpBB,

 

you can see it on line at www.hosting-osc.com (which does have the powered by logo for the forum cops).

 

This one I will be adding to the template package soon, if you want to get the layout, I still have a few more things to work out. If you wanted to make one up, look to the file catalog.php in the templates/osc directory.

 

This file controles how the layout is....in each of the lower folders (colours) I have the buttons, info box images and css file......here you can add additional colours to the layout system.

 

If you do this you will need to update the database table templates to reflect the addition of the new layout/colour scheme...

 

If you are planning on doing this, let me know and I will help you to get it up and operational......

 

didn't you have other 'themes' like 'Dove_Blue" or something like that??

 

If you are interested in additional layouts, contact me via email which would be more appropriate since this topic can lead to contraversy in this forum....

 

cheers,


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

Hi Jeff...

 

The problem is straight forward, switch my theme_boxes/information.php file with a standard one from any osc release.....

 

 

You have my information.php file which is dynamically run......

 

 

sorry.....I will re do the zip file right now to reflect this fix....

 

 

cheers,


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

Hi all,

 

As promised, I have up graded the template system....

 

  • Two Template layouts included

standard osc layout with 6 colour variations

layout based on phpBB (standard silver layout) with 6 colour variations

Roll over buttons (static links only) with the phpBB layout

 

are now included with the standard install package for the system.

 

As well I have had to move the download site to a different server, where I have a lot more band width....

 

was starting to become a problem with the systemsmanager site, so I have moved it to my new site.

 

Please use this link instead of the systemsmanager site

 

www.hosting-osc.com

 

The download is still free for all to get...


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

Since this is the third time it has moved, I hope you imported the customer table, I'm not creating a third account ;) Free or not.


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

Hi Deborah,

 

 

Yes I did import the tables so the customers and orders have been reflected onto the new site, and this will be the last major change in moves, for now on it will reside on that server for free download....

 

The logins will be the same for the store only, you will need to make up an account if you want to use the forum...

 

 

 

cheers,


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

:) thx


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

I just installed it, everything looks good so far, havn't had any problems except the following, when hitting submit on my user account profile, I get the following errror.

 

Parse error: parse error, unexpected '}' in /home/virtual/site14/fst/var/www/html/includes/bottom/account_edit_process.php on line 5

 

Has anyone else had this problem?


-Twenty7

Share this post


Link to post
Share on other sites

errr, bad wording.

I should of said...

 

When hitting submit on the edit user account profile form, I get the error...


-Twenty7

Share this post


Link to post
Share on other sites

Hi there,

 

 

Code:

 

Parse error: parse error, unexpected '}' in /home/virtual/site14/fst/var/www/html/includes/bottom/account_edit_process.php on line 5

 

I will look at this, thanks for pointing it out, if there is a problem there, I will correct it tomorrow....I appreciate the feed back.....I will post a fix if this is necessary tomorrow....

 

 

cheers,


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

Hi,

 

I would like instruction to install the template system only. I have already setup my store with a few contributions and hope not to reinstall the whole store again. Thanks.

 

nj

Share this post


Link to post
Share on other sites

Hi there,

 

 

I have found the problem with the system and have up-dataed the zip file.

 

for those who do not want to re-download the system, the file

 

catalog/includes/bottom/account_edit_process.php should be as follows:

 

 

 

<?php

   $sql_data_array = array('customers_firstname' => $firstname,

                           'customers_lastname' => $lastname,

                           'customers_email_address' => $email_address,

                           'customers_telephone' => $telephone,

                           'customers_fax' => $fax,

                           'customers_newsletter' => $newsletter,

                           'customers_password' => tep_encrypt_password($password));



   if (ACCOUNT_GENDER == 'true') $sql_data_array['customers_gender'] = $gender;

   if (ACCOUNT_DOB == 'true') $sql_data_array['customers_dob'] = tep_date_raw($dob);



   tep_db_perform(TABLE_CUSTOMERS, $sql_data_array, 'update', "customers_id = '" . tep_db_input($customer_id) . "'");



   $sql_data_array = array('entry_street_address' => $street_address,

                           'entry_firstname' => $firstname,

                           'entry_lastname' => $lastname,

                           'entry_postcode' => $postcode,

                           'entry_city' => $city,

                           'entry_country_id' => $country);



   if (ACCOUNT_GENDER == 'true') $sql_data_array['entry_gender'] = $gender;

   if (ACCOUNT_COMPANY == 'true') $sql_data_array['entry_company'] = $company;

   if (ACCOUNT_SUBURB == 'true') $sql_data_array['entry_suburb'] = $suburb;

   if (ACCOUNT_STATE == 'true') {

     if ($zone_id > 0) {

       $sql_data_array['entry_zone_id'] = $zone_id;

       $sql_data_array['entry_state'] = '';

     } else {

       $sql_data_array['entry_zone_id'] = '0';

       $sql_data_array['entry_state'] = $state;

     }

   }



   tep_db_perform(TABLE_ADDRESS_BOOK, $sql_data_array, 'update', "customers_id = '" . tep_db_input($customer_id) . "' and address_book_id = '" . tep_db_input($customer_default_address_id) . "'");



   tep_db_query("update " . TABLE_CUSTOMERS_INFO . " set customers_info_date_account_last_modified = now() where customers_info_id = '" . tep_db_input($customer_id) . "'");



   $customer_country_id = $country;

   $customer_zone_id = $zone_id;



   tep_redirect(tep_href_link(FILENAME_ACCOUNT, '', 'SSL'));



?>

 

please replace the entire file with the above code.....and thanks for pointing this out......any other problems please do not hesitate to report them and I will look to fixing them asap....

 

As well any comments or suggestions are more then welcome......

 

 

cheers and enjoy...


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites
I would like instruction to install the template system only. I have already setup my store with a few contributions and hope not to reinstall the whole store again. Thanks.

 

Well to do this I would suggest that you do the following (to make it easier)

 

upload the system to a test diecrtory

set it up so it is running

any files you have modified with contributions will need to be converted (if you are using MS1)

 

these modified files will need to be changed in the following way:

 

from the

top of the file to the closing ?> tag prior to the <head>
tag needs to be placed into a separate file

 

 

next the main body of the page (marked off by the <!-- body_text //--> and <!-- body_text_eof //-->) needs to be placed into a new file.

 

both of these file are to be named the same as the original filename. The files are to be placed into the main top folder where the original file was and in the directory includes/body respectively....

 

If the original file contains java, then you must do the same as above, and save this file in the includes/java_code directory.

 

There are two exceptions to this, these being the account_edit_process.php file and the create_account_process.php file. the division is similar, but there is a bottom part to the file wich is saved in the same mannor, but in the includes/bottom directory.

 

the java true value will need to be set to either true or false depending if the file uses java or not....

 

 

Have a look at how I have set up the files....in a few different files.....

 

you should be able to swap the application_top.php files in the cat side....as well as the actual code once you the pattern in the code....

 

cheers, and let me know how you are progressing....


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

Hi all,

 

I have updated the template sytem to remove a few bugs found in it, as well as clean up the code a bit.

 

Additional features now include the original features plus a new dynamic page creation system which allows the store owner to add pages of information or articles of interest into the site via a HTML tool in the administration area....

 

As well the system now has over 20 different layout/colour schemes available to choose from via the admin tool made for the system....

 

You can see it in action and download the entire project via my site http://www.hosting-osc.com

 

 

if you find problems with the system please post them via this forum..

 

cheers and enjoy....


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

Sounds interesting, I'll be sure to check it out. What snapshot is this for? Before or after 3/24/03?

 

If it's before I'll be bringing it up to current actually.


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

FYI, this was posted in another thread....

 

Posted: Mon May 19, 2003 11:19 am    Post subject:    

 

--------------------------------------------------------------------------------

 

http://forums.oscommerce.com/faq.php  

 

~ The forum is for information exchange only. Commercial advertising is not allowed.  

~ Any features mentioned in the forums must be freely available under the GPL license and freely downloadable at the Contributions section on the osCommerce support site.  

 


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites
FYI, this was posted in another thread

 

which thread, and who posted this?


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

The Shoppe Enhancement Controller, if you go look, it is around page 2 or 3, but is brought up right on page one.


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites
The Shoppe Enhancement Controller, if you go look, it is around page 2 or 3, but is brought up right on page one.

 

 

I have read that thread, and for the same reasons I am offering it on my site. I contacted Harald to see if I could upload it to the contributions, but it is limited to 300 K.....which is too small even for the layouts and the graphics ...not to mention the system itself......

 

If Harald wants to set up a place where these larger projects can go into, I would be more thn happy to upload it there.....

 

 

cheers,


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

Hi Peter,

 

First let me say thanks for your hard work, for what's sure to be a great mod! Contributors don't seem to get enough support around here anymore, only flack and grief :roll:

 

I have run into a couple of what are probably small problems, maybe you can point me in the right direction. I am running an MS1 catalog with your admin & catalog files.

 

After an install, I got this at default.php:

Fatal error: Cannot redeclare tep_date_raw() (previously declared in /home/lifesalt/public_html/catalog/includes/languages/english.php:27) in /home/lifesalt/public_html/catalog/includes/languages/english.php on line 27

 

I noticed on the english.php file that lines in that area are commented out, but as I'm not proficient in PHP, I can't troubleshoot it.

 

The admin side seems to be working fine, other than the main page editor, where I get "TEXT_FILE_DOES_NOT_EXIST"... what file does this pertain to? It may not have uploaded properly, so if I know while file I can check into it.

 

Any help greatly appreciated!

 

Thanks,

Violet

Share this post


Link to post
Share on other sites

It would probably help if the themers for Dezina_dove (Themesosc), Thema and the gentleman from hosting-osc.com got together and made a uniform system. That would make integration into Osc easier for everyone and insure some uniformity.

 

Just my 2 cents


"If you rundown your shadow, you will never catch it"

Bob Marley

Share this post


Link to post
Share on other sites

Hi there,

 

It would probably help if the themers for Dezina_dove (Themesosc), Thema and the gentleman from hosting-osc.com got together and made a uniform system. That would make integration into Osc easier for everyone and insure some uniformity.

 

 

Tried that, Paul did not ever reply back on this matter......so I went ahead and incorperated the themes into my system, his is still a thema system rather then a template type of system....I I just changed the thema to fit into my system....

 

I have run into a couple of what are probably small problems, maybe you can point me in the right direction. I am running an MS1 catalog with your admin & catalog files.

 

I hope you did a new installation, rather then switch the files around....let me know what you did, I just did a fresh install of it, and noticed I added in the wrong thema versions, so I am just upgrading that.....but the rest works just fine....

 

 

Send me a link via email and I will have a look and let you know what I think....

 

The admin side seems to be working fine, other than the main page editor, where I get "TEXT_FILE_DOES_NOT_EXIST"... what file does this pertain to? It may not have uploaded properly, so if I know while file I can check into it.

 

The admin tool lists the define name that is used in the coding, as well as the page it is on and the text that the defined name ie (TEXT_FILE_DOES_NOT_EXIST) holds....this is all editable via the admin tool you are referring too....

 

 

cheers and HTH


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

Peter,

Just downloaded from your site earlier and all I have is the admin and installs. Is the catalog part separate?


"If you rundown your shadow, you will never catch it"

Bob Marley

Share this post


Link to post
Share on other sites

Also, there are no instructions or cocumentation. Is there a link for the,m


"If you rundown your shadow, you will never catch it"

Bob Marley

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×