Jump to content
Sign in to follow this  
nan

Is anybody using the Template System?

Recommended Posts

If use the Template System made by Peter McGrath, could you share your experience with us... Is this contribution bug free?

 

Thanks in advance.


Nunny

Share this post


Link to post
Share on other sites

Hi all,

 

Yes the beta version has some bugs in it. I have just finished the next version and it is bug free. I have yet to put together any documentation or instructions yet, but will be doing so.

 

The new system is currently set up with

 

MS1

admin section to switch templates (point and click to switch templates)

uses the thema contribution as well

 

if anyone is interested in this I will look to put the instructions as a contribution later next week .....

 

cheers


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

Peter,

 

Your news is great! Please, put it asap! Thank you for your VERY USEFUL contribution.


Nunny

Share this post


Link to post
Share on other sites

Hi all,

 

I have just set up my new site with my template system.

 

If you are interested, you can download the osc project via MY SITE http://www.systemsmanager.net. I would have provided it here but I have not heard back from Harald so I have put it up on my site.

 

This system provides the the following:

 

Admin functionality for the editing of the site text via an html editor, this editor needs IE 5.5 or higher to function correctly.

 

Admin functionality to switch templates being used and thema options as well, so each layout can use the ability to switch colour schemes via the admin tool. Each layout needs only one html page to be created to function correctly.

 

Additionally we have added the following contributions from other developers:

 

CMS site text editor by Peter McGrath

Main Page by Mattice

Download controller by Linda McGrath

Paypal IPN WYSIWYG editor (requires IE 5.5 or higher)

 

I might have added in others if so and I did not mention them, I am sorry, been adding in lots of things all over and not positive if I missed a contribution or two that I added in.

 

The system is working on several sites now and I have not had problems with it yet.....

 

have a look though my site and let me know what you think of the front end tool as well, I now can add in web site information pages and articles via an admin tool with has an WYSIWYG editor in place...

 

cheers,


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

I tried to download and ran into problems. You can't check out without a payment method and it won't take a fake cc number. You may want to add pay by Check as an option and you can set the order to complete.

 

Also, the logged in box has languae file issues.

 

d


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

Hi there...

I have fixed up the login box text.....this is working fine now....

 

The checkout, I left the cod in place, I tried it with that and it worked fine...I will go over it again later....I also added in the cheque option as well for now....

 

 

cheers,


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

I'll go back in, I didn't see COD as an option :)


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

Peter

 

that would be wonderful - I tried installing the original version and it was a bear in MS1 - have a new version updated for MS1 would be great!!!!!!


Reading is beneficial - Searching is enlightening

find answers at wiki.oscommerce.com/top

Share this post


Link to post
Share on other sites

I had the downloader working on my test site, thought I had it going on the site I posted. As soon as I get it working again, it will be available for download....

 

 

sorry.....

 

will be looking at it tonight...

 

cheers,


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

Hi all,

 

I had the download system set up incorrectly before. This is fixed. I have set up the system for using the cheque and paypal payment systems.

 

For the template system I will have to manually change the status of the order, since I will be adding different products for download that people will have to pay for. This I will do periododically though the day with a email being sent to you, notifing you of the status change.

 

If you have any bugs or problems with it, please post them here in this thread, as I will be watching it and will reply to any questions here so I am not repeating myself to others.....

 

cheers,


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

Fatal error: Failed opening required 'includes/template/original_osc/blue/buttons.php' (include_path='.:/usr/share/pear') in /home/mattiputko/public_html/catalog/includes/template/original_osc/catalog.php on line 58

 

Can be fixed by removing

 

<?php require(DIR_WS_SITE_FILES . '/buttons.php'); ?>

 

on line 58 in catalog.php


"Use no way as way, have no limitation as limitation." - Bruce Lee

Share this post


Link to post
Share on other sites

Hi all,

 

As was mentioned in the above posting, there is an error in the catalog.php file.....

 

I have just fixed that error up in the main zip file......just uploading it.....any other problems please post them here......

 

I am in the process of setting up a rollover dynamic button system for the tempalte system....

 

 

 

 

cheers,


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

hi ,i see in your template thatu include some contirbution that i qlready had installed like administrators ,so if i just wanna have the template system is it possible ?


MS2

Share this post


Link to post
Share on other sites

Hi there,

 

I made up a complete install package that is available for free download via my site www.systemsmanager.net

 

if you want to change your current store into the template system, I would be willing to give directions on how to do so via this forum.

 

To get the osc install package you need to register at my site and download it. The registration is so I can set up my download account so it works for both the free stuff and for other stuff that isa not for free...

 

As soon as I see an order for the template system, I will change the order process from the status of processing to download. When you recieve the download email, click on the link in the email and it will bring you to the download page...

 

Would love to get some feed back on it, about 100 people have downloaded it so far, but no one seems to say much about it.....hmmmm

 

 

cheers,


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

I haven't had time to work with the download, I installed it on a test site and the install failed for some reaon. Truthfully, it dropped to the bottom of my priority list due to some other issues.

 

I will try to install again in the coming week or so.


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

Peter,

 

i love your contribution!

 

could you please update your instructions for MS1 as the instructions I used to install it seemed to be for a previous version.

 

keep up the great work!!!!


Reading is beneficial - Searching is enlightening

find answers at wiki.oscommerce.com/top

Share this post


Link to post
Share on other sites

Peter,

 

sorry, I am blind this morning - I just went to your site and see that you have updated the system for MS1.... thank you!! 8)


Reading is beneficial - Searching is enlightening

find answers at wiki.oscommerce.com/top

Share this post


Link to post
Share on other sites

Peter,

 

I went to your site to make sure I had the latest version, did you change the user database? I am not recognized and I hate typing info over again :)


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

just did a fresh install of the latest version on my local server and getting the following error:

 

1146 - Table 'themes.web_pages' doesn't exist

select distinct page_name from web_pages order by page_name


Reading is beneficial - Searching is enlightening

find answers at wiki.oscommerce.com/top

Share this post


Link to post
Share on other sites

Hi there,

 

 

just did a fresh install of the latest version on my local server and getting the following error:

 

1146 - Table 'themes.web_pages' doesn't exist

select distinct page_name from web_pages order by page_name

 

When did you download the system?

 

I found that I had in advertently switched the left_column/right_column files with what I am using.....

 

to fix this just switch your columns with what I have in there....at the directory templates/osc

 

If you still have a problem, please post the entire message and a link if possible, I will look at it, I did a fresh install this morning to test it, and this is when I noticed I had did this....

I re did the zip file this morning so it should be fixed.....

 

i love your contribution!

 

could you please update your instructions for MS1 as the instructions I used to install it seemed to be for a previous version.

 

keep up the great work!!!!

 

 

Thanks, I enjoy working with osc....great project to work on.... 8)

 

I went to your site to make sure I had the latest version, did you change the user database? I am not recognized and I hate typing info over again

 

 

Sorry, I switched servers on my system since I had a problem with the hosting company I was dealing with, I lost a bunch of customers info in this process, and well since it is for free, you might have to do it again......sorry....


Peter McGrath

-----------------------------

See my Profile (click here) for more information and to contact me for professional osCommerce support that includes SEO development, custom development and security implementation

Share this post


Link to post
Share on other sites

i dl'd it a few hours ago - i will dl it again and reinstall to see if that fixes it

 

didn't you have other 'themes' like 'Dove_Blue" or something like that??


Reading is beneficial - Searching is enlightening

find answers at wiki.oscommerce.com/top

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×