Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

spc456

Supertracker v3.5 installation issues - OSCommerce 2.3.1

12 posts in this topic

I am sorry to bother you, please let me know where to place this Post.

 

I have an installation question for Supertracker but I don't know where to post the question:

 

On Step 1 of the installation instruction:

 

UPLOAD the "catalog" folder to the corresponding folders:

1) catalog/images/st_no_image.jpg

2) catalog/supertracker_setup_db.php

3) catalog/includes/classes/supertracker.php

4) catalog/includes/geoip.inc

5) catalog/includes/geoipregionvars.php

 

6) admin/supertracker.php <-- is this a typo?

On my isntallation of oscommerce_2.3.1. I don't have www.mysite.com/admin/ but I have www.mysite.com/catalog/admin/

Should it be: catalog/admin/supertracker.php ?

 

7) catalog/admin/includes/languages/english/supertracker.php

8) catalog/admin/includes/languages/espanol/supertracker.php

9) catalog/admin/includes/languages/french/supertracker.php

10) catalog/admin/includes/languages/german/supertracker.php

 

11) admin/images/geo_flags/flags <-- is this a typo?

Should it be: catalog/admin/images/geo_flags/flags?

 

In any case after installing the files as the instructions above I end up with a blank screen on

www.mysite.com/index.php

The Administration side is working but there is no activity on Supertracker window.

 

I would appreciate very much if you can help.

 

Regards,

 

spc456

Share this post


Link to post
Share on other sites

I would assume it is a typo, the files in question should be catalog/admin/

Easy is way to tell would be to put them there and see if it works, worse case scenerio is it don't work and you can easily delete them.

Share this post


Link to post
Share on other sites

Don,

Thank you for your input.

Yes, that is what I did, but if I put my thinking hat on I have not seem any osCommerce installation with two adim folders. It is always www.mysite.com/catalog/admin/ so I think it is a typo.

In either case at the end I still end up with a blank page.

I read through the postings on this subject and over the years other people have had the same problem and as of today (03-25-2012) I have not seem any fix for it. :mellow:

One case the moderator suggested that there was something wrong with the server and one separate case the user fixed the problem but did not say how he did it.

Do you have Supertracker working on your site?

 

Regards,

 

Mark

Share this post


Link to post
Share on other sites

Hi Mark,

 

I have not used it myself. The problem with a blank page is that only on your /index.php? have you tried typing in a specific url like.. yoursite.com/index.php?cPath=1 or yoursite.com/shipping.php ?

Share this post


Link to post
Share on other sites

Don,

 

You asked "have you tried typing in a specific url like.. yoursite.com/index.php?cPath=1 or yoursite.com/shipping.php ?"

 

Yes, they all come up blank.

Reading some of the posts I found out that any or all of the three lines of code on application_top.php at the end of the file are causing the problem, please see below.

 

// Supertracker

require(DIR_WS_CLASSES . 'supertracker.php');

$tracker = new supertracker;

$tracker->update();

?>

 

If I comment these three lines then the pages display correctly.

 

Thank you,

 

Mark

Share this post


Link to post
Share on other sites

Can you post your catalog/includes/configure.php

 

Minus the senstive info like database information

 

My guess is that it is not correctly referenced in the configure file (or it is not in the specified location) or that there is something wrong with the supertracker.php file itself. Obviously since none of the pages are working it has to be one of those things.

Share this post


Link to post
Share on other sites

Can you post your catalog/includes/configure.php

 

Minus the senstive info like database information

 

Don,

Here is my configure.php (please note that I replace my web page name with store-x.com)

 

<?php

define('HTTP_SERVER', 'http://store-x.com');

define('HTTPS_SERVER', 'http://store-x.com');

define('ENABLE_SSL', false);

define('HTTP_COOKIE_DOMAIN', '');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/home/mark2/store-x.com/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

define('DB_SERVER', 'localhost');

define('DB_SERVER_USERNAME', 'myname');

define('DB_SERVER_PASSWORD', 'long-passwd');

define('DB_DATABASE', 'store-xdb');

define('USE_PCONNECT', 'false');

define('STORE_SESSIONS', 'mysql');

?>

 

Hope this will help.

 

Thank you,

 

Mark

Share this post


Link to post
Share on other sites

Hi Mark on the surface there doesn't appear to be any issues, however supertracker may require some cookie functionality so maybe try being specific about your domain

  define('HTTP_COOKIE_DOMAIN', 'store-x.com');
 define('HTTPS_COOKIE_DOMAIN', 'store-x.com');

 

That is the best help I can offer from here, and I hope it helps!

Share this post


Link to post
Share on other sites

Hi Mark on the surface there doesn't appear to be any issues, however supertracker may require some cookie functionality so maybe try being specific about your domain

  define('HTTP_COOKIE_DOMAIN', 'store-x.com');
 define('HTTPS_COOKIE_DOMAIN', 'store-x.com');

 

That is the best help I can offer from here, and I hope it helps!

 

Hello Don,

 

That seems to have done the trick, you hit the nail on the head.

Your support is absolutely epic!

 

My site seems to be working normal.

 

I am not done with it yet because I have not tested Supertracker.

The admin report says:

Database Info: The Supertracker database currently holds 0 rows (Oldest Record:)

 

I checked mySQL database and supertracker table was created but it has nothing in it. I will put my site online to see if I get any activity on the Supertracker report.

 

I will get back here after more testing

 

Thank you a million.

 

Mark

Share this post


Link to post
Share on other sites

Hi I'm hoping someone can help me I just installed Supertracker on my site followed all the steps my admin section works good but when I try to open the catalog I get this error message

"Parse error: syntax error, unexpected '/', expecting ')' in /home/site_name/public_html/includes/classes/supertracker.php on line 216"

if I remove :

// Supertracker

require(DIR_WS_CLASSES . 'supertracker.php');

$tracker = new supertracker;

$tracker->update();

From the Application_top.php file the site works properly minus Super tracker

 

When I open includes/classes/supertracker.php this is what i see:

);

 

foreach($browsers as $browser=>$pattern)

{

if (preg_match(/'$pattern/', '/$user_agent/'))

return $browser;

}

return 'Unknown';

}

 

 

$user_agent = $_SERVER['HTTP_USER_AGENT'];

 

 

Line 216 is: if (preg_match(/'$pattern/', '/$user_agent/')) in Dreamweaver this line number (216) appears highlighted

 

Can anyone help explain what I'm doing wrong?

 

Thank You

Andrew

Share this post


Link to post
Share on other sites

I have installed today the Supertracker contrib into a fresh osCommerce 2.3.1 and it appear exactly the same problem. Any help would be very appreciated.

 

Thanks

Share this post


Link to post
Share on other sites

I have changed this code:

if (preg_match(/'$pattern/', '/$user_agent/'))

into

if (preg_match("/".$pattern."/", "/".$user_agent."/"))

 

This works for me.

Share this post


Link to post
Share on other sites