Jump to content
ednique

[Contribution] Ship In Cart

Recommended Posts

Thank you for zip code chart. With a little work, one could crossreference so would work with all zones. But that will be another day.

Share this post


Link to post
Share on other sites

I would be interested in an MS2 compatible version. I tried adapting it myself but didn't get very far.

 

David

Share this post


Link to post
Share on other sites

I have it working with MS2, as I recall the necessary changes were fairly minor. I can run a compare and post changes tonight, if you would like.

 

FYI, I am only using the UPS XML shipping module. I have no experience using ship in cart with other shipping modules.

Share this post


Link to post
Share on other sites

the shipping modules aren't really a problem for me, the biggest issue is that it seems that it isnt grabbing the right variables, like the zip code and what not. I hard coded the zip code just to get it barely working. Also Zip and ship method cannot be updated, when you click to change it goes to an error page?

Share this post


Link to post
Share on other sites

Oh yes, this really drove me crazy. I followed the install instructions (which were written for MS1) to install into MS2.

 

When I did this I got "Error 404 doucment '_' not found" whenever I clicked on the "recalculate" or "select" links. It took me quite a while to figure out that when I followed the install intructions to the letter I placed the ship in cart form (<form></form) tags inside the shopping cart form tags. This is an invalid construct in HTML.

 

So, I needed to move the code in shopping_cart.php to include the ship in cart module immediately after the shopping cart </form> tag, but before the </td> that appeared after the </form>. Sheeesh, I hope that makes sense.

 

Anyway, there are still problems with the module on MS2 related to the bottom infobox showing "Total cost if you order today". I looked at it briefly and think it is related to how the check out process was reworked for MS2 (possibly involving use of session variables to maintain check out choices).

 

I decided, for now, that the totals including tax and being able to change totals by selecting different shipping choices was a relatively unimportant feature. My main concern is not losing shoppers (like me) who want to know what it will cost to ship without having to create an account first. I can't remember how many shopping carts I have orphaned on web sites that would not provide shipping costs without me first giving my personal information.

 

So, I set the one flag to turn off the order total box and (by hand) removed the "select" links that appear to the right of each shipping choice.

 

Good luck,

Paul

Share this post


Link to post
Share on other sites

as i read here are already some ppl running UPS XML Shipping together with Ship in Cart.

The Contrib works great so far, but i am getting wrong rates in the order total display of the ship in cart contrib.

At the end of checkout the ups rates show up correctly. i only can't get the right order total in tht ship in cart window when i select an ups rate for shipping.

 

MS1 Loaded5, UPS XML 1.02, Ship in Cart 1.71

 

any help appreciated

 

Stephan


 

 

Share this post


Link to post
Share on other sites

Some time could you create an updated install.txt for the newest version?

 

I assume i have to go to each install.txt file do what it says then move on to the next making sure those changes were made or complete them.

Share this post


Link to post
Share on other sites

Any word on MS2 compatibility with this conrtib yet???

 

Has anybody got it working?


Lee

 

"Pleasure in the job puts perfection in the work" -- Aristotle

Share this post


Link to post
Share on other sites

Dear,

 

Really thanks to the contribution as this is the function I was looking for so long time, as the customers will be unhappy when the register several pages and find the shipping charge are even more than the products cost itself......

 

However I got some error when I install this mod, and hope to have some help....after I install it I got this error:

 

Fatal error: Call to undefined function: get_content_type() in /home/ezreef/public_html/catalog/includes/modules/shipping_estimator.php on line 186

 

And when I chen the line 186 on shipping_estimator.php it is:

if($cart->get_content_type() == 'virtual') {

 

Because I set the products download are false and I try to enable it but also with no luck....so any suggest what can I do??

 

My shopping cart file version are $Id: shopping_cart.php,v 1.67 2002/11/23 02:08:10 thomasamoulton Exp $

 

Thank you for your guys help....

Share this post


Link to post
Share on other sites

just trying to get this working with MS2

 

This is the error I get -

Fatal error: Call to undefined function: tep_output_warning() in /home/hardwaresale/olshop/catalog/includes/modules/shipping_estimator.php on line 206

 

Now I look at line 206 and I have this

$ShipTxt.=tep_output_warning(CART_SHIPPING_OPTIONS_LOGIN);

 

So its seems there is an undefined function as the error says. I can't find this in the shipping module so I would have to say its calling to a defined name that has changed in MS2... Anyone have any ideas what the new name is?

 

Or am I completely off track?

Share this post


Link to post
Share on other sites

I received the same error.

 

In MS2, they have changed the way that error message are output. Instead of a function in general.php, a new class file, message_stack.php was created to handle all of the error messages.

 

To fix the error...

 

Locate the following line of code...

   $ShipTxt.=tep_output_warning(CART_SHIPPING_OPTIONS_LOGIN);

and replace it with this...

   $ShipTxt.=$messageStack->add('header', CART_SHIPPING_OPTIONS_LOGIN, 'warning');

 

That should remove your error.

 

Hope this helps.

 

-R


"Courage is not the absence of fear, but the awareness of fear and the ability to get past it."

 

It's difficult to diagnose an issue when the patient says, "I have this pain right here Doc, what do you think it is?"

Share this post


Link to post
Share on other sites

Hey all...

 

I have re-written this contribution for use with MS2 and have it installed...

 

So far, ITS WORKING!!! ...except for one small item.

 

With multiple Shipping modules loaded, (for testing purposes, I have Flat Rate Shipping and Table Shipping Rate active) when I click on the "select" link to choose a quote for a different shipping module rate, the page refreshes and the Shipping selection does not change.

 

Any ideas?

 

This seems to be the last piece before I can package it up and let all of you test it. I'm very close.

 

I'm also working on a new contribution that will integrate this contribution's functionality with the one I am writing.

 

Thanks.

 

-R


"Courage is not the absence of fear, but the awareness of fear and the ability to get past it."

 

It's difficult to diagnose an issue when the patient says, "I have this pain right here Doc, what do you think it is?"

Share this post


Link to post
Share on other sites

Wish I could help.... Thanks for your time spent on it as its a much needed addition for any shop I believe.

Share this post


Link to post
Share on other sites

Ok I played round with it a little bit... And this is what I done and I got it working... Put in your code to take away that error msg. Then as said above do not put inside the <form>...</form>.. So I deleted the </table> just before the </form> and then under this :

<?php

 }

?>

   </form>

</td>

(remember I removed </table>)

 

I added this

   <tr>

     <td><br><?php require(DIR_WS_MODULES . 'shipping_estimator.php'); ?></td>

   </tr></table>

And it now works! lovely stuff!

Share this post


Link to post
Share on other sites

hi john,

 

I saw your site and the ship in cart shows Country as dropo down menu

and be able to post e post code..

 

I have downloaded the contribution and I didn't see that, also I one had to be registered see all that you have...

is it the same contribution or you have a modified one?

 

could you pls direct me on this?

 

Thanks

 

PS: By the way, it load very fast....

Share this post


Link to post
Share on other sites

I have this same mod installed on my website and it works fine.. check this out www.hardwaresale.com.au .

 

Besides at little thing that does not put the store postcode in when you first start. but besides that it works fine.

Share this post


Link to post
Share on other sites

John... THAT WAS IT!!!

 

I am now able to select a different shipping method from the list and have it become the selected shipping module.

 

Thank you very much for that.

 

You know... I really appreciate the fact that this forum is a great place to not only brainstorm, but to help and be helped.

 

I now have a fully working version running on MS2!!! :D

 

Thanks again!

 

-R


"Courage is not the absence of fear, but the awareness of fear and the ability to get past it."

 

It's difficult to diagnose an issue when the patient says, "I have this pain right here Doc, what do you think it is?"

Share this post


Link to post
Share on other sites

Hi everyone!

 

Is this mod Milestone 2 compatable? I looked at the contribution page and it did not mention it at all. :( Any ideas?

 

Thanks,


Kevin Rosenthal

Share this post


Link to post
Share on other sites

Yes, it does work with MS2 with the few changes given above...

 

however I have some reservation that many of the site above seems don't pay attention...

 

1- if someone enter a different country (by mistake or just trying) and there are NOT cost entered, the user may not go back and check his/her own cost.... (maybe because the cookies installed in the pc)

 

2- as standared the initial estimate is calculated taking in consideration the country where the shop is: ie Australia and the location: ie. region or state.

as far as the country is concern, that fine. initially the estimation is correct. however if one tries to enter a different postcode/state or anything else, it doesn't work...

I still don't know how this is suppost work...

 

the input field next to country is there, therefore must be a reason for it...

 

Can someone that is happy with their estimator tell me how it is supposed work THE FIELD NEXT TO COUNTRY?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×