Jump to content
ednique

[Contribution] Ship In Cart

Recommended Posts

Hi guys,

 

I had this mod working really well on my old site, however - I have had to upgrade to the latest version of Oscommerce and tried to install/uninstalled it (several times now) but can't for the life of me get it to work.

 

It just won't appear at all either logged in or not.??? I even copied over my old files from my other site and still couldnt'get it to work in the new site.

 

So, I guess my question is - Does anyone know if this mod works with 2.2rc2a ( osCommerce Online Merchant v2.2 Release Candidate 2a)

 

Its an easy mod, so i cant figure out why i'm having so many probs.

 

Thanks

Jodes

 

BTW - its enabled etc. :o)

 

I just tried installing this mod on RC2a. No luck. I have the same problem you're having, unless you figured out a way to fix it.

 

If the nimble fingered maintainers of this contribution could figure out a way for this to work with RC2a, I'd really appreciate it!

 

Thanks!

 

NOTE: this doesn't break the shopping cart - just the shipping_estimator mod does not show up!

Edited by sitandspin

Share this post


Link to post
Share on other sites
I just tried installing this mod on RC2a. No luck. I have the same problem you're having, unless you figured out a way to fix it.

 

If the nimble fingered maintainers of this contribution could figure out a way for this to work with RC2a, I'd really appreciate it!

 

Thanks!

 

NOTE: this doesn't break the shopping cart - just the shipping_estimator mod does not show up!

 

Okay, I patched the Ship in Cart mod to work with RC2.2a. I'll put it up as a fix under addons later today. Works like a charm, but kind of slow.

Share this post


Link to post
Share on other sites

Hi Sit and Spin,

 

Just wanted to thank you for fix in the contribution for 2.2ra. Works great now!

 

Thanks again

Jodes

Share this post


Link to post
Share on other sites

Just noticed that it didn't allow the cart to be updated when you click the update button, so i just moved it to a different spot - I've updated it in the contribution file.

 

Thanks

Jodie

Share this post


Link to post
Share on other sites

Hi

 

I'm trying to get this to work with FEC & RC2a

 

The shipping from ship in cart doesn't get passed to the shipping options in checkout shipping

 

Is there anyway of fixing this?

 

Thanks in advance

 

Dave

Share this post


Link to post
Share on other sites
Hi

 

I'm trying to get this to work with FEC & RC2a

 

The shipping from ship in cart doesn't get passed to the shipping options in checkout shipping

 

Is there anyway of fixing this?

 

Thanks in advance

 

Dave

 

Just had a play with this

 

If I select an option in checkout shipping, then continue to checkout confirmation, then go back to the cart the shipping estimator, then it works fine.

Share this post


Link to post
Share on other sites
Many osc users may not be aware that when selecting a shipping quote (logged in or not) from shopping_cart.php (or where ever your shipping_estimator.php is called from) that the rate is not carried over to checkout_shipping.php.

 

Here is the fix for ShipInCart (MS2) assuming your shipping_estimator.php uses the: $cart_sid = $HTTP_POST_VARS['sid']; around line 134

 

In checkout_shipping.php find:

 

} else {

for ($j=0, $n2=sizeof($quotes[$i]['methods']); $j<$n2; $j++) {

// set the radio button to be checked if it is the method chosen

 

Below that add:

 

if ($cart_sid) {

$shipping['id'] = $cart_sid;

}

 

Hope this helps...

Mac

Thanks Mac - Solved my problem :D

Share this post


Link to post
Share on other sites

The contribution seems to work well, except for one thing. If a person who isn't logged in makes any changes to their cart contents, their zip code info is lost. As long as they don't change the shipping method, the correct shipping will continue to be calculated, but if they select a different shipping method, they have to reenter their zip code to get the new quote.

 

I have OSC version is RC2.2a, and I'm using the latest version of the contribution (2.2.2a), plus the revised install.txt file posted on Mar. 30.

Share this post


Link to post
Share on other sites

Hi Ednique,

 

Thanks for this contribution, works great. I would like to remove the need for users to select country and zip code because it makes no difference to them as my shipping is standard. How can I remove this or set it as default?

 

Many Thanks

LML

Share this post


Link to post
Share on other sites
I finally fixed the problem with the Shipping Calculator. Optional updates caused a problem with the module. However, I've got another problem now. I have 4 shipping modules installed: FedEx, UPS, USPS, and Pickup. Estimate Shipping shows correct shipping rates but when any of UPS or FedEx methods are selected, the Order Total Estimate shows UPS or FedEx rates x2. For example:

 

There is also a problem with FedEx shipping rates. Doesn't matter what FedEx method I select it always shows FedEx Ground Service selected and Order Total Estimate also shows only FedEx Ground rate. Is there any solution to the problem?

 

Thanks in advance.

 

 

In case you still need answers...

 

 

"When the default shipping appears in ship-in-cart, the shipping total is double what the ups ground amount is."

 

I was also getting this problem after installing the "ship in cart" module however my ups.xml file was already updated with the "reset quantities" code as outlined above. After researching and working on this issue for many hours, it appeared that this problem was linked to the "Dimensions Support" in the UPS module which was apparently converting 1 item purchased into 2 packages. Since I did not really use this feature, I changed my selection in the "Dimensions Support" from "With product dimensions" to "No" in the Admin panel. So....

 

Go to the Admin control panel

Click on "Module">"Shipping">"United Parcel Services (XML)"

Click on "Edit"

Select "No" under the "Dimensions Support" category

Click on "Update"

 

The above settings should resolve the double counting appearing in the "Total Cost Estimate" for the ship-in-cart module.

 

Good Luck!

Share this post


Link to post
Share on other sites

Having a small problem with this mod

 

works fine when a user is not logged in, but when a user is logged in it show some php code

 

$this->info['total'] = $this->info['subtotal'] + $this->info['shipping_cost']; } else { $this->info['total'] = $this->info['subtotal'] + $this->info['tax'] + $this->info['shipping_cost']; } } } ?>

 

Have not managed to track down where this code is coming from

 

but I also have pwa installed so do not know if this is causing the problem

 

site is at http://www.safety-glow.co.uk

 

 

 

regards

 

 

Chris

Share this post


Link to post
Share on other sites

Hello. Thanks for the contribution. It helps me a lot.

 

I have one problem.

I'd like to add some words on 'Total:' which is shown in the bottom.

I grepped 'Total:' in files of my site and changed every part I've found, but 'Total:' in my basket is still 'Total:'.

 

So I tried to see the souce of \includes\modules\shipping_estimator.php but I couldn't understand.

 

maybe

    new infoBoxHeading($info_box_contents, false, false);
   $otTxt='<table align="right">';
   $otTxt.=$order_total_modules->output().'</table>';

 

This would be the part I shold see but where the exact souce of '$order_total_modules->output().' is written?

 

Could someone give me advice?

 

Regards.

 

aki

Share this post


Link to post
Share on other sites

Love this mod! For being such a powerful mod, it was very easy to install. FYI I use USPS Methods.

 

I have some questions/suggestions:

 

1) I would like to disable the logged-in functionality. Basically I want it to function like the guest cart even when logged in. I like the simplicity of the estimator with just the zip code entered. When logged in, you can select a shipping address from the book, but it doesn't save it through checkout. This might be confusing for customers. Also, the selection menu doesn't show the full address. You could have two addresses to the same city and zip and they look identical in the pull down.

 

Since you only have to put in the zip once per session (and change it anytime you like), I don't see a need to pull address book entries.

 

2) Is there a way for it to show the zip code entered? If a customer puts in the wrong zip or forgets what zip they put in, there isn't a way to know. Along these lines, if you put in an invalid zip, nothing happens.

 

3) Where is the text for "Post Code"? I want to change it to "ZIP Code." I can probably figure this out, but couldn't find it at first.

 

4) I'll be taking out the text and menu for "Products quantity" and the country selector (I only ship to the US). I don't see a need for a visual total of items. The quantities are displayed in the cart contents.

 

GREAT contribution! Any ideas on addressing any of my issues?

Share this post


Link to post
Share on other sites

I charge an additional $3 surcharge amount for each UPS and FedEx shipping method. The shipping estimator doesn't take Handling Fee (UPS XML) and Fedex Surcharge (FedEx) into consideration. How can I modify the module to account for the additional surcharge if specified in admin panel?

 

Thanks.

Share this post


Link to post
Share on other sites

yeah.. finally I found this module..thanks for the great contribution before...

 

I'm not a programmer.

I tried to install last contribution uploaded by misterbling dec,9...

 

before I installed this contrib- I used MVS shipping estimator..but it's not integrated estimation based by state selected pull down when user not log in.

 

everything go well with this module. in product info and shopping cart...

 

but the problem come when user not log in in product info but go well in shopping cart..

 

this is the error code..

 

"Object not found!

 

The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

 

If you think this is a server error, please contact the webmaster.

Error 404

localhost

12/17/08 23:13:08

Apache/2.0.54 (Win32) mod_autoindex_color mod_ssl/2.0.54 OpenSSL/0.9.8 PHP/5.0.5

 

 

does anyone now the problem is and help me to solve..

thank's and sorry for my worst english...

 

bye the away I also tried to created this shipping estimator works as pop up like MVS model..

but I found the same error like above...

 

:lol: :lol: :lol: :lol: :lol:

Share this post


Link to post
Share on other sites

yeah...finally I Found my mistake about ship estimator pop up in shopping cart box.

but there's still a little erorr but my machine walk..

 

this is my step because I'm not programer..LOL

 

I create new module I call "ship_estimator_pop.PHP". then I put this PHP under catalog...

 

 

this is the code I've crated.

my modification almost seem with shipping estimator.php under module. I only made alitle changed.

 

in line 29 :

I change with :

require_once(DIR_WS_LANGUAGES . $language . '/modules/' . FILENAME_SHIPPING_ESTIMATOR_POP);

 

at line 189 $ShipTxt= tep_draw_form('estimator', tep_href_link(FILENAME_SHOPPING_CART, '', 'NONSSL'), 'post');

 

canged

 

$ShipTxt= tep_draw_form('estimatorpop', tep_href_link(FILENAME_SHIPPING_ESTIMATOR_POP, '', 'NONSSL'), 'post');

 

 

I also changed

"estimator" in javacascrip and in syntac -->"estimatorpop"

"shipincart_submit"-------->"shipincartpop_submit"

 

next step

in shoppingcart box I add this code

 

"<script LANGUAGE="JavaScript">

function estimatorpopupWindow(URL) {window.open(URL,'shippingestimator','toolbar=0,scrollbars=1,location=0,statusbar=0,menubar=0,resizable=1,width=80

0,height=600')}

</script>"

 

and

if ($cart->count_contents() > 0) {

echo ' <li><a href="java script:estimatorpopupWindow(\'' . tep_href_link(FILENAME_SHIPPING_ESTIMATOR_POP, '', 'NONSSL') . '\')">' . tep_image_button('button_estimate_shipping.gif', IMAGE_BUTTON_SHIP_ESTIMATOR) . '</a></li>';

}

 

 

it's so waw......

my machine worked....I make costumer didn't need more to see shipping estimator via shopping cart..they can clik in shopping cart box..

 

but there alittle mistake in my code and I almost feel desaperate..

 

here is the code appear in my web..

 

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at C:\xampp\xampp\htdocs\goocek2\catalog\shipping_estimator_pop.php:15) in C:\xampp\xampp\htdocs\goocek2\catalog\includes\functions\sessions.php on line 97

 

 

anyone can solve this prob... so we can upload in full version shping estimator with pop up in shopping cart box

 

o

Share this post


Link to post
Share on other sites

I really like this contrib, but I'm having issues with it picking up my USPS rates and when I click the update button to remove something from the cart it doesn't work. I have FEC installed and at first I thought it worked fine, but after looking closer at it. Even if I turn the option off to show the estimates my update button still doesn't work. Here's a link

to my site and you can add something and check it out yourself.

Just click "buy now" and then mess around, you can't even add it into the shopping cart.


Steve

I appreciate all the help that everyone on this site has given me!

Share this post


Link to post
Share on other sites

This issue has been taken care of...thanks all!


Steve

I appreciate all the help that everyone on this site has given me!

Share this post


Link to post
Share on other sites

i have this error:

 

Fatal error: Cannot redeclare class in
httpclient in /includes/classes/http_client.php on line 37

Share this post


Link to post
Share on other sites
yeah.. finally I found this module..thanks for the great contribution before...

 

I'm not a programmer.

I tried to install last contribution uploaded by misterbling dec,9...

 

before I installed this contrib- I used MVS shipping estimator..but it's not integrated estimation based by state selected pull down when user not log in.

 

everything go well with this module. in product info and shopping cart...

 

but the problem come when user not log in in product info but go well in shopping cart..

 

this is the error code..

 

"Object not found!

 

The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

 

If you think this is a server error, please contact the webmaster.

Error 404

localhost

12/17/08 23:13:08

Apache/2.0.54 (Win32) mod_autoindex_color mod_ssl/2.0.54 OpenSSL/0.9.8 PHP/5.0.5

 

 

does anyone now the problem is and help me to solve..

thank's and sorry for my worst english...

 

bye the away I also tried to created this shipping estimator works as pop up like MVS model..

but I found the same error like above...

 

:lol: :lol: :lol: :lol: :lol:

 

Hello, I have same problem. When logged in it's work perfectly, but when not logged in, and I select the state and click in button, appears "Object not found! The requested URL was not found on this server".

 

I think the problem is " www.mysite.com/_ " <<<------ " _ "

 

Help me please.

Share this post


Link to post
Share on other sites

Hi i install it but when i click in button "Recalculate" the give me to my index pag and i don't know what is the error

 

 

Thank you

Share this post


Link to post
Share on other sites

I have free postage module with this module.

 

My issuse is that when free postage australian postage (default) all the postage options disappear. The problem is when you select another country it does not refresh the postage options.

 

Is some able to add that when a different country is selected the page refreshes. I have not got a clue how to do this.

 

Thanks.

Share this post


Link to post
Share on other sites

Hello I love the contib and I would love to use it but... I use USPS and UPS XML when a customer is not logged in and you go to the cart i only get 2 options Pick a country and type in zip code so my state drop down is not here. I can see the code for it to be pulled from the db but doesn't seem to work. I get a email right away as a php error from the UPS module... Im using the latest version of OSC.. Please help

 

Thanx

Share this post


Link to post
Share on other sites

My problem is when user not log in, although they have selected the country and state, all shipping option cannot calculate a rate (it will display "(No shipping available to the selected location)" for all shipping option), but user log in, it work just fine, any idea what has gone wrong??

 

u can check it here:

 

http://www.mmo.net.my/store/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×