Jump to content
Sign in to follow this  
jeni.keliikuli

debugging Discount Code module for osCommerce 2.3.1

Recommended Posts

I implemented the discount code module for an osCommerce Online Merchant v2.3.1 running on Mac Highway. Everything is setup according to the readme.txt for the module. I have reviewed the changes several times and it all looks correct. The module looks and seems to function correctly in the admin panel - I can add/edit/delete new codes, and the module looks correct in the store system, but when I enter the discount code into the field during checkout process, it always comes back with a response code of 0.

 

Has anyone run into this? I can't seem to find any debugging tools or logs to see what is going wrong...

Share this post


Link to post
Share on other sites

Jeni did you ever get this issue sorted? I have been using discount codes on my 2.3.1 store for a long time with all going well. But lately, even if the correct code is entered, the graphic returned is for a fail, even though on the confirmation page the discount has been correctly included. Anyone else come across this?

Share this post


Link to post
Share on other sites

I have the same problem. Everything seems to work, discount codes show up fine in admin, always fails during the ajax check, and is not applied in the final checkout. I'm not sure where in the process it's failing, or how to find out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×