Latest News: (loading..)
fulluvscents

Simple Checkout - for 2.3.1 (official support thread)

368 posts in this topic

Ok, I have simple checkout and guest checkout installed. They work fine with fix by MiCR0 to actually show the shipping and billing address instead of a "," but... still have the "trash" icon out on of the box, although I think I can isolate this and fix it myself.

 

The real problem is that BOTH the Sub-Total and Total show $0.00, no matter if the Update button is refreshed or the browser is refreshed. Any ideas on how to fix this issue? This appears in both Chrome and IE8.

Share this post


Link to post
Share on other sites

Micro.. can you elaborate on the fix you posted link to?

 

Timmy C

Share this post


Link to post
Share on other sites

line 431 added in below

$address_id = tep_db_insert_id();

 

 $sendto = tep_db_insert_id();
 $billto = tep_db_insert_id();

Share this post


Link to post
Share on other sites

Fixed the "Remove" trash can icon out on the right side of the screen by changing this line in stylesheet.css

#checkoutPage div.cartRow6 {position:absolute;right:0;width:75px;text-align:center;}

to this

#checkoutPage div.cartRow6 {float:left;width:75px;text-align:center;}

 

Works in Chrome, not tested in any other browser.

 

Still have no idea why the Subtotal and Total are showing $0.00 however...any help me figure this one out???

Edited by Two Pillars

Share this post


Link to post
Share on other sites

Alright, I'm using Simple Checkout with Authorize.net AIM Module, and it works PERFECTLY! This contrib ROCKS!

 

One small issue I have ... If I type incorrect credit card info into the boxes, checkout.php just reloads for me, and I do not get an error message .. can anyone shed any light on around what lines of code wait for the response from payment (or is that all payment.php)? Or, it anyone knows a line of code that's supposed to display an error if failed payment authorization, that'd ROCK!

 

Thanks all in advance!

Share this post


Link to post
Share on other sites

If anyone needs the solution ... you need to modify checkout_payment.php

 

As you were instructed to add some code under the line: require('includes/application_top.php');

 

The following code replaces the entire code block you were instructed to add to checkout_payment.php when installing this contribution:

 

 // SIMPLE CHECKOUT START
if(SIMPLE_CHECKOUT_ENABLED == 'True') {
   $qs =  $_SERVER['QUERY_STRING'];
   tep_redirect(tep_href_link(FILENAME_CHECKOUT, $qs, 'SSL'));
 }
// SIMPLE CHECKOUT END

Share this post


Link to post
Share on other sites

Thanks for these Contrib!

I find two issues, if anyone know how it get them fixed would be awesome.

- When the Guest finish the checkout, it "session" is still open. It will be very helpful that when the Guest finish the checkout, the last click work like a logoff.

- At the check out, if the guest doesn´t select a Payment Method and click "continue", it goes nowhere. It would be very useful for the guest, if a error message appear..

 

Thank you again! :D

Share this post


Link to post
Share on other sites

Can this be installed by merging the qtip.js and qtip.css to my existing custom theme files? Any hint as to how I'd do that properly?

 

Thanks!

Share this post


Link to post
Share on other sites

hi,

 

The dialog login/checkout box position does not going to stay put if Im using different resolution or browser size/resize. Is there any way that I can make it permanent fix position? help or pointers much appreciated

Share this post


Link to post
Share on other sites

Thanks for your contribution.

I just downloaded this version "simple_checkout_v3.02 (1)_1" and I'm getting the "The page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete." error. Can someone please point me to what I missed? I have read almost the entire thread all 16 pages. Please help!

Thanks

Share this post


Link to post
Share on other sites

Ive installed the contribution local and worked perfectly but now after the installation on server the pop-up windows for create account & change adress/both-shipping,billing/ wont show up.Great contribution anyway

Share this post


Link to post
Share on other sites

Nvm i just look at jserror and now its working correct! The problem was quotes after language translation.Thank you for the great contrb

Share this post


Link to post
Share on other sites

This is an excellent contribution as the standard oscommerce checkout is too complicated. Unfortunately I can't get this addon to work fully.

When customer is not logged in when the addon redirects to checkout.php I get the error

 

"1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ORDER BY zone_id' at line 5

 

SELECT zone_id FROM zones_to_geo_zones WHERE geo_zone_id = 3 AND zone_country_id = ORDER BY zone_id

 

[TEP STOP]

 

My host server is using PHP v 5.2.17

 

When the customer is logged in to their account, all works fine BUT PayPal does not charge the tax of 10% on the shipping price. I don't know what I am doing wrong.

Share this post


Link to post
Share on other sites

Hi all,

 

First thanks very much for a great addon , love it!!

 

I do have some little problems with it , first one is that if i am in the checkout and i hit the log-out button than this code is shown on the log-off page.

 

// SIMPLE CHECKOUT START if (tep_session_is_registered('jscript')) tep_session_unregister('jscript'); // SIMPLE CHECKOUT END

 

Does anyone have a idea were i went wrong??

 

Many thanks in advance,

 

Rob

Share this post


Link to post
Share on other sites

I need a bit of help. I would like to accomplish 2 things.

 

First, I need to get the guest login popup window back down where it belongs. I have searched for the instructions earlier in the thread, but I must not be changing the right "100" to a higher number to move that block down. Tried several, anyone have a code line # that will put me in a closer proximity to my target?

 

Second, same form only displays what is needed in the text input fields by hovering over them. Is there any way to display what needs to be entered next to them? Where would I change the font color for that so that one could actually see what they were suppose to type into those blocks?

 

Any help is greatly appreciated.

 

blackmountaindesigns.com/catalog/

 

Thank you in advance,

 

C.J.

Share this post


Link to post
Share on other sites

Hi all,

 

First thanks very much for a great addon , love it!!

 

I do have some little problems with it , first one is that if i am in the checkout and i hit the log-out button than this code is shown on the log-off page.

 

// SIMPLE CHECKOUT START if (tep_session_is_registered('jscript')) tep_session_unregister('jscript'); // SIMPLE CHECKOUT END

 

Does anyone have a idea were i went wrong??

 

Many thanks in advance,

 

Rob

 

Found it, in logoff.php i had the code before the require....templ.bottom but outside the <?php tag , not tooo smart ;-)

 

on to the next one!

 

Gr. Rob

Share this post


Link to post
Share on other sites

I really like this contibution, but i am having a couple of errors with it, number one was the discount module didn't unload, when after typing a correct coupon code and than typing a faulty code, fixed that with this modification to the jquery:

 

/* Discount Code 3.1.1 - start */
 <?php if (MODULE_ORDER_TOTAL_DISCOUNT_STATUS == 'true') { ?>
 var a = 0;
 discount_code_process();
 $('#discount_code').blur(function() {if (a == 0) discount_code_process(); a = 0 });
 $("#discount_code").keypress(function(event) { if (event.which == 13) { event.preventDefault(); a = 1; discount_code_process();window.location.href = unescape(window.location.pathname); } });
 function discount_code_process() {
  if ($("#discount_code").val() != "") {
   $("#discount_code").attr("readonly", "readonly");
   $("#discount_code_status").empty().append('<?php echo tep_image(DIR_WS_ICONS . 'dc_progress.gif'); ?>');
   $.post("discount_code.php", { discount_code: $("#discount_code").val() },
   function(data) {
 if (data == 1) {
 $("#discount_code_status").empty().append('<?php echo tep_image(DIR_WS_ICONS . 'dc-success.png'); ?>');
 $("#totalsContent").fadeOut('fast').load('checkout.php #totalsContent > *').fadeIn('fast');
 }else{
 $("#discount_code_status").empty().append('<?php echo tep_image(DIR_WS_ICONS . 'dc-failed.png'); ?>');
 $("#totalsContent").fadeOut('fast').load('checkout.php #totalsContent > *').fadeIn('fast');
 }
 $("#discount_code").removeAttr("readonly") }); } }
 <?php } ?>
 /* Discount Code 3.1.1 - end */

 

second, the shipping modules won't show up when first entering the checkout process loged in, but when updating the adress they show, I have shipping modules only available for one country. I have payment modules based on shipping modules, pickup in store and pay in store. When i choose a shipping option the payment option don't refresh.

 

Any ideas on what can be causing this or if there is any solution?

Share this post


Link to post
Share on other sites

Error in IE9?

 

Hi all,

 

I just installed the Simple Checkout for 2.3.1 v3.05 from the 25 of July.

It works fine in Google Chrome and Mozilla Firefox.

But in IE9 the box for the shoppingcart above the Shipping Adress-box is missing.

 

When I compare how IE9 and Firefox is rendering the pages I can see that there is some code missing in the source code when viewing it in IE9.

 

In IE9 this code is missing:

<div id="cart" class="contentText">
  <div class="ui-widget-header">
   <div class="cartRow1" style="width:100px;"> </div>
   <div class="cartRow2">Product(s)</div>
   <div class="cartRow3">Price</div>
   <div class="cartRow4">Qty.</div>
   <div class="cartRow5">Total</div>
   <div class="cartRow6">Remove</div>
   <div class="clear"></div>
  </div>
  <div class="ui-widget-content">
   <form name="cart_quantity" action="http://localhost/lds002/checkout.php?action=update_product" method="post">    <div id="cartContent" class="contentText">
 <div class="contentText cartRow">
    <div class="cartRow1" style="width:100px;"><a href="http://localhost/lds002/product_info.php?products_id=26"><img src="images/products/microsoft-mouse.jpg" alt="Microsoft IntelliMouse Explorer" title=" Microsoft IntelliMouse Explorer " width="100" height="80" /></a></div>
    <div class="cartRow2"><a href="http://localhost/lds002/product_info.php?products_id=26"><strong>Microsoft IntelliMouse Explorer</strong></a></div>
    <div class="cartRow3">$64.95</div>
    <div class="cartRow4 fields cartQty"><input type="text" name="cart_quantity[]" value="1" size="4" /><input type="hidden" name="products_id[]" value="26" /></div>
    <div class="cartRow5">$64.95</div>
    <div class="cartRow6 cartDelete" data-pid="26"><a href="http://localhost/lds002/checkout.php?products_id=26&action=remove_product"><span class="ui-icon ui-icon-trash"> </span></a></div>
    <div class="clear"></div>
   </div>    </div>
   <div id="cartRefresh" class="contentText">
 <div class="right"><span class="tdbLink"><button id="tdb9" type="submit">Update</button></span><script type="text/javascript">$("#tdb9").button().addClass("ui-priority-secondary").parent().removeClass("tdbLink");</script></div>
 <div class="clear"></div>
   </div>
   </form>
   <div id="stockWarning" class="contentText">
	 </div>
   <div id="totals" class="contentText">
 <div id="totalsContent">
  <table summary="" cellpadding="2" cellspacing="0" border="0">			  <tr>
		    <td align="right" class="main">Sub-Total:</td>
		    <td align="right" class="main">$64.95</td>
		  </tr>			  <tr>
		    <td align="right" class="main">Flat Rate (Best Way):</td>
		    <td align="right" class="main">$5.00</td>
		  </tr>			  <tr>
		    <td align="right" class="main">Total:</td>
		    <td align="right" class="main"><strong>$69.95</strong></td>
		  </tr></table>	 </div>
 <div  id="discountContent">
 </div>
 <div class="clear"></div>
   </div>
  </div>
 </div>

 

Does any one else had this problem?

Share this post


Link to post
Share on other sites

Error in IE9?

 

Hi all,

 

I just installed the Simple Checkout for 2.3.1 v3.05 from the 25 of July.

It works fine in Google Chrome and Mozilla Firefox.

But in IE9 the box for the shoppingcart above the Shipping Adress-box is missing.

 

When I compare how IE9 and Firefox is rendering the pages I can see that there is some code missing in the source code when viewing it in IE9.

 

In IE9 this code is missing:

 

Does any one else had this problem?

 

 

Buy acident I had Internet Explorer in compatibility mode, anyone have this problem in older internet explorers?

Share this post


Link to post
Share on other sites

Buy acident I had Internet Explorer in compatibility mode, anyone have this problem in older internet explorers?

 

Browser compatibility issues have plagued this add-on since it's release! :x

Share this post


Link to post
Share on other sites

post-251045-0-51077100-1349033607_thumb.jpg

 

Hi All, If anyone can shed any light on this I would appreciate the help. As you can see I have no labels for the different fields. It appears the javascript and stylesheets are not being picked up for the Simple Checkout but are being picked up for other parts of the page.

 

I have checked and double checked the install and all looks well. The only thing I can thinks of is that I am using the Theme Switcher addon which may be interfering with things.

 

Any Ideas??

 

Simon

Edited by simonhornby

Share this post


Link to post
Share on other sites

Simple Checkout and Server error 500.

 

Hi,

 

I am getting a Server Error 500 when I select any of the payment modules on the Simple Checkout page (checkout.php)

 

The error shows up in the apache log file as a:

 

<snip>

PHP Fatal error: Call to a member function javascript_validation() on a non-object in <snip></snip>/catalog/checkout.php on line 839, referer: http://www.sangskjulerfabrikken.dk/checkout.php

</snip>

 

The line is offset due to other changes, but I do use the version 3.05 from June 2012.

 

The line 839 contains:

<?php echo $payment_modules->javascript_validation(); ?>

 

So no of the two

$payment_modules = new payment;

are executed - why I do not know (yet).

 

Any hints ?

 

The site is already running two 2.2 based shops, without any problems.

 

Server OS: Linux 2.6.32-5-686

Database: MySQL 5.0.51a-24

HTTP Server: Apache/2.2.16 (Debian) PHP/5.3.3-7+squeeze13 with Suhosin-Patch

PHP Version: 5.3.3-7+squeeze13 (Zend: 2.3.0)

 

Thanks,

Martin.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now