Jump to content
fulluvscents

USPS Rate V4, Intl Rate V2 (official support thread)

Recommended Posts

International...getting priority mail international , but not 1st class package international.

 

Domestic...getting both 1st class parcel and priority.

 

I have error reporting turned off.


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

OK, maybe if I admit my stupidity it will help.  I'm running the original USPS Rate V4 Intl Rate V2_r3.4 downloaded from the Add-On area.  My domestic First-Class Mail Parcel and First-Class Package International Service are working just fine.  Turns out that I had the Tare Weight set to 3 lbs and that's over the weight limit for 1st Class services.  I only use 1st Class Parcel/Package, Priority and Priority Express for both domestic and international, however.

Share this post


Link to post
Share on other sites

@a.forever  Thanks for the bug reports. I'll fix those and upload a new version.

 

@@altoid   I haven't tested International yet, so I need to go do that. Thanks for letting me know.

 

Everyone who is complaining that the current module still works: That will change next Monday. Do you want to wait until it breaks?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@a.forever  Thanks for the bug reports. I'll fix those and upload a new version.

 

@@altoid   I haven't tested International yet, so I need to go do that. Thanks for letting me know.

 

Everyone who is complaining that the current module still works: That will change next Monday. Do you want to wait until it breaks?

 

Regards

Jim

Well, I had in my post that it was OK until Monday, but then edited it out because I thought maybe that was pressuring someone too much. B)

Share this post


Link to post
Share on other sites

I just installed this module. I set all my options, but was not getting any USPS shipping methods offered. I went back to the configuration and in the section where you select the class/min/max/handling, all the boxes are unchecked and the values are in the wrong columns. (See attached.)

 

I did see an earlier that describes a similar problem, but I was not clear if it had been solved, or how to solve it.

post-129127-0-94917000-1409867126_thumb.jpg

Edited by georgecvsc

Share this post


Link to post
Share on other sites

@@georgecvsc  That means that you didn't make the changes to admin/modules.php, or you made them wrong.

 

After you fix that, uninstall and reinstall the module.

 

Regards

Jim

Edited by kymation

See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

And try #4. This seems to have fixed all of the bugs in International shipping. Please let me know if you can find any more problems. Time is running out....

 

Regrds

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

International: first class package international and priority are working

 

domestic:  first class parcel and priority are working.

 

run with error reporting off.

 

those options above are the only ones I use in this particular shop.  if you'd like me to test other options I can enable for testing purposes.

 

thanks for working on this   :thumbsup:


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

Please test everything you can. I've done this, and everything is working as far as I can tell. I might have missed something though, so it's always good to get a second opinion.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Err, it doesn't run very fast. If you meant turn off, comment out line 560 of the module file.

 

Just remember that this is the test version, and it will stop working when USPS turns off the test server. You'll need to change the URL on line 18, or wait for the final version of this module.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Before I mess things up.  I think I will wait until you release the final version.

Line 560 in the usps.php I down loaded (#4) is "}" so I left it alone.

Share this post


Link to post
Share on other sites

My mistake; I was too lazy to type the code tags. The line you want should look like this:

 

 

mail( EMAIL_FROM, 'USPS Debug Message for ' . STORE_NAME, $mail_body );

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I added a few more options that made sense for the product type:

 

international:

 

First-Class Mail® International Large Envelope $4.79 First-Class Package International Service $8.24 Priority Mail International® $27.13 Priority Mail Express International $36.19 Global Express Guaranteed® (GXG) $56.52
 

 

Domestic:

 

United States Postal Service 0 lbs, 10 oz shipping_usps.gif First-Class Mail® Large Envelope $2.87 First-Class Mail® Parcel $3.58 Priority Mail $5.05 Priority Mail Flat Rate Envelope $5.05 Priority Mail Express $15.13
 

 

All that I checked worked.


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

And try #4. This seems to have fixed all of the bugs in International shipping. Please let me know if you can find any more problems. Time is running out....

 

Regrds

Jim

So that error I reported went away. +1.

Here are some new problems:

 

Media Mail and Library Mail no longer function. I'm assuming it's the change to Flat. So, I just reverted back to the Parcel coding back in your #3 version.

 

I also figured out why Small FRB wasn't showing up for international. The dimensions are causing this. Length, Width, and Height should probably be hard-coded to 0.2 for now. Doing so makes the service appear!

 

Finally, this is a cosmetic issue I found on Chrome. It's been bugging me, but I never bothered to push a fix. I personally think that 5px matters.

 

Around line 739, FIND:

<div style="width:50px;float:right;text-align:center;">Handling</div> 

CHANGE TO:

<div style="width:55px;float:right;text-align:center;">Handling</div> 

Around line 749, FIND:

        $string .= '<div style="float:left;">' . preg_replace(array ( 

CHANGE TO:

        $string .= '<div style="float:left;padding:5px;">' . preg_replace(array ( 

Around line 780, FIND:

$string .= '<div style="width:50px;float:right;text-align:center;">$

CHANGE TO:

$string .= '<div style="width:55px;float:right;text-align:center;">$

EDIT: I think I've attached my file to this post. Plus, some pictures of the working attached file.

 

post-264939-0-90469000-1409984591_thumb.png

post-264939-0-17572000-1409984601_thumb.png

post-264939-0-97936500-1409984607_thumb.png

usps.php

Edited by a.forever

Share this post


Link to post
Share on other sites

@a.forever  Thanks for all of the changes. That's working fine on my test store. I think we have a winner here.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@@kymation  just checking in, is the above usps.php from @a.forever the one to use?  Do I need to change line 581 and 18 or just leave alone?

Share this post


Link to post
Share on other sites

@@dculley  The above post by @a.forever is the final version, unless someone spots a bug. That is using the test server, and that will be shut down in the near future, so you will need to change line 18 on Monday. You may also comment out line 567 if you don't want to get the debug emails. I should probably make one or both of those an option in the setup.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I've uploaded the final version to the usual location. I've tested this and the USPS production server seems to be updated and working correctly. Please upload and test this ASAP If you spot any anomalies, please post them here so we can fix them.

 

For those who are doing this for the first time, you will need to uninstall your USPS module first. Make a note of all your settings first. Then upload the following files:

  • <catalog>/includes/modules/shipping/usps.php
  • <catalog>/includes/classes/http.php

Now reinstall the USPS module. Edit the module settings and put back the settings you have saved. Your shipping quotes should now be working again.

 

Many thanks to all of the testers who reported bugs, and special thanks to @a.forever for the code and for correcting my misunderstanding of the USPS API docs.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@@kymation Thanks again! Just grabbed the latest package from your last post. All looks good and running well. Doesn't look like we need to change the API back tomorrow or comment out the debugging. Here's a quick question regarding the layout of the the shipping. Take a look at my pic, is the extra space in there something in the layout of the entire site or is it something in the usps code? It looks good on a small browser but a lot of extra space when in a widescreen etc.

 

Thanks @a.forever also!!

post-174347-0-62009200-1410113451_thumb.jpg

Edited by Jayman11

Share this post


Link to post
Share on other sites

@@Jayman11  That's just osCommerce. The elements are in a table, and your browser spaces out the table cells the way it wants to. You could probably fix that with some CSS if it bothers you.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Jim - Just wanted to say thank you for all your hardwork.  Seems to running great. Big thank you again. :thumbsup:

Share this post


Link to post
Share on other sites

The MVS version is still buggy. I'm working on it.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

One last update to fix the MVS bug. Everyone using the standard version should be fine with the previous release.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hey Jim.. I checked my cart this AM and .. everything is working just fine with no update.. I only use First Class, Priority & Express domestic and international..  

USPS Rate V4 Intl Rate V2 - v.1.7
  $Mod: Changed from Parcel Post to Standard Post 20130129 Kymation $
  $Mod: USPS API changes 20130729 Kymation v 1.3 $

thoughts??? I'll definitely update, but apparently I don't have to kill myself doing so..


Debbie D
Franklin County, VA "Moonshine Capitol of the World"
osCmax Mobile Template oscmaxtemplates.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×