Jump to content
fulluvscents

USPS Rate V4, Intl Rate V2 (official support thread)

Recommended Posts

Just as a point of info.. if you keep making changes and are not progressing where you think you should be.. check your database the CONFIGURATION TABLE to see if there are any USPS entries that were not removed the last time you uninstalled. Clearing CACHE & COOKIES might also help but the bigger finger pointing is to left over stuff in the database..


Debbie D
Franklin County, VA "Moonshine Capitol of the World"
osCmax Mobile Template oscmaxtemplates.com

Share this post


Link to post
Share on other sites

@@kymation I am using the domestic part so mine is probably more simplistic than what most others are using. I only use 1st class, regular priority, and regular express for domestic. I would have answered much earlier, but I was combing through the code to remember where to comment out the weight in check out. Now I remember *facepalm*.

 

Dave

Edited by videod

Share this post


Link to post
Share on other sites

@@bkpie @@JeffroDH

I am running seemingly identical carts - 3 of them that I use the USPS module and I have updated.. something else must be different between them, but I am blind now..

 

USPS Rate V4 Intl Rate V2 - v.1.7

$Mod: Changed from Parcel Post to Standard Post 20130129 Kymation $

$Mod: USPS API changes 20130729 Kymation $

located : http://forums.oscommerce.com/topic/383307-usps-rate-v4-intl-rate-v2-official-support-thread/page__st__560#entry1676958 )in this thread post #575

based on: http://addons.oscommerce.com/info/8327 :: USPS Rate V4 Intl Rate V2 - v.1.7 - FIX fulluvscents 11 Feb 2012

 

I am running osCmax v2.0.35 which pretty much lines up with osC v2.2. The MAX installation is HIGHLY modified, some installs more modified than others (tho I have been trying to align them better for just this reason)

 

Cart 1 my main site - yes international & domestic with handling fees

First-Class Mail

First-Class MailRM International Large Envelope**

First-Class Package International ServiceTM**

Priority Mail ExpressTM

Priority Mail ExpressTM International

Priority MailTM

Priority MailTM International

 

NO EXTRA services for domestic or international

RETAIL rates

 

osCmax has jQuery so from the readme I was able to install the Int'l regulations within the shipping page

-------------

cart 2 basically a mirror install of my main cart with the same results

-------------

cart 3 is the base install as the others but has a custom HAZMAT module added in.. besides that I can not see why I can not get international rates

here I am only using

Priority MailTM

Priority MailTM International

 

While I should be using insurance and sig confirmation I have not turned them on here..

retail rates

 

 

 


Debbie D
Franklin County, VA "Moonshine Capitol of the World"
osCmax Mobile Template oscmaxtemplates.com

Share this post


Link to post
Share on other sites

remember where to comment out the weight in check out. Now I remember *facepalm*.

 

Dave share that will ya.. my brain hurts already :)

 

thanks!

 

 


Debbie D
Franklin County, VA "Moonshine Capitol of the World"
osCmax Mobile Template oscmaxtemplates.com

Share this post


Link to post
Share on other sites

One more try. Since the file download link is so far back in this thread, I'll repeat it here. Please post detailed results: Which services work for you and which don't? This will help me track down any bugs.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Where are you getting the 1 Day? This module shouldn't show that information. In any case, that's the time-in-transit that USPS expects for the address given. Try a more distant address and you'll see that change.

 

Flat rate boxes should be fixed price. Which ones are you seeing change? That could meant the module is pulling the wrong prices from the rates being returned.

 

Regards

Jim

Share this post


Link to post
Share on other sites

Where are you getting the 1 Day? This module shouldn't show that information. In any case, that's the time-in-transit that USPS expects for the address given. Try a more distant address and you'll see that change.

 

Flat rate boxes should be fixed price. Which ones are you seeing change? That could meant the module is pulling the wrong prices from the rates being returned.

 

Regards

Jim

Share this post


Link to post
Share on other sites

I don't know why I can't type in the quote box. Anyway, regarding the above from Jim, I live in Florida. I changed the shipping address to Oregon. The rates changed. The 1 day delivery did not, for all options. So same thing. I'm now back to square one. I can't get through the shipping again, I get to the "choose shpping option" radio button, (one day anywhere) select the option, nothing. Which was working earlier, now it isn't. Flat rate boxes still change prices depending on weight, regardless, no one can buy anything on my store anyway. Im pulling my hair out and I'm about to start pulling out credit cards to whomever can fix this USPS crap. Anyone know of someone who can fix it let me know with a price range. I'm sick of it/.

Share this post


Link to post
Share on other sites

@@wkdwich had to venture out for a while.

Look for:

$this->quotes = array (

'id' => $this->code,

'module' => $this->title . ' ' , //$this->pounds . ' lbs, ' . $this->ounces . ' oz', (hides displaying of weight)

'methods' => $methods,

 

Note: I put a comma after the 2 single quotes, and put the // just before the $this->pounds to comment out the rest of the line. This hides the weight display in USPS on checkout. This was actually documented in one of the threads. But I think there was an extra space that didn't allow me to do a search and replace. So I manually tracked it down (I am really slow when it comes to code).

Edited by videod

Share this post


Link to post
Share on other sites

was having some issues with international rates.. but this last update seems to have resolved that.. now I am working with the Extra Services both domestic & international and those settings don't seem to HOLD (the tic boxes) - it does however look like it is adding in the insurance $$ --international & domestic priority - both look like it added $3 for insurance on a $368 order

 

 


Debbie D
Franklin County, VA "Moonshine Capitol of the World"
osCmax Mobile Template oscmaxtemplates.com

Share this post


Link to post
Share on other sites

The rates changed. The 1 day delivery did not, for all options.

 

IF you picked up the USPS module version that EVERY service says: "1-Day"

then that's where it comes from.. MAYBE :)

 

I guess we would have to know more about what module version you are working with!

 

The 6.1x version comes with a utility that reaches over to USPS for the service names and stuff to drop in the arrays in that version of the module.. that is where I saw that EVERY service was appended to say "1-Day"

 

If on the other hand you are using a different version that can display or not the "transit time" then that is a different story completely and someone else will have to tackle that with you..

 

Don't blame you for being sick of it either.. mine is finally working except right now maybe insurance options etc..

 

 


Debbie D
Franklin County, VA "Moonshine Capitol of the World"
osCmax Mobile Template oscmaxtemplates.com

Share this post


Link to post
Share on other sites

One more try. Since the file download link is so far back in this thread, I'll repeat it here. Please post detailed results: Which services work for you and which don't? This will help me track down any bugs.

 

Regards

Jim

 

Hi Jim,

 

I installed this update. Just so you know, it works with USPS methods 5.2.2 as well.

 

The only thing I can't get to work is Show Intl Regulations: but I haven't had that before anyway.

 

Thanks,

Steve

Share this post


Link to post
Share on other sites

does usps rate v4 work with usps methods for oscommerce? I had the most recent version of USPS rate V4 installed. Then I tried to install the new usps file with the usps_utility file. This returned an xml_5 error. I then read that you need USPS methods for the xml_5 error. So I installed the most recent version for 2.3.

 

Does that sound logical or is there something inherently wrong with that logic? I'm going to take another shot at it tonight. I'm still getting 1 day delivery anywhere for any option with no descriptors and I can't check out, checkout_shipping.php is called but doesn't load. I'm really not too sure where to look at this point, unless I start from scratch. I have no clue why checkout shipping doesn't work suddenly unless something is wrong with my process above?

 

I can almost deal with the 1 day shipping anywhere, I'll just turn the estimates off. But the checkout_shipping not loading flat kills any order attempts obviously.

 

Thanks for any help.

Edited by Dizzycajun

Share this post


Link to post
Share on other sites

@a.forever I found another bug. The First Class Mail Parcel, after selecting it then continuing, brings me back to shipping page and then no other services of USPS are available. You have to go back to the cart to reinitialize the services. First Class Mail Parcel does not work.

Alan


Production:
osCommerce V. 2.3.4BS
VPS Box

Share this post


Link to post
Share on other sites

@@beemertec

The Show International Regulations bit only works with osC 2.3+. Everything else should work with 2.2*, but I haven't tested it.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@@Dizzycajun

It sounds like you are using the USPS Methods addon. I can only support the USPS Rate V4, Intl Rate V2 addon here. If you want to try this one, uninstall your module and upload the latest USPS Rate V4, Intl Rate V2, then overwrite the module file with the one I posted and install from the Admin.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I get this to install in admin...however when I go to checkout it gives me a blank screen.

 

My orginal USPS module was:

* USPSMethods 6.0 for osCommerce MS2 RC2a *

 

os

v2.2 rc2

 

Any ideas?

I like this much better as it lets me set $$ limits to the type of service offered. My old one did not do this.

Share this post


Link to post
Share on other sites

It's possible that your database still has old entries from your previous version. Try uninstall and reinstall in your Admin. If that doesn't work you'll have to find your PHP error log or turn on error reporting in your application_top.php so you can see the error being generated.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@a.forever I found another bug. The First Class Mail Parcel, after selecting it then continuing, brings me back to shipping page and then no other services of USPS are available. You have to go back to the cart to reinitialize the services. First Class Mail Parcel does not work.

Alan

 

Try this new usps_beta.php file. Instead of redesigning the contribution to include Letter, Large Envelope, and Parcel as options, I basically reverted back to the original design where they're controlled through thresholds. There are slight database changes, so you will need to:

 

1) write down your current USPS settings

2) uninstall your current module

3) download this attachment

4) rename from usps_beta.php to usps.php

5) upload new file to catalog/includes/modules/shipping

6) re-install module (preferably in a new browser window or after a cleared cache)

7) reapply USPS settings

 

This is an update to the v5.x USPS Methods add-on contribution:

usps_beta.php

 

Time to try kymation's update to the contribution I like at Post #607.

Share this post


Link to post
Share on other sites

@a.forever thanks. I am testing it right now. What I like about this contribution is the Signature confirmation threshold. Here are my finding so far:

 

The handling fee for Priority Mail Express on the shipping page is accurate but when I get to the confirmation page with Priority Mail Express selected it picks up the First Class Mail handling fee amount. That is, Priority Mail Express does not use its designated handling fee but rather First Class Mail's handling fee.

 

Priority Mail is doing the same thing as I wrote above for Priority Mail Express.

 

I'll keep testing for other features.

Edited by spiritalan

Production:
osCommerce V. 2.3.4BS
VPS Box

Share this post


Link to post
Share on other sites

I think I have found my problem. The error in the error log is

Call to undefined function json_decode() in /var/www/html/cb/includes/modules/shipping/usps.php on line 390

 

From what I can see my version of PHP is too old. Looks like we need to be version 5.2 or higher. I am runing 5.1.6

Share this post


Link to post
Share on other sites

This addon uses both json_encode() and json_decode() which were introduced in PHP 5.2. There is no easy replacement for these functions.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hello,

I seriously apologize to all the experts on here, but i have a simple question,

I just started an oscommerce 2.3.3 website and would really like to add shipping

by the post office on it, but i am majorly confused by all the discussion as to if

there is a working post office shipping calculator and which one it is.

Can anyone direct me to the last working addon?

I have signed up with the usps and got an active working production server

logon ids etc and just need software that works.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×