Jump to content
fulluvscents

USPS Rate V4, Intl Rate V2 (official support thread)

Recommended Posts

@@DesertCoder

 

i have a shop running

5.2.17 (Zend: 2.2.0)

with this usps module and it works fine.


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

@@altoid Thank you for the fast response!

 

Any idea why I'm not getting shipping options on screen? I have a few options checked and all I get is a blank page.

 

Many thanks!

 

DesertCoder

Share this post


Link to post
Share on other sites

@@DesertCoder

 

Sorry...that part i'm not sure of. Do you mean blank screen shop side or admin side?


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

@@altoid Not a blank screen, just no shipping options in the checkout phase. My one site works fine. Just the other two are showing up with no options. Ugh...

 

Cheers,

 

DesertCoder

Share this post


Link to post
Share on other sites

@@DesertCoder

hmmmm...all i can think of is

1 - making sure your site is considered live with usps, you actually have to contact them about this. but you apparently did that if you have another shop working

2 - the usps user id wasn't entered in the module admin side

3 - i found i had to futz with the shipping option sort order, i have more than usps...to get usps to show.

 

other than that i am out of ideas


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

@@altoid

 

I'm feeling a bit like an idiot. I forgot to add a zip code in the Shipping/Packaging section of the Configuration section. Amazing how things work once you fill in the details! I'm posting this here to help someone else who may have missed such a basic step.

 

Thank you for your suggestions!

 

Sincerely,

 

DesertCoder

Share this post


Link to post
Share on other sites

@@DesertCoder

let's hear it for happy endings!


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

Hello All,

 

Okay, with the successful installation of the USPS Rate V4 Intl Rate V2 - v.1.7 module installed in five stores, I now want to move on to installing the next of Jetta's modules, the USPS Restrict Methods module.

 

The installation instructions for this module are spartan at best, the only actual instruction in the readme.txt file is, 'Please use a file compare tool to make the necessary changes to the included files. Perform the small sql query.'

 

OK, so the query is no big deal, nor really is file comparing the included files to the files in the (I assume) USPS Rate V4 Intl Rate V2 - v.1.7 module. So we compare the files...then what? Are these files for 'drop on top' or are we adding the code from these to the USPS Rate V4 Intl Rate V2 - v.1.7 module files? Really, there has GOT to be some better instructions than this.

 

Any and all help will be appreciated.

 

Sincerely,

 

DesertCoder

Edited by DesertCoder

Share this post


Link to post
Share on other sites

Hello All Again,

 

As time is of the essence, I took the plunge, compared all the files that come with the USPS Restrict Methods module against relevant files in the USPS Rate V4 Intl Rate V2 - v.1.7 module and also relevant files from the original osc bundle.

 

I made some notes and carefully walked through replacing the files that come with the USPS Restrict Methods module AS IS and so far, so good. I'm adding these notes here to help clarify things in case there are others, such as myself, who want to install the USPS Restrict Methods module and may be unsure as to what to do.

 

Jetta, if you happen across this post, I would be happy to give you my contact information so that we could collaborate on a thorough set of installation instructions for these fine modules. Please post here if you're interested, I'd like to help.

 

Cheers all,

 

DesertCoder

Share this post


Link to post
Share on other sites

Hello All,

 

NEW question. Regarding the USPS Rate V4 Intl Rate V2 - v.1.7 module, when I'm in Modules -> Shipping -> Edit, toward the bottom of the list are extra domestic and international services that each have four checkboxes, one in each column, the column names are N, C, S, H.

 

The legend says:

N: Not Availble

S: Forced (Show)

H: Forced (Hide)

 

Aside from the typo (Available), where is the definition for the C variable? I see no mention of it and would like to know what C does.

 

Many thanks!

 

Sincerely,

 

DesertCoder

Share this post


Link to post
Share on other sites

Anyone know how to ensure that the radio buttons for "Restrict Methods" remain saved when you reload the product edit page?

 

Sincerely, :)

Isaiah

Romans 8

Share this post


Link to post
Share on other sites

I set it up but when I try and do a test order, it tells me:

 

This is currently the only shipping method available to use on this order. United States Postal Service shipping_usps.gif An error occured with the USPS shipping calculations.

If you prefer to use USPS as your shipping method, please contact the store owner.

 

 

It says I need to register with USPSprioritymail.com but I've been using USPS.com.....is that where the error lies? Any ideas?

Share this post


Link to post
Share on other sites

@@StonerArms

 

For what it's worth:

 

Sign up for USPS API tools here:

https://secure.shippingapis.com/registration/

 

USPS technical guides can be found here:

http://www.usps.com/webtools/technical.htm

 

If you haven't signed up for the USPS shipping APIs, do so. It's fast and easy. Once you get your username, enter it into the module and then call the USPS at the number included with your email. You will get to talk to a live person, ask them to switch you over to the production servers. At that point, you should be good to go.

 

I hope that helps!

 

Cheers,

 

DesertCoder

Share this post


Link to post
Share on other sites

OK, I got it all set up...now what do I need to do so I'm not typing in 30 different addresses every day? Can I set it up to automatically generate labels?

Share this post


Link to post
Share on other sites

@@StonerArms

 

Call the USPS at the number in the confirmation email. They have the ability to verify addresses in addition to generating labels. As for if and how that is available through this module, I am not certain.

 

Hope that helps!

 

Cheers,

 

DesertCoder

Share this post


Link to post
Share on other sites

Anyone notice a slow down over the last couple days in response/reply times when getting a rate quote on checkout_shipping.php or estimate shipping?

 

I don't have any clue why but it sure takes a long time to get rates.....4-5 seconds now since 1-2 last week

Share this post


Link to post
Share on other sites

Hello All,

 

NEW question. Regarding the USPS Rate V4 Intl Rate V2 - v.1.7 module, when I'm in Modules -> Shipping -> Edit, toward the bottom of the list are extra domestic and international services that each have four checkboxes, one in each column, the column names are N, C, S, H.

 

The legend says:

N: Not Availble

S: Forced (Show)

H: Forced (Hide)

 

Aside from the typo (Available), where is the definition for the C variable? I see no mention of it and would like to know what C does.

 

Many thanks!

 

Sincerely,

 

DesertCoder

 

I had no such column after installing this contribution. It could be remnants of a previous USPS install.

 

OK, I got it all set up...now what do I need to do so I'm not typing in 30 different addresses every day? Can I set it up to automatically generate labels?

 

Probably. There was an add-on that claimed to do this for osC v2.2. I've never used it since I mainly rely on PayPal Shipping. I also export my orders into Excel and import the address fields into USPS.

Share this post


Link to post
Share on other sites

OK, I got it all set up...now what do I need to do so I'm not typing in 30 different addresses every day? Can I set it up to automatically generate labels?

Sounds like your looking for USPS auto fill....to generate labels from the order details page?

 

http://addons.oscommerce.com/info/1498

 

That saves me hours a day!

Share this post


Link to post
Share on other sites

I installed this into my oscommerce 2.3 and for some reason when I go to configure it, it won't save certain fields into the database.

 

I can change the fields to "true/false" and insert my USPS API username and those will save. But the shipping methods will not save to the database.

 

Any suggestions?

Share this post


Link to post
Share on other sites

Ok, I admit it, I am stuck!!

 

I downloaded the module just today and followed the instructions TO THE LETTER!! No problems with the installation and there did not appear to be any issues what so ever until I went to edit the USPS shipping module - then everything went south! (Well, not really, but it did mess up!!)

 

This is what the situtation is:

 

I am installing this to a virgin 2.3.3 cart. No other modules installed outside the ones that have been installed by the programmers.... So, I have the cart about 90% configured and working the way I want when I discover I don't have the shipping options that I need. So, I install the USPS module, but there are almost no options available there so I install this module. Installed with no problems as stated above. However, when I go in the modules tab to edit the values that for the USPS shipping module - EVERYTHING that is on the right side of the screen disappears - I mean just gone! The center portion of the window expands to take up all of the space on the right and SHOVES the configuration options all the way off the screen! There is not scroll bar along the bottom with which to scroll and find those options, its like they just got bullied off the screen!!

 

I'll attach a couple of photos to show you what I mean.....

 

Here it is, nestled all nice and snug along the right margin: post-321564-0-32473500-1368918256_thumb.png

Now its gone, not under the computer: post-321564-0-61160600-1368918265_thumb.png

 

What the heck is going on????

 

-DON-

Share this post


Link to post
Share on other sites

Hello All,

 

having problems with this mod on version 2.33 - the check off boxes to select the services to not get saved and the weight and handling get mixed random data in them.

so there is no shipping method displayed to the customer to select.

 

Also when selecting paypal as the method of payment it throws this error: Fatal error: Class 'httpClient' not found in /home/content/70/11154170/html/includes/modules/shipping/usps.php on line 287

 

any help would be great!

 

Thank You!

 

Dan

Share this post


Link to post
Share on other sites

I've been installing and uninstalling this module for a week, and I'm getting extremely frustrated. I don't get any errors at all. I believe I have all the setting correct in my administrator panel. I've contacted USPS and made sure that my username and account are activated on the production server. I've got OS commerce 2.3.1.

 

When I go to checkout, there is nothing there. I've uninstalled, reinstalled, uninstalled the module, reinstalled the module, revised the files again, put in the closest shipping city, reset the min/max lbs, rechecked all the settings, nothing. Nothing at all at checkout, no errors but nothing there. It's like I can't turn it on.

 

I can't figure this out, it's got to be something simple. I'm exhausted pouring over these files and finding nothing wrong.

 

Any ideas?

 

Thanks,

 

Don

Share this post


Link to post
Share on other sites

I'm having a bit of trouble with this module myself. Whenever an international customer tries to place an order with a weight above 4 lbs, I get this error:

 

"Warning

: Invalid argument supplied for foreach() in

/home/cubicdis/public_html/test/catalog/includes/modules/shipping/usps.php

on line

95"

 

As seen here:

http://www.cubicdissection.com/temp/firsterrorpage.jpg

 

If I try to continue with the order, the second page completely stops working:

"Warning: Invalid argument supplied for foreach() in /home/cubicdis/public_html/test/catalog/includes/modules/shipping/usps.php on line 95

 

Warning: Cannot modify header information - headers already sent by (output started at /home/cubicdis/public_html/test/catalog/includes/modules/shipping/usps.php:95) in/home/cubicdis/public_html/test/catalog/includes/functions/general.php on line 33"

 

As seen here:

http://www.cubicdissection.com/temp/seconderrorpage.jpg

 

 

When I open the file and go to line 95 I see this code:

   foreach ($Package['ExtraServices']['ExtraService'] as $key => $val)

 

Seems like it has something to do with the extra services, all of which I have checked as "no".

 

Can anyone help with this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×