Jump to content
fulluvscents

USPS Rate V4, Intl Rate V2 (official support thread)

Recommended Posts

Hi, I really could use some help I down loaded this program and I get library mail when I do a test run. And does anyone know how to change the weight to gram's the product I am selling starts as low as 1/3 of a gram. Any help would be very much appreciated. Thanks

Share this post


Link to post
Share on other sites

Hello

Was there a fix posted for the radio buttons not being saved in the product setup page. I tried the usps.php that was posted for pre php 5.2. Didnt help I have php 5.0.

 

 

+Restrict USPS Shipping Methods

 

 

Express MailRM

 

Priority MailRM International

 

Priority MailRM International Flat Rate Envelope**

 

Priority MailRM International Small Flat Rate Box

 

Express MailRM International

 

Thank You

Bill

Share this post


Link to post
Share on other sites

some while ago i saw that jetta was working on a fix but i don't recall seeing that.

 

when you check some method you want to exclude, the database stores that action. i've found that even though the method becomes unchecked, on the edit screen, the database entry remains unaffected and the exclusion still works


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

Thank You for the repy, What I found also was if you change anything on the listing it resets the boxes clear. Problem is I have a lot of products that won't fit in a small flat rate box or envelope. And I have to insure that an international purchase made with products that do not fit in a small flat rate box, doesnt show that rate available at checkout. Or i will lose alot of money on shipping. So you can't be sure that the boxes didnt become unchecked from editing or changes.

Wish there was a better way for blocking small flat rate boxes, when the products purchased won't fit.

Share this post


Link to post
Share on other sites

Thank You for the repy, What I found also was if you change anything on the listing it resets the boxes clear. Problem is I have a lot of products that won't fit in a small flat rate box or envelope. And I have to insure that an international purchase made with products that do not fit in a small flat rate box, doesnt show that rate available at checkout. Or i will lose alot of money on shipping. So you can't be sure that the boxes didnt become unchecked from editing or changes.

Wish there was a better way for blocking small flat rate boxes, when the products purchased won't fit.

 

there's an add on out there somewhere that allows more control over the types of shipping you offer per vendor and even geographically. i haven't needed such for my shops so other than noticing it's there i can't say much more. try some googling for this add on in oscommerce and maybe that's what you'd need.


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

 

The weight is easy to edit out.

 

Find this line:

'module' => $this->title . ' ' . $this->pounds . ' lbs, ' . $this->ounces . ' oz',

 

Change it to this:

 

'module' => $this->title,

 

Does any one know what file this is in? I've looked through the all the files and the closest I came was "catalog\includes\modules\shipping\usps.php." Might have been changed in the numerous revisions.

 

Thanks,

 

Tom

Share this post


Link to post
Share on other sites

Does any one know what file this is in? I've looked through the all the files and the closest I came was "catalog\includes\modules\shipping\usps.php." Might have been changed in the numerous revisions.

 

Thanks,

 

Tom

 

I the latest version I have it can be found in includes/modules/shipping/usps.php

 

line 183


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

I the latest version I have it can be found in includes/modules/shipping/usps.php

 

line 183

 

Thanks. I was looking through my original file and not the one to upload. I would have left that line in there but for products over 60 lbs, the weight shown is cut in half. But the shipping cost returned looks to be correct.

Edited by tomb321

Share this post


Link to post
Share on other sites

I see another issue. The insurance is correct for 1 item but does not increase for multiples of that item or if other items are added to the cart. Can some one verify this and/or point to how and where I can fix this?

Share this post


Link to post
Share on other sites

I tried to install this USPS Rate V4 Intl Rate V2 - v.1.7 - FIX and I got this error message. Can someone please help me, Thanks.

 

Warning: Cannot modify header information - headers already sent by (output started at /home/content/68/10012345/html/includes/application_top.php:1090) in /home/content/68/10012345/html/includes/functions/general.php on line 65

 

 

Steve

Share this post


Link to post
Share on other sites

If you need support, then you may want to consider paying for it.

 

Jetta has done some work with our store, and is absolutely fantastic.

Or maybe she should not add one if she wants people to pay to fix her stuff.

Share this post


Link to post
Share on other sites

I just installed the new version and when I go through the check out, all I see is UPS as an option. I've selected USPS as 1 and UPS as 2 in the order of services. My country and zip are already set, and the USPS is set to true (enabled). Any ideas? Thanks, Steve

Share this post


Link to post
Share on other sites

Did you ask USPS to switch you to the production server? Have you received the verification email confirming that this was done?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Yes, my production ID was received and added to the configuration. I'm just not seeing a shipping option (as a customer) for USPS, only UPS (which was the default previously).

Share this post


Link to post
Share on other sites

Then there's something wrong in your setup. Check that your store's address and zip code are entered correctly, then check all of the settings in the module itself. It's best to check all of the service options at first, then uncheck the ones you don't want after you have verified that everything else is working.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I guess it helps to check the boxes next to the shipping services I want enabled. :-) Thanks!!

Share this post


Link to post
Share on other sites

Well WHat the crap, Ive installed this Module onto 2.3.3 (new Install) and had my username confirmed as production, but it still fails to show any output as far as shipping is concerned. the test product has a weight of 1lb, store address set in admin config, all shipping options set and username entered.... I'm i missing a edit that I need to make to this module?

Share this post


Link to post
Share on other sites

I ran into the same problem Brett. You have to check the boxes next to each shipping option when you enable and add your USPS Shipper's ID. Otherwise, nothing shows up. There were no instructions that this was a required step so it is easily overlooked. :-)

Share this post


Link to post
Share on other sites

I actually already did both of those... Checked the output from the email sent to me and got a huge XML output with <error> tags, the only thing I can think of is that I may have mistyped the URL during the signup process... so I made another ID request.... now I just get an email stating that I dont have authorization to access the server using the new ID.... Waiting for it to be set to Production.... Changing the server URLs to the testing servers listed in the USPS confirmation Email results in a return email of an error that USPSv4 not being an authroized protocol... thinking I'm S.O.L. until the new ID is set to production in order to rule out the idea that they not only use ID's for authorization but also check the requesting URL and ID match original access request, if that makes any sense.

Share this post


Link to post
Share on other sites

this was the email I received using the first ID that I had set to production:

 

 

<?xml version="1.0"?>

<RateV4Response><Package ID="0"><Error><Number>-2147219498</Number><Source>DomesticRatesV4;RateEngineV4.ProcessRequest</Source><Description>Please enter a valid ZIP Code for the sender. </Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package><Package ID="1"><Error><Number>-2147219498</Number><Source>DomesticRatesV4;RateEngineV4.ProcessRequest</Source><Description>Please enter a valid ZIP Code for the sender. </Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package><Package ID="2"><Error><Number>-2147219498</Number><Source>DomesticRatesV4;RateEngineV4.ProcessRequest</Source><Description>Please enter a valid ZIP Code for the sender. </Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package><Package ID="3"><Error><Number>-2147219498</Number><Source>DomesticRatesV4;RateEngineV4.ProcessRequest</Source><Description>Please enter a valid ZIP Code for the sender. </Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package><Package ID="4"><Error><Number>-2147219498</Number><Source>DomesticRatesV4;RateEngineV4.ProcessRequest</Source><Description>Please enter a valid ZIP Code for the sender. </Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package><Package ID="5"><Error><Number>-2147219498</Number><Source>DomesticRatesV4;RateEngineV4.ProcessRequest</Source><Description>Please enter a valid ZIP Code for the sender. </Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package><Package ID="6"><Error><Number>-2147219498</Number><Source>DomesticRatesV4;RateEngineV4.ProcessRequest</Source><Description>Please enter a valid ZIP Code for the sender. </Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package><Package ID="7"><Error><Number>-2147219498</Number><Source>DomesticRatesV4;RateEngineV4.ProcessRequest</Source><Description>Please enter a valid ZIP Code for the sender. </Description><HelpFile></HelpFile><HelpContex!

t>1000440</HelpContext></Error></Package><Package ID="8"><Error><Number>-2147219498</Number><Source>DomesticRatesV4;RateEngineV4.ProcessRequest</Source><Description>Please enter a valid ZIP Code for the sender. </Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package><Package ID="9"><Error><Number>-2147219498</Number><Source>DomesticRatesV4;RateEngineV4.ProcessRequest</Source><Description>Please enter a valid ZIP Code for the sender. </Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package><Package ID="10"><Error><Number>-2147219498</Number><Source>DomesticRatesV4;RateEngineV4.ProcessRequest</Source><Description>Please enter a valid ZIP Code for the sender. </Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package><Package ID="11"><Error><Number>-2147219498</Number><Source>DomesticRatesV4;RateEngineV4.ProcessRequest</Source><Description>Please enter a valid ZIP Code for the sender. </Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package><Package ID="12"><Error><Number>-2147219498</Number><Source>DomesticRatesV4;RateEngineV4.ProcessRequest</Source><Description>Please enter a valid ZIP Code for the sender. </Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package><Package ID="13"><Error><Number>-2147219498</Number><Source>DomesticRatesV4;RateEngineV4.ProcessRequest</Source><Description>Please enter a valid ZIP Code for the sender. </Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package><Package ID="14"><Error><Number>-2147219498</Number><Source>DomesticRatesV4;RateEngineV4.ProcessRequest</Source><Description>Please enter a valid ZIP Code for the sender. </Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error></Package><Package ID="15"><Error><Number>-2147219498</Number><Source>DomesticRatesV4;RateEngineV4.ProcessRequest</Source><Description>Please enter a valid ZIP Code for the sender. </Description>!

<HelpFile!

></HelpFile><HelpContext>1000440</HelpContext></Error></Package></RateV4Response>

Share this post


Link to post
Share on other sites

No something that just came to mind, in the admin interface where you set your address, my zip code is set correct, but it states that you are suppose to use business name, address and phone number there.... Do you just have your address listed in that section? maybe the code is misreading my address due to the business name and phone number???

Share this post


Link to post
Share on other sites

Now my next issue is if the shipping is 50lbs, it computes the shipping correctly. But if it's 51LBS it computes 25 LBS 8oz, and likewise with anything > 50LBS (if shipping weight > 50 then / 2). USPS ships up to 70LBS. dont they?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×