I started with r1.8 and the last time I looked, I could not find it on the Apps Marketplace. Hmm … guess it was my search error, because it's there, now.  Anyway, those files in my post a page back should work if you start with the r1.8 version, uploaded by kymation as you say - 2 years ago.   Do this to the database: Then do the stuff in this post:  It should work.  I've had to re-edit the modules.php file with every update of Phoenix, but my USPS shipping has been working all the way through from 1.0.4.0 to 1.0.5.0. I've posted this before for you, so if it doesn't work, I apologize.  There may be something else with your store that's different that we're not taking into account.