Jump to content

Archived

This topic is now archived and is closed to further replies.

NodsDorf

Need Help with Ultra Pics in 2.3.1 Losing Jquery Buttons

Recommended Posts

I working on installing Utra Pics for 2.2 in 2.3.1 but I ran into conflicting Javascript files.

 

I'll throw this out there real fast..I actually prefer the popup functionality to the new pIgal functionality in 2.3.1 which is why I'm going down this road.

 

That said; It appears the problem is between

<script type="text/javascript" src="js/prototype.js">

required by the UltraPics for pop up effects

&

<script type="text/javascript" src="ext/jquery/bxGallery/jquery.bxGallery.1.1.min.js"></script>

required for ThemeSwitcher

don't like each other.

 

Which ever one is the last listed in the template_top.php will change the issue,

If the js/prototype.js is last, the jquery buttons (add to cart, header buttons, ect...) dissappear but my lightbox popup works great

If the ext/jequery/bxGallery/jquery.bXgallery.1.1.min.js is last, my produt info pages popup fails to work but my jquery buttons are back.

 

With that I can only say that the last is overwritting the previous and breaking certain functions each need to do their job.

 

My Javascript coding ability is not great and these files actually appear to be framework.. I'm lost on how to fix this one. I'd be happy to post both files but they are rather realtively large, I'm hoping somebody has made this work and is willing to give some advice.

 

Thanks,

Don

Share this post


Link to post
Share on other sites

Ya this one looks like is going to suck to solve,

 

I found that in fact Jquery does in fact conflict with prototype.js Jquery references it on their official site. (Ref Overriding the $-function )

 

If anybody understands that overide stuff / and how I can make it work inside Oscommerce I would apprciate any help.

 

Thanks,

Don

Share this post


Link to post
Share on other sites

In case anybody else runs into this,

 

I was able to finally fix this by going through the following files:

js/builder.js

js/effects.js

js/lightbox.js

js/prototype.js

js/scriptaculous.js

 

And replacing every `$(` with `$$$(` making sure not to replace the doubles `$$(` just the single `$(` with a triple `$$$(`

 

I also tried a bunch of Jquery conflict resolutions.. but none of them worked for me, but this finally did.

 

Good Luck

Share this post


Link to post
Share on other sites

×