Jump to content

Archived

This topic is now archived and is closed to further replies.

techs21

help with ssl

Recommended Posts

I have my site running on all ssl right now because some of the pages that need to use my ssl are not working one of the pages that doesn't work is my login page and my account page

 

 

 

can anyone help me out

Share this post


Link to post
Share on other sites

First you have to put it back the way it was (not SSL all the time).


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

Looks as if the only ones that aren't SSL that should be are the "Log In|Create an Account |Checkout" links at the top of the page.

 

But since it's a template I'm not sure what files to look in.

 

Perhaps /includes/header.php?


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

I have this section in the header.php is there something that needs to be added or changed

 

<tr>

<td colspan="3" class="top_part"><table width="100%" border="0" cellpadding="0" cellspacing="0">

<tr>

<td class="topleft"><b>Customer Service (847)693-8117</b></td>

<td class="top_shopingcart"><img src="images/design/shopingcart.png" align="absmiddle"/><?php echo SHOPPING_CART_TITLE;?> : <a href="<?php echo tep_href_link(FILENAME_SHOPPING_CART); ?>"><?php echo MODULE_BOXES_SHOPPING_CART_BOX_CART_EMPTY; ?></a></td>

<td id="topmenupadding"><a href="#"><img src="images/design/en.png" align="absmiddle"/></a></td>

<td class="topmenu"><a href="<?php echo tep_href_link(FILENAME_DEFAULT) ?>" id="topmenupadding"><?php echo HEADER_TITLE_HOME?></a>|<?PHP if (!tep_session_is_registered('customer_id')) { echo '<a href="'.tep_href_link(FILENAME_LOGIN).'">'.HEADER_TITLE_LOGIN.'</a>'; } else { echo '<a href="'.tep_href_link(FILENAME_LOGOFF).'">'.HEADER_TITLE_LOGOFF.'</a>'; } ?>|<?PHP if (!tep_session_is_registered('customer_id')) { echo '<a href="'.tep_href_link(FILENAME_CREATE_ACCOUNT).'">'.HEADER_TITLE_CREATE_ACCOUNT.'</a>'; } else { echo '<a href="'.tep_href_link(FILENAME_ACCOUNT).'">'.HEADER_TITLE_MY_ACCOUNT.'</a>'; } ?> |<a href="<?php echo tep_href_link(FILENAME_CHECKOUT_SHIPPING)?>"><?php echo HEADER_TITLE_CHECKOUT?></a></td>

</tr>

</table></td>

Share this post


Link to post
Share on other sites

Backup the file header file and use this code instead of what you posted:

 

<tr>
<td colspan="3" class="top_part"><table width="100%" border="0" cellpadding="0" cellspacing="0">
<tr>
<td class="topleft"><b>Customer Service (847)693-8117</b></td>
<td class="top_shopingcart"><img src="images/design/shopingcart.png" align="absmiddle"/><?php echo SHOPPING_CART_TITLE;?> : <a href="<?php echo tep_href_link(FILENAME_SHOPPING_CART); ?>"><?php echo MODULE_BOXES_SHOPPING_CART_BOX_CART_EMPTY; ?></a></td>
<td id="topmenupadding"><a href="#"><img src="images/design/en.png" align="absmiddle"/></a></td>
<td class="topmenu"><a href="<?php echo tep_href_link(FILENAME_DEFAULT) ?>" id="topmenupadding"><?php echo HEADER_TITLE_HOME?></a>|<?PHP if (!tep_session_is_registered('customer_id')) { echo '<a href="'.tep_href_link(FILENAME_LOGIN,'','SSL').'">'.HEADER_TITLE_LOGIN.'</a>'; } else { echo '<a href="'.tep_href_link(FILENAME_LOGOFF,'','SSL').'">'.HEADER_TITLE_LOGOFF.'</a>'; } ?>|<?PHP if (!tep_session_is_registered('customer_id')) { echo '<a href="'.tep_href_link(FILENAME_CREATE_ACCOUNT,'','SSL').'">'.HEADER_TITLE_CREATE_ACCOUNT.'</a>'; } else { echo '<a href="'.tep_href_link(FILENAME_ACCOUNT,'','SSL').'">'.HEADER_TITLE_MY_ACCOUNT.'</a>'; } ?> |<a href="<?php echo tep_href_link(FILENAME_CHECKOUT_SHIPPING,'','SSL')?>"><?php echo HEADER_TITLE_CHECKOUT?></a></td>
</tr>

 

If you want a link to use SSL you have to supply the 'SSL' as the 3rd parameter in the tep_href_link()


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

even if you type this into the address bar it is still not useing the ssl

 

http://www.techsonha...e.com/login.php

 

Try using a https URL.

 

I know a way to force it to be SSL if you're interested.


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

You need to reset the category cache in your admin, all the categories are still SSL

 

And your "recaptcha" on the create account page is a piece of sh*t (pardon my vulgarity).

 

I tried multiple times to create an account and never succeded because if it.

 

That might explain slow sales - it's hard for people to create an account.


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

i think the cache is been reset

 

All the categories are still SSL so I think not.


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

×