Jump to content
Latest News: (loading..)
kymation

[Addon] PDF Datasheet

Recommended Posts

/includes/functions/information.php is not a part of the PDF Datasheet or of stock osCommerce. It must be something else you've added. Try the support thread for that Addon, or ask in the general support forum.

 

Regards

Jim

 

For any one using information pages unlimited together with PDF Datasheet

 

attached is the include/functions/information.php  .

 

The file should correct any errors when they are used together

 

Regards

Joli

information.php


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Can anyone suggest a fix for this? Tried in the Wish List 3.0 forum with no success. If I remove the Wish List box both PDF datasheet and Wish List work well however I need to have the Wishlist box ...

Fatal error: Call to a member function count_contents() on a non-object in /homepages/xx/xxxx/htdocs/clickandbuilds/xxxxx/xxxx/xxxx/includes/modules/boxes/bm_wishlist.php on line 37

Thanks again,

 

Lorraine

Share this post


Link to post
Share on other sites

That's really a problem with your Wishlist install and not this one. I would start by checking that this code got added to application_top.php per the instructions:

// wishlist data
  if(!tep_session_is_registered('wishList')) {
  	tep_session_register('wishList');
  	$wishList = new wishlist;
  }

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi Jim,

 

Thanks again, yeap triple yep I've checked this and reuploaded my application_top.php and everything is the exactly the same the error message as above. If I remove the wishlist box PDF datasheet works fine and account link to wishlist but I need the box ... I think I'll have to remove PDF datasheet sadly ...

 

Lorraine

Share this post


Link to post
Share on other sites

The PDF datasheet addon has nothing to do with this problem. It's just telling you that you have an error in your Wishlist addon. Errors are always displayed in the PDF since the PDF generator is sensitive to error messages.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Did you read my previous post? Your product has no description and no image. Fix that before you try to do anything else.

 

Regards

Jim

@kymation

 

Hi Jim,

 

I move the shop to the new server, and have the same problem, Notice: Constant MODULE_BOXES_BEST_SELLERS_DISPLAY_PAGES already defined in /.../.../pdf_datasheet.php on line 66

 

I checked the file has no description but has images, does it need to be with both description and image?

 

Updated: I put the description in, and found the notice: constant xxx already defined in error still appear. What should I check to see if any part/error I made now?

 

Thanks!

Edited by ce7

Share this post


Link to post
Share on other sites

The error message says that a constant has been defined twice. The constant is associated with the Best Sellers addon, so that's where you need to look.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

So, I'm testing out this addon in a local install and I believe this is the last hurdle that I have. Any tips as to what I'll need to look at from here?

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'from products_options popt join products_attributes patrib ' at line 4

select distinct popt.products_options_id, popt.products_options_name, from products_options popt join products_attributes patrib on patrib.options_id = popt.products_options_id where patrib.products_id='52' and popt.language_id = '1' order by popt.products_options_sort_order, popt.products_options_name 

[TEP STOP]

Share this post


Link to post
Share on other sites

Remove the comma after products_options_name (in pd_image_price.php, line 437).

 

Looks like I need to put up a new version. Thanks for the bug report.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Remove the comma after products_options_name (in pd_image_price.php, line 437).

 

Looks like I need to put up a new version. Thanks for the bug report.

 

Regards

Jim

 

Awesome and thank you. I was able to remove that error but I received an error 1054 Unknown column 'popt.products_options_sort_order' in 'order clause'

 

I imagine this is due to the fact that I do not have a "sort_order" field in my database for this section? I'll research this to see what I can find out. Thank you again!

Share this post


Link to post
Share on other sites

There should be a sort order, but I believe that is not a stock field. You should add it if you are going to use the options/attributes at all. There is an addon for that: Sort Product Options v1.0

 

If you don't need the sort order just say so and I'll rewrite that SQL for you.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

There should be a sort order, but I believe that is not a stock field. You should add it if you are going to use the options/attributes at all. There is an addon for that: Sort Product Options v1.0

 

If you don't need the sort order just say so and I'll rewrite that SQL for you.

 

Regards

Jim

 

Thanks Jim!

 

I do not need it but if it's something that is going to take you awhile, don't worry about it. 

 

I've found a quick fix for the moment.

Share this post


Link to post
Share on other sites

After looking at it again, it only needs one line removed. Thanks for pointing this out. I'll try to get an update up to fix this.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

On osC 2.3.4 and with the current version of tcpdf, this module will NOT work out of the box. As the author, who has blocked the add-on from public uploads, cannot be reached for comment, I thought I'd post my findings here.

Open the User Manual .pdf and go to page 7, paragraph 2.2.4 "The FPDF Library Files"

1) After this, in your shop root, create an additional directory ext/tcpdf/config/lang
From the unpacked FPDF archive, copy tcpdf/examples/languages/eng.php to the new directory you have just created. This package will NOT function without it.

2) Go to your store’s Administration Section, Modules, PDF Datasheet and use the following sort order in order to avoid seemingly missing pieces of information in the generated PDF:

Disable: Features, Image and Price, Product Page Link, Specifications

Enable:

Initialise                     9000
Header                      9001
Fonts                         9002
Title                            9010
Manufacturer’s Name 9045
Description                9050
Extra Images             9060
File Name                  9999

 

Kind regards,

Share this post


Link to post
Share on other sites

@@dp.ramone  I replied to your PM. What more did you want?

 

Public uploads are blocked because the addons were being bombed with worthless spam. I wish there was another way to handle this, but there isn't.

 

I'll add this to the instructions as soon as I can.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I've updated the manual to account for the layout in the current version of the TCPDF package and to add some install warnings. I have found that most of the problems reported on this thread are due to not having read the User's Manual, so I'm not hopeful of this solving many problems.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hoi,
may i ask if all the problems of the other guys are solved now ?
I see no more discussion

 

Doei
Trixi


SELECT signatur FROM dummesprueche WHERE forumsbezug > 0

Share this post


Link to post
Share on other sites

"most of the problems reported on this thread are due to not having read the User's Manual".

 

If you find something that is not covered in the manual, post here and I'll try to help.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi ! 

I've found this bug at the footer, but it has to do with the "description" module.

When the Image is Set to the Right side of the page, the footer doesn´t fill correctly at all the width

Image_At_Right.thumb.png.4dc34453fd53a6dabef6ea0a0f3650e3.png

 

When the Image is at the left the foother fills ok at the whole width

Image_at_left.thumb.png.48bdff0396cd0c6208e50fb96c8d58ff.png

 

Other Things to consider

When is at the Left, but the document has more than one page, the first one is ok, the footer fills all the width and it will be ok until the very last page when the content cant fill the page; And  if the content is less than one page, it gets stucked like the first picture.

Maybe this has something to do with the "regions" ? at the description module ?

 $pdf->setPageRegions( $regions );

 

Configuration at the Panel

595433cbe3266_2017-06-2817_53_51-osCommerceOnlineMerchantHerramientadeAdministracin.png.8a50a12f103578e094a0f4db6eb0f33e.png

 

I really want the images to be at the right side of the page, do you have an idea of how this be solved ?

Yoytec_Computer_S.A.-Hoja_de_caracteristicas-Google_Chromebook_Pixel_-_Intel_Core_i5-3427U_a_1.8GHz_12.8_Tctil_2560_x_1700_4GB_DDR3_32GB_SSD_WiFi_Chrome_OS_Ingls (1).pdf

Edited by dennis.garcia
add more comments

Share this post


Link to post
Share on other sites

Sorry, but I have no idea what's happened here. The footer is automatically generated, so it should just work. You'll just have to debug it, or live with it the way it is.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
14 hours ago, kymation said:

Sorry, but I have no idea what's happened here. The footer is automatically generated, so it should just work. You'll just have to debug it, or live with it the way it is.

Regards

Jim

Hi Jim!

Indeed i was doing some debug and already seemed to me that the region part was the trouble. 

Today i fixed it adding this to pd_description.php file, at the end of the execute() function:

        $pdf->lastPage();
        $pdf->removePageRegion(0); 

And it cleaned the margin limit at the line of the footer. (i think is a bug in the library)

 

Thanks for the plugin Jim

Share this post


Link to post
Share on other sites

It could be due to recent changes in the library. I don't remember ever seeing this problem with the original build, but there have been a lot of changes in the PDF library since then.

Thanks for posting your fix. I'll see about getting that into a new release.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi,

I installed the PDF Datasheet add-on and all is working good. 

The only problem I have with it is it uoutput the PDF Datasheet in just one language. I have two language on the online store and If I set the Language default to be english, it will output only in english not in the other languages.

How I can fix that please ?

 


John

--------------------

osCommerce 2.3.4 Bootstrap Edge

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×