Jump to content
Sign in to follow this  
bhbilbao

Support System

Recommended Posts

I have a problem with the contribution Support System

http://addons.oscommerce.com/info/936

 

Sorry, if this was posted before. I suggest to the osc forum administrators to add a form to search the ID of the addon. Not by name or date added. It will be more precisely and this will avoid duplicated content.

 

In the Tickets Support System my problem is with the catalog/support_info.php

 

The ticket details always says:

TEXT_NO_COMMENTS_AVAILABLE

 

The code for it:

<td width="30%" valign="top"><iframe id="messages_show" name="messages_show" scrolling="auto" width="100%" height="300" src="support_iframe.php?ticket_id=<?php echo $ticket_id; ?>" border="0"> 
<textarea readonly cols=100 rows=10 style="color:#ff0000"><?php echo ((strlen($ticket['ticket_comments']) > 0) ? nl2br($ticket['ticket_comments']) : '<i>' . TEXT_NO_COMMENTS_AVAILABLE . '</i>'); ?></textarea>
</iframe></td>

 

What could be the problem?? My host doesnt permit iframes or what??

 

Is there a best ticket support addon based on contact_us.php page???

Share this post


Link to post
Share on other sites

You are missing the language definition, like this:

 

define('TEXT_NO_COMMENTS_AVAILABLE', 'No Comments Available');

 

This would be in the english.php or their could be a support.php file in the /includes/languages/english/ directory

 

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

Thanks DunWeb

 

 

A +1 point for you.

 

I always install new addons in a fast way, giving the languages defines to the end of work.

 

I´ll try again.

Edited by bhbilbao

Share this post


Link to post
Share on other sites

Sorry again,

 

now is defined and translated. But not the problem.

http:// www .myweb .com /support_info.php?page=&ticket_id=1

 

Under the Ticket details always says:

"No information submitted"

 

But in admin I submited diferent answers for the tickets. Is there a problem with the query?

Share this post


Link to post
Share on other sites

I think the problem is the IFRAME , Of the archive support_iframe.php

 

especially in:

<?php echo ((strlen($thiscomments) > 0) ? nl2br($thiscomments) : '<i>' . TEXT_NO_COMMENTS_AVAILABLE . '</i>'); ?>

 

Im thinking on remove the iframe and modify the code to echo the database info.

 

nobody??

Edited by bhbilbao

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×