Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

rimote

PHP 5.4 - what impact will it have on OsC v.2.x?

64 posts in this topic

So I noticed that PHP 5.4., which now has a release candidate and thusly will be most likely before the year is out, no longer supports functions such as session_register(), session_unregister() and session_is_registered().

 

There are of course a host of other changes, interesting things being the new Traits, as well as the fact that PHP 5.4 will apparantly run almost twice as fast (without having to make any modifations to your existing code), for more info check out: http://www.tech-lull...reparing-php-54 and: http://php.net/relea..._4_0_alpha1.txt

 

Anyway, I'm wondering if any of you know if it's necessary to patch/hack/update OsC v.2.x because of this new PHP version. Or if someone else already made a post on this subject, I tried Google and this forum's search but I didn't find anything relevant.

Share this post


Link to post
Share on other sites

Hi Ennio..

 

v2.2/v2.3 will not work with PHP 5.4. A v2.4 release will be made available shortly after PHP 5.4 is released with the remaining deprecated functions removed.

 

The new framework in v3.0 has no problems working with PHP 5.4. I would love to make PHP 5.4 the minimum requirement - next year perhaps when PHP 5.4 is more widespread innocent.gif

 

Kind regards,

panicgripdesigns and dadada like this

Share this post


Link to post
Share on other sites

So I noticed that PHP 5.4., which now has a release candidate and thusly will be most likely before the year is out, no longer supports functions such as session_register(), session_unregister() and session_is_registered().

 

There are of course a host of other changes, interesting things being the new Traits, as well as the fact that PHP 5.4 will apparantly run almost twice as fast (without having to make any modifations to your existing code), for more info check out: http://www.tech-lull...reparing-php-54 and: http://php.net/relea..._4_0_alpha1.txt

 

Anyway, I'm wondering if any of you know if it's necessary to patch/hack/update OsC v.2.x because of this new PHP version. Or if someone else already made a post on this subject, I tried Google and this forum's search but I didn't find anything relevant.

 

 

That is hilarious considering PHP 5.3 still isn't used by 95% of hosting companies. So even if 5.4 was released tomorrow, it would still take hosting companies 2-3 years to update.

 

 

 

Chris

Share this post


Link to post
Share on other sites

@Harold: thanks very much, you've answered my question completely. I'll treat my osCommerce websites accordingly.

@Chris: That's not PHP's fault per se ;). Regardless of how well adopted it will be in the near future, my question and Harold's answer on it would be relevant for anyone who is willing or unwilling but still has to upgrade/is upgraded to PHP 5.4.

 

Edit: the improved performance that PHP 5.4 also offers might be more enticing to hosts, than say closure.. Hopefully.

Share this post


Link to post
Share on other sites

That is hilarious considering PHP 5.3 still isn't used by 95% of hosting companies. So even if 5.4 was released tomorrow, it would still take hosting companies 2-3 years to update.

While hosting companies will take years to get up to PHP 5.4, I have noticed that many people who make test/development installations on XAMPP, etc. tend to be using bleeding-edge PHP and MySQL levels. So, it wouldn't hurt to get osC 2.4 out the door fairly soon, to help them along. In some cases it's just ignorance, but some are really trying to prepare for the future. The question then becomes, how much longer will 2.x be supported, once PHP 5.3 becomes commonplace? And at what point will 3.x be a real product and 2.x can be retired?

Share this post


Link to post
Share on other sites

While hosting companies will take years to get up to PHP 5.4, I have noticed that many people who make test/development installations on XAMPP, etc. tend to be using bleeding-edge PHP and MySQL levels. So, it wouldn't hurt to get osC 2.4 out the door fairly soon, to help them along. In some cases it's just ignorance, but some are really trying to prepare for the future. The question then becomes, how much longer will 2.x be supported, once PHP 5.3 becomes commonplace? And at what point will 3.x be a real product and 2.x can be retired?

 

 

Phil,

 

Very true about those who set up local machine environments, they do seem to use the latest versions of Php and MySQL. Once Php 5.4 is released, I am sure patches will become available to make 2.3.1 compliant with the changes.

 

Ennio,

 

I wasn't trying to undermine your question in any way, I just find it funny how software is developed years before anyone will actually be able to use it. Once they are able to use it, a revision or new version of the software is already being worked on so hosting companies will never be able to offer the 'latest' release. I apologize if you took offense to my reply.

 

 

Chris

Share this post


Link to post
Share on other sites

 

 

That is hilarious considering PHP 5.3 still isn't used by 95% of hosting companies.

 

 

Chris

 

PCI will drive this faster. We have updated ahead of schedule to continue meeting compliance.

 

Tim

Share this post


Link to post
Share on other sites

Hi All..

 

I wouldn't be surprised to see hosting providers that have not yet updated to PHP 5.3 to skip it and jump to PHP 5.4 once ready.

 

Lets make PHP 5.4 a minimum requirement for v2.4 to speed this up :D (unfortunately just kidding)

 

Kind regards,

dadada likes this

Share this post


Link to post
Share on other sites

Hi All..

 

I wouldn't be surprised to see hosting providers that have not yet updated to PHP 5.3 to skip it and jump to PHP 5.4 once ready.

 

Lets make PHP 5.4 a minimum requirement for v2.4 to speed this up biggrin.png (unfortunately just kidding)

 

Kind regards,

 

 

You certainly are a visionary Harald. w00t.gif

 

 

Chris

 

ps, Why don't the smileys work ??

Share this post


Link to post
Share on other sites

off topic: What is going on with the osCommerce versions? A v 2.4 now?

 

2.4.x will be the PHP 5.4 compatible version - Since this requires more than just bug fixing its common to increase the middle version number

2.3.2 will be the next minor bug fix release and only contains minor changes so only the last digit is increased.

 

This follows pretty common versioning standards

Share this post


Link to post
Share on other sites

 

2.4.x will be the PHP 5.4 compatible version - Since this requires more than just bug fixing its common to increase the middle version number

2.3.2 will be the next minor bug fix release and only contains minor changes so only the last digit is increased.

 

This follows pretty common versioning standards

 

No issues with the numbers used, the question was more about direction of development. Well anyway, let's not hijack this topic, sorry for jumping in

Share this post


Link to post
Share on other sites

Mark, how about skipping 2.4 (name) entirely. And instead saying it is called; 2.5.4

 

Serious idea, which would be (I think, with my fuddled brain) a good move.

 

Harald, I cannot see any reason why you should not set 5.4 as minimum for 3.x (3.5.4 ;)) as 5.4 brings with it good benefits over previous version.

Share this post


Link to post
Share on other sites

Hi Gary..

 

Harald, I cannot see any reason why you should not set 5.4 as minimum for 3.x (3.5.4 wink.png) as 5.4 brings with it good benefits over previous version.

 

We will ultimately move to PHP 5.4 for v3.x (not v3.0; v3.1 is too sudden). BTW, v3.0 runs superbly under PHP 5.4 thumbsup.gif

 

Kind regards,

Share this post


Link to post
Share on other sites

Excuse my ignorance - but does this mean that if my host jumps to php 5.4 that my 2.2 Rc2a site will cease to function and will not be able to be patched to work under php 5.4?

 

Thanks

Share this post


Link to post
Share on other sites

Hi Heather..

 

The 2.4 upgrade guide will describe what changes are necessary to apply to existing installations that need to run on PHP 5.4.

 

From our internal notes, this mainly boils down to:

 

* Replace HTTP_*_VARS with super globals (eg, HTTP_GET_VARS to _GET)

* Replace session_register, session_unregister, and session_is_registered with $_SESSION['key'] = $value, isset($_SESSION['key']), and unset($_SESSION['key'])

* Replace global session variables with $_SESSION['key'] (and remove "global $session_var" from functions)

* magic_quotes deprecated since v5.3 but compatibility.php works around it as if it was on; either this is kept or we look at changing this to work as if it was off.

 

From the PHP 5.4 Alpha 1 release notes:

 

* Removed: break/continue $var syntax

 

break/continue is used, but not with the $var syntax so this has no affect.

 

* Removed: register_globals, allow_call_time_pass_reference, and register_long_arrays ini options

 

This only affects v2.2/v2.3 with register_long_arrays. register_globals is only needed for <PHP4.3 due to the session class; register_globals can be removed with the session changes.

 

* Removed: session_is_regisitered(), session_registered(), and session_unregister()

 

This affects v2.2/v2.3 with the session functions file and how session variables are set and accessed (in the global scope).

 

That should be it, and would bring the minimum requirement to PHP 4.1 due to the super global variables.

 

####

 

Kind regards,

rimote likes this

Share this post


Link to post
Share on other sites

 

2.4.x will be the PHP 5.4 compatible version - Since this requires more than just bug fixing its common to increase the middle version number

2.3.2 will be the next minor bug fix release and only contains minor changes so only the last digit is increased.

 

This follows pretty common versioning standards

I think you would be doing the oscommerce platform a huge favor if you released the next version without the template code already added. I've had a very large number of clients that chose not to use 2.3, and some even moved away from the main oscommerce package, due to the limitation that system places on existing shops. Not having it part of the package would make for a more natural upgrade and make it more popular, in my opinion.

Share this post


Link to post
Share on other sites

 

The new framework in v3.0 has no problems working with PHP 5.4. I would love to make PHP 5.4 the minimum requirement - next year perhaps when PHP 5.4 is more widespread innocent.gif

 

Kind regards,

 

Hi Harald,

It's hard to say that, because $this support for Closures was removed. OSCOM3 will need the changes.

 

A simple article about that:

http://drupal4hu.com/node/291

 

http://stackoverflow.com/questions/5734011/php-5-4-closure-this-support

Share this post


Link to post
Share on other sites

Hi all,

 

it is time for the main flagship needs change and it looks like not good idea to develop v2.3.1 for php 5.4...

 

The next oscommerce php 5.4 combatibility version should call v3.1. I think the community do suicides if works too hard to solve php 5.4 projects in contributions on v2 core. v3's new projects will be more easy to develop.

 

I dont belive the v2 system is the good way for php 5.4. The v2 core is not a modern system and it will be a "blind track" in the future. The v2 core has limited functions. Why would you like to develop old timers? I do not understand you really.

Share this post


Link to post
Share on other sites

Reading through this post again has thrown me off track.

 

I have several stores running on 2.2Rc2a which I adjusted to work with PHP 5.3 when my host upgraded.

 

From advice I received I have been working on a 2.3.1 store to replace these 2.2 stores when the time comes.

 

What Im reading now is that I may be better waiting for 2.4 than spending time developing 2.3.1?

 

All very confusing to my simple mind.....

Share this post


Link to post
Share on other sites

@@Gergely

 

2.3.x is stable usable now and will be for 5 years or more ( a few change for 5.4, big deal).

3.x is unusable now and will not be stable usable for a year or more after release.

 

We all know that 3 is so much better than 2 ever was.

 

2 has 1000s of contributions. 3 has less than 50.

 

Why would any developer who works with real life shopowners spend client time working on 3 is dumb.

 

Do it on your own developer time, sure. Do it on client time and are ripping a client off.

 

Big deal if 5.4 breaks contributions - a lot of contributions need to be broken and not used anymore.

Share this post


Link to post
Share on other sites

2.3.1 needs mainly 2 small code changes to work on PHP5.4 , so its not that much of a major issue.

 

Many add-ons on the other hand might break and need to be modified or even re-done to work, but as Burt states many of the add-ons are way outdated and should not really be used anyway.

 

Actually the add-ons area should be redone a bit to make it easier to "sift" through what is usable and what is not. It should also include "user" ranking/comments for add-ons.

burt and panicgripdesigns like this

Share this post


Link to post
Share on other sites

omg, what a passivity! Welcome everybody in oscommerce community! :)

 

@@burt

 

I am not calm if you would say that v3 never will be stabilized. oscommerce is running crisis if only a few jobless fellow works on core developing. The community power is not on self made men. I think that developers not ripping time to work on the future is the dump.

 

@@toyicebear

 

The 2 minor change that's not enough when the oldtimer flagship is stopping and the power-boat is standing the dock. We have to put the v3 on water, but without developers we might not afford it...

Share this post


Link to post
Share on other sites

@@Harald Ponce de Leon

 

v2.2/v2.3 will not work with PHP 5.4. A v2.4 release will be made available shortly after PHP 5.4 is released with the remaining deprecated functions removed.

 

PHP 5.4.0 was released on 1st March and we have already seen members reporting issues with it installed on their server, is there any update on the v2.4 release?

 

Will there be a new option for add-ons to state their use of long arrays etc ?

 

Thanks

Share this post


Link to post
Share on other sites