Jump to content
Sign in to follow this  
alverman

[Contribution] PDF data-sheet maker v.1.1

Recommended Posts

hhhm..did you try to download the file by right-clicking on the link ? this will show you at least if you generate correctly the pdf.

 

As final solution, try to install a previous version (just 2-3 files to change) and tell me if that works. I read that there are some bugs with MSIE (of course) and you must have Adobe Reader installed of course.

 

There is FAQ#3 of www.fpdf.org that explains what to do if you have a blank page. Maybe you can find some information there.

 

Didier.

thx a lot for your help. I'll try and make you know. Bye


my contribution: Alex's Contributions

Share this post


Link to post
Share on other sites

Will 1.3 work on MS2.2?

 

I get this DB error.

 

1054 - Unknown column 'popt.products_options_images_enabled' in 'field list'

 

select distinct popt.products_options_id, popt.products_options_name, popt.products_options_images_enabled from products_options popt, products_attributes patrib where patrib.products_id='13' and patrib.options_id = popt.products_options_id and popt.language_id = '1' order by popt.products_options_name

 

[TEP STOP]

 

Any ideas?

Share this post


Link to post
Share on other sites

Same error here -

 

1054 - Unknown column 'popt.products_options_images_enabled' in 'field list'

 

select distinct popt.products_options_id, popt.products_options_name, popt.products_options_images_enabled from products_options popt, products_attributes patrib where patrib.products_id='314' and patrib.options_id = popt.products_options_id and popt.language_id = '1' order by popt.products_options_name


Always seeking & Desperate to find a solution!

Share this post


Link to post
Share on other sites
Same error here -

 

1054 - Unknown column 'popt.products_options_images_enabled' in 'field list'

 

select distinct popt.products_options_id, popt.products_options_name, popt.products_options_images_enabled from products_options popt, products_attributes patrib where patrib.products_id='314' and patrib.options_id = popt.products_options_id and popt.language_id = '1' order by popt.products_options_name

use version 1.2.2 that works for me

 

 

14 Jun 2003 - PDF data_sheet maker 1.2.2

 

 

http://www.oscommerce.com/community/contri...,all/search,PDF

 

 

regards

 

Jorn

 

www.jt-edb.dk


Jorn

Share this post


Link to post
Share on other sites

hmmm.strange that database error. The field "products_options_images_enabled" is only used if you have the "Options as Images" contribution installed. There is a test on variable OPTIONS_AS_IMAGES_ENABLED not to execute the code but this does not seems to work.

 

Try this : add in file pdf_datasheet_config.php the following line at the end :

 

define('OPTIONS_AS_IMAGES_ENABLED ', 0);

 

Tell we if that works !

 

Didier.

Share this post


Link to post
Share on other sites

Still get the error below after adding the snip above,

 

1054 - Unknown column 'popt.products_options_images_enabled' in 'field list'

 

select distinct popt.products_options_id, popt.products_options_name, popt.products_options_images_enabled from products_options popt, products_attributes patrib where patrib.products_id='108' and patrib.options_id = popt.products_options_id and popt.language_id = '1' order by popt.products_options_name

 

[TEP STOP]

 

Any other help plz last thing before stoer products install fully


Always seeking & Desperate to find a solution!

Share this post


Link to post
Share on other sites

Thx Jorn, took 1 step back to get 1 step further all works fine now great contrib thx.


Always seeking & Desperate to find a solution!

Share this post


Link to post
Share on other sites

Ok I understood my error. I did not test correctly the variable OPTIONS_AS_IMAGES_ENABLED. The values are true and false and not 0 and 1. Some code is always executed when it should not.

 

In file pdf_datasheet_functions.php, replace line

 

if (OPTIONS_AS_IMAGES_ENABLED)

 

by

 

if (OPTIONS_AS_IMAGES_ENABLED == 'true')

 

This should work...

 

Didier.

Share this post


Link to post
Share on other sites
Ok I understood my error. I did not test correctly the variable OPTIONS_AS_IMAGES_ENABLED. The values are true and false and not 0 and 1. Some code is always executed when it should not.

 

In file pdf_datasheet_functions.php, replace line

 

if (OPTIONS_AS_IMAGES_ENABLED)

 

by

 

if (OPTIONS_AS_IMAGES_ENABLED == 'true')

 

This should work...

 

Didier.

:D It worked as you mentioned. The error is gone. Many thanks for great code.

Share this post


Link to post
Share on other sites

For some reason even with spiders.txt installed and working the OSCid still displays when it goes through the pdf files.... any idea why?

Share this post


Link to post
Share on other sites

Hi Guys,

 

I have just installed v1.2.2 after not being able to get the latest version working.

 

Everything works hunky dorey apart from the image not being displayed in the pdf file, any ideas why not???

 

Also how do I change the text at the bottom of the pdf, the bit that says store name, email address etc.??

 

Also I would like the image and product title to be a clickable link (if possible!)

 

Any ideas or help would be greatly appreciated.

 

Mark


Lifes a bitch, then you marry one, then you die!

Share this post


Link to post
Share on other sites

That is a setting in your Adobe Acrobat Reader settings. It has something to do with browser integration or whatever. If you set it up to be integrated with your web browser, then it will open in a browser window.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

I have v1.30 installed on osC 2.2 MS2

 

It works great, but I noticed a few things that I need help on. I hope someone here can help me...

 

1) How do I get the price line to drop down one more line?

 

2) If you use your logo, then the image is all stretched out and looks like crap. If you use the site name, then the name is over to the right a few spaces. How do I fix the logo to display correctly and how do I get the site name over to the left so that it lines up with the rest of the file?

 

3) The product_bimage is stretched way to big. How do I get the product images to show up in normal size?

 

4) If you have any " in the product description, then when the PDF is printed or displayed, you see \". How can I get rid of the slashes?

 

5) Not all of the product descriptions are being displayed. Go to http://www.popthetop.com/catalog/product_i...?products_id=65 and click on the PDF icon at the bottom and you will see what I mean.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

Hello,

 

I have a similar problem to that mentioned above. When I select the pdf icon I am invited to download the file rather than get it displayed. Also, the file offered for download is pdf_datasheet.php, so not even a pdf! I expect I made a silly mistake somewhere - any ideas?

 

I have checked my acrobat settings in edit->preferences->internet and display PDF in browser is SET.

 

cheers

Simon

Share this post


Link to post
Share on other sites

Hi,

 

has somebody fixed the problem whith tables in the produkt_info?

The Datasheetmaker dont know html tables and bring it in disorder - so i have a layout problem in my produktpdf's.

 

siuck

Share this post


Link to post
Share on other sites

Dear all,

 

I installed v1.3, and it's work fine.

but my Mysql char is unicode(chinese),so it's display something wrong.

And i had download ufpdf at http://www.acko.net/node/56. but i don't know how it's work. anybody can help me.tks.

 

regards,

 

 

Tefa

Share this post


Link to post
Share on other sites
did someone tested the last version on a ms1 load 5 version ?

thnaks for the info

 

 

I have a problem with the output of Version 1.3 in MS2

 

I keep getting text output in place of the PDF

 

So I have implemented this which I read on Page 3 of this thread

 

++++++++++++++++++++++++++

 

Maybe I have found something that make it works . I put a script found in the fpdf.org faq, at the end of your pdf_datasheet_functions.php, erasing or coment this:

CODE

// Prints content to browser

 

// $pdf->Output("",false);

 

 

and adding this:

CODE

//Determine a temporary file name in the current directory

 

$file=basename(tempnam(getcwd(),'tmp'));

 

rename($file,$file.'.pdf');

 

$file.='.pdf';

 

//Save PDF to file

 

$pdf->Output($file);

 

//JavaScript redirection

 

echo "<HTML><script>document.location='$file';</SCRIPT></HTML>";

 

exit;

 

?>

 

I now get a mix of Colour formatted text and HTML

 

++++++++++++++++++++++++++++

 

Model : SONORIX OBHManufacturer

: -

src="http://pics.ebay.com/aw/pics/x.gif" width=1>

background=http://pics.ebay.com/aw/pics/vit/boutique/BoutiqueTop_40x48.gif>

height=48

src="http://pics.ebay.com/aw/pics/vit/boutique/BoutiqueCtrTop_240x48.gif"

width=240>

src="http://pics.ebay.com/aw/pics/x.gif" width=1>

width=1>

SONORIX Bluetooth

Audio Player OBH-0100

World's FIRST

BLUETOOTH Audio Player

TAKE YOUR MUSIC PLAYER

IN YOUR CELLPHONE HEADSET !

The SONORIX Bluetooth

Audio Player OBH-0100 is the first product of its kind in the world to integrate

Mobile, Wireless and Audio technologies into a multi-purpose entertainment

device, thereby providing the user with the Ultimate Solution for hands free and

audio demands. It functions as Wireless Headphone for PC enabling 2 way voice

communication (voice chatting) and direct streaming of high quality audio,

Wireless Headset for hands free operation with mobile phones, Standalone Audio

Player for listening to music anytime, anywhere

 

 

+++++++++++++++++++++++++

 

I use the HTML editor contribution for the Product Info pages

but I guess the problem is coming from the

additional fpdf.css file

 

Can anyone please help to get the HTML removed from the PDF

 

You can see an example here

 

http://www.affiliatesexcel.com/catalog/pro...products_id=121

 

and by clicking the PDF Icon on top of the page

Share this post


Link to post
Share on other sites

Hi,

 

I've installed PDF data sheet maker and it writes the following error:

 

Warning: _parsegif(gif.php): failed to open stream: No such file or directory in /www/1vhosts/mycompany.com/html/dealers/pdf/fpdf/fpdf.php on line 1596

Fatal error: _parsegif(): Failed opening required 'gif.php' (include_path='') in /www/1vhosts/mycompany.com/html/dealers/pdf/fpdf/fpdf.php on line 1596

 

Can some one help, does it write this error?

File gif.php is present in destination dir.

 

Also I have this mod installed on other site (same host provider), but osC is in root dir and it works fine.

 

Thanks for help.

 

Alexander

Edited by alex_rus

Share this post


Link to post
Share on other sites

Hi, I use the Hide Price if $0,- contri.

How can I set 'SHOW_PRICE',1 to 'SHOW_PRICE',0 if the productprice is $ 0,- for the PDF?!?

 

I think it would be a great addition for all.

Why show a price if there's no price?!

 

Thanks in advance...

Share this post


Link to post
Share on other sites

Hi to all.

 

I'm using pdf_datasheet 1.3 and it's a very beautifull contrib, but now in the product_info.php, I've added a new step:

under the

          <p><?php echo stripslashes($product_info['products_description']); ?></p>

I've put this

<table width="100%">
 <tr>
   <td colspan="2" class="main">
   <?php
     if ($new_text=tep_get_products_html($product_info['products_model'])) {
       include($new_text);
     }
   ?>
    </td>
 </tr>
</table>

I've also added a new function, this:

  function tep_get_products_html($products_model) {
 $products_html_file= DIR_WS_INCLUDES . 'html/' . $products_model . '.html';
   if (!file_exists($products_html_file)) {
     $products_html_file='';
   }
   return $products_html_file;
 }

Now if ther's a file called [products_model].html, it's code are added after the products_description.

 

But now the pdf_datasheet don't report che correct description, can I integrate this modification with the pdf_datasheet contrib?

 

tnx a lot, jo.

Share this post


Link to post
Share on other sites
Hi, I use the Hide Price if $0,- contri.

How can I set 'SHOW_PRICE',1 to 'SHOW_PRICE',0 if the productprice is $ 0,- for the PDF?!?

 

I think it would be a great addition for all.

Why show a price if there's no price?!

 

Thanks in advance...

Anybody?

Share this post


Link to post
Share on other sites
But now the pdf_datasheet don't report the correct description, can I integrate this modification with the pdf_datasheet contrib?

Of course you can.

 

Upload your *NEW* pack with a full description of what you did.

 

Call it PDF data-sheet v.1.3-ExternalProductsModel.zip

 

This will avoid problems.

 

Best and thanks.

 

Lopo

PS: When done post it here and I'll be warned. Thanks!

Edited by humaneasy

If I helped you, you can help others too.

Search Affero Network. Thanks :)

--

moving mentalities >> fast forward

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×