Jump to content
Sign in to follow this  
moyashi

version 1.4 -- NewsDesk released!

Recommended Posts

Hy, I find the problem with newsdesk.sql, it's a problem of apostrophe (in text)

 

line 288 -> €r€nIsn€'t this

line 291 -> you€'ll enjoy

line 294 -> Isn€'t life grand

line 304 -> I wonder who€'ll

 

;)

 

On the other hand, I did not find the solution for

Parse error: parse error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting T_STRING or T_VARIABLE or T_NUM_STRING in e:conceptioneasyphpwwwsitecatalognewsdesk_index.php on line 185

when I click on News Catagories :(

Share this post


Link to post
Share on other sites

@ MoooH

 

looks like that we are going the same way :)

 

for a fast short tmp solution you can comment those 4 lines out.

it?s not surching for those news-cat-pictures and obviously you wont get them.

BUT after doing so you?ll be able to collapse the news categories tree.

I think thats a good starting point for further debugging of this fine module.

 

DevTec

Share this post


Link to post
Share on other sites

catalog/newsdesk_index.php

apr. line 183-187

 

//if (($categories['categories_image'] = 'NULL') or categories) {

//} else {

//$print_echo = "tep_image(DIR_WS_IMAGES . $categories['categories_image'], $categories['categories_name'], 

//SUBCATEGORY_IMAGE_WIDTH, SUBCATEGORY_IMAGE_HEIGHT)";

//}

 

i haven?t had a closer look at this yet, but i?ve wanted to have categories working so I commented out this statement.

 

there are some more minor things here and there, but overall it?s great.

btw. using .zip-file of day 1

 

i found out that newsdesk-nav-box is "escaping" if one is browsing in deeper cPath 1_12 section of the catalog.... funny

 

breadcrump trail for newsID is missing, newsPath itself is fine as long as you are browsing the categories. it?s just not there after selecting an article.....

 

alltogether, seams to be doable *g :)

 

DevTec

Share this post


Link to post
Share on other sites

Here's the fix:

if (($categories['categories_image'] = 'NULL') or categories) {

} else {

$print_echo = "tep_image(DIR_WS_IMAGES) . $categories['categories_image'], $categories['categories_name'],

SUBCATEGORY_IMAGE_WIDTH, SUBCATEGORY_IMAGE_HEIGHT)";

}

 

a missing right bracket after (DIR_WS_IMAGES


Unexpect the Expected

Share this post


Link to post
Share on other sites

Thank's mouflon

I try it

but unfortunately the fix doesn't work for me :?

 

for the moment I apply the DevTec's idea (with //)

Share this post


Link to post
Share on other sites

I don't get it... I first had the .zip file and that's corrupt. Then I downloaded the .tar file and I still get garbage when I try to insert the newsdesk.sql file in my db?

 

CVS: $Id: sqlparser.lib.php,v 1.29 2002/09/23 14:15:31 nijel Exp $

MySQL: 4.0.0-alpha-nt

USR OS, AGENT, VER: Win IE 6.0

PMA: 2.3.2

PHP VER,OS: 4.2.3 WINNT

LANG: nl-iso-8859-1

SQL: INSERT INTO newsdesk_description (newsdesk_id, language_id, newsdesk_article_name, newsdesk_article_description, newsdesk_article_shorttext, newsdesk_article_url, newsdesk_article_viewed, newsdesk_image_text, newsdesk_image_text_two, newsdesk_image_text_three) VALUES (1, 1, 'Stickies are here!', 'Stickies have been implemented in v1.4?r?n?r?nIsn?'t this a nifty feature?', 'Welcome to the Sticky area', '', 5, '', '', ''),

(1, 2, '', '', '', '', 0, '', '', ''),

(1, 3, '', '', '', '', 0, '', '', ''),

(2, 1, 'NewsDesk version 1.4', 'NewsDesk version 1.4 RELEASED!?r?n?r?nWith the great help of a few brave souls we can all now enjoy a newer and more powerful, flexible, function rich (too rich?) NewsDesk!?r?n?r?nMulitple imagesReview ApprovalsRSSHTML Bar EditingRemove ImagesSubtitles for ImagesAnd of course Stickies?r?nI hope that you?'ll enjoy your NewsDesk!', 'Welcome to NewsDesk version 1.4?r?n?r?nSpecial thanks to those who helped with Beta Testing!', '', 9, '', '', ''),

(2, 2, '', '', '', '', 0, '', '', ''),

(2, 3, '', '', '', '', 0, '', '', ''),

(3, 1, '3 images !!!', '3 images !!!?r?n?r?nNewsDesk version 1.4 now has the capability to use 3 images plus subtitles.?r?n?r?nYippe Isn?'t life grand?', 'NOW up to 3 images can be used!!!', '', 32, 'action', 'cartoons', 'graphic'),

(3, 2, '', '', '', '', 0, '', '', ''),

(3, 3, '', '', '', '', 0, '', '', '');



INSERT INTO newsdesk_reviews (reviews_id, newsdesk_id, customers_id, customers_name, reviews_rating, date_added, last_modified, reviews_read, approved) VALUES (1, 1, 2, 'test test', 5, '2003-03-11 01:26:31', NULL, 0, 1),

(2, 3, 2, 'Carsten aka Moyashi', 4, '2003-03-11 01:29:02', NULL, 0, 1),

(3, 2, 2, 'Carsten aka Moyashi', 5, '2003-03-11 01:29:53', NULL, 0, 0);



INSERT INTO newsdesk_reviews_description (reviews_id, languages_id, reviews_text) VALUES (1, 1, 'Thanks to Emiliano for his efforts in beta testing and providing ideas and code to help make NewsDesk better'),

(2, 1, 'hehe, after almost a week of effort I was able to finish this part of the mod.?r?n?r?nI hope that you all enjoy it!'),

(3, 1, 'I wonder who?'ll approve this review just to read it ????r?n?r?n:-D')----Einde RAW----



Fout



SQL-query :  



INSERT INTO newsdesk_description (newsdesk_id, language_id, newsdesk_article_name, newsdesk_article_description, newsdesk_article_shorttext, newsdesk_article_url, newsdesk_article_viewed, newsdesk_image_text, newsdesk_image_text_two, newsdesk_image_text_three) VALUES (1, 1, 'Stickies are here!', 'Stickies have been implemented in v1.4

?r?n

?r?nIsn?'t this a nifty feature?', 'Welcome to the Sticky area', '', 5, '', '', ''), (1, 2, '', '', '', '', 0, '', '', ''), (1, 3, '', '', '', '', 0, '', '', ''), (2, 1, 'NewsDesk version 1.4', 'NewsDesk version 1.4 RELEASED!

?r?n

?r?nWith the great help of a few brave souls we can all now enjoy a newer and more powerful, flexible, function rich (too rich?) NewsDesk!

?r?n

?r?n



Mulitple images

Review Approvals

RSS

HTML Bar Editing

Remove Images

Subtitles for Images

And of course Stickies



?r?nI hope that you?'ll enjoy your NewsDesk!', 'Welcome to NewsDesk version 1.4

?r?n

?r?nSpecial thanks to those who helped with Beta Testing!', '', 9, '', '', ''), (2, 2, '', '', '', '', 0, '', '', ''), (2, 3, '', '', '', '', 0, '', '', ''), (3, 1, '3 images !!!', '3 images !!!

?r?n

?r?nNewsDesk version 1.4 now has the capability to use 3 images plus subtitles.

?r?n

?r?nYippe Isn?'t life grand?', 'NOW up to 3 images can be used!!!', '', 32, 'action', 'cartoons', 'graphic'), (3, 2, '', '', '', '', 0, '', '', ''), (3, 3, '', '', '', '', 0, '', '', ''); INSERT INTO newsdesk_reviews (reviews_id, newsdesk_id, customers_id, customers_name, reviews_rating, date_added, last_modified, reviews_read, approved) VALUES (1, 1, 2, 'test test', 5, '2003-03-11 01:26:31', NULL, 0, 1), (2, 3, 2, 'Carsten aka Moyashi', 4, '2003-03-11 01:29:02', NULL, 0, 1), (3, 2, 2, 'Carsten aka Moyashi', 5, '2003-03-11 01:29:53', NULL, 0, 0); INSERT INTO newsdesk_reviews_description (reviews_id, languages_id, reviews_text) VALUES (1, 1, 'Thanks to Emiliano for his efforts in beta testing and providing ideas and code to help make NewsDesk better'), (2, 1, 'hehe, after almost a week of effort I was able to finish this part of the mod.?r?n?r?nI hope that you all enjoy it!'), (3, 1, 'I wonder who?'ll approve this review just to read it ????r?n?r?n:-D') 



MySQL retourneerde: 





You have an error in your SQL syntax near 't this a nifty feature?', '<b>Welcome to the Sticky area</b>', '', 5, '', '', ''' at line 1

 

anyone?


_____.:::.________###__________|/______

:(o o): . (o o) (o o)

ooO--(_)--Ooo-ooO--(_)--Ooo-ooO--(_)--Ooo-

Share this post


Link to post
Share on other sites

boy, I feel stupid - my fix is not a fix at all. The bracket is in the right place - I tested without uncommenting the offending code - of course it worked!! Doh :?

Off to have another look.....


Unexpect the Expected

Share this post


Link to post
Share on other sites

single quote problems.

 

Have no idea why they are doing that ... 1 thought is that going from unix to M$ code be a problem. Those inserts are just some examples of how you can use NewsDesk. If you still want to see them just ::


backslash them.

 

 

@ category images

I'm not comprehending completely what's happening here. Could somebody s.p.e.l.l. it out for me :oops:

 

Basically what was done is that pre-MS1 snapshots had a problem with images. osC just wanted to make sure IE on M$ would show you a wonderful default blank image in place of the non-existent image. A NewsDesk user passed along some code to help combate that problem.

 

 

@ "approved" for upgraders.

Sorry, I haven't gotten around to that. Been busy with a home life.

 

@ bread-crumb trail

Next release I'll try to work on that some more. I'm hoping to clean up the code some more too.

 

@ any other known issues?


NewsDesk(934) / FAQDesk(1106) / OrderCheck(1168) :::

Share this post


Link to post
Share on other sites
Here's the fix:

if (($categories['categories_image'] = 'NULL') or categories) {

} else {

$print_echo = "tep_image(DIR_WS_IMAGES) . $categories['categories_image'], $categories['categories_name'],

SUBCATEGORY_IMAGE_WIDTH, SUBCATEGORY_IMAGE_HEIGHT)";

}

 

a missing right bracket after  (DIR_WS_IMAGES

 

 

 

I had issues with both the newsletter_info.php for the news articles as well as with the newsletter_index.php for the categories - there was an error in the newsletter_index.php file as well.

 

Instead of: (about lines 183-187 without wordwrap on!)

 

if (($categories['categories_image'] = 'NULL') or categories) {

} else {

$print_echo = "tep_image(DIR_WS_IMAGES . $categories['categories_image'], $categories['categories_name'],

SUBCATEGORY_IMAGE_WIDTH, SUBCATEGORY_IMAGE_HEIGHT)";

}

 

 

 

It should be: (about lines 183-187 without wordwrap on!)

 

if (($categories['categories_image'] = 'NULL') or categories) {

} else {

$print_echo = tep_image(DIR_WS_IMAGES . $categories['categories_image'], $categories['categories_name'],

SUBCATEGORY_IMAGE_WIDTH, SUBCATEGORY_IMAGE_HEIGHT);

}

 

 

Hope this helps someone else...

Share this post


Link to post
Share on other sites

above comment regarding newsletter_index.php was for

 

catalog/newsletter_info.php

 

forgot to mention that :oops: sorry!

Share this post


Link to post
Share on other sites

Parse error: parse error, expecting `T_STRING' or `T_VARIABLE' or `T_NUM_STRING' in c:program filesapache groupapachetestbettalondon_17mar03newsdesk_index.php on line 185

 

this is at line 185

if (($categories['categories_image'] = 'NULL') or categories) {

} else {

$print_echo = "tep_image(DIR_WS_IMAGES . $categories['categories_image'], $categories['categories_name'],

SUBCATEGORY_IMAGE_WIDTH, SUBCATEGORY_IMAGE_HEIGHT)";

}

 

Sorry, I didn't get the solution.. can someone tell me?

 

one more thing, what is the "LOADED 5 version"

what am it supposed to do?

 

Thanks

 

Salvo

Share this post


Link to post
Share on other sites
I had issues with both the newsletter_info.php for the news articles as well as with the newsletter_index.php for the categories - there was an error in the newsletter_index.php file as well.

 

Instead of: (about lines 183-187 without wordwrap on!)

 

if (($categories['categories_image'] = 'NULL') or categories) {

} else {

$print_echo = "tep_image(DIR_WS_IMAGES . $categories['categories_image'], $categories['categories_name'],  

SUBCATEGORY_IMAGE_WIDTH, SUBCATEGORY_IMAGE_HEIGHT)";

}

 

 

 

It should be: (about lines 183-187 without wordwrap on!)

 

if (($categories['categories_image'] = 'NULL') or categories) {

} else {

$print_echo = tep_image(DIR_WS_IMAGES . $categories['categories_image'], $categories['categories_name'],  

SUBCATEGORY_IMAGE_WIDTH, SUBCATEGORY_IMAGE_HEIGHT);

}

...

 

You will notice that there is a pair of " that should not be in the script - go to catalog/newsletter_index.php

 

around line 183 or so you will see a line that begins with

 

$print_echo =

 

 

the code currently has "tep_image

but it should be simply tep_image - no " before the t

 

also the end of that same line is:

 

SUBCATEGORY_IMAGE_HEIGHT)";

 

 

again it should NOT have the " between the ) and the ;

 

it should simply be SUBCATEGORY_IMAGE_HEIGHT);

 

hope that helps!

Share this post


Link to post
Share on other sites

I just posted this twice above burt -

 

if you remove the " in this statement:

 

$print_echo = "tep_image(DIR_WS_IMAGES . $categories['categories_image'], $categories['categories_name'], SUBCATEGORY_IMAGE_WIDTH, SUBCATEGORY_IMAGE_HEIGHT)";

 

your error will go away - or you can simply copy and paste this over your existing code:

 

$print_echo = tep_image(DIR_WS_IMAGES . $categories['categories_image'], $categories['categories_name'], SUBCATEGORY_IMAGE_WIDTH, SUBCATEGORY_IMAGE_HEIGHT);

 

try that...

 

this change is made in the

 

catalog/newletter_index.php file

Share this post


Link to post
Share on other sites

Thanks, I got it now.... taken away the "" from the statement..

 

Now I like to know what the

"LOADED 5 version"

 

Thanks

 

Salvo

Share this post


Link to post
Share on other sites

For those who use the Loaded addition, (I'M lazy) just upload all files first and then

just over-write the files with the ones located in the "LOADED 5 version" directory.

 

this is what I have found and I don't understand it.. ( I am sorry)

 

should I use the files in the loaded 5 version or there are the same?

 

I have os oct 2002, and so far works...

 

are the loaded 5 version better? should I use them?

 

Thanks

 

Salvo

 

PS: very very nice contribution... well done

Share this post


Link to post
Share on other sites

Hello again :lol:

 

Now it's all right but in newsdesk_info.php i can't see the images :roll:

In newsdesk_index.php and front page i can see it, but not in the complete articles.

 

I'm the only? :?

Share this post


Link to post
Share on other sites

@salvo

If you use Ian's Loaded version then you should use those files. If you just MS1 or a snapshot then don't use those files.

 

@ newsdesk_info

I added a corrected file to the contribution area. It's just 1 file.

 

 

 

@ other image bug.

I still have no idea what you're all referring to. If someone one kindly fill me in I'll fix that file too.


NewsDesk(934) / FAQDesk(1106) / OrderCheck(1168) :::

Share this post


Link to post
Share on other sites

Thanks Moyashi, as I don't use ian' version, I will not use the loaded...

 

Regarding the image mentioned above by mikimoto, I have the same problem...

 

The Image will not show on full article....

 

salvo

Share this post


Link to post
Share on other sites

@salvo

 

check the contribution area. I have uploaded a patch for that problem.


NewsDesk(934) / FAQDesk(1106) / OrderCheck(1168) :::

Share this post


Link to post
Share on other sites
@salvo

 

check the contribution area. I have uploaded a patch for that problem.

 

Thanks moyashi, that is very good...

 

Job well done....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×