Jump to content
Sign in to follow this  
detoner

DELETE FROM cache WHERE

Recommended Posts

Hi

 

Just installed v22d_11 Ultimate SEO - on oscommerce 2.3.1

 

The catolog front end is working fine but the admin is broken - cannot upload images/add categories - we get this error

 

 

1146 - Table 'xxxx.cache' doesn't exist

 

DELETE FROM cache WHERE cache_name LIKE '%seo_urls%'

 

[TEP STOP]

 

and tried to enable page editor cache in admin but it gave same error

 

Checked install and seem to have followed all instructions - does anybody know whats wrong?

Thanks in advance

Share this post


Link to post
Share on other sites
Checked install and seem to have followed all instructions - does anybody know whats wrong?

check if the cache table in your mysql database is exist


Please read this line: Do you want to find all the answers to your questions? click here. As for contribution database it's located here!

8 people out of 10 don't bother to read installation manuals. I can recommend: if you can't read the installation manual, don't bother to install any contribution yourself.

Before installing contribution or editing/updating/deleting any files, do the full backup, it will save to you & everyone here on the forum time to fix your issues.

Any issues with oscommerce, I am here to help you.

Share this post


Link to post
Share on other sites

check if the cache table in your mysql database is exist

 

no it doesn't exist-

 

so I looked at the includes/classes/seo.class.php - file (which I believe to install the database) and saw the code TYPE=MyISAM; and changed this to ENGINE=MyISAM; - as I had the same problem yesterday - when I went to run an sql script it said syntax error for your mysql version - we have the latest php installed 5.3.7 - so I unistalled the contribution and then tried to reinstall but I get the same error! and still no cache table in the database - I did click on the catalog front end and it was doing the clean url rewrites - which according to the install instructions this should then load the tables into the database -

 

so maybe there is other no valid syntax for my version of php -

 

is the sql script available for ultimate urls 22d_11 separately and then we can see the errors as they happen? or is their some other fix?

 

Thanks in advance

Share this post


Link to post
Share on other sites

To fix this error, remove or comment out the following block of code from admin/categories.php around line 22

 

// Ultimate SEO URLs v2.1

// If the action will affect the cache entries

if ( eregi("(insert|update|setflag)", $action) ) include_once('includes/reset_seo_cache.php');

To comment it out, put /* at the beginning and */ at the end, so it looks like this:

/*

// Ultimate SEO URLs v2.1

// If the action will affect the cache entries

if ( eregi("(insert|update|setflag)", $action) ) include_once('includes/reset_seo_cache.php');

*/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×