Jump to content
Sign in to follow this  
jdgrinder

upsxml installing help

Recommended Posts

ok I am trying to install upsxml and I got to step 3 and couldn't find catalog/admin/modules.php in my os commerce folder. Also what do I do with the upsxml folder do I put that in os commerce? Any help is much appreciated.

Share this post


Link to post
Share on other sites

ok I manage to install everything up to step 3 and I input the code and then when I go to put in my ups info in the admin area for os commerce. I get this error

Warning: Variable passed to each() is not an array or object in /home/bbhyd/public_html/oscommerce/admin/modules.php on line 36

Warning: Cannot modify header information - headers already sent by (output started at /home/bbhyd/public_html/oscommerce/admin/modules.php:36) in /home/bbhyd/public_html/oscommerce/admin/includes/functions/general.php on line 34

 

here is the code for module.php

 

  if (tep_not_null($action)) {
   switch ($action) {
     case 'save':

       while (list($key, $value) = each($HTTP_POST_VARS['configuration'])) {
       if (is_array($value) ) {
         $value = implode( ", ", $value);
	      $value = ereg_replace (", --none--", "", $value);
	    }
         tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = '" . $value . "' where configuration_key = '" . $key . "'");
       }
       tep_redirect(tep_href_link(FILENAME_MODULES, 'set=' . $set . '&module=' . $HTTP_GET_VARS['module']));
       break;
     case 'install':

 

can anyone help me out please

Share this post


Link to post
Share on other sites

You need to go back through the files you modified and check the additions. The first warning is a missing bracket or a line that was mixed with the previous line. The second warning means that the info you added was previously added somewhere else.

Re-read the instructions and start again.

You also need to post more of your module file for us to help. I would post the complete file text.

Matt


If the only tool you have is a hammer, all your problems look like nails

Share this post


Link to post
Share on other sites
$module_type = $cfgModules->get($set, 'code');
 $module_directory = $cfgModules->get($set, 'directory');
 $module_language_directory = $cfgModules->get($set, 'language_directory');
 $module_key = $cfgModules->get($set, 'key');;
 define('HEADING_TITLE', $cfgModules->get($set, 'title'));
 $template_integration = $cfgModules->get($set, 'template_integration');

 $action = (isset($HTTP_GET_VARS['action']) ? $HTTP_GET_VARS['action'] : '');

 if (tep_not_null($action)) {
   switch ($action) {
     case 'save':

       while (list($key, $value) = each($HTTP_POST_VARS['configuration'])) {
       if (is_array($value) ) {
         $value = implode( ", ", $value);
	      $value = ereg_replace (", --none--", "", $value);
	    }
         tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = '" . $value . "' where configuration_key = '" . $key . "'");
       }
       tep_redirect(tep_href_link(FILENAME_MODULES, 'set=' . $set . '&module=' . $HTTP_GET_VARS['module']));
       break;
     case 'install':
     case 'remove':

Share this post


Link to post
Share on other sites

Are you using a template for OSC? That code is not normal OSC code.


If the only tool you have is a hammer, all your problems look like nails

Share this post


Link to post
Share on other sites

Good evening guys

I had install the uos xml rates , i believe that i had done it right , i haven't steel take my keys from UPS and the program in my shop it sais :

" 10002: The XML document is well formed but the document is not valid. If you prefer to use UPS as your shipping method contact with owner in the email...".

Also i havn't configure the kg or Lb. Do you know if this error comes only from my missing keys?


One amateur made the Arc, 5.000 pro made the Titanic...

Share this post


Link to post
Share on other sites

I need help installing UPSXML 1.4.0

 

According to install.txt file I have to run three queries found in (or use the file itself) the included sql file: configuration_shipping.sql to add three configuration keys to the table configuration. Then configure them in Admin->Configuration->Shipping/Packaging:

 

When I enter configuration_shipping.sql nothing happens!

 

This is what the screen says: - Nothing changes in my Admin Set ups

 

INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Dimensions Support', 'SHIPPING_DIMENSIONS_SUPPORT', 'No', 'Do you use the additional dimensions support (read dimensions.txt in the UPSXML package)?', '7', '6', 'tep_cfg_select_option(array(\'No\', \'Ready-to-ship only\', \'With product dimensions\'), ', now());

 

INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) values ('Unit Weight', 'SHIPPING_UNIT_WEIGHT', 'LBS', 'By what unit are your packages weighed?', '7', '7', 'tep_cfg_select_option(array(\'LBS\', \'KGS\'), ', now());

 

INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) values ('Unit Length', 'SHIPPING_UNIT_LENGTH', 'IN', 'By what unit are your packages sized?', '7', '8', 'tep_cfg_select_option(array(\'IN\', \'CM\'), ', now());

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×