Latest News: (loading..)
greasemonkey

FedEx - Web Services v9

685 posts in this topic

The module works so I am not sure why it does not work on your site. YOu are saying that when you get to checkout_shipping the entire page is blank? Hvae you done the Soap test to see that soap is installed on your server?

 

i have checked my sever, it said the soap is enable and php version is 5.1.6

what can I do to fix the error?

Share this post


Link to post
Share on other sites

i have checked my sever, it said the soap is enable and php version is 5.1.6

what can I do to fix the error?

 

OK, I went back through the posts and in one of them, you said that you were missing a couple of the items that you need to fill in on the Admin panel for this module.

 

Did you ever get the additional codes to fill in?

 

Your need:

 

FedEx Web Services Key

FedEx Web Services Password

FedEx Meter Number

FedEx Account Number

 

The last one you probably have as it is the one for your standard FedEx account. For the other 3, you need to call FedEx and tell them you want to use their Web Services. They will take you through the procedure, talking you through it over the phone, of what to click on to, first, get your test server credentials and then your production server credentials.

 

After you get those three, it should just be a matter of plugging them in and away you go.

Share this post


Link to post
Share on other sites

Well, after spending a couple of hours on the phone with a technical support team from my ISP, easyCGI (yes, it's in the EIG list), it appears that the module can't be easily modded to work with PEAR SOAP. A re-wrire seems to be what is needed.

 

So, that is that if you are on the EIG list in a previous post. The time frame for PHP SOAP, which is what this module really needs, is, as I said earlier, one to two months.

 

For those of you on EIG servers who are still using the old API model, you should be fine until the PHP SOAP roll-out and then you can switch to this module.

 

For those of us that were switching because of the Canada Post strike, well, they should be legislated back to work the end of this week or the beginning of next, so we can go back to CP and wait until the PHP roll-out to add this shipping module.

 

For those that are new, on an EIG server and want to add this module, you'll either have to wait or switch to an ISP that has PHP SOAP.

 

I did what I could, EIG did what they could and the scope of the required change was outside of what they do about code that won't run. They see the need for PHP SOAP and they also see the need to roll it out in a responsible manner.

 

If anyone HAS re-written this application so that it runs under PEAR SOAP, I'd be glad to hear about it.

Share this post


Link to post
Share on other sites

Well, after spending a couple of hours on the phone with a technical support team from my ISP, easyCGI (yes, it's in the EIG list), it appears that the module can't be easily modded to work with PEAR SOAP. A re-wrire seems to be what is needed.

 

So, that is that if you are on the EIG list in a previous post. The time frame for PHP SOAP, which is what this module really needs, is, as I said earlier, one to two months.

 

For those of you on EIG servers who are still using the old API model, you should be fine until the PHP SOAP roll-out and then you can switch to this module.

 

For those of us that were switching because of the Canada Post strike, well, they should be legislated back to work the end of this week or the beginning of next, so we can go back to CP and wait until the PHP roll-out to add this shipping module.

 

For those that are new, on an EIG server and want to add this module, you'll either have to wait or switch to an ISP that has PHP SOAP.

 

I did what I could, EIG did what they could and the scope of the required change was outside of what they do about code that won't run. They see the need for PHP SOAP and they also see the need to roll it out in a responsible manner.

 

If anyone HAS re-written this application so that it runs under PEAR SOAP, I'd be glad to hear about it.

 

LOL, I am with Startlogic. Sorry it took so long to reply. I had to step away for a few days or I was going to loose my mind! Once I did more searching throughout my admin area, it noticed quite a few errors because I have a heavily mod'ed site...so I ended up deleted it anyways, I just didn't have time to start messing with everything. I might approach it again in a while though (a while meaning when I get my sanity back LOL).

I still don't quite get the difference between php soap and pear soap though, I searched and searched and my tech support was no help, they had the nerve to tell me to google it. I nearly lost my mind on them! Either way, I can't obviously do anything anytime soon :@

Share this post


Link to post
Share on other sites

LOL, I am with Startlogic. Sorry it took so long to reply. I had to step away for a few days or I was going to loose my mind! Once I did more searching throughout my admin area, it noticed quite a few errors because I have a heavily mod'ed site...so I ended up deleted it anyways, I just didn't have time to start messing with everything. I might approach it again in a while though (a while meaning when I get my sanity back LOL).

I still don't quite get the difference between php soap and pear soap though, I searched and searched and my tech support was no help, they had the nerve to tell me to google it. I nearly lost my mind on them! Either way, I can't obviously do anything anytime soon :@

 

Yes, it's been a rather trying experience for me as well, but, we gave it our best shot.

 

OK, let me see if I can explain the difference.

 

The "operating system" of non-Windows servers is a bunch of code called Apache. Basically, it handles the "calls" from all the code that makes up you OsCommerce store (for example) and directs those calls to the "libraries" that handles what that code wants to do.

 

With PHP SOAP, the SOAP "library" is part of the Apache code so, any module that "calls" for a SOAP function is handled automatically.

 

With PEAR SOAP, the way it works is as a "stand-alone" program outside of the Apache code. Therefore, if you want a SOAP function handled, you have to build the module to "call" any of the functions individually. So, if you are writing code for the stand-alone PEAR SOAP, you have to include these calls which you wouldn't have to if you had the PHP SOAP extension installed because the Apache code would handle them all without the calls.

 

Here is the ultimate simplified explanation; PHP Soap is an automatic transmission, PEAR SOAP is a 4 speed manual transmission LOL

Share this post


Link to post
Share on other sites

 

Here is the ultimate simplified explanation; PHP Soap is an automatic transmission, PEAR SOAP is a 4 speed manual transmission LOL

LOL understood!

Share this post


Link to post
Share on other sites

Hi everyone,

 

Just wonder how to make the shipping insurance work? We tried to unlock the below module for insurance but no matter how much we declare, it only generates one value and it's the shipping cost itself (insurance = 0)

 

 

function _setInsuranceValue($order_amount){

if ($order_amount > (float)MODULE_SHIPPING_FEDEX_WEB_SERVICES_INSURE) {

$this->insurance = sprintf("%01.2f", $order_amount);

} else {

$this->insurance = 0;

}

}

 

//$totals = $order->info['subtotal'] = $_SESSION['cart']->show_total();

$this->_setInsuranceValue($totals);

 

 

request['RequestedShipment']['TotalInsuredValue']=array('Ammount'=> $this->insurance, 'Currency' => $_SESSION['currency']);

 

 

Any help would be much appreciated.

Share this post


Link to post
Share on other sites

Hi, I'm having issues with international quotes from this app. Some work just fine but only if using 2 letter states. We get quite a bit of traffic from Spain and it uses a dropdown of states in the default osc 2.3.1.

 

When they get to shipping quotes, it gets the error:

Error in processing transaction.

 

ERROR

crs

840

The length of the destination state or province exceeds the limit of 2 characters.

The length of the destination state or province exceeds the limit of 2 characters.

 

I haven't found any other countries that get this error, but seeing how much traffic we get from spain we need to get it working, Any ideas?

Share this post


Link to post
Share on other sites

Well it seems to be working if the state goes through correctly at least, but I'd like to add some simple error handling. I'm new to php and cannot find which file I would need to edit. I'd like it to display "Error fetching shipping amounts from FedEx - Please check your address and try again or contact us if you wish to use FedEx service." and also display the error code in parentheses.

 

I think it would be good to have these sort of options or something available, once FedEx shuts off the old API I bet tons of users will migrate to this add-on.

Edited by jonesy827

Share this post


Link to post
Share on other sites

The FedEx Web services is working on mine, but anyone can help to add the transit time in the Fedexwebservices.php same as the old FedEx1 module? Fedex web site give us this code:

 

 

  $rateReply = $response -> RateReplyDetails;

echo '<table border="1">';

echo '<tr><td>Service Type</td><td>Amount</td><td>Delivery Date</td></tr><tr>';

$serviceType = '<td>'.$rateReply -> ServiceType . '</td>';

$amount = '<td>$' . number_format($rateReply->RatedShipmentDetails[0]->ShipmentRateDetail->TotalNetCharge->Amount,2,".",",") . '</td>';

if(array_key_exists('DeliveryTimestamp',$rateReply)){

$deliveryDate= '<td>' . $rateReply->DeliveryTimestamp . '</td>';

}else if(array_key_exists('TransitTime',$rateReply)){

$deliveryDate= '<td>' . $rateReply->TransitTime . '</td>';

}else {

$deliveryDate='';

}

echo $serviceType . $amount. $deliveryDate;

echo '</tr>';

echo '</table>';

 

printSuccess($client, $response);

}

else

{

printError($client, $response);

}

 

writeToLog($client); // Write to log file

 

Thanks

Share this post


Link to post
Share on other sites

Maybe someone can help me here. My fedex would not load this morning. the page wouldnt get any further than the delvery option page. Fedex shipping prices would not even register.

 

So I figured I go ahead and reinstall the files. Now I'm getting this: And Im about to kill myself

 

 

Warning: require_once(/home/theholy4/public_htmlincludes/library/fedex-common.php5) [function.require-once]: failed to open stream: No such file or directory in /home/theholy4/public_html/includes/modules/shipping/fedexwebservices.php on line 59

 

Fatal error: require_once() [function.require]: Failed opening required '/home/theholy4/public_htmlincludes/library/fedex-common.php5' (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/theholy4/php') in /home/theholy4/public_html/includes/modules/shipping/fedexwebservices.php on line 59

 

I'm thinking it may have to do something with the public_htmlincludes not having a / btwn them

Share this post


Link to post
Share on other sites

Open letter to FedEx Web Services Developers,

 

Thank you for providing this module. V.9 is functioning very well for me. With the old API to go offline next spring, I would like to make some urgent roadmap suggestions for this module that would hopefully improve the functionality and flexibility that many osCommerce sellers need. As the module stands some would consider it feature-poor, only in that the it is very rigid, with little room for customization per each shippers needs. Technically it seems very well crafted.

 

I would ask the Developers to look closely at the features and capabilities of the original FedEx Real Time Quotes module for osCommerce -2.07.2

http://addons.oscommerce.com/info/1462

This module has been improved and enhanced over the years by many contributors to provide a fairly good amount of rate customization based on the shippers needs.

 

Learning from FedEx Real Time Quotes, things that would improve this modules flexibility:

- Ship-Separate item designations - so that FedEx will generate per-item separate quotes when desired (heavy items, bulky items, etc...) Products not checked "Ship Separately" continue to be processed per your stores existing configuration. This field already exists in the osCommerce database for current Real Time Quote users 2.06 or later. products_ship_sep in the products table.

- Separated Surcharge entry on a per-service type, in positive or negative dollars, or +/- percentage.

- Ability to display discounted rates, or FedEx list rates, to customer

- Ability to apply tiered Ground shipping discounts based on Order Total Weight (for Ground Multi-Weight shippers)

- Insurance handling

- Add a README to the uploaded package. People like instructions.

- In Checkout_shipping, the customer should see an item count and total weight, along with an accurate quote for the entire order such as:

FedEx (Total items: 1 pcs. Total weight: 6 lbs.)

 

As sellers we are all FedEx Customers, and as FedEx’s customers I would think that it is in the best interest of FedEx to improve this module, especially if they expect to retain customers and grow their shipper base. If anyone else has a suggestion to make this module work better for your specific needs please post. Hopefully the Developers will pay attention and continue to improve this very nice beginning of a module. If nothing improves from the current version by next spring, when all the old API accounts are no longer functioning there could be a bit of a rough transition ahead.

 

Thanks for listening

Share this post


Link to post
Share on other sites

Roaddoctor, FedEx did not supply this Add On. Someone from over at ZenCart generously provided it. It is up to the osCommerce community to continue its development.

 

Savierrnr, your path "/home/theholy4/public_htmlincludes/library/fedex-common.php5 is missing a / between the public_html and the includes.

Share this post


Link to post
Share on other sites

Roaddoctor, FedEx did not supply this Add On. Someone from over at ZenCart generously provided it. It is up to the osCommerce community to continue its development.

 

Savierrnr, your path "/home/theholy4/public_htmlincludes/library/fedex-common.php5 is missing a / between the public_html and the includes.

 

Good to know. Thank you ZenCart folks. I'm very limited in my ability to code, but plan on adding my .02 where possible. Hopefully this module will become more robust before the old API is retired.

Share this post


Link to post
Share on other sites

Good to know. Thank you ZenCart folks. I'm very limited in my ability to code, but plan on adding my .02 where possible. Hopefully this module will become more robust before the old API is retired.

 

Indeed thanks to the people over at ZenCart, and anyone currently working on the contribution.

 

A quick interjection; has anyone encountered an issue where the module returns $0.00 quotes? Everything else seams to be working fine.

 

Thanks!

 

Ben

Share this post


Link to post
Share on other sites

I've tried and tried installing, uninstalling and installing again the FedEx - Web Services v9. I’ve moved from Test to Production and still receiving the same error. All of the info is 100% correct and was advised that I've haven’t configured the Fedex Mod correctly. Where is the exact file I need to look into to see if it is configured correctly? This mod is being used only for Shipping for printing shipping labels. Thanks.

 

Error in processing transaction.

 

ERROR

prof

1000

Authentication Failed

Edited by Beauricua

Share this post


Link to post
Share on other sites

It is configured in the module in Admin. Make sure you have PRODUCTION keys and not TEST keys. You cannot use the same valuesfor both.

Share this post


Link to post
Share on other sites

I installed the V9.1 full package by creating new folders in the includes folder for library and wsdl and then proceeded to go to includes/languages/english/modules/shipping to upload the file fedexwebsrvices.php. I then went to includes/modules/shipping and uploaded the file fedexwebservices.php. I uploaded fedex-common.php into the includes/library and RateService_v9.wsdl into the icnludes/wsdl folder.

I then went to my admin panel and installed the fedex module with my production key, meterid, production password, account number and other required info.

When I tried a test run, I went to checkout after choosing an item and all I get is a blank screen at the location website/checkout_shipping.php/session id.

What else do I need to do to make the module work? There is nothing in the contribution other than upload everything. I did the soaptest and it worked fine. I have made no other changes. If I change use fedex to false in the admin panel and refresh the screen on checkout, I get the options for USPS and UPS. Not sure what else I need to do.

Jim

 

I also posted this as a new topic, Blank screen at checkout. Just not sure where to put it to get an answer. Also sent an email to atnaples asking the questions

Share this post


Link to post
Share on other sites

There is really no need to load each file one by one. If you just load the includes folder via ftp it will load everything in the right place.

 

Apart from configuring it in Admin then is nothing more to add. Anyone looking for more documentation than that needs read the FedEx documentation there. http://www.fedex.com/us/developer/product/WebServices/MyWebHelp/

 

For detailed information see http://www.fedex.com/us/developer/product/WebServices/MyWebHelp/Utilities/c_RateCodingDetails.html#/us/developer/product/WebServices/MyWebHelp/Transactions/WS/r_RateRequestElements.html

 

Forestshopkeeper, if you have more than one shipping module turned on then make sure they each have a unique sort order.

 

Anyone else, if you come here looking for help and then resolve your problem it would be a good idea to then post how you fixed it in order to help others.

Edited by FlyingKites

Share this post


Link to post
Share on other sites

I had to turn FTP off for PCI compliance. That leaves me with uploading one file at a time. I have three shipping modules sorted as 0.1,and 2. My OSCommerce website works fine with FedEx disabled, but crashes at the checkout shipping page when it is turned on. I have no idea why. I am running OSC 2.2MS 2 RC2A. I copied and pasted everything I got from FedEX: The production key, the production password, the meter id and the account number. I can see the module in the admin panel and I can edit it. It works with order editor, and I can change the order I see to reflect FedEX, but I have not been able to get it to work on the checkout process to let the customer choose a shipping method. I even tried disabling the UPS module and I still could not get it to work. Is there something I need to change in any of the OSC files to make it work?

Jim

Share this post


Link to post
Share on other sites

I have even tried it with no other modules turned on and I still get a blank page. I have seen this in other posts about this topic, but I have not seen an answer.

Jim

Share this post


Link to post
Share on other sites

You don't have to turn off ftp to be PCI compliant.

 

We have this module working on Rc2a. I don't know of other posts that talk about it.

 

You did not say if you checked the sort order of your shipping modules. They need to be all unique.

 

If you can see it in Admin and not on the site then it points to it not actually being installed properly. Perhaps when it goes to call something in the other folders. So you might want to check yout setup again.

 

Also check your error log to see if there is an error message there.

Edited by FlyingKites

Share this post


Link to post
Share on other sites

Thank you for getting back to me

 

Yes, I did have to turn off FTP to get my PCI compliance. I am on a shared server and the only way McAfee would allow me to be PCI Compliant was to shutdown FTP access to my web site.

 

I too am on MS2.2RC2A, but I get a blank page when the customer goes to checkout if FedEx shipping is turned on.

 

I did say that each shipping module has a unique sort order. 0, 1, and 2. It was in my previous post.

 

I have not seen anything in the logs, but I am having difficulty interpreting them.

 

The other post I talked about was not in this exact topic, but found under a FedEX query.

 

Jim

Share this post


Link to post
Share on other sites

Dsolutions, actually the way it is set up, it is supposed to show the LIST rates but there is a bug in the code that means it actually uses the ACCOUNT rates. ozEworks are looking into it now and we'll be loading a new version maybe later this week.

Edited by FlyingKites

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now