Jump to content
Sign in to follow this  
ms35d4

Why No Products on Search Engine

Recommended Posts

Hello

 

I am new to ecommerce and slowly learning and developing a site.

 

I have currently installed the following add ons.

 

KissMT_1.0_r72_RC

Ultimate_Seo_Urls_5_PRO_r205

usu5 XML Site Maps

 

 

I have checked and re-checked the intallation instructions and am sure all have bene isntalled correctly,

 

However, after several weeks gone by, I can't see any of my products when searching search engine, for example google.

 

If I take a particualr model or manufacturer number from my site and put it in google it will display results but when I click on the link it takes me to adifferent page altogether, and not the page the product is at.

 

I have checked other competitors using the same search phrases or words, number and the results are shown and when I click on it take me direct to the product page.

 

I am new to ecommerce and ocsommerce and thought I would have dont enough to get some results PLEASE can someone tell me looking at the above add ons do I need anything more? another add on so i can achieve this

 

Any advice or help would be much appreciated as I am really struggling, reading so many post etc casuing even more confusion and information overload. I tried to use add on conrtributions what work together, or that are mentioned as compatible.

 

Kind Regards

Share this post


Link to post
Share on other sites
However, after several weeks gone by, I can't see any of my products when searching search engine, for example google.

have you submitted your website or xml website map to search engines?


Please read this line: Do you want to find all the answers to your questions? click here. As for contribution database it's located here!

8 people out of 10 don't bother to read installation manuals. I can recommend: if you can't read the installation manual, don't bother to install any contribution yourself.

Before installing contribution or editing/updating/deleting any files, do the full backup, it will save to you & everyone here on the forum time to fix your issues.

Any issues with oscommerce, I am here to help you.

Share this post


Link to post
Share on other sites

Hello There

 

Thank you for the reply,

 

Yes, site has been submitted,

 

 

 

I have installed

 

SEO add on:

KissMT_1.0_r72_RC

 

Sitemap add on:

usu5 XML Site Maps

 

 

Ultimate_Seo_Urls_5_PRO_r205

 

Still not able to see anything as of yet.

 

Kind Regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×