Jump to content
arka

Trying to load WYSIWYG

Recommended Posts

Hi there,

 

sorry for the silly question... I went to the link that is present in the documentation in order to download an editor for the "Products description" box, but I have found a stumbling block at the fist step. The instructions read:

 

STEP 1.1 -->

====================================================================================

Firstly, Open /PHPMyAdmin --> (your_osCommerce_database) --> SQL --> Browse file --> HTML_WYSIWYG_SQL.sql --> [OK]

 

I am not quite clear what I am supposed to do with the bit in bold... I have accessed my database and clicked on SQL, but all I can do (in thoery...) is a query and there is no "browse file" box.

I have tried to "import" it, but it returns an error.

 

Where am I going wrong?

 

I am using FF4.0 on a MAC and OS Commerce 2.3.1

 

Thanks for your help.

Share this post


Link to post
Share on other sites

Should say

 

IMPORT --> Browse file --> HTML_WYSIWYG_SQL.sql --> [OK]

a few tabs along on the right

 

Nic

 

Hi there,

 

thanks for that.

 

I had tried that (for want of better things to try...) and this is what I got in return:

 

query SQL:

 

# NEW RECORDS FOR: WYSIWYG HTML AREA 1.6 BETA (Much)

# HTML_WYSIWYG_SQL.sql

# Created by: www.maxidvd.com.au MaxiDVD

INSERT INTO configuration_group( configuration_group_id, configuration_group_title, configuration_group_description, sort_order, visible )

VALUES (

'112', 'WYSIWYG Editor 1.6', 'HTMLArea 1.6 Options', '15', '1'

);

 

Messaggio di MySQL: Documentazione

#1062 - Duplicate entry '112' for key 1

Share this post


Link to post
Share on other sites

change it to

 

INSERT INTO configuration_group( configuration_group_id,  configuration_group_title, configuration_group_description, sort_order,  visible )
VALUES (
'199', 'WYSIWYG Editor 1.6', 'HTMLArea 1.6 Options', '15', '1'
);

 

and try again, it just means that for groupd id 112 is already taken by something else

 

Nic


Sometimes you're the dog and sometimes the lamp post

[/url]

My Contributions

Share this post


Link to post
Share on other sites

change it to

 

INSERT INTO configuration_group( configuration_group_id,  configuration_group_title, configuration_group_description, sort_order,  visible )
VALUES (
'199', 'WYSIWYG Editor 1.6', 'HTMLArea 1.6 Options', '15', '1'
);

 

and try again, it just means that for groupd id 112 is already taken by something else

 

Nic

 

Done, no difference:(

 

Now the error message is as follows:

query SQL: Documentazione

 

INSERT INTO `configuration` ( `configuration_id` , `configuration_title` , `configuration_key` , `configuration_value` , `configuration_description` , `configuration_group_id` , `sort_order` , `last_modified` , `date_added` , `use_function` , `set_function` )

VALUES (

'', 'PRODUCT DESCRIPTIONS use WYSIWYG HTMLAREA?', 'HTML_AREA_WYSIWYG_DISABLE', 'Enable', 'Enable/Disable WYSIWYG box', 199, 0, now( ) , now( ) , NULL , 'tep_cfg_select_option(array(\'Enable\', \'Disable\'),'

);

 

Messaggio di MySQL: Documentazione

#1062 - Duplicate entry '0' for key 1

 

Forgot to say that I have removed 112 from the whole text and replaced it with 199.

I also tried with 198, but no difference.

 

If instead I change ONLY the first 112, I get

# NEW RECORDS FOR: WYSIWYG HTML AREA 1.6 BETA (Much)

# HTML_WYSIWYG_SQL.sql

# Created by: www.maxidvd.com.au MaxiDVD

INSERT INTO configuration_group( configuration_group_id, configuration_group_title, configuration_group_description, sort_order, visible )

VALUES (

'199', 'WYSIWYG Editor 1.6', 'HTMLArea 1.6 Options', '15', '1'

);

 

Messaggio di MySQL: Documentazione

#1062 - Duplicate entry '199' for key 1

 

 

Everything else failing, can someone suggest another editor that is easy to install?

Edited by arka

Share this post


Link to post
Share on other sites

TinyMCE

Hi there,

 

I am not that clear how it should work...

I have had a look at the instructions, but it is really not clear to me how I should make it interface with OSC.

 

Pardon the stupid question, but why isn't this editor available by default?

 

Thanks:)

Share this post


Link to post
Share on other sites

I have just discovered that I can actually add style command (like bold, italics, etc) within the text. That should be enough to keep me going for now while I try to sort this thing out, but I would need to know how to add a carriage return... Any advise would be most appreciated

Share this post


Link to post
Share on other sites

Cannot find the "edit" button... never mind.

 

Anyway, I have found the various HTML commands I needed to edit my docs, so that's kind of sorted for now.

Anyway, I would still like the WYSIWYG editor to work as entering the commands by hand is really a palaver.

 

PS

 

The Edit button is in this last message... perhaps after so many minutes it disappears.

Edited by arka

Share this post


Link to post
Share on other sites

Did you do a search in the addons/contributions area, or did you goto tinymce's site? Hopefully the former.. I would then d/l several of the tinymce contributions, comparing the install instructions, and you should be able to figure it out....

Share this post


Link to post
Share on other sites

Ok, so I looked in the add-ons and wasn't happy with what I found. I added a contribution to add TinyMCE to the admin side of a v2.3.1 site. It needs still needs to be approved however. So in the next couple days look for my contribution, and you should be good to go. If you're just to much in a hurry to wait, let me know, and I'll post the instructions here for ya....

Edited by SLiCK_303

Share this post


Link to post
Share on other sites

Did you do a search in the addons/contributions area, or did you goto tinymce's site? Hopefully the former.. I would then d/l several of the tinymce contributions, comparing the install instructions, and you should be able to figure it out....

:'( :'( Alas it was the latter...

 

Anyway, I am having a shot at this:

http://addons.oscommerce.com/info/7661

BUT... i the install it says:

Upload all the files in your admin folder and just past this code:

 

 

<script type="text/javascript" src="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_ADMIN; ?>jscripts/tiny_mce/tiny_mce.js"></script>

<!-- made by niels voorn - Next-Gen Webdesign - www.ngwebs.com - info@ngwebs.com -->

<script language="javascript" type="text/javascript">

tinyMCE.init({

mode : "textareas",

elements : "ajaxfilemanager",

theme : "advanced",

plugins : "advimage,advlink,media,contextmenu",

theme_advanced_buttons1_add_before : "newdocument,separator",

theme_advanced_buttons1_add : "fontselect,fontsizeselect",

theme_advanced_buttons2_add : "separator,forecolor,backcolor,liststyle",

theme_advanced_buttons2_add_before: "cut,copy,separator,",

theme_advanced_buttons3_add_before : "",

theme_advanced_buttons3_add : "media",

theme_advanced_toolbar_location : "top",

theme_advanced_toolbar_align : "left",

extended_valid_elements : "hr[class|width|size|noshade]",

file_browser_callback : "ajaxfilemanager",

paste_use_dialog : false,

theme_advanced_resizing : true,

theme_advanced_resize_horizontal : true,

apply_source_formatting : true,

force_br_newlines : true,

force_p_newlines : false,

relative_urls : true

});

 

function ajaxfilemanager(field_name, url, type, win) {

var ajaxfilemanagerurl = "<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_ADMIN; ?>jscripts/tiny_mce/plugins/ajaxfilemanager/ajaxfilemanager.php";

switch (type) {

case "image":

break;

case "media":

break;

case "flash":

break;

case "file":

break;

default:

return false;

}

tinyMCE.activeEditor.windowManager.open({

url: "<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_ADMIN; ?>jscripts/tiny_mce/plugins/ajaxfilemanager/ajaxfilemanager.php",

width: 782,

height: 440,

inline : "yes",

close_previous : "no"

},{

window : win,

input : field_name

});

 

/* return false;

var fileBrowserWindow = new Array();

fileBrowserWindow["file"] = ajaxfilemanagerurl;

fileBrowserWindow["title"] = "Ajax File Manager";

fileBrowserWindow["width"] = "782";

fileBrowserWindow["height"] = "440";

fileBrowserWindow["close_previous"] = "no";

tinyMCE.openWindow(fileBrowserWindow, {

window : win,

input : field_name,

resizable : "yes",

inline : "yes",

editor_id : tinyMCE.getWindowArg("editor_id")

});

 

return false;*/

}

</script>

 

 

 

befor the

</head>

In for example newsletter.php or mail.php or categories.php

Or if you want to have it every where past it in all 3 the files!

 

(My bold, so that it is "easier" to read. I have copied the whole code in case it helps...)

 

I have looked into admin and found 2 files called categories.php, one in admin/include/languages/English (not sure if I have remembered the whole path) and one in admin, neither of which contain the string "/head". Is that because I am using 2.3 and the plugin is for 2.2??

 

Thanks a lot:)

Edited by arka

Share this post


Link to post
Share on other sites

Yes, the instructions are for 2.2x. In your case, add the code in admin/includes/template_top.php.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

HHmmm... there is something fishy here.

I have done as kymation has suggested and, lo and behold, the buttons, etc. have appeared where before there was only a box. HOWEVER, it is not working... If I try to edit a text (say I make two words in bold or add a few carriage returns), when I save it it reverts to the original version and all the changes are lost. In addition, the html codes don't work either.

 

Suggestions?

Share this post


Link to post
Share on other sites

You have tried getting different editors working with no success, so you have complicated the issue. The very first thing you need to do is go back, and remove ALL modifications to files in regards to getting an editor working. I have seen contributions telling you to edit admin/categories.php, and others you want the editor working in. Ive seen them have you edit admin/includes/functions/general.php and/or html_output.php. So I'll repeat myself you need to remove ALL modifications to files in regards to getting an editor working.

 

Ok, now that we're back to square-one, let's try this...

 

Goto TinyMCE site and get the latest version (3.4.2), save it to your harddrive, and then extract it to a temp folder on your harddrive. If you open that folder you just unzipped you will see a jscripts folder, and inside that a tiny_mce folder, take the tiny_mce folder, in it's entirety, and ftp it into your admin/includes/javascript folder, so you now have a admin/includes/javascript/tiny_mce folder, and inside it, just to make sure, you see the file tiny_mce.js, amongst others. Ok while you are in ftp, go ahead and delete the admin/includes/jscripts folder, from your old install. Now...do the following...

 

STEP 1:

EDIT: admin/includes/template_top.php

(if you changed the name of your admin folder, like you should have, change as necessary)

FIND: </head>

BEFORE ADD:

<?php
 if ((TINYMCE_USE == 'true') && (!strstr($PHP_SELF,FILENAME_REVIEWS))) {
?>
<!-- TinyMCE -->
<script type="text/javascript" src="includes/javascript/tiny_mce/tiny_mce.js"></script>
<script type="text/javascript">
tinyMCE.init({
	// General options
	mode : "textareas",
	theme : "advanced",
	plugins : "pagebreak,style,layer,table,save,advhr,advimage,advlink,emotions,iespell,inlinepopups,insertdatetime,preview,media,searchreplace,print,contextmenu,paste,directionality,fullscreen,noneditable,visualchars,nonbreaking,xhtmlxtras,template,wordcount,advlist,autosave",

	// Theme options
	theme_advanced_buttons1 : "save,newdocument,|,bold,italic,underline,strikethrough,|,justifyleft,justifycenter,justifyright,justifyfull,styleselect,formatselect,fontselect,fontsizeselect",
	theme_advanced_buttons2 : "cut,copy,paste,pastetext,pasteword,|,search,replace,|,bullist,numlist,|,outdent,indent,blockquote,|,undo,redo,|,link,unlink,anchor,image,cleanup,help,code,|,insertdate,inserttime,preview,|,forecolor,backcolor",
	theme_advanced_buttons3 : "tablecontrols,|,hr,removeformat,visualaid,|,sub,sup,|,charmap,emotions,iespell,media,advhr,|,print,|,ltr,rtl,|,fullscreen",
	theme_advanced_buttons4 : "insertlayer,moveforward,movebackward,absolute,|,styleprops,|,cite,abbr,acronym,del,ins,attribs,|,visualchars,nonbreaking,template,pagebreak,restoredraft",
	theme_advanced_toolbar_location : "top",
	theme_advanced_toolbar_align : "left",
	theme_advanced_statusbar_location : "bottom",
	theme_advanced_resizing : true,

	// Example content CSS (should be your site CSS)
//		content_css : "css/content.css",

	// Drop lists for link/image/media/template dialogs
//		template_external_list_url : "lists/template_list.js",
//		external_link_list_url : "lists/link_list.js",
//		external_image_list_url : "lists/image_list.js",
//		media_external_list_url : "lists/media_list.js",

	// Style formats
	style_formats : [
		{title : 'Bold text', inline : 'b'},
		{title : 'Red text', inline : 'span', styles : {color : '#ff0000'}},
		{title : 'Red header', block : 'h1', styles : {color : '#ff0000'}},
		{title : 'Example 1', inline : 'span', classes : 'example1'},
		{title : 'Example 2', inline : 'span', classes : 'example2'},
		{title : 'Table styles'},
		{title : 'Table row 1', selector : 'tr', classes : 'tablerow1'}
	],

	// Replace values for the template plugin
//		template_replace_values : {
//			username : "Some User",
//			staffid : "991234"
//		}
});
</script>
<!-- /TinyMCE -->
<?php
 }
?>

 

STEP 2:

Using phpmyadmin, or whatever mysql tool you use, import the following:

INSERT INTO `configuration` VALUES(NULL, 'Use TinyMCE', 'TINYMCE_USE', 'true', 'Select if you want to use TinyMCE or not', 1, 22, now(), now(), NULL, 'tep_cfg_select_option(array(''true'', ''false''), ');

 

You're done, go use your editor.....

Share this post


Link to post
Share on other sites

 

 

STEP 2:

Using phpmyadmin, or whatever mysql tool you use, import the following:

INSERT INTO `configuration` VALUES(NULL, 'Use TinyMCE', 'TINYMCE_USE', 'true', 'Select if you want to use TinyMCE or not', 1, 22, now(), now(), NULL, 'tep_cfg_select_option(array(''true'', ''false''), ');

 

You're done, go use your editor.....

 

Thanks a lot for that. I REALLY appreciate it.

However I have fallen at the last hurdle.

What am I supposed to do in STEP2? I have saved

INSERT INTO `configuration` VALUES(NULL, 'Use TinyMCE', 'TINYMCE_USE', 'true', 'Select if you want to use TinyMCE or not', 1, 22, now(), now(), NULL, 'tep_cfg_select_option(array(''true'', ''false''), ');

into a file, but I am not sure what to do with it...

Do I save it as .... what?? An .sql file and then import it using phpadmin? I have tried that, but got an error; here it is:

query SQL:

 

{ \ rtf1 \ ansi \ ansicpg1252 \ cocoartf1038 \ cocoasubrtf350{ \ fonttbl \ f0 \ froman \ fcharset0 Times - Roman;

 

Messaggio di MySQL: Documentazione

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '{\rtf1\ansi\ansicpg1252\cocoartf1038\cocoasubrtf350

{\fonttbl\f0\froman\fcharset' at line 1

 

Also, in case it is relevant, under configuration it looks as if the editor exists (see screenshot), but it doesn't work (it was enabled firts). If I click on the other WYSIWYG, the resulting page is empty.

Edited by arka

Share this post


Link to post
Share on other sites

Hhhmmm I have tried to link an image, but it is not allowing me. I am trying again:

http://db.tt/zDxv4Hk

The above is the screenshot I was referring to in my previous message.

Edited by arka

Share this post


Link to post
Share on other sites

Thanks a lot for that. I REALLY appreciate it.

However I have fallen at the last hurdle.

What am I supposed to do in STEP2? I have saved

 

into a file, but I am not sure what to do with it...

Do I save it as .... what?? An .sql file and then import it using phpadmin? I have tried that, but got an error; here it is:

 

 

Also, in case it is relevant, under configuration it looks as if the editor exists (see screenshot), but it doesn't work (it was enabled firts). If I click on the other WYSIWYG, the resulting page is empty.

 

go into phpMyAdmin, click on your database in the upper left, after it comes up in the frame on the right, click on SQL on the top of the right panel then paste the sql statement i gave you in the box, and hit go. If you have a prefix on your tables, you will need to add that to the `configuration' part. IE if you have a osc_ prefix, you need to make it `osc_configuration`.

 

You still have left over configuration crap from previous attempts to get an editor working.. You need to go back, and look at the install instructions of the previous contributions, maybe they had a seperate .sql file you imported... Then browse your configuration table, and try and find those, and remove them. Before you attempt this backup your database first!!

Share this post


Link to post
Share on other sites

go into phpMyAdmin, click on your database in the upper left, after it comes up in the frame on the right, click on SQL on the top of the right panel then paste the sql statement i gave you in the box, and hit go. If you have a prefix on your tables, you will need to add that to the `configuration' part. IE if you have a osc_ prefix, you need to make it `osc_configuration`.

STAR!!!

A+!!

It worked!!!

What a relief... I wasn't looking foward having to enter a longish list of description using HTML commands.

 

This thread should be highlighted... I can't be only clueless user who couldn't get a simple editor to work:):)

 

You still have left over configuration crap from previous attempts to get an editor working.. You need to go back, and look at the install instructions of the previous contributions, maybe they had a seperate .sql file you imported... Then browse your configuration table, and try and find those, and remove them. Before you attempt this backup your database first!!

Yes, there was such a file (I mention it in my previous posts within this thread), but there is nothing OBVIOUS (for me at least) in the phpadmin, nor do I have any code left that I previously transferred via ftp.

There again, if it is not doing any harm, I can live with that.

Share this post


Link to post
Share on other sites

Never mind, I am just a big dope:)

 

Everything is just fine :-" :-"

Edited by arka

Share this post


Link to post
Share on other sites

Hi there,

 

I completed all steps provided by SLICK_303 but I don't have a WYSIWYG editor when adding or amending products.

 

The only difference I had to the instruction is that I didn't have a template_top.php in my admin/includes/ folder.

 

I created a new template_top.php using gedit (linux text editor) inserted details, saved it and uploaded to admin/includes/ using ftp.

 

What have I done wrong?? :'(

Share this post


Link to post
Share on other sites

If you dont have template_top.php in the admin/includes, that means you are not using 2.3.1. Find a contrib for 2.2

Share this post


Link to post
Share on other sites

go into phpMyAdmin, click on your database in the upper left, after it comes up in the frame on the right, click on SQL on the top of the right panel then paste the sql statement i gave you in the box, and hit go. If you have a prefix on your tables, you will need to add that to the `configuration' part. IE if you have a osc_ prefix, you need to make it `osc_configuration`.

 

You still have left over configuration crap from previous attempts to get an editor working.. You need to go back, and look at the install instructions of the previous contributions, maybe they had a seperate .sql file you imported... Then browse your configuration table, and try and find those, and remove them. Before you attempt this backup your database first!!

You have tried getting different editors working with no success, so you have complicated the issue. The very first thing you need to do is go back, and remove ALL modifications to files in regards to getting an editor working. I have seen contributions telling you to edit admin/categories.php, and others you want the editor working in. Ive seen them have you edit admin/includes/functions/general.php and/or html_output.php. So I'll repeat myself you need to remove ALL modifications to files in regards to getting an editor working.

 

Ok, now that we're back to square-one, let's try this...

 

Goto TinyMCE site and get the latest version (3.4.2), save it to your harddrive, and then extract it to a temp folder on your harddrive. If you open that folder you just unzipped you will see a jscripts folder, and inside that a tiny_mce folder, take the tiny_mce folder, in it's entirety, and ftp it into your admin/includes/javascript folder, so you now have a admin/includes/javascript/tiny_mce folder, and inside it, just to make sure, you see the file tiny_mce.js, amongst others. Ok while you are in ftp, go ahead and delete the admin/includes/jscripts folder, from your old install. Now...do the following...

 

STEP 1:

EDIT: admin/includes/template_top.php

(if you changed the name of your admin folder, like you should have, change as necessary)

FIND: </head>

BEFORE ADD:

<?php
 if ((TINYMCE_USE == 'true') && (!strstr($PHP_SELF,FILENAME_REVIEWS))) {
?>
<!-- TinyMCE -->
<script type="text/javascript" src="includes/javascript/tiny_mce/tiny_mce.js"></script>
<script type="text/javascript">
tinyMCE.init({
	// General options
	mode : "textareas",
	theme : "advanced",
	plugins : "pagebreak,style,layer,table,save,advhr,advimage,advlink,emotions,iespell,inlinepopups,insertdatetime,preview,media,searchreplace,print,contextmenu,paste,directionality,fullscreen,noneditable,visualchars,nonbreaking,xhtmlxtras,template,wordcount,advlist,autosave",

	// Theme options
	theme_advanced_buttons1 : "save,newdocument,|,bold,italic,underline,strikethrough,|,justifyleft,justifycenter,justifyright,justifyfull,styleselect,formatselect,fontselect,fontsizeselect",
	theme_advanced_buttons2 : "cut,copy,paste,pastetext,pasteword,|,search,replace,|,bullist,numlist,|,outdent,indent,blockquote,|,undo,redo,|,link,unlink,anchor,image,cleanup,help,code,|,insertdate,inserttime,preview,|,forecolor,backcolor",
	theme_advanced_buttons3 : "tablecontrols,|,hr,removeformat,visualaid,|,sub,sup,|,charmap,emotions,iespell,media,advhr,|,print,|,ltr,rtl,|,fullscreen",
	theme_advanced_buttons4 : "insertlayer,moveforward,movebackward,absolute,|,styleprops,|,cite,abbr,acronym,del,ins,attribs,|,visualchars,nonbreaking,template,pagebreak,restoredraft",
	theme_advanced_toolbar_location : "top",
	theme_advanced_toolbar_align : "left",
	theme_advanced_statusbar_location : "bottom",
	theme_advanced_resizing : true,

	// Example content CSS (should be your site CSS)
//		content_css : "css/content.css",

	// Drop lists for link/image/media/template dialogs
//		template_external_list_url : "lists/template_list.js",
//		external_link_list_url : "lists/link_list.js",
//		external_image_list_url : "lists/image_list.js",
//		media_external_list_url : "lists/media_list.js",

	// Style formats
	style_formats : [
		{title : 'Bold text', inline : 'b'},
		{title : 'Red text', inline : 'span', styles : {color : '#ff0000'}},
		{title : 'Red header', block : 'h1', styles : {color : '#ff0000'}},
		{title : 'Example 1', inline : 'span', classes : 'example1'},
		{title : 'Example 2', inline : 'span', classes : 'example2'},
		{title : 'Table styles'},
		{title : 'Table row 1', selector : 'tr', classes : 'tablerow1'}
	],

	// Replace values for the template plugin
//		template_replace_values : {
//			username : "Some User",
//			staffid : "991234"
//		}
});
</script>
<!-- /TinyMCE -->
<?php
 }
?>

 

STEP 2:

Using phpmyadmin, or whatever mysql tool you use, import the following:

INSERT INTO `configuration` VALUES(NULL, 'Use TinyMCE', 'TINYMCE_USE', 'true', 'Select if you want to use TinyMCE or not', 1, 22, now(), now(), NULL, 'tep_cfg_select_option(array(''true'', ''false''), ');

 

You're done, go use your editor.....

 

 

I have a quick question. I was using your above information to add TinyMCE to my oscommerce site and everythign was going well until I added the above part to MYSQL. It immediately gave me an error.

SQL query:b_help.png

VALUES (

NULL ,'Use TinyMCE','TINYMCE_USE','true','Select if you want to use TinyMCE or not', 1, 22, now() , now() ,NULL ,'tep_cfg_select_option(array(''true'', ''false''), '

)

 

MySQL said: b_help.png

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'VALUES(NULL, 'Use TinyMCE', 'TINYMCE_USE', 'true', 'Select if you want to use Ti' at line 1

I checked the configuration and I have 2 (1) configuration and (2) configuration_group. I was attempting to add it to the former.

 

Do you have an ideas as to why the error message,. I havent tried to add anything to the original installation apart from products to my site and I was hoping to use this TinyMCE to help re-organize my display. Any help would be appreciated

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×