Jump to content
Sign in to follow this  
Chubbs

Canada Post Sell Online for osCommerce 2.3.1

Recommended Posts

Rather then wait on someone to get around to doing this, I managed to figure out how to get insaini's Canada Post Automated Labels 2.0 AND Canada Post Shipping Module 4.0 for osCommerce 2.2 working for 2.3.1.

 

I've also updated the install document and hopefully didn't miss anything. My Coding skills are enough to get me by, so can not guarantee you will get any support from me. Hopefully someone with good skills will be able to pick this up and provide any support that's needed.

 

You can find the contribution here: http://addons.oscommerce.com/info/7900

Share this post


Link to post
Share on other sites

Hi,

 

Would you happen to know if this contribution works well with v. 2.2 RC2?

 

Thanks.

Share this post


Link to post
Share on other sites

In the instructions it tells us to replace the same line twice. It may be an error in the instructions? Ive a slightly modified categories.php but as far as I know Id not modified that line out previously.

 

The instructions say to find:

 

$product_query = tep_db_query("select pd.products_name, pd.products_description, pd.products_url, p.products_id, p.products_quantity, p.products_model, p.products_image, p.products_price, p.products_weight, p.products_date_added, p.products_last_modified, date_format(p.products_date_available, '%Y-%m-%d') as products_date_available, p.products_status, p.products_tax_class_id, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "' and p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "'");

 

And replace with: (x code)

 

But then later in the instructions is says to find that same line again

 

and replace with: (x code)

Edited by Mrmike

Share this post


Link to post
Share on other sites

Otherwise, this module is working very well in 2.3.1!

 

Thanks again

Edited by Mrmike

Share this post


Link to post
Share on other sites

Hello,

 

I have installed Canada Post Sell Online for osCommerce 2.3.1, it is seems to be working, that is in testing I would get Canada Post services and rates and prices and when I changed the address the prices and services changed.

 

On the admin side of things - there is seems to be an issue.

 

when I try to get a customer sales report I get the following error: Parse error: syntax error, unexpected T_VARIABLE, expecting T_FUNCTION the file is

admin/includes/classes/order.php on line 43.

 

I have reviewed my files and they seem good, any suggestions?

 

Thanks

Share this post


Link to post
Share on other sites

I started installing this add-on last night. I obtained a VentureOne account and sent an e-mail to register for Electronic Shipping Tools as per the instructions. I haven't copied files to my server or modified files, yet, as I'll do that once I've gotten "the paperwork" out of the way.

 

This morning, I received an e-mail from Canada Post informing me that they no longer issue Merchant ID's for EST as they have a new "Parcel Web" program.

 

What now??? Will this add-on still work without the merchant ID Canada Post won't give me? I don't want to go through installing the new files and modifying existing files if this thing isn't going to work.

 

Thanks for any help/suggestions offered!

 

Regards,

 

Chris

Share this post


Link to post
Share on other sites

Hi I was just wondering if this add on will automaticaly calculate Canada Post shipping charges on orders?

 

Thanks,

 

Rob

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×