Jump to content
Sign in to follow this  
Druide

User Tracking with Admin 1.31 Released

Recommended Posts

I get this when browsing categories in the admin at the bottom of the page

any ideas??

 

Fatal error: Call to undefined function: tep_parse_category_path() in includes/functions/user_tracking.php on line 47

 

line 47 $cPath_array = tep_parse_category_path($cPath);

 

 

any help would be appreciated

 

i am running cvs from march 22

Share this post


Link to post
Share on other sites

copy the catalog/includes/functions/user_tracking.php to admin/includes/functions/user_tracking.php and change your admin/includes/footer.php to

<?php

/*

 $Id: footer.php,v 1.11 2002/10/29 22:28:51 hpdl Exp $



 osCommerce, Open Source E-Commerce Solutions

 http://www.oscommerce.com



 Copyright (c) 2002 osCommerce



 Released under the GNU General Public License

*/

 require(DIR_WS_FUNCTIONS . 'user_tracking.php');

if ( ADMIN_CONFIG_USER_TRACKING == 'true') { tep_update_user_tracking(); echo ' <font size="-2" color=red>your behavior is recorded</font>'; }

?>

<br>

+ rest of normal code

 

That will do the job, 110% sure ;)


Robert

 

We all need to learn it once, how hard it may seem when you look at it, also you will master it someday ;)

Share this post


Link to post
Share on other sites

For some reason my Tracker shows all visitors as being from my host IP...

 

Any ideas what I could have done wrong ?

Share this post


Link to post
Share on other sites

I posted on this: Flags displaying incorrectly or not at all

back down the thread and decided to wait till I had my shop on a remote server. Now I have I am seeing some, but not many flags. Some of the ones that are appearing are wrong.

 

I connect at work from a .gov.uk address and it shows the stars and stripes.

 

similarly someone testing for me logs on from a demon account and this also appears as a US Flag.

 

Any ideas? If not I'll have a go myself when I get some time but I guess this must have happened to others. I have user tracking with my ISP but I'm sure I will still use this because it's all in the same place place with the admin module. Great contribution

Share this post


Link to post
Share on other sites
http://www.oscommerce.com/community/contributions,1055

 

Let me know if you like the new version :)

 

or if you find a bug or so too ofcourse...

 

Thank's for the very useful contribution. It works great for viewing visitors and session details for the past 24 hours. However I when view previous 24 hours periods (the SELECT VIEW link "Back to Apr 20, 2003") and then I click a "view session" link, it just jumps back to the page displaying the sessions for the latest 24 hours.

 

-Stick

Share this post


Link to post
Share on other sites
http://www.oscommerce.com/community/contributions,1055

 

Let me know if you like the new version :)

 

or if you find a bug or so too ofcourse...

 

Thank's for the very useful contribution. It works great for viewing visitors and session details for the past 24 hours. However I when view previous 24 hours periods (the SELECT VIEW link "Back to Apr 20, 2003") and then I click a "view session" link, it just jumps back to the page displaying the sessions for the latest 24 hours.

 

-Stick

 

I had the same problem too. Instead of racking my head trying to figure out a solution, I just went into PhpMyAdmin and searched my database for the info I needed. It's all listed in there chronologically.

Share this post


Link to post
Share on other sites
Thank's for the very useful contribution.  It works great for viewing visitors and session details for the past 24 hours. However I when view previous 24 hours periods (the SELECT VIEW link "Back to Apr 20, 2003") and then I click a "view session" link, it just jumps back to the page displaying the sessions for the latest 24 hours.

 

-Stick

 

That is a well known BUG by me, but i haven't looked into it for a few weeks, i will try to fix it after this weekend


Robert

 

We all need to learn it once, how hard it may seem when you look at it, also you will master it someday ;)

Share this post


Link to post
Share on other sites

Greetings,

 

I just installed 1.34 over my old 0.2 version. Nice work putting this together. I really like the new look and added whois functionality. Plus all the 'times' now seem to work. No more 3:00 minute idle times for everyone!

 

Everything was working fine and I could expand to view the session until, it appears, a customer actually had something in their cart. When I view session with something in the cart I get the following error:

 

Fatal error: error traversing database - perhaps it is corrupt? in /home/web/sites/everythingtights/admin/includes/geoip.inc on line 220

 

Also, this is what the link appears like in the address bar:

 

http://www.mysite.com/admin/user_tracking.php?viewsession=c627ed6b6d26111bdb1b46e4f4f1b274#c627ed6b6d26111bdb1b46e4f4f1b274

 

Note the duplicate session ids.

 

Does anyone know what might be wrong and how I can correct? Thanks for your time.

 

Mark

Share this post


Link to post
Share on other sites

Greetings,

 

I just installed 1.34 over my MS1.

Everything working fine but don't display:

 

cart contents

Originating URL

and User Shopping Cart is permanent session expired

 

someone help me?

 

thanks

Share this post


Link to post
Share on other sites
Greetings,

 

Fatal error: error traversing database - perhaps it is corrupt? in /home/web/sites/everythingtights/admin/includes/geoip.inc on line 220

 

Also, this is what the link appears like in the address bar:

 

http://www.mysite.com/admin/user_tracking.php?viewsession=c627ed6b6d26111bdb1b46e4f4f1b274#c627ed6b6d26111bdb1b46e4f4f1b274

 

Note the duplicate session ids.

 

Does anyone know what might be wrong and how I can correct?  Thanks for your time.

 

Mark

 

about your Fatal error: , you should contact Greg Williams (?) for that.

 

-----------------

 

The session ID is NOT a duplicate but note the #c627ed6b6d26111bdb1b46e4f4f1b274

that is the function to start that session at the top of the page ;)


Robert

 

We all need to learn it once, how hard it may seem when you look at it, also you will master it someday ;)

Share this post


Link to post
Share on other sites
Greetings,

 

I just installed 1.34 over my MS1.

Everything working fine  but don't display:

 

cart contents

Originating URL

and User Shopping Cart is permanent session expired

 

 someone help me?

 

  thanks

 

what version PHP & MySQL ?


Robert

 

We all need to learn it once, how hard it may seem when you look at it, also you will master it someday ;)

Share this post


Link to post
Share on other sites

Robert,

 

Thanks for the tip on contacting Greg W.

 

I lost ya here, though.

 

The session ID is NOT a duplicate but note the #c627ed6b6d26111bdb1b46e4f4f1b274  

that is the function to start that session at the top of the page

 

Mark

Share this post


Link to post
Share on other sites

Mark,

 

do you know what http://your.domain.com/faq.html#top does ?

 

Well it brings you back to the top of the page, you can make 'bookmarks' this way for a FAQ etc...

 

Hope this helps you out to understand it a little :)


Robert

 

We all need to learn it once, how hard it may seem when you look at it, also you will master it someday ;)

Share this post


Link to post
Share on other sites

Well we all have/had to learn it once ;)


Robert

 

We all need to learn it once, how hard it may seem when you look at it, also you will master it someday ;)

Share this post


Link to post
Share on other sites

almost daily... :twisted: hehe :wink:


Robert

 

We all need to learn it once, how hard it may seem when you look at it, also you will master it someday ;)

Share this post


Link to post
Share on other sites

These are the errors that I am getting. What file or direcory should I make :?:

 

Warning: main(../../catalog/includes/functions/user_tracking.php) [function.main]: failed to create stream: No such file or directory in /hsphere/local/home/scot0/corshas.com/admin/includes/footer.php on line 48

 

Fatal error: main() [function.main]: Failed opening required '../../catalog/includes/functions/user_tracking.php' (include_path='.:/usr/local/lib/php') in /hsphere/local/home/scot0/corshas.com/admin/includes/footer.php on line 48

Share this post


Link to post
Share on other sites
Greetings,

 

I just installed 1.34 over my MS1.

Everything working fine but don't display:

 

cart contents

Originating URL

and User Shopping Cart is permanent session expired

 

someone help me?

 

thanks

 

what version PHP & MySQL ?

 

 

Hello Robert

 

Server HTTP: Apache/1.3.27 (Unix) FrontPage/5.0.2.2510 mod_ssl/2.8.11 OpenSSL/0.9.6a

 

PHP: 4.1.2 (Zend: 1.1.1)

 

MySQL 3.23.36-log

Share this post


Link to post
Share on other sites

I have installed v1.34 in an osC snapshot from 12/17/02.

 

The contribution works beautifully (Thanks, guys!!!), and it appears that all of the data that is supposed to be collected and displayed is doing so, with a couple of minor quirks. I've seen both of these situations referred to earlier in this thread, but am posting here again because the prior discussion didn't seem to address the same conditions under which I am seeing them:

 

1) The error

Fatal error: error traversing database - perhaps it is corrupt? in /home/farmex/public_html/osc/includes/geoip.inc on line 220

when it appears, is always the last entry on the page (of course, because it stops the output right there). It appears to be triggered by something in the Country/Flag information that is trying to be displayed or parsed, as the last info shown in the entry is "Country:". If the session is deleted, then the page will continue as it should, up to the full 50 sessions, unless it hits another of this same error.

 

2) I get quite a few flag images which do not show up on various sessions, even though the 'netgeo' shows the country as US and the US flag does show up for other sessions. The location of the flag appears as

 

http://farmex.now.tc/osc/images/flags/.gif

 

... (thinking out loud here-) Is it possible that some of the queries are getting through in caps and that a duplicate set of flag gifs named in caps is needed (what a mess!) or is it possible that the geoIP information is not current to those IPs that are failing to produce a picture?

 

Not complaining a bit... I LOVE this contribution - just trying to narrow down where these inconsistancies might be getting triggered


... if you want to REALLY see something that doesn't set up right out of the box without some tweaking,

try being a Foster Parent!

Share this post


Link to post
Share on other sites
Thank's for the very useful contribution.  It works great for viewing visitors and session details for the past 24 hours. However I when view previous 24 hours periods (the SELECT VIEW link "Back to Apr 20, 2003") and then I click a "view session" link, it just jumps back to the page displaying the sessions for the latest 24 hours.

 

-Stick

 

That is a well known BUG by me, but i haven't looked into it for a few weeks, i will try to fix it after this weekend

 

I think I sqashed this BUG bug.

On, or near line 329 find:

<a href="user_tracking.php?viewsession="

and change to

<a href="user_tracking.php?time=" . $time_frame . "&viewsession="

 

I'm looking into the refering URL not showing up. Would this make sense to store in the database? I don't follow what you added to application_top with tep_session_register('refere_url')

I am not familiar with what tep_session_register accomplishes

-Stick

Share this post


Link to post
Share on other sites
I'm looking into the refering URL not showing up. Would this make sense to store in the database?

 

This will be an essential information to know

where the visitors are coming from like a paid

ad etc. and hence to increase the traffic.

 

It will be nice to add this feature.

 

Also is there a way to know the duration of visit

when it is only a single page. Currently this info

comes up only if the visitor clicks on more pages

Share this post


Link to post
Share on other sites
I'm looking into the refering URL not showing up. Would this make sense to store in the database?

 

This will be an essential information to know

where the visitors are coming from like a paid

ad etc. and hence to increase the traffic.

 

It will be nice to add this feature.

 

Also is there a way to know the duration of visit

when it is only a single page. Currently this info

comes up only if the visitor clicks on more pages

 

I'm not sure about this, but I'd have to say no. You don't know when they leave so if their is only one page click, there would be no way to calculate this. Hopefully I am wrong.

 

I made a typo in my BUG fix in my previous post. The line number is wrong, or atleast differed between vi and dreamweaver. Either way, just do a string search instead. The changes to make are correctly posted though.

 

As far a the Ref URL, I agree. I just signed up with Google AdWords and would like to know which campaign they come from. I am about half way through fixing this. I have added another field to the table, and got it to plug in the value (not sure if this is the most efficient way since this field is set to 255 and will basically just repeat). I just need to get the script to display the value out of the database in the admin.

 

Having the Ref URL we can also extract out any GET parameters for further analysis.

-Stick

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×