Jump to content
Sign in to follow this  
Druide

User Tracking with Admin 1.31 Released

Recommended Posts

I am trying to use this great Mod on Mozilla Firefox 0.9 and it works great, loading 10 times faster than in IE6.

Only problem is that the layout seem to be optimized to be viewed in IE and not in Mozilla. In IE the list fit the page width, but in FF it is about 20% wider than the screen.

Does anyone know how to revise the file so that it will fit the screen in FF too?

Thanks in advance!

im doing everything in Firefox 0.92 and no probs here everything just perfect, 34258798% better then IE or NS

I'm using FireFox 0.9.3 and the problem persist.

I tell you what cause it, maybe we can find a solution here.

When the originating URL is long, it make the page wide accordingly, instead of being wrapped (like "word wrap" in MS notepad I mean) to fit the frame width.

Of course that if I resize the font to be very small, the frame will fit the page perfectly, but then it is unreadable.

The question is - how can I make the originating URL wrapped like it is when displayed in IE?

Share this post


Link to post
Share on other sites

It seems like firefox indeed has a problem with text wrap.

I just read this: http://forums.devshed.com/archive/t-161350

 

Here is a test, please try to view this page with firefox:

TESTING-FIREFOX-WORDWRAP-xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Share this post


Link to post
Share on other sites

Here is another test

HERE-IS-ANOTHER-EXAMPLE-HERE-IS-ANOTHER-EXAMPLE-HERE-IS-ANOTHER-EXAMPLE-HERE-IS-ANOTHER-EXAMPLE-HERE-IS-ANOTHER-EXAMPLE-HERE-IS-ANOTHER-EXAMPLE-HERE-IS-ANOTHER-EXAMPLE-HERE-IS-ANOTHER-EXAMPLE-HERE-IS-ANOTHER-EXAMPLE-HERE-IS-ANOTHER-EXAMPLE-HERE-IS-ANOTHER-EXAMPLE-HERE-IS-ANOTHER-EXAMPLE-HERE-IS-ANOTHER-EXAMPLE-HERE-IS-ANOTHER-EXAMPLE-HERE-IS-ANOTHER-EXAMPLE-

Share this post


Link to post
Share on other sites

Hi!

Great contrib.

 

Curious, see the Idle and Total time.

 

Click Count: 1

Start Time: 04:25:06 Idle Time: 10:06:34

End Time: 04:25:06 Total Time: 09:00:00

 

This is hapenning in every case.

Total time: 9 hours for 1 click?

 

Another one:

Click Count: 4

Start Time: 01:08:48 Idle Time: 13:22:21

End Time: 01:09:19 Total Time: 09:00:31

 

I dont have time to read the full topic.

Need an advice where to start to get fix.

 

Cheers,

Andrew

Share this post


Link to post
Share on other sites

I read about the entire forum (for a few hours <_< ) but still could not find a fix for the two following problems.

 

1.) in admin User tracking changes admin language when vieuwing a track from someone that visited the site in an other language than te default one.

 

2.) Sessions of previous dates cannot be vieuwed because de page refreshes to todays date..

 

 

Anyone????

Edited by Noutje

Share this post


Link to post
Share on other sites

Hello all, first post so please go easy on me!

 

I am using "User Tracking with Admin Area Modification v.1.35".

 

I've installed everything as per the instructions, and implemented the Alverman fix. My "originating url" seems to work, and the stats are brilliant. However, I'm left with a nasty error on all my catalog pages:

 

"Fatal error: Cannot redeclare tep_update_user_tracking() (previously declared in /home/computer/public_html/catalog/includes/functions/user_tracking.php:18) in /home/computer/public_html/catalog/includes/functions/user_tracking.php on line 16"

 

I'm no PHP coding expert, and I've searched this site and there have been a couple of other posts, but no answer that I can find.

 

Can any of you shed some light on this?

 

Many thanks

 

Ben

Share this post


Link to post
Share on other sites

Hello Ben,

 

I just did a search on "Fatal error: Cannot redeclare" I found this tid bit that may get you started:

 

PHP is complaining that the function is getting defined twice.

 

This means that the "function user_tracking.php" is trying to get created again.

 

Notice the both the files mentioned in the error are user_tracking.php

 

So somehow user_tracking.php is getting invoked twice.

 

 

I would search the forum for "Fatal error: Cannot redeclare" and check the

results, there are quite a few, sorry I don't have time to help you out more.

 

Monte

Share this post


Link to post
Share on other sites
Hello Ben,

 

I just did a search on "Fatal error: Cannot redeclare" I found this tid bit that may get you started:

 

PHP is complaining that the function is getting defined twice.

 

This means that the "function user_tracking.php" is trying to get created again.

 

Notice the both the files mentioned in the error are user_tracking.php

 

So somehow user_tracking.php is getting invoked twice.

I would search the forum for "Fatal error: Cannot redeclare" and check the

results, there are quite a few, sorry I don't have time to help you out more.

 

Monte

 

Thanks Monte!

 

I had a good read - turns out I had added the code for includes\footer.php to application_bottom.php as well for some strange reason! All sorted now, no error messages.

 

Thanks

 

Ben

Share this post


Link to post
Share on other sites

Did I miss the tread?. I still got no value on originating URL.

Does any body know what wrong with my installation?/

Thanks

CubeCom

 

 

Thanks Monte!

 

I had a good read - turns out I had added the code for includes\footer.php to application_bottom.php as well for some strange reason! All sorted now, no error messages.

 

Thanks

 

Ben

Edited by CubeCom

Share this post


Link to post
Share on other sites
Did I miss the tread?.  I still got no value on originating URL.

Does any body know  what wrong with my installation?/

Thanks

CubeCom

 

 

sorry if this was psoted before .. is it possible to display flags also in Whos's Online infobox on frontpage?

Share this post


Link to post
Share on other sites
I read about the entire forum (for a few hours  <_< ) but still could not find a fix for the two following problems.

 

1.) in admin User tracking changes admin language when vieuwing a track from someone that visited the site in an other language than te default one.

 

2.) Sessions of previous dates cannot be vieuwed because de page refreshes to todays date..

Anyone????

 

Does anyone know a solution for this?

Share this post


Link to post
Share on other sites

I made a fix for this contribution you can find it here:

http://www.oscommerce.com/community/contributions,1055

 

This is Only a fix to make User Tracking admin more language friendly.

 

fixes next bug:

 

-changing default language in admin.

-Modification to purge all records (beware all records will be deleted!!)

-some modifications to make this contribution more language friendly

 

INSTALL:

Just copy all the files over your copy of your old user_tracking files

This is written from the latest 1.35 version.

You can change the language files to your needs

 

NOTE: This is not a complete install !! you must have a previous install present !!

Share this post


Link to post
Share on other sites

So now there is still one bug present :

 

Sessions of previous dates cannot be vieuwed because de page refreshes to todays date..

 

Anyone????

Share this post


Link to post
Share on other sites

I had read in an earlier post where someone had filtered out all of the single click sessons. Does anyone know how to do this? I'm showing 200 sessions per page, and most of them are single sessions (with 200 sessions this morning I can only view the last hour - robots seem to be really busy lately).

Share this post


Link to post
Share on other sites
So now there is still one bug present :  Sessions of previous dates cannot be vieuwed because de page refreshes to todays date..

 

 

 

I third this bug - does anybody have a clue how to fix it? It's pretty useless when you can't view anything other than "today"... :(

 

Jacob

Share this post


Link to post
Share on other sites

Hello everyone,

 

I just updated to version 3.5 with the language fix, but I am getting this error on the admin side.

 

1054 - Unknown column 'referer_url' in 'field list'

 

select customer_id, full_name, ip_address, time_entry, time_last_click, last_page_url, page_desc, referer_url, session_id from user_tracking where time_entry > 1101688216 and time_entry < 1101774616 order by time_last_click desc

 

[TEP STOP]

 

I also notice that if I make a product that will have this example:

 

A bug's Life I will get some kind of error due to the ' on the name. If I do not put that on, it will be fine.

 

I also noticed that I am not getting the refered url at all... Does anyone care to give me a hand?

Share this post


Link to post
Share on other sites

This is what I get on the product info footer when I add the ' on the Name of the Product!

 

1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 's Something About Mary', 'http://www.lglivart.com/osctest/')' a

 

insert into user_tracking (customer_id, full_name, session_id, ip_address, time_entry, time_last_click, last_page_url, page_desc, referer_url) values ('', 'Guest', 'cad18fbb9d43d7acc98df2e88aa1ec38', '67.118.189.46', '1101778678', '1101778678', 'http://www.lglivart.com?products_id=19', 'There's Something About Mary', 'http://www.lglivart.com/osctest/')

Share this post


Link to post
Share on other sites

Hi David,

 

Your getting the column error because the apostrophe in your title is confusing the MySQL syntax and causing the MySQL code to terminate in an inappropriate place.

 

Have you tried "escaping" the apostrophe? by adding a backslash before the apostrophe i.e. there\'s something about mary

 

I'm assuming that the upgrade you made does not escape apostrophes correctly.

 

Monte

Share this post


Link to post
Share on other sites

Actually,

 

I have done that exactly in order to block that \' , but when I want to see the product it would show like this There\'s Something about Mary...

 

I know it has to do with the sql, but where is that exactly specified. I believe is not only in my upgrade to 3.5 but in all of versions of it. People don't actually noticed unless the product name has an apostrophe on it.

 

Can Anyone else confirm this? Can anyone find a solution?

Share this post


Link to post
Share on other sites

Hi

I have got the same problem and it seem to by a database error:

 

The cration of database:

CREATE TABLE user_tracking (

customer_id int(11) default NULL,

click_id int(11) default NULL,

full_name varchar(64) NOT NULL default '',

session_id varchar(128) NOT NULL default '',

ip_address varchar(15) NOT NULL default '',

time_entry varchar(14) NOT NULL default '',

time_last_click varchar(14) NOT NULL default '',

last_page_url varchar(64) NOT NULL default '',

page_desc varchar(64) NOT NULL default ''

) TYPE=MyISAM;

 

does not make the column 'referer_url' that is required from the file "/admin/user_tracking.php" app. line 152:

 

$whos_online_query =

tep_db_query("select customer_id, full_name, ip_address, time_entry, time_last_click, last_page_url, page_desc, referer_url," .

" session_id from " . TABLE_USER_TRACKING .

" where time_entry > " . ($time_frame - 86400) .

" and time_entry < " . $time_frame .

" order by time_last_click desc");

 

Solution:

Simply add a column to the end of the table named "referer_url", Datatype: "varchar(255)". If you are lazy ;-) you can simply use the following sql-replace of your current table:

 

DROP TABLE IF EXISTS `user_tracking`;

CREATE TABLE `user_tracking` (

`customer_id` int(11) default NULL,

`click_id` int(11) default NULL,

`full_name` varchar(64) NOT NULL default '',

`session_id` varchar(128) NOT NULL default '',

`ip_address` varchar(15) NOT NULL default '',

`time_entry` varchar(14) NOT NULL default '',

`time_last_click` varchar(14) NOT NULL default '',

`last_page_url` varchar(255) NOT NULL default '',

`page_desc` varchar(64) NOT NULL default '',

`referer_url` varchar(255) NOT NULL default ''

) TYPE=MyISAM;

 

-please backup your data first. This version delete all present data.

 

Good luck:

 

-Jes

 

Hjemmealarmer

Share this post


Link to post
Share on other sites

Jes,

 

That actually does fix the bottom part of the sql in the admin side, but it will still not fix the apostrophe on the product info if in the Admin side we give a name like

 

There's Something About marry...

 

I have tried using the There\'s Something About Marry, but the \ will comeout in the bottom of the page.

 

I know that there is too many ' on the sql or in the footer where it is looking the info from. Can anyone get to a conclusion regarding this? I am possitive it is on every shop that has that working. If I know more sql and php I would do it :(

 

Thanks,

 

Dark

Share this post


Link to post
Share on other sites

I've tried looking through this topic, but I can't find anyone else with this problem.

 

I've installed it all and the site still works. But when I go into admin, the initial page displays but if I click on any link, I get a 'page cannot be displayed' error.

 

The user tracking bit appears under tools but nothing's working.

 

I've checked everything in the how to install instruction and it seems fine.

 

Help!!

 

Tamsyn

Share this post


Link to post
Share on other sites

My Idle Time and Total Time start at 09:00:00 not sure why because there are 6 hours between the server and where I live?

 

Start Time: 20:20:24 Idle Time: 09:23:31

End Time: 20:20:24 Total Time: 09:00:00

Share this post


Link to post
Share on other sites
My Idle Time and Total Time start at 09:00:00 not sure why because there are 6 hours between the server and where I live?

 

Start Time: 20:20:24 Idle Time: 09:23:31

End Time: 20:20:24 Total Time: 09:00:00

how to exclude two IP-Addresses?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×