Jump to content
easyq

Dutch Language Incl Admin

Recommended Posts

Door ErwinTo is een probleem gemeld met de BTW-percentages. Hij heeft het ook opgelost!

 

De producten werden in de webwinkel getoond excl. BTW terwijl dat incl. BTW moest zijn.

 

Je kunt als admin onder Landen / Belastingen bij Belasting Zones op de map EUR klikken. Je krijgt dan de landen te zien, voor elk land staat de zone op het land zelf, maar dit moet op 'Alle Zones' staan.

 

Binnenkort ook weer een nieuwe versie met het vertaalpakket. Je kunt als alternatief voor het wijzigen via de webshop ook wijz_BTW.sql uitvoeren.

In de voorlaatste regel (van de huidige versie) moet je dan @NL_CODE vervangen door NULL en in de laatste regel @BE_CODE door NULL.

 

In de webwinkel create_account.php wordt dan ook de vertaling van Hr. en Ms. gewijzigd.

Verder probeer ik een andere term te verzinnen voor uitbater.

Share this post


Link to post
Share on other sites

Hallo,

 

ik heb gemerkt dat het euro teken verkeerd staat het staat achter het bedrag eigelijk moet het er voor staan ik weet niet of die aan het dutch language pack ligt of aan oscommerce zelf

Share this post


Link to post
Share on other sites

Hallo,

 

ik heb gemerkt dat het euro teken verkeerd staat het staat achter het bedrag eigelijk moet het er voor staan ik weet niet of die aan het dutch language pack ligt of aan oscommerce zelf

 

Kan je in het admin gedeelte goed zetten :-)

Share this post


Link to post
Share on other sites

Dit kun je in Admin goedzetten, ik heb wel op 30-03-2011 een stap aangepast in installatie.txt waarmee de plaats van het euro-teken wordt goedgezet (wijz_waarden).

In het vertaalpakket heb ik eerder de vertaling losgemaakt van de instelling van waarden zodat je altijd een nieuwe vertaling kunt laden zonder je instellingen te wijzigen. Als je zelf al instellingen hebt gewijzigd of je hebt je webwinkel al in productie dan kun je vermoedelijk de sql-bestanden in de map waarde beter niet gebruiken of in ieder geval goed de toelichting lezen en kijken of je zelf al deze waarden hebt gewijzigd.

Edited by HanV

Share this post


Link to post
Share on other sites

Ik krijg het niet goed geinstalleerd.

Admin is in het Nederlands, maar als ik in de webshop op taal Nederlands klik krijg ik de volgende meldingen:

 

Warning: require(includes/languages/dutch.php) [function.require]: failed to open stream: No such file or directory in /home/allekant/public_html/catalog/includes/application_top.php on line 279

 

Warning: require(includes/languages/dutch.php) [function.require]: failed to open stream: No such file or directory in /home/allekant/public_html/catalog/includes/application_top.php on line 279

 

Fatal error: require() [function.require]: Failed opening required 'includes/languages/dutch.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/allekant/public_html/catalog/includes/application_top.php on line 279

 

Geen flauw idee wat ik verkeerd heb gedaan, ik heb de handleiding gevolgd. Maar ik weet niet zo heel veel van PHP.

Kan iemand mij helpen?

Share this post


Link to post
Share on other sites

Hoi HanV en anderen,

 

Thanx voor het Nl taalpakket!!!

Ik heb echter een vraagje over het installeren: Bij stap 3A wordt gezegd dat ik de bestanden uit map 'catalog' moet uploaden, maar ik heb geen idee hoe... Via FTP beheer?

(Jullie merken dat ik weinig ervaring heb met dit soort dingen :-))

 

Ik hoor het graag!

 

Groetjes Lola Hesp

Share this post


Link to post
Share on other sites

En weet iemand hoe kan ik de standaard tekst van oscommerce op mijn beginpagina (zie hieronder) veranderen?

 

Groetjes! Lola

"Welkom op onze online shop

 

Welkom Gast! Wilt u inloggen? Of wilt u een nieuw account aanmaken?

Alleen m�t een account kunt u op onze site dingen bestellen.

U kunt ook tijdens het bestellen een account aanmaken.

Dit is een standaardinstallatie van osCommerce project, de Artikelen zijn enkel voor demonstratiedoeleinden, gelijk welk Artikel dat wordt gekocht zal niet worden geleverd en aangerekend. Etc Etc....."

Share this post


Link to post
Share on other sites

Ik krijg het niet goed geinstalleerd.

Admin is in het Nederlands, maar als ik in de webshop op taal Nederlands klik krijg ik de volgende meldingen:

 

Warning: require(includes/languages/dutch.php) [function.require]: failed to open stream: No such file or directory in /home/allekant/public_html/catalog/includes/application_top.php on line 279

 

Warning: require(includes/languages/dutch.php) [function.require]: failed to open stream: No such file or directory in /home/allekant/public_html/catalog/includes/application_top.php on line 279

 

Fatal error: require() [function.require]: Failed opening required 'includes/languages/dutch.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/allekant/public_html/catalog/includes/application_top.php on line 279

 

Geen flauw idee wat ik verkeerd heb gedaan, ik heb de handleiding gevolgd. Maar ik weet niet zo heel veel van PHP.

Kan iemand mij helpen?

 

 

RTFM (read the funking manual)

In het installatie- tekst bestand (in de Neederlandsche contributie) staat: "Krijg je een blanco scherm of scherm vol met fouten, log dan in MET ACHTER DE URL ?language=en"

Doe dat en je krijgt je gewone engelse pagina te zien.van je shop.

Log in op het Admin deel, ga naar Lokale Instellingen/talen en voeg Nederlands toe, stel Nedelands in als standaard, en je bent klaar.

Edited by wotsupdoc

Share this post


Link to post
Share on other sites

Ik heb echter een vraagje over het installeren: Bij stap 3A wordt gezegd dat ik de bestanden uit map 'catalog' moet uploaden, maar ik heb geen idee hoe... Via FTP beheer?

(Jullie merken dat ik weinig ervaring heb met dit soort dingen whistling.gif))

 

Ik hoor het graag!

 

Groetjes Lola Hesp

In één keer goed!

Inderdaad, via FTP!

Je kunt bv. filezilla gebruiken, of het programma dat je gebruikte om OsC mee te installeren.

Share this post


Link to post
Share on other sites

En weet iemand hoe kan ik de standaard tekst van oscommerce op mijn beginpagina (zie hieronder) veranderen?

 

Groetjes! Lola

"Welkom op onze online shop

 

Welkom Gast! Wilt u inloggen? Of wilt u een nieuw account aanmaken?

Alleen m�t een account kunt u op onze site dingen bestellen.

U kunt ook tijdens het bestellen een account aanmaken.

Dit is een standaardinstallatie van osCommerce project, de Artikelen zijn enkel voor demonstratiedoeleinden, gelijk welk Artikel dat wordt gekocht zal niet worden geleverd en aangerekend. Etc Etc....."

 

Ga naar regel 225 in catalog\includes\languages\dutch.php en vervang

define('TEXT_GREETING_GUEST', 'Welkom <span class="greetUser">Gast!</span> Wilt u <a href="%s"><u>inloggen</u></a>? Of wilt u liever een <a href="%s"><u>account aanmaken</u></a>?');

door:

define('TEXT_GREETING_GUEST', '');

Dit verwijdert in het Nederlandse deel de tekst: "Welkom Gast! Wilt u inloggen? Of wilt u een nieuw account aanmaken?"

Hetzelfde moet je ook doen met alle andere talen die je in je winkel geïnstalleerd hebt.

Dus bv. in: catalog\includes\languages\english.php vervang je de alinea (op regel nr. 223)

define('TEXT_GREETING_GUEST', 'Welcome <span class="greetUser">Guest!</span> Would you like to <a href="%s"><u>log yourself in</u></a>? Or would you prefer to <a href="%s"><u>create an account</u></a>?');

door:

define('TEXT_GREETING_GUEST', '');

 

 

De rest (Alleen m�t een account enz.) ken ik niet, ik heb dat nog nooit meegemaakt, maar ik vermoed dat je eerst wat gegevens in het admin deel moet invoeren, om uit de demo winkel te komen.

 

Succes!

Share this post


Link to post
Share on other sites

wow wat een werk, moet ik ook nog aanpassingen doen in de bestanden zelf????????? waardeloze systeem van oscommerce, het word tijd dat zij eens een voorbeeld nemen aan die andere systemen, waarin je simpelweg de nederlandse taal selecteert. Waarom zijn de makers van oscommerce zo dom????? Ze begrijpen toch wel dat het systeem zodanig moeten maken dat de gebruiker simpel weg de nederlandse taal of dergelijke kunnen selecteren??????

Share this post


Link to post
Share on other sites

If you hate osC so much, what did you come here for!! :'(

 

 

I did point out in your other post you've messed up in your install, nice you blame your failings on the software!

Edited by spooks

Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Ik loop tegen een probleem aan en hoop hiermee geholpen te kunnen worden.

Ik heb de Nederlanse taal op de juiste manier geinstalleerd maar krijg alsnog het onderstaande probleem.

 

Een aantal bestanden die vereist zijn worden niet in de map boxes gevonden, het gaat om de volgende bestanden:

 

fm_menu.php

hm_shoping_cart.php

fm_currencies.php

fm_languages.php

hm_user_menu.php

cm_banner_set.php

hm_search.php

 

Wanneer ik uit de engelse map deze bestanden kopier en deze in de Nederlandse map zet geeft de browser geen fouten / "missing files" meer aan. Echter heb ik dan alsnog de helft van de site in het Engels.

 

Ik hoop dat iemand mij hiermee kan helpen door de juiste bestanden toe te voegen aan de map: /includes/languages/dutch/modules/boxes.

 

 

Warning: include(includes/languages/dutch/modules/boxes/fm_menu.php) [function.include]: failed to open stream: No such file or directory in/home/***/html/***/catalog/includes/classes/osc_template.php on line 86

 

Warning: include(includes/languages/dutch/modules/boxes/fm_menu.php) [function.include]: failed to open stream: No such file or directory in/home/***/html/***/catalog/includes/classes/osc_template.php on line 86

 

Warning: include() [function.include]: Failed opening 'includes/languages/dutch/modules/boxes/fm_menu.php' for inclusion (include_path='.:/php/includes:/opt/php5/lib/php') in/home/***/html/***/catalog/includes/classes/osc_template.php on line 86

 

Deze drie "warnings" worden per bestand dat gemist wordt aangegeven. Wanneer ik naar onderen scroll zie ik de site gedeeltelijk.

*** = ipv domeinnaam.

Edited by basstortelers

Share this post


Link to post
Share on other sites

Ik heb net een nieuwe versie geladen v1.7, die zal dus na akkoord verklaren, beschikbaar komen.

 

De versie is alleen voor 2.3.3 (en 2.3.2), dus niet gebruiken voor 2.3.1.

 

Als late reactie op de vorige post:

In het vertaalpakket worden alleen de onderdelen die bij de download van osCommerce meegeleverd worden, vertaald.

Als je een Add-On toevoegd, kijk dan of daar ook een vertaling bijzit.

Als er bij osc_template geen vertaling is, maak dan van elke map englisch binnen de add-on een kopie-map aan met de naam dutch. (Met dezelfde documenten erin.)

Als je verder niks vertaald heb je in ieder geval weer een werkende applicatie, zonder ide warnings.

Share this post


Link to post
Share on other sites

@@HanV waar kan ik deze laatste nieuwe versie downloaden?

 

Op de addon pagina vind ik alleen oudere versies en de links die ik vond vanaf het begin van dit draadje werken allemaal niet meer. Ik heb zonet een verse osc 2.3.3 geinstalleerd en wilde nu de nl lang. erin bouwen maar de vertaling die ik heb gevonden vinden is voor Osc 2.3.1. dus ik durf daarom niet zo goed de 2.3.3 files te overschrijven.

Edited by Gerard64

Share this post


Link to post
Share on other sites

Hallo Gerard,

 

ik heb je reactie pas zonet gelezen en je hebt gelijk. Het uploaden van mijn vertaling is blijkbaar mislukt.

Als je op de add-ons pagina zoekt naar dutch zie je dat ik een versie heb geladen op 22-10-2012, maar als je daar op klikt krijg je als meest recente versie een versie 14-6-2011. Dat kan komen omdat een nieuwe versie door de beheerders goedgekeurd moet worden vanwege de grootte. Ik denk dat ik het beste een nieuwe zip maak en maar weer upload (ik probeer woensdag).

 

Ik denk dat je er juist aandoet om de oude vertaling voor 2.3.1. niet te gebruiken voor de versie 2.3.3. Er zijn namelijk wat files bijgekomen (vooral sociale media) en die mis je dan, ook waren er wat aanpassingen in de shoppingcart die in 2.3.1 handmatig in de vertaling gedaan moesten worden en wat nu standaard in 2.3.3 gedaan is, maar wel weer in een iets andere vorm. Het invoeren van de vertaling wordt dus wat gemakkelijker.

Share this post


Link to post
Share on other sites

De nieuwe versie (v1.7) is gisteren beschikbaar gekomen.

Dus alleen gebruiken voor 2.3.3, want anders krijg je problemen met de shopping_cart.php.

Share this post


Link to post
Share on other sites

Ik krijg alleen de volgende melding met je Language pack and versie 2.3.3:

Warning: include(includes/languages/dutch/modules/header_tags/ht_canonical.php) [function.include]: failed to open stream: No such file or directory in /home/dekaar1q/public_html/includes/classes/osc_template.php on line 86

 

Warning: include(includes/languages/dutch/modules/header_tags/ht_canonical.php) [function.include]: failed to open stream: No such file or directory in /home/dekaar1q/public_html/includes/classes/osc_template.php on line 86

 

Warning: include() [function.include]: Failed opening 'includes/languages/dutch/modules/header_tags/ht_canonical.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/dekaar1q/public_html/includes/classes/osc_template.php on line 86

 

Warning: include(includes/languages/dutch/modules/header_tags/ht_robot_noindex.php) [function.include]: failed to open stream: No such file or directory in /home/dekaar1q/public_html/includes/classes/osc_template.php on line 86

 

Warning: include(includes/languages/dutch/modules/header_tags/ht_robot_noindex.php) [function.include]: failed to open stream: No such file or directory in /home/dekaar1q/public_html/includes/classes/osc_template.php on line 86

 

Warning: include() [function.include]: Failed opening 'includes/languages/dutch/modules/header_tags/ht_robot_noindex.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/dekaar1q/public_html/includes/classes/osc_template.php on line 86

 

EDIT: SORRY HET IS AL OPGELOST DOOR DE VORIGE POSTS

Edited by arjanschip

Share this post


Link to post
Share on other sites

hoi, ik krijg in plaats van de € teken een € teken, enige idee hoe om dat op te lossen? Ik heb al in admin includes languages en in catalog dutch.php de ISO_8859-15 in plaats van ISO_8859-1 verandert,

Geen success,

Enige hulp is zeer erg gewardeerd

met vriendelijke groeten

Len

Share this post


Link to post
Share on other sites

opgelost

 

gebruik UTF8 .

vul dat in bij catalog includes languages dutch.php

en in index bij mij was het in line 22 'nl_NL.UTF8' , 'Dutch');

Share this post


Link to post
Share on other sites

probleem opgelost

in dutch.php in languages in includes in catalog change character set to UTF8and in index languages includes catalog.

Share this post


Link to post
Share on other sites

Ik ben bezig met een upgrade van het vertaalpakket van versie 2.3.3. naar 2.3.3.4 en daarin zit ook een aanpassing naar utf-8.

In de meest recente versie v1.7 (voor 2.3.3 van 26-11-2012 7839) staat al wel define('CHARSET', 'utf-8'); Maar osCommerce gaat nu ook de data als UTF-8 opslaan.

Gebruikt iemand al een een recentere versie dan 2.3.3?

Het lukt me nog niet om de nieuwe functie admin_backup_directory_listing in 2.3.3.4 uit te voeren. Dus zal ik een wijziging in de wijzigingsoverzichten gemist hebben, of is het nog niet echt aan te raden om te upgraden. Ik heb het als probleem gemeld en wacht op een oplossing. Misschien is het toch beter om te wachten met het upgraden op versie 2.3.4.

Share this post


Link to post
Share on other sites

Het probleem met de nieuwe functie admin_backup_directory_listing is te verhelpen door in php.ini de regel

;extension=php_curl.dll

actief te maken door de ; te verwijderen.

Share this post


Link to post
Share on other sites

Ik heb net een nieuwe versie v1.8 gemaakt van de vertaling,

(http://addons.oscommerce.com/ Volledig NL taalpakket incl ADMIN)

Deze versie is bedoeld voor versie 2.3.3.4 van osCommerce.

 

Voor het upgraden van osCommerce zelf, zou ik eerst controleren als beheerder of de module Google Buzz actief is, en als dat zo is, die module verwijderen.

Bij de upgrade van het pakket zelf hoort de conversie van de database naar utf8 met de keuze hulpprogramma's -> database tabellen. Maar dat staat natuurlijk los van de vertaling.

Edited by HanV

Share this post


Link to post
Share on other sites

 

Hallo,

 

Recent heb ik osC geinstalleerd en dat verliep prima, tot nu toe tevreden.

Ik wil graag Nederlandse teksten hebben maar vind alleen de hier beschreven versie.

Volgens de ¨Version Checker¨ heb ik de meest recente versie van osC (2.3.4) Is de hier beschreven versie van de NL tekst daar ook geschikt voor?

 

Groet,

Gerard

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×