Jump to content
Latest News: (loading..)
aybc

OSC 2.3 order editor?

Recommended Posts

Hi,

 

I have installed this and have a question on a couple of things

 

1. 'New Order Email' button is not sending the email.

2. How do I get rid of the old buttons for Invoice etc from order and when you goto edit and order?

 

Thanks

 

 

To answer youre first question.

 

add below code to admin/include/function/general.php before closing tag ?>

 

function tep_add_base_ref($string) {

$i = 0;

$output = '';

$n=strlen($string);

for ($i=0; $i<$n; $i++) {

$char = substr($string, $i, 1);

$char5 = substr($string, $i, 5);

if ($char5 == 'src="' ) {$output .= 'src="' . HTTP_SERVER; $i = $i+4;}

else {

$output .= $char;

} }

return $output;

}

 

This is also the sollution for

Fatal error: Call to undefined function tep_add_base_ref() admin\edit_orders_ajax.php on line 1144

 

 

Greetz

 

Twindaddy

Share this post


Link to post
Share on other sites

I installed order editor on 2.3.1. Everything seems to work except 2 problems:

  1. The select your credit card payment method. It wont allow me to edit.
  2. Also in order to view an order for editing, I had to edit the edit_order.pdp. It stated the payment module drop down directory as catalog_modules and I changed it to catalog_includes_modules now it works but the only option besides the payment made is other otherwise it offers cash on deliver. Any ideas?

Share this post


Link to post
Share on other sites

I installed order editor on 2.3.1. Everything seems to work except 2 problems:

  1. The select your credit card payment method. It wont allow me to edit.
  2. Also in order to view an order for editing, I had to edit the edit_order.pdp. It stated the payment module drop down directory as catalog_modules and I changed it to catalog_includes_modules now it works but the only option besides the payment made is other otherwise it offers cash on deliver. Any ideas?

 

I figured these things out but while testing does not send new order message

Share this post


Link to post
Share on other sites

Deprecated: Function split() is deprecated in /home/public_html/admin/order_editor/http_client.php on line 389

 

change

 

 

list($hdr, $value) = split(': ', $str, 2);

 

into

list($hdr, $value) = preg_split("/: /", $value, 2); ???

Share this post


Link to post
Share on other sites

How do you delete an order?

I thought my install was fine, until I read the other posts.

There is no delete order present in my admin screen

Share this post


Link to post
Share on other sites

How do you delete an order?

I thought my install was fine, until I read the other posts.

There is no delete order present in my admin screen

 

Go to Admin>orders select order you want to delete and click delete ;)

Share this post


Link to post
Share on other sites

My ../admin/orders.php has the delete button commented out.

I have order editor and http://addons.oscommerce.com/info/8334/v,23 installed.

One led to the other.

 

When I uncomment the line, it shows the old style "Create" and "Delete" buttons, but I just need the delete button. And preferably the new style button.

How can I retrieve or retain it?

 

Right now I have buttons:

Invoice

Packing Slip

Edit

Create

Share this post


Link to post
Share on other sites

I installed order editor without any problem, but when I click the edit button i get :

 

Error: Order 8062013175033 does not exist.

 

Any idea why or a solution?

 

Thanks

Regards

Kozak

Share this post


Link to post
Share on other sites

Hello

I have installed this contribution but I can't edit any order from chrome or safari! It only works with ie!!! From chrome when I press the edit button of an order it redirect me to the ...catalog/admin/index.php!! Any suggestion? I have install and upload the files twice!

 

Also from ie the sent email button not sending mails!!


regards

Lazaros

Share this post


Link to post
Share on other sites

Why does the "back" button create a new window?  If I want to go back, I want to exit that window, meaning it should not do a "target=_blank".  I edited the "edit_orders.php" file to 'newwindow' => false on the string that draws the back button, but that didn't change anything.  After re-loading, the HTML has a "target=_blank" command in the href.

 

Just an FYI, but it does this in FireFox or IE.

Edited by TomB01

Share this post


Link to post
Share on other sites

OK - in edit_orders.php, around line 1096:

 

Change this:

<li><?php echo tep_draw_button(IMAGE_BACK, 'arrow-1-w', tep_href_link(FILENAME_ORDERS, tep_get_all_get_params(array('action'))) , null, array('newwindow' => true))?></li>

 

To this:

<li><?php echo tep_draw_button(IMAGE_BACK, 'arrow-1-w', tep_href_link(FILENAME_ORDERS, tep_get_all_get_params(array('action')))/* , null, array('newwindow' => true)*/)?></li>

 

Or, completely delete from /* to */ (php comment).

Edited by TomB01

Share this post


Link to post
Share on other sites

Anyone have a way to convert the "Submit new comments and/or status" button gif to jQuery?

 

Maybe I'm getting too picky, now. B)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×