Jump to content
DunWeb

[Contribution] Super Download Store for Version 2.3.x

Recommended Posts

This is the Official Support Thread for Super Download Store for osCommerce 2.3.x

 

 

This contribution is based on Super Download Shop for version 2.2 RC2a (http://addons.oscommerce.com/info/4868)

----------------------------------------------------

Super Download Shop contribution is an enhancement of the osCommerce download module and download file management, including following features:

 

* Secure download for pending orders based on DownLoads Controller v5.3 by Linda McGrath which was the best solution to secure downloads. Without similar control, customers could get their downloads before they actually pay.

 

* Group files download per product which enable download shops to offer multiple files in a single product. With this ability, shop owners can:

 

- Break a large download file into a group of files, to prevent problems like insufficient resource, time out errors...etc.

- Bundle multiple downloads in one package to increase sells.

 

* Store download files in sub folders under the download directory to improve the file management.

 

* Built-in superior file management interface in admin panel.

 

------------------------------------------------------------------------------------------------

Changes include:

 

* File changes to work with the 960 Grid System

* Creation of an Order Status SQL to set the orders status automatically

* Rewrite of the installation file

* Addition of Manual Installation Instructions


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

Hi George,

 

If you have a clean install, you can drop the supplied files ON TOP of your existing files. So, just replace the files on your server with the files included in the Modified Files folder. Then run the three supplied SQL files using phpmyadmin.

 

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

Is there an easy way to create a subscription based service with this plugin where say a user can only download 10 products per a month yearly. This would be nice for setting up a photo store like iStockPhoto that sells based on subscriptions.

 

Thanks!

Share this post


Link to post
Share on other sites

Hi Andrew,

 

This release does not regulate the number of downloads based on a subscription. However, it could be modified to do so but the core code would also need to change to accommodate the download restrictions.

 

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

When I add a new videoclip download though the product attributes I'm getting an error. When I click the back button the attribute is added, and the videoclip is able to be downloaded. But I'm curious about the error and how to correct it... any suggestions? Just FYI... I haven't added any addons.

 

George

 

1136 - Column count doesn't match value count at row 1

 

insert into products_attributes_download values (37, 'the_nosey_neighbor.zip', '2', '2')

 

[TEP STOP]

Share this post


Link to post
Share on other sites

This will be my final bump. I paid DunWeb to install this add-on on my website and he is not responding in this thread nor via PM. Certainly not what I expected from a Sponsor.

Share this post


Link to post
Share on other sites

George,

 

I am tried to unsuccessfully replicate the error on a clean installation of v2.3.1. I am not sure why you are getting the error. When I installed the contribution onto your site and WE BOTH TESTED IT, it was functional. Something has been changed since it was originally installed.

 

 

Edit: My sponsoring the osCommerce Project doesn't mean I a magician. It means I support those who write the base code and I help out other members as I can. Your problems are unique to your website as they are not present with any other installations I have done. I currently use this contribution on ALL of my websites, without error.

 

 

Chris

Edited by DunWeb

:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

We could have had this conversation privately via PM, but you ducked my PM's. You're only responding now after 4-days because you've been called out on it in open forum.

 

You are correct, you are not a magician, and you know as well as I do that you did indeed have trouble during the installation... I have 43 PM's to prove it. Don't kid yourself, Chris. Much like when you didn't reply to my PM's as to why my project wasn't finished and then claimed my server was down for 15 hours. Funny, the 6,000 member forum I own that sits on that same dedicated server wasn't down during that time. Nor were any of the sites I host. Nice try, buddy.

 

Unfortunately your actions have lead me to think of you as one of those business people that we see too often online... once you have the money you do as little as possible, you duck PM's, then you make false accusations and erroneous claims in an to attempt disparage the customer when you're called out in open forum.

 

I'll sit with the error and hire someone to correct it, buddy. I hope the money you made was worth me voicing how poorly I feel about you and your business ethics.

Edited by biggeorge

Share this post


Link to post
Share on other sites

George,

 

I receive 100's of emails daily and countless PM's ! I do not have the time to respond to all, my Support Plan customers get first reply, followed by sales inquiries and then if I have time.....those with general questions.

 

 

In my opinion, you have messed up your site after the contribution was installed and then expect me to repair it at no charge. You can make as many excuses as you wish, the fact is that you messed up your website and now you need to get it repaired again. The $25 you paid me didn't even cover my time to review your site, so don't think you spent a ton of money for my time. My hourly rate is more than twice that so if you want me to repair your site again, you will need to pay for my time.

 

 

Otherwise, try finding someone else to repair it for free.

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites
I'll sit with the error and hire someone to correct it, buddy. I hope the money you made was worth me voicing how poorly I feel about you and your business ethics.

 

I never asked you to repair my site for free, big boy.

 

receive 100's of emails daily and countless PM's ! I do not have the time to respond to all, my Support Plan customers get first reply,

 

Your response speaks volumes as to the caliber of business man you think you are.

Share this post


Link to post
Share on other sites

Moving forward... I have large downloads that I need to break up into into multiple files for download. I see that this option should be available based on the description:

 

Group files download per product which enable download shops to offer multiple files in a single product. With this ability, shop owners can:

- Break a large download file into a group of files, to prevent problems like insufficient resource, time out errors...etc.

- Bundle multiple downloads in one package to increase sells.

 

But I cannot find the option to enable this in the Admin Config. Here's my screen:

 

oscommerce2.jpg

 

I happened to find this image in a thread for an older version of SDS. So I wonder where I can find the options for my install of SDS?

 

oscommerce.jpg

Share this post


Link to post
Share on other sites

Hi George,

 

It has already been established that you have made changes to the site since the original installation. With that in mind, the Options available from admin are inserted using the SQL statement. You will need to run the SQL statement again.

 

 

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

Hi George,

 

It has already been established that you have made changes to the site since the original installation. With that in mind, the Options available from admin are inserted using the SQL statement. You will need to run the SQL statement again.

 

Chris

 

It is easy to blame others for incompetency and refuse to own up to yours when there is nobody else to shed light on the reality.

 

Tsk, tsk, tsk. I have never seen this module until today, because ya see, I don't sell downloadable products and have no need for it. Yet, I installed it on George's website, fixed the time stamp error, the unexpected $end error, and successfully set all configurations in a matter of about an hour. George still needs to add some attribute properties to his products so that his customers can download them, but all in all, it is a fully working module. I will note for the record that the php errors I ran across were not module related, but OSC2.3.1 related.

 

This is the third module that I installed on his site in the past 20 hours and I assure you that the only changes he made to the site were cosmetic. There were no functional changes which would have had any impact whatsoever on this installation. There was nothing to repair. The module just needed to be installed and one date stamp command needed to be changed. It took me an hour because I knew the installation had already been attempted, so I had to manually compare each file and db configuration entry. If I had known the extent of work already done or not done, it would have taken half the time.

 

To take $25 from someone to install a module that YOU contributed and then fail to install it is a bit scammish in my opinion. It was a nude site and with your experience with the module, you could have had it done in 15 minutes. Shame on you. I'll admit that I had a hard time trying to figure out why I couldn't download the products (someone was missing the download links in attributes). But, nonetheless, the accusations here are false, the demeanor offensive, and the business ethics lacking.

Share this post


Link to post
Share on other sites

Jetta,

 

I installed the module and both George and I tested it. It was functional. Then George said it wasn't working and I couldn't figure out what had changed. The contribution was tested several times and does work. I came to the conclusion it was D.U.E (dumb user error) but refunded his $25.00 upon his request.

 

 

I am glad you got it installed for him, but don't come on here bashing me for his mistakes. The contribution was released without warranty or support. If you have found an error in the code, please upload an update, if not......then quit your whining.

 

Have a nice day !

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites
I came to the conclusion it was D.U.E (dumb user error) but refunded his $25.00 upon his request.

 

Of course you'd assume I'm dumb, because you're brilliant. But you see, it wasn't me, it was your contribution. And you did not freely refund the money, I filed a PP complaint and they took the money from you.

 

I am glad you got it installed for him, but don't come on here bashing me for his mistakes. The contribution was released without warranty or support. If you have found an error in the code, please upload an update, if not......then quit your whining.

 

There were NO mistakes on my part, but you want to think that because that's what will make you feel better about yourself.

 

Jetta is not whining, she is merely pointing out the obvious: You charged me to install your contribution on my site and it failed. Then you refused to fix it. And you left me with no choice but to pay someone else to fix it.

 

Thank you Jetta.

Edited by biggeorge

Share this post


Link to post
Share on other sites

Ok George,

 

You're right, I am wrong. You never requested your money back, until you filed a PP dispute, and I refunded it. Please don't bother me again. I am too busy with real clients to respond to your banter.

 

 

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

Chris

 

I have just installed this contribution on my relatively new store. I have used your files supplied and dropped them on top of my files, and added the extra bits as required. I have entered the product info, and added the attribute. The file to be downloaded is definately in the folder and the file name is correct. The item enters the cart fine and the checkout process is carried through. The item is a free download, and no shipping or payment methods are required. Downloads are enabled and the standard 7 days and five downloads are set.

 

Now, when the process is completed the checkout sucess page has all the information that it should, but the download link is not available. There is a warning above the link that says

 

Warning: mktime() expects parameter 6 to be long, string given in /home/railway1/public_html/catalog/includes/modules/downloads.php on line 48

 

Line 48 is the one marked in the below code

 

 

<!-- list of products -->

<?php

while ($downloads = tep_db_fetch_array($downloads_query)) {

// MySQL 3.22 does not have INTERVAL

list($dt_year, $dt_month, $dt_day) = explode('-', $downloads['date_purchased_day']);

$download_timestamp = mktime(23, 59, 59, $dt_month, $dt_day + $downloads['download_maxdays'], $dt_year);

$download_expiry = date('Y-m-d H:i:s', $download_timestamp);

?>

<tr class="infoBoxContents">

<!-- left box -->

 

Do you have any idea that may be causing this. I have checked the insall and everything seems to be fine.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Forgot to add

 

Because of this error, the download status is still at pending.

 

This is probably something i have done and not your contribution.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Burt,

 

Perhaps when I get time, but as of right now I am too busy to re-do it. If anyone else wishes to make a revision, please feel free.

 

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

Chris

 

I have just installed this contribution on my relatively new store. I have used your files supplied and dropped them on top of my files, and added the extra bits as required. I have entered the product info, and added the attribute. The file to be downloaded is definately in the folder and the file name is correct. The item enters the cart fine and the checkout process is carried through. The item is a free download, and no shipping or payment methods are required. Downloads are enabled and the standard 7 days and five downloads are set.

 

Now, when the process is completed the checkout sucess page has all the information that it should, but the download link is not available. There is a warning above the link that says

 

Warning: mktime() expects parameter 6 to be long, string given in /home/railway1/public_html/catalog/includes/modules/downloads.php on line 48

 

Line 48 is the one marked in the below code

 

 

<!-- list of products -->

<?php

while ($downloads = tep_db_fetch_array($downloads_query)) {

// MySQL 3.22 does not have INTERVAL

list($dt_year, $dt_month, $dt_day) = explode('-', $downloads['date_purchased_day']);

$download_timestamp = mktime(23, 59, 59, $dt_month, $dt_day + $downloads['download_maxdays'], $dt_year);

$download_expiry = date('Y-m-d H:i:s', $download_timestamp);

?>

<tr class="infoBoxContents">

<!-- left box -->

 

Do you have any idea that may be causing this. I have checked the insall and everything seems to be fine.

 

There are a couple needed instructions in addition to those included in the contribution. Rather than spend time tinkering with someone else's contrib and uploading a new mod, I'll post those changes on the forum and hope that others find the post and can make the fixes. Perhaps, the contributor will make the necessary changes and upload a package with the patches.

 

1. In catalog/includes/modules/download.php around line 48,

 

find:

 

      $download_timestamp = mktime(23, 59, 59, $dt_month, $dt_day + $downloads['download_maxdays'], $dt_year);

 

replace with:

 

          $dty = intval($dt_year);
         $download_timestamp = mktime(23, 59, 59, $dt_month, $dt_day + $downloads['download_maxdays'], $dty);

 

2. In catalog/checkout_process.php around line 118

 

find:

 

                          'date_purchased' => 'now()', 

 

Add the following line AFTER the above code:

 

                          'last_modified' => 'now()', 

 

The first change will fix the time error. The second change will fix the problem with missing download links and bad expiration dates (which you won't notice until after you get past the time error).

 

I think these were the only things that I ran across. I'll keep an eye on this thread. If you run into any other problems, it might be something that I also ran across and if I have a fix for it, I'll get it posted.

 

Jetta

Share this post


Link to post
Share on other sites

Jetta

 

That seems to have worked. many thanks for the advice.

 

Any idea how to change the button to the new type rather than an image.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Jetta

 

That seems to have worked. many thanks for the advice.

 

Any idea how to change the button to the new type rather than an image.

 

catalog/includes/languages/english.php

Find:

 

define('IMAGE_BUTTON_DELETE', 'Delete');

Add the following after:

 

define('IMAGE_BUTTON_DOWNLOAD', 'Download Now!');

catalog/includes/modules/downloads.php

Find around line 101:

 

          echo '            <td class="main" align="center">' . $downloads['products_name'] . ' - <a href="' . tep_href_link(FILENAME_DOWNLOAD, 'order=' . $last_order . '&id=' . $downloads['orders_products_download_id']) . '">' . $file_array['download_group_file_description'] . '<br>' . tep_image_button('button_download.gif', 'Download') . '</a> - ' . $file_size . '</td>' . "\n";

Replace with:

 

          echo '            <td class="main" align="center">' . $downloads['products_name'] . ' - <a href="' . tep_href_link(FILENAME_DOWNLOAD, 'order=' . $last_order . '&id=' . $downloads['orders_products_download_id']) . '">' . $file_array['download_group_file_description'] . '</a><br>' . tep_draw_button(IMAGE_BUTTON_DOWNLOAD, 'triangle-1-e', tep_href_link(FILENAME_DOWNLOAD, 'order=' . $last_order . '&id=' . $downloads['orders_products_download_id']), 'primary') . '<br>' . $file_size . '</td>' . "\n";

Find around line 103:

 

          echo '            <td class="main" align="center"><a href="' . tep_href_link(FILENAME_DOWNLOAD, 'order=' . $last_order . '&id=' . $downloads['orders_products_download_id']) . '">' . $downloads['products_name'] . '<br>' . tep_image_button('button_download.gif', 'Download') . '</a> - ' . $file_size . '</td>' . "\n";

Replace with:

 

          echo '            <td class="main" align="center"><a href="' . tep_href_link(FILENAME_DOWNLOAD, 'order=' . $last_order . '&id=' . $downloads['orders_products_download_id']) . '">' . $downloads['products_name'] . '</a><br>' . tep_draw_button(IMAGE_BUTTON_DOWNLOAD, 'triangle-1-e', tep_href_link(FILENAME_DOWNLOAD, 'order=' . $last_order . '&id=' . $downloads['orders_products_download_id']), 'primary') . '<br>' . $file_size . '</td>' . "\n";

 

catalog/includes/languages/english/images/buttons/button_download.gif

 

delete that image file.

 

Worked for me. Save a copy of your files before making changes though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×