Jump to content
Sign in to follow this  
saif316

MIGS payment for ANZ egate

Recommended Posts

Hi Guys,

I've recently installed MIG payment gateway on one of the sites, the transactions go thru fine with ANZ but then it redirects me back to Merchant site with credit card error. and i receive an email with the following error: Secure Hash was not able to be verified against the Secret Hash, possible tampering with response. Please help.

 

Thanks

Share this post


Link to post
Share on other sites

Saif,

 

I am not familiar with that payment gateway, but with other gateways I know that your return URL has to point back to the verification file given to you by the Merchant Processor. Ensure you have that verification file in the proper directory and that the return URL is correct.

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

sorry, forgot to mention i am using server hosted gateway. the only thing we received from bank was

 

Merchant ID

Access code

secure hash secret

Share this post


Link to post
Share on other sites

Hi saif, did you get this sorted out? I am having a similar issue, only different in that it is not consistent, the error is occasional.

 

Thanks and regards, Sam

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×