Jump to content

Archived

This topic is now archived and is closed to further replies.

kymation

Designing New Themes the Easy Way

Recommended Posts

Ok, I following the instructions, except for the part that states:

 

Copy the le-frog (or whatever yours is named) directory in its entirety into the catalog/ext/jquery/ui/ directory on your server. Copy the entire directory with all of its files and subdirectory structure intact.

 

Mine was actually located in: /ext/jquery/ui/.

 

But I found it anyways. Got everything loaded on the server, but when I edited the actual /template_top.php file, and refreshed my web site, all of the items that I wanted changed, just vanished. No bars or anything. Although it looks different, it didn't load the temp like it should have.

 

What could I have done wrong?

There is only a few more things I need to do to the web site, and it will be fully up and running.

 

Great step by step procedures, just wished mine worked.

Share this post


Link to post
Share on other sites

Great post. Option 1 and 2 work well. I have trouble with option 3 where I click and drag the themeroller development tool into my firefox bookmark toolbar. When I open up my site and try to use the themeroller panel to see the instant changes to my site....... but I don't see any instant changes. Is the themeroller development tool not working?

Thanks

Share this post


Link to post
Share on other sites

The Themeroller Bookmarklet has been broken for a very long time. I've provided a set of working files in the Theme Switcher Addon package. You don't have to install Theme Switcher to use the Bookmarklet files; just upload the catalog/developertool.js.php and catalog/developertool.php files, open developertool.php in your browser, and follow the instructions.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I have been reading thorugh this thread trying to figure out how to add the theme switcher so I can change my client's theme; however, I find much conflicting information. I downloaded Theme Switcher using the above link and there is only one file called theme_switcher_1.3.tar which is a gz file. In later portions of this thread, it says there are three files to be loaded, but there is none.

 

I tried the theme roller dev tool, but alas that is broken. There must be an easier way to change the themes for people who aren't coders. How is this accomplished?

Share this post


Link to post
Share on other sites

@ yes i have similar problem, install a theme. My admin saying that there are 4 additional modules to install, but when i click on them- there are only 3 :)

 

@@kymation where can we finf developertools.php files??

Share this post


Link to post
Share on other sites

@@shawnpmackey Your archive program is defective, or you need to take another step to unpack the .tar file. All of the files you need are in there.

 

@@peterpetranin The developertools files are in the archive, in the catalog directory.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The problem of many addons is that they are not compactible with other adons.

First I read the supportpage of the addon, then i deside if i gone give it a try or not.

Then i install the new addon in a clean catalog, if it works and i find it usefull i try to install it in a shop with other addons.

Sometimes i'm lucky but many times some parts af the shop dont work anymore or in worst case the shop is F.U.

The addons based on their own php files are the best, then those you have to ADD code, but when it starts to changing code you start the HELL.

 

It should be nice if we know everything before we start to spend time for nothing

 

Grtz

Share this post


Link to post
Share on other sites

<p>@@kymation thanks,  jQuery UI Theme Roller Developer tool works perfectly, but it doesnt sort out problem with the boxes. I mean i would like to change a look of boxes, do not want theme square and stuck one underneath other.</p>

<p>Any add on for that?</p>

<p>Anybody?</p>

<p> </p>

<h1>

 </h1>

 

Share this post


Link to post
Share on other sites

You can change the styling with CSS. The boxes have an ID of #columnLeft or #columnRight. I use Firebug in Firefox to show the current styles attached to each element, and change them from there.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The firefox themeroller bookmarklet does not update the html page when changing theme colors

Hi,

Found the fix for the themeroller bookmarklet. This post on http://forum.jquery.com. ( http://forum.jquery.com/topic/the-firefox-themeroller-bookmarklet-does-not-update-the-html-page-when-changing-theme-colors)

 

Right click on the ThemeRoller Dev Tool Themeroller Bookmarklet go to properties and under Location: change the link to this.....

 

 

javascript:(function(){if(!/Firefox[\/\s](\d+\.\d+)/.test(navigator.userAgent)){alert("Sorry,%20due%20to%20security%20restrictions,%20this%20tool%20only%20works%20in%20Firefox");return%20false}else{if(window.jquitr){jquitr.addThemeRoller()}else{jquitr={};jquitr.s=document.createElement("script");jquitr.s.src="http://jqueryui.com/themeroller/developertool/developertool.js.php";document.getElementsByTagName("head")[0].appendChild(jquitr.s);var%20a=function(){jquitr.reloadCSS=function(){var%20c=jquitr.getHash(),b;if(jquitr.trString!==c&&c!==""){jquitr.trString=c;b='<link%20href="http://jqueryui.com/themeroller/css/parseTheme.css.php?'+c+'"%20type="text/css"%20rel="Stylesheet"%20/>';if($("link[href*=parseTheme.css.php],%20link[href=ui.theme.css]").size()>0){$("link[href*=parseTheme.css.php]:last,%20link[href=ui.theme.css]:last").eq(0).after( B)}else{$("head").append( B)}if($("link[href*=parseTheme.css.php]").size()>3){$("link[href*=parseTheme.css.php]:first").remove()}}window.setTimeout(jquitr.reloadCSS,1000)};jquitr.reloadCSS()};window.setTimeout(a,1100)}}})();

 

works for me.

Regards

John


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

When I have the theme roller control box open and click on the gallery tab and when I click on the theme I like and click download, the entire control box turns black and nothing downloads...... I didn't install the whole theme roller package, I just uploaded developertool.js.php and developertool.php to my catalog folder. Anyone know where I'm going wrong? THanks

Share this post


Link to post
Share on other sites

I love theme roller (finally managed to get it right 2nd time around) yet when I put in a theme my buttons do not change with the theme. Now I have no idea if I'm ding anything wrong or not (I will do it again if need be) but I wanted the mint-choc one...it has brown buttos.... mine stay grey. :(

 

Wow not only that but the admin part of it well.... went so bizzare. No more sections, just one long section that was not even fully on the page.

 

Guess I just suck at this & should stick to redmond :(


I really am learning, but just not in the right parts.

Share this post


Link to post
Share on other sites

@@Jacki , in an other post you said you us a template, that had the logo display removed.

 

Did you add a new theme to that template or to a default store? It may be that your template use images or who knows what else for the buttons

 

Regarding admin: You should not remove the redomnd theme, because that's used in admin. You can have as many themes you want side by side. In case you want the new theme for admin too, you need to change the path in admin/includes/template_top.php

Share this post


Link to post
Share on other sites

@@multimixer yeah I went back to the redmond one, simple for me cause I backed it up offline & then just FTP it back over. So then I instaled theme switcher not a problem even though it took me 2 tries. Then I put choc-mint one on from theme roller & it just was not right for some reason. I really just need someone to put it all on for me I think. I have to other one that I had backed up as well (one with the template I was using the 1st time that I got going good) and have that one installed now. I really do suck at this :( I guess I will try another time :(


I really am learning, but just not in the right parts.

Share this post


Link to post
Share on other sites

@@Jacki

 

If you need someone to do it for you, then you can post at the commercial support section

 

But to add a new theme it's really not hard to do. I have an illustrated example on my blog if you want to check this (link via my profile here). Themeschwitcher also work fine with no issues at all

 

I would suggest you do all your trials on a default install first

Share this post


Link to post
Share on other sites

@@multimixer I keep trying, actually I'm at the 'in tears' point. Yep I'm female haha. I just gave up & went back to the one theme I knew I could install no problem :(


I really am learning, but just not in the right parts.

Share this post


Link to post
Share on other sites

I managed to get it working right this time, at the cost of my manufacture module (no big deal I think cause I dont have manufactures for my stuff) anyway in http://aussiecollectables.net/index.php?cPath=28_22 it comes up where I cant read every 2nd line cause of the color. How can I make it all brown rather than white/brown/white/brown I dont want the alternating part.

 

 

EDIT:Nope scratch that. Not only did it take away manufactures module, but systematically made each module remove on it's own.

 

I don't know why I can't get this to work for me. I'm not a total numbskull, I can read the manual. But for some reason it does nto like me. I'm almost ready to get rid of my store all together at this rate


I really am learning, but just not in the right parts.

Share this post


Link to post
Share on other sites

Wow I could not even restore it from a backup. Seems as though not only did it break my modules, but my whole store. I had to start fresh :(


I really am learning, but just not in the right parts.

Share this post


Link to post
Share on other sites

hi, i was wondering what people's thoughts are on the use of javascript in oscommerce?

 

i know the admin side doesn't function without it.

 

but for the front end, if javascript is disabled, what features are mainly weakened if no javascript is allowed by the browser?

 

the reason i ask is that i've been looking at various big clothing shops online and if you turn off the javascript, a lot of the site features become unusable, like tabs on the product information pages, and shopping cart features.

 

Yet, its commonly said that a website should first be designed to run without the need for javascript, and javascript/jquery should only be used to enhance it.

 

what are your thoughts on this? do you think its worth editing the 2.3.2 store to cope without javascript or this is an impossible and needless task?

 

would be interesting to hear your thoughts on this.

thanks

Share this post


Link to post
Share on other sites

×