Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
Guest

Easy Populate v2.76h

Recommended Posts

Guest

I'm running OSC v2.3.1

I want to install EP v2.76h

 

I had no problem with installation instructions STEP 1 or STEP 2

STEP #1 - Upload the following files to your osCommerce Store Directory

Copy file /catalog/admin/easypopulate.php into /catalog/admin/

Copy file /catalog/admin/easypopulate_functions.php into /catalog/admin/ folder.

Copy the /catalog/admin/EPDocumentation/ folder (3 files) into your /catalog/admin/ folder.

 

 

STEP #2 - Setup the "temp" folder

The "/catalog/temp/" folder should be uploaded to (or created in) the root of your store (Beside the /admin/, /images/, and /includes/ Directories)

Set the CHMOD permissions of this folder to 777.

 

However, STEP 3 asks me to change code located in the /catalog/admin/boxes/catalog.php, but I don't have this file structure, I have /catalog/admin/includes/boxes/catalog.php

 

Now I went on to assume that this is okay, however, the code that the instructions said to look for in the file isn't in the file...here's what's in my catalog.php file:

 

<?php

/*

$Id$

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2010 osCommerce

 

Released under the GNU General Public License

*/

 

$cl_box_groups[] = array(

'heading' => BOX_HEADING_CATALOG,

'apps' => array(

array(

'code' => FILENAME_CATEGORIES,

'title' => BOX_CATALOG_CATEGORIES_PRODUCTS,

'link' => tep_href_link(FILENAME_CATEGORIES)

),

array(

'code' => FILENAME_PRODUCTS_ATTRIBUTES,

'title' => BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES,

'link' => tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES)

),

array(

'code' => FILENAME_MANUFACTURERS,

'title' => BOX_CATALOG_MANUFACTURERS,

'link' => tep_href_link(FILENAME_MANUFACTURERS)

),

array(

'code' => FILENAME_REVIEWS,

'title' => BOX_CATALOG_REVIEWS,

'link' => tep_href_link(FILENAME_REVIEWS)

),

array(

'code' => FILENAME_SPECIALS,

'title' => BOX_CATALOG_SPECIALS,

'link' => tep_href_link(FILENAME_SPECIALS)

),

array(

'code' => FILENAME_PRODUCTS_EXPECTED,

'title' => BOX_CATALOG_PRODUCTS_EXPECTED,

'link' => tep_href_link(FILENAME_PRODUCTS_EXPECTED)

)

)

);

?>

 

The instructions wants me to change:

 

'<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' .

 

To:

 

'<a href="' . tep_href_link('easypopulate.php', '', 'NONSSL') . '" class="menuBoxContentLink">Easy Populate</a><br>' .

 

Any help would be greatly appreciated.

Jack

Share this post


Link to post
Share on other sites

I could be mistaken, but I don't think Easy Populate works with 2.3


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

Read this


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites
Guest

Well in fact, it looks like there's a workable solution.

Thank you for the "Read this"...just made my morning.

Regards,

Jack

Share this post


Link to post
Share on other sites
Guest

Was able to install and run it...however, when i click on the Easy Populate choice in the Catalog (admin area), the EP is displayed over the entire catalog menue...wierd..

this is a screenshot of it:

screenshot.gif

Share this post


Link to post
Share on other sites

Was able to install and run it...however, when i click on the Easy Populate choice in the Catalog (admin area), the EP is displayed over the entire catalog menue...wierd..

this is a screenshot of it:

screenshot.gif

 

You need to replace the top formatting of the file with template_top

 

Compare easy populate with a standard file. I have running fine in 2.3.1

 

Here is the top bit. Do the same at the bottom of file

 

// S T A R T

// PAGE DELIVERY

//*******************************

//*******************************

?>

<!--<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">

<html <?//php echo HTML_PARAMS; ?>>

<head>

<meta http-equiv="Content-Type" content="text/html; charset=<?//php echo CHARSET; ?>">

<title><?//php echo TITLE; ?></title>

<link rel="stylesheet" type="text/css" href="includes/stylesheet.css">-->

<?php require(DIR_WS_INCLUDES . 'template_top.php'); ?>

<script type="text/javascript"><!--

function switchForm( field ) {

var d = document;

Share this post


Link to post
Share on other sites
Guest

I'm afraid I'm just not that savy yet to follow exactly what you're saying...

I'm thinking you're saying make some changes in the easypopulate.php file?

Share this post


Link to post
Share on other sites
Guest

You need to replace the top formatting of the file with template_top

 

Compare easy populate with a standard file. I have running fine in 2.3.1

 

Here is the top bit. Do the same at the bottom of file

 

// S T A R T

// PAGE DELIVERY

//*******************************

//*******************************

?>

<!--<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">

<html <?//php echo HTML_PARAMS; ?>>

<head>

<meta http-equiv="Content-Type" content="text/html; charset=<?//php echo CHARSET; ?>">

<title><?//php echo TITLE; ?></title>

<link rel="stylesheet" type="text/css" href="includes/stylesheet.css">-->

<?php require(DIR_WS_INCLUDES . 'template_top.php'); ?>

<script type="text/javascript"><!--

function switchForm( field ) {

var d = document;

Share this post


Link to post
Share on other sites
Guest

Paul, I want to try and do this...

Where in the template_top file should I add the code you wrote?

Jack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×