Jump to content
Sign in to follow this  
wasson65

Fedex Zone Contrib version 2.0 ready

Recommended Posts

I installed this add on and it went so well

after i clicked the link to check out , i can see the shipping automatically using FedEx ( since I only use that one )

but when I clicked continue, the page didn't go to the next page, it just returned to the same page

 

anyone has idea bout this ?

Share this post


Link to post
Share on other sites

I'm about to install this contribution as FedEx is my prefered method of shipping.

 

My concerns are as follows:

 

1. Does this contribution takes into account the weight of the shipment? If so, from what data field?

2. I need to block certain states since I'm not allowed to ship to all states. Any suggestions? Is there a way to turn states "on" and "off" for shipping?

 

Best,

 

Avi

Share this post


Link to post
Share on other sites
1. Does this contribution takes into account the weight of the shipment? If so, from what data field?

2. I need to block certain states since I'm not allowed to ship to all states. Any suggestions? Is there a way to turn states "on" and "off" for shipping?

1. Data is from the shopping cart weight

2. To selectively turn off states, you need to add the following code:

 

	  // Refuse shipping if the following zip codes matches
  if ($order->delivery['zone_id'] == 'xxx' || $order->delivery['zone_id'] == 'xxx' || $order->delivery['zone_id'] == 'xxx') {
	return $this->quotes;
  }

 

after

 

	  if ( $zone_id == '' ){
	  // something is wrong, we didn't find any zone
	$this->quotes['error'] = MODULE_SHIPPING_FEDEXZIPZONES_NO_ZONE_FOUND;
	  return $this->quotes;
  }

 

replacing the xxx above with the zone_id with the states you don't ship to. For the exact list of zone_id, look at the OSCommerce zone table in the database.


- The Jackal

Share this post


Link to post
Share on other sites
1. Data is from the shopping cart weight

2. To selectively turn off states, you need to add the following code:

 

	  // Refuse shipping if the following zip codes matches
  if ($order->delivery['zone_id'] == 'xxx' || $order->delivery['zone_id'] == 'xxx' || $order->delivery['zone_id'] == 'xxx') {
	return $this->quotes;
  }

 

after

 

	  if ( $zone_id == '' ){
	  // something is wrong, we didn't find any zone
	$this->quotes['error'] = MODULE_SHIPPING_FEDEXZIPZONES_NO_ZONE_FOUND;
	  return $this->quotes;
  }

 

replacing the xxx above with the zone_id with the states you don't ship to. For the exact list of zone_id, look at the OSCommerce zone table in the database.

 

Thank you so much!

I've installed this great contribution and need your help with the following:

 

1. After every service name (i.e. "Express Service") appears a series of dots (".........."). How can I remove it?

2. There is a weight problem: If I'm increasing the quantity of the same item (x3), or shipping three different items - I'm getting different rates (all of my items weigh the same). How do I fix this?

3. Shipping is taxable as well. How do I fix this?

3. How do I varify that the rates are correct (generally)?

 

Best,

 

Avi

Share this post


Link to post
Share on other sites
Thank you so much!

I've installed this great contribution and need your help with the following:

 

1. After every service name (i.e. "Express Service") appears a series of dots (".........."). How can I remove it?

2. There is a weight problem: If I'm increasing the quantity of the same item (x3), or shipping three different items - I'm getting different rates (all of my items weigh the same). How do I fix this?

3. Shipping is taxable as well. How do I fix this?

3. How do I varify that the rates are correct (generally)?

 

Best,

 

Avi

 

1. To remove the series of dots, make sure in the 1st line of the csv files, there is no other characters after the name of the service, e.g. change 'Fedex 2nd day,,,,,,' to 'Fedex 2nd day'

2. Haven't have time to investigate this

3. This feature is not implemented in the current version

4. Use fedex.com and compare the rates.


- The Jackal

Share this post


Link to post
Share on other sites
To remove the series of dots, make sure in the 1st line of the csv files, there is no other characters after the name of the service, e.g. change 'Fedex 2nd day,,,,,,' to 'Fedex 2nd day'

 

I'm having the same problem, I made sure there was no characters after the service name in the csv file. It still shows up with commas. Am I missing something?

Share this post


Link to post
Share on other sites
I'm having the same problem, I made sure there was no characters after the service name in the csv file. It still shows up with commas. Am I missing something?

 

Ok, nevermind. I was only looking at the file through Excel.

 

But now I have another problem, It only shows 4 options and not all 6. its misssing 2day and Ground. it seams that the buildfedexdata file runs no errors.

Share this post


Link to post
Share on other sites

*EDIT*

 

One more thing, I read a couple posts back that the PHP timeout settings might be hindering it. I've changed those and still won't load all the files. According to my test of my php.ini files, it has a much longer limit than it runs.

Share this post


Link to post
Share on other sites

Great contribution!

 

I've almost got it working...

 

However, if I have multiple "Ship to" addresses in my address book, and switch to one that is not the primary, the shipping cost goes away, and I am unable to proceed. I get stuck on the "checkout_shipping.php" page.

 

I am only using FedEx ground, and no other shipping methods.

 

I wanted to make sure that the zone import went okay, so I set up several addresses in my address book with different zip codes. None of them worked.

At first I thought there was a problem with the zone imports, but after pulling my hair out for hours-- uninstalling/reinstalling, hand editing the SQL, etc, etc... I finally went in and simply changed the zip in my "primary" address. This worked (I was able to see different rates for different zip codes).

 

I have a feeling it has to do with the checkout_shipping.php or maybe the checkout_shipping_address.php file.

 

 

If I go into the address book and set one of the *other* addresses as my default, it still does not work-- the shipping module does not load.

I even went in and deleted the contents of the entire sessions table in the database.

 

Frustrating.

 

Any ideas?

Edited by ThrashNeon

Share this post


Link to post
Share on other sites

Hello,

 

I've downloaded/installed 3.1.1 and it looks like i'm having a "multiplying the rate for multiple boxes properly", listed as a bug resolved w/ release 2.0.

 

Will someone point me in the right direction to verify the fix that was put in w/ 2.0 is in place for 3.1.1?

 

Thank You,

Tuan

Share this post


Link to post
Share on other sites

Just wanted to share a bugfix by bitingenious:

 

==========================================

The site I'm working on is US only, so if anyone entered a letter or other character into the shipping zip code field the site will crash:

 

"1054 - Unknown column '8090B' in 'where clause'

 

SELECT * FROM fedex_pcode_to_zone_xref WHERE 8090B >= pcode_from and 8090B <= pcode_to

 

"

 

I fixed it by changing line 60 in "includes/modules/shipping/fedexzipzones.php" to:

 

if (( $zip == '' ) || ( preg_match("/D/", $zip) )) {

 

this detects any non numeric characters and then exits through the normal error system.


- The Jackal

Share this post


Link to post
Share on other sites

I apologize if this has already been addressed. I just installed this add-on. But customers can not select "Federal Express" as a shipping method. There is no radio-button next to it when they get to the "Delivery Information" screen. And when, it is the only shipping method offered, the user simply can not get past the Delivery Method screen (it keeps returning back).

 

Thanks in advance for any assistance. matt

Share this post


Link to post
Share on other sites

I know I'm dumb so please don't remind me. When I try to run /admin/buildfedexdata.php It returns "Unable to connect to database server!" Is this a permissions problem? My admin folder is set to 755 and the file is 644. I use firefox as my browser. I know there's not much activity in this thread recently, but maybe someone could point me in the right direction ..

Edited by mb01a

Share this post


Link to post
Share on other sites

ed:

Ok .. I found that I don't need application_top.php in buildfedexdata.php. I changed that line to "require('includes/configure.php');" It loads now, runs 2-3 seconds, then crashes with a 500 (Internal Server Error). I guess this contribution is just too old to be used with ver 2.2rc2

 

I've uninstalled it.

Share this post


Link to post
Share on other sites

hello, Iinstalled FedEx ZipZones v3.1.1 but the Ground Shipping doest now show up after I clicked CHECK OUT but all others such as Home Delivery is showing up, do you have any idea how to make GROUND Shipping appear in the Check Out ( checkout_shipping.php )

 

I will wait for a reply

 

Thank You

Share this post


Link to post
Share on other sites

It's either 'Ground' or 'Home Delivery' depending on your 'company' field. If you key in something in the company field when checking out, 'Ground' will appear and 'Home delivery' will not.


- The Jackal

Share this post


Link to post
Share on other sites

I have just created a crude USA international zones version. (shipping from USA to other countries only) Let me know if anybody is interested and I will try post in contributions.


- The Jackal

Share this post


Link to post
Share on other sites

I have just created a crude USA international zones version. (shipping from USA to other countries only) Let me know if anybody is interested and I will try post in contributions.

 

I installed FedEx ZipZones v3.1.1 on my store osc v2.3.1 www.alohaplumeria.net but it's not working,

 

Warning: Invalid argument supplied for foreach() in /home/content/96/9287396/html/catalog/includes/modules/shipping/fedexzipzones.php on line 128

 

I followed the instruction but can't find the cause of error, any help will be greatly appreciated

Share this post


Link to post
Share on other sites

I believe it is not getting data from the rates table. Did you load the data in the rates table correctly?


- The Jackal

Share this post


Link to post
Share on other sites

I believe it is not getting data from the rates table. Did you load the data in the rates table correctly?

 

No, the modified table did not load, I had uploaded your 2008 rates and they work just fine, so I need to work on my updated fedex rates csv. How do I remove unwanted shipping options like Home Delivery, and what makes 2nd Day quote 2 different rates radio button?

 

thanks for the reply and help

Share this post


Link to post
Share on other sites

Hello,

 

Thank you for a great contribution.

 

While installing the contribution I found that the excel table provided from FedEx for FedEx Ground Standard List Rates effective 1-1-2012 contains a dash (-) in the column of results for FedEx Ground Shipping from my zip code to Puerto Rico and I am wondering if I should remove the dashs as well as the references to Zone "10" (Puerto Rico) before processing the CSV file via buildfedexdata.php or will the shipping rate calculations be negatively affected if I do so? There was a reference to "Piece was non-numeric: -" in the buildfedexdata.php processing output results but I am not sure if that would constitue an error and would affect the shipping rate results or not.

 

Thank you in advance for your reply and assistance.

 

Dreamlab

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×