Jump to content
Sign in to follow this  
robinwarren

Missing, Duplicate Etc. Order Problems

Recommended Posts

We've been having problems on several of my OSC shopping carts for about a week. I think because of high volume on the internet. Several of these shopping carts have been stable for years, and we've never had any of these problems before. Many orders ARE going through fine, but a significant number are not. Symptoms include:

 

Authorize.net shows a charge but order never shows up in OSC

Authorize.net charges the customer multiple times (possibly customer is getting impatient and submitting more than once)

OSC gives the "Please try again and if problems persist, please try another payment method" message 3 times in a row, and 4th time the same card works

OSC keeps giving the "Please try again and if problems persist, please try another payment method" message, but same card works 30 minutes later

 

HELP! Has anyone had this problem before?

 

I'm using this version of authorizenet_cc_aim.php: $Id: authorizenet_cc_aim.php 1803 2008-01-11 18:16:37Z hpdl $

 

PayPal orders are going through fine ...

 

Thank you!

Share this post


Link to post
Share on other sites

I'm having the exact same problem. Did you ever find a solution to this problem?

 

So far it seems that it's only happening when the credit card was denied the first time for some reason.

Share this post


Link to post
Share on other sites

I think I have narrowed it down even further. It seems to be only missing the order from the database when the billing address does not match the shipping address. The order is validated by authorize.net (and charged on the card), but when OSC gets the reply from authorize.net that it was successful, OSC starts putting the order in the database, but when it gets to ot_shipping it gets an error - I'm guessing because the addresses do not match?

 

I think that OSC starts adding to the orders_total table in the database first. The entry for ot_subtotal works, but the next one is ot_shipping and it never gets entered into the database and neither does the total from ot_total. The order_products, order_products_attributes and order_status_history tables never not get entered into the database either, and so the email never gets sent, and the "order successful" page is never displayed, so the customer doesn't know that the order was charged to their card, and they keep trying to enter the order, resulting in multiple charges and multiple missing orders.

 

So far, I have been manually adding the information to the database that is missing, but this requires you to know exactly what they ordered, with what attributes and what shipping method they used as well as how much the shipping charge was. Most times, if you log into the user's account on the store, you can see that the products were still in their cart. I guess the cart is cleared after the database is updated fully? If you go to checkout, you can find out what shipping charge they used by deducting the products totals from the total that was charged to their card.

 

Does anyone have any more information about this phenomenon? I cannot figure out what is causing this error, but it only happens when the order is processed by authorize.net and only when the shipping and billing addresses are different.

Share this post


Link to post
Share on other sites

I have the same problem. Email from Authorize.net shows approved order yet OSC does not show an order for the customer. Shipping address and billing address the same in my case. Two orders from the same customer. OSC shows NO orders for the customer. How do you log into the customers account with no password?

 

Thanks

Share this post


Link to post
Share on other sites

You can't retrieve passwords on an osC site, they're hashed not encrypted, so you can't just "log into" a customers account.

 

I beleieve there are "Master Password" add-ons that can allow you to log on to any account.


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×