Jump to content
kymation

[Addon} Theme Switcher

Recommended Posts

You need to finish unpacking the file. It's double compressed, so just run your uncompress utility on the .tar file and it should give you the package. Or get a better program to unpack archives -- most will do the double unpack automatically.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I use theme switcher for about a year now and have about 15 themes on 1 site, now I don't remember how I got them their. what file are the themes store in?

Share this post


Link to post
Share on other sites

Themes are in catalog/ext/jquery/ui/. The Theme Switcher instructions tell you how to get and install more themes.

 

Regards

Jim

Edited by kymation

See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi,

I would like to know if there would be a way to change the code in Theme Switcher in order to have Google API references and let Google host the Jquery files.

 

I am using a Shared SSL and the file size limit is around 100kb per files. If the files are to big, some of the objects or icons will not show up on my webpage.

 

I know there is this mod on this post that you can do when not using Theme Switcher:

 

http://www.css-oscommerce.com/cut-page-load-time-in-oscommerce-2-3-osc-to-css/

 

but the required code needing to be replaced are the one needed to be deleted by Theme Switcher:

 

<link rel="stylesheet" type="text/css" href="ext/jquery/ui/redmond/jquery-ui-1.8.6.css" />
<script type="text/javascript" src="ext/jquery/jquery-1.4.2.min.js"></script>
<script type="text/javascript" src="ext/jquery/ui/jquery-ui-1.8.6.min.js"></script>

 

To replace the Jquery references in OSCommerce 2.3 open:

includes/template_top.php

replace:

 

<script type="text/javascript" src="ext/jquery/jquery-1.4.2.min.js"></script>
<script type="text/javascript" src="ext/jquery/ui/jquery-ui-1.8.6.min.js"></script>

 

with:

 

<script type="text/javascript" src="<?php echo (isset($_SERVER['HTTPS']) && (strtolower($_SERVER['HTTPS']) == 'on') ? 'https://' : 'http://') . 'ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js'; ?>"></script>
<script type="text/javascript" src="<?php echo (isset($_SERVER['HTTPS']) && (strtolower($_SERVER['HTTPS']) == 'on') ? 'https://' : 'http://') . 'ajax.googleapis.com/ajax/libs/jqueryui/1.8.6/jquery-ui.min.js'; ?>"></script>

 

Any ideas on how to modify the code in Theme Switcher to have Google host the Jquery files?

 

Cheers

 

Dan

Share this post


Link to post
Share on other sites

You can use version 1.1 of Theme Switcher. That version does not replace the jQuery and jQuery UI header tags.

 

Be careful to use the https includes correctly with the Google files. Also note that Google is sometimes slow, and that will slow your site response.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Thanks Jim,

 

Is version 1.1 compatible with OSC 2.3.1?

 

Also, how would I do the downgrade?

Undo everything from the instructions or just upload the files for version 1.1?

 

Thanks

Dan

Share this post


Link to post
Share on other sites

Theme Switcher only works with osC 2.3.1. No ohter versions are supported.

 

Uninstall Theme Switcher from the Admin, then upload all of the files over the existing files. If you have made other changes to your template_top.php, you'll have to patch that by hand, just like a new install.

 

Regards

Jim

Edited by kymation

See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi, thanks for this contribution, it's terrific. I have one slight little issue that's driving me batty...my buttons for 'cart content' 'checkout' 'my account' have all disappeared and are now just text links (see pic).

If I use the firefox tool, they'll show up when I browse different calendar themes, but when I download and install one, they are still missing like in the pic, no matter what theme I use. At first they were showing up fine when the default redmond was selected, so being the cool guy that I am, I thought I'd trick the system by renaming and replacing my custom images in the redmond images folder with mine.. but they dissapeared now on redmond. I even replaced all the redmond images back just as they were in the contribuion zip but they still don't show up anymore lol.

2.3.1 store, current version of the contribution, no other mods installed.

 

Thanks

7518977.png

Share this post


Link to post
Share on other sites

That is caused by either missing jQuery/jQuery UI files or by a version mismatch. Check that you have the latest version of those files and the filenames match the names in template_top.php. See the User's Manual for instructions.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi. The problem Im having is that the drop down menus do not appear in the admin module. It shows me all the js versions, and that the Redmond theme is loaded..

Share this post


Link to post
Share on other sites

The pulldown is generated by tep_cfg_pull_down_themes() which is in admin/includes/functions/modules/header_tags/theme_switcher.php. Is that file in the correct location?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The pulldown is generated by tep_cfg_pull_down_themes() which is in admin/includes/functions/modules/header_tags/theme_switcher.php. Is that file in the correct location?

 

Regards

Jim

 

Nope! Thats the one file I missed.. :blush:

 

thats what I get for trying to install something in the middle of the night when I should be sleeping. Thanks Ill give it a go now! Apologies for asking about something I should have easily read in the manual. I even re-read it 4 times but I must have been confusing it with admin/includes/modules/...

Share this post


Link to post
Share on other sites

That is caused by either missing jQuery/jQuery UI files or by a version mismatch. Check that you have the latest version of those files and the filenames match the names in template_top.php. See the User's Manual for instructions.

 

Regards

Jim

 

In regards to this issue. Ive used the template_top.php as provided in the add-on, but I think its removed the reference to jquery version.. Should I be bothering with that file or is it the module that controls this now?

 

Ive tried downloading and setting in the module, AND using the default OSC template_top.php and changing it in there, to no avail.

 

 

Ive put jquery (1.7.1.min.js) in /ext/jquery/

 

and then (ui-1.8.17.min.js)into the /ext/jquery/ui folder

 

Ive set these in the module as 1.7.1 and 1.8.17

 

I lose all theme formatting, whether in redmond or ui-darkness.

 

Am I missing something here?

Share this post


Link to post
Share on other sites

Yes, the module now controls the jQuery and jQuery UI version numbers. Use version 1.1 if you don't want this.

 

The files must be named EXACTLY as in the instructions. Variations will not work. Check your filenames, then use View Source in your browser to check the filename it is calling for. In Firefox you can click on the filenames in View Source and see if the file is being called correctly.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Seems to be all sorted now.

 

Thanks a million for your advice and a really great contribution! :thumbsup:

Share this post


Link to post
Share on other sites

Jim,

The error on line 138 was the translation I was doing.

But what I meant. The opening of the datepicker remains.

He does not open to the themes made with ThemeRoller.

Only with the original theme done in 1.8.6.

Thanks

yes,same problem with me..i bought oscommerce template at businesstemplatestore.com and get error. I'm contacting with webmaster to fix it. while get anwser, i found this topic and hope have a new solution

Edited by Jan Zonjee

Share this post


Link to post
Share on other sites

The answer is the same as I gave the person you quoted. If that doesn't work for you, the problem is with your template. Ask your template supplier for support.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The most likely cause is failing to make the changes to template_top.php. Don't forget to force a reload of your browser to see the changes.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi JIm, installed this and its there in admin, made a couple of templates with themeroller, uploaded them to the directory it said (ui) withe the redmond theme in, but when i change themes, and go and look at the site, its just blank nothings there, chnge theme names to relevant numbers (1.8.6) etc but cant think what i am doing wrong

 

Any help would be appreciated thanks

 

Alan

SB

Edited by squarebanana

Share this post


Link to post
Share on other sites

One or more files are missing or incorrectly named. Use View Source in Firefox and click on each of the links in the head in turn. The one that returns a 404 error message is the one that is incorrect.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I've added a new release to the Addons area. This fixes the bug/conflict with the Modular Front Page Addon, and probably others that require the jQuery files to be loaded first. If you are upgrading, uninstall Theme Switcher before replacing your module file with the one in this release.

 

The package is over the size limit again, so I've also uploaded it to my server until the official release is approved.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I've given up on the previous upload. I stripped out all of the Addons, including the full Theme package, to make it fit without approval. If you want the full version with all of the extras, download from the link in my previous post.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×